SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

286 Plugins, 197 contribs sur SPIP-Zone, 194 visiteurs en ce moment

Accueil > Squelettes > Outils pour squelettes > Changez de navigateur ! > Changez de navigateur !

Changez de navigateur !

21 février 2009 – par Fil, tetue – 40 commentaires

47 votes

Ce plugin permet d’afficher un gentil message aux internautes surfant avec un trop vieux navigateur afin de les prévenir qu’ils ne visitent pas le site dans les meilleures conditions.

Téléchargez, installez et activez le plugin ci-joint et... c’est tout !

Ce plugin insère automatiquement le message ci-après, en haut de chaque page de votre site, uniquement dans les vieux navigateurs.

Message affiché

Dans sa dernière version, le message s’affiche pour les navigateurs Internet Explorer inférieurs à la version 8 :

Attention, votre Internet Explorer n’est pas à jour !
Savez-vous que votre navigateur est obsolète ? Pour naviguer de façon plus satisfaisante sur ce site et le reste du Web, nous vous recommandons d’actualiser votre Internet Explorer ou d’essayer d’autres navigateurs web populaires.

Personnaliser l’affichage

Si vous souhaitez afficher le message à un autre endroit de la page, il vous suffit de placer le bloc div#noie à l’endroit voulu du squelette, par exemple : <div id="noie"></div>

Voir en ligne : http://plugins.spip.net/noie

Dernière modification de cette page le 27 avril 2015

Retour en haut de la page

Tout afficher

Vos commentaires

  • Le 5 septembre 2012 à 14:36, par RealET En réponse à : Changez de navigateur !

    Pouvoir changer la version de IE ciblée ?

    En regardant Le code :

    <!--[if lte IE 6]>

    Il me semble qu’il serait facile de paramétrer (via mes_options.php ou un écran de CFG) la version à prendre en compte.

    Je le fais ?

    PS : j’ai vu qu’il fallait aussi modifier Ligne 27.

    Répondre à ce message

  • Le 15 avril 2012 à 13:41, par Regis92 En réponse à : Changez de navigateur !

    bonjour à tous,

    mon site n’est pas compatible avec les versions de IE <= 8 (en fait il marche uniquement avec IE9).

    j’aimerais donc modifier ce script pour qu’on qu’on puisse faire apparaitre le message « Savez-vous que votre navigateur est obsolète ? » pour version IE6, IE7 et IE8

    pourriez-vous m’aider SVP ? (je n’ai pas réussi...)

    merci !

    • Le 4 mai 2012 à 12:04, par Julien En réponse à : Changez de navigateur !

      Bonjour,

      Savez vous que IE-9 n’est disponible que sur Seven (et Vista) ?
      Votre site ne fonctionne donc pas pour tous les utilisateurs de Windows XP
      C’est voulu ?

    • Le 4 mai 2012 à 12:28, par regis92 En réponse à : Changez de navigateur !

      Non effectivement... merci pour l’info !

    Répondre à ce message

  • Le 1er juillet 2011 à 13:30, par Steph en Bretagne En réponse à : Changez de navigateur !

    Excellente initiative que ce plugin : merci !

    En réalité, je viens de me rendre compte de ce que tout le monde savait déjà, à savoir que les librairy Jquery n’était pas facilement intégrables à IE. Résultat, mes diaporamas fancybox ne passent pas dans Explorer 9 ...

    Je voudrais donc afficher la campagne 2 (trop cool pour IE) mais je ne comprends pas l’explication :

    Pour afficher une autre campagne, insérez une autre noisette dans vos squelettes, par exemple : <INCLURE{fond=toocool}> pour afficher la campagne « Trop cool pour IE

    Dans quel fichier exactement faut-il coller ce code ? Et où dans ce fichier ?

    Par ailleurs, puisque ce souci ne concerne pas uniquement ceux qui utilisent IE6 mais tous ceux qui utilisent IE, faut-il changer une autre ligne de code pour que les infos soient bien visibles par les utilisateurs de toutes les versions d’Explorer ?

    Merci d’avance pour vos réponses.

    Répondre à ce message

  • Le 4 mars 2011 à 19:07, par Valéry En réponse à : Changez de navigateur !

    Pour info Microsoft propose a rejoint le camp de ceux qui proposent ce genre de bannière : http://www.ie6countdown.com/

    Répondre à ce message

  • Le 31 janvier 2010 à 13:49, par ? En réponse à : Changez de navigateur !

    1) Pour les petits jeunes qui n’y connaissent rien en développement de programmes, refaire un intranet qui soit compatible avec les dernières versions des navigateurs coute TRES cher. Vous ne réfléchissez pas plus loin que le bout de votre souris, changer un intranet ne coute pas seulement en développement, il y’a aussi l’intégration sur de nouvelles machines (changer tout le parc) acheter les dernières versions des logiciels utilisés, former les utilisateurs et en dernier (j’en ai surement oublié) éponger les pertes et différents manques à gagner du fait du manque de rentabilité des premiers mois des utilisateurs. N’oubliez pas que votre ordi à 2€ que vous achetez chez le chinois du coin coute plus de 3000€ pour une entreprise : qualité du matériel, assistance et maintenance sans délai, harmonisation des matériels, intégration de tous les composants et mise en réseau sans compter les serveurs et les périphériques (imprimantes, claviers, souris, scanners, écrans, onduleurs, switchs, routeurs, ...).
    J’arrête là en espérant que vous ayez compris. Si vous n’avez pas compris, je ne peux rien pour vous.

    2) Vous avez des sites Internet et vous avez des visiteurs qui vous font l’honneur de visiter votre site et qui par la même occasion vous donnent la possibilité de garder votre emploi, de manger ou tout simplement de gonfler votre égo. Est-ce que çà serait trop vous demander d’avoir un minimum de respect pour ces personnes ? Vous en avez marre de vous faire chier pour IE6 et eux ne peuvent pas changer de navigateur ou ne comprennent rien à l’informatique. De toute façon s’il était possible pour eux de changer, çà serait déjà fait !
    Je vous rappelle que dans les entreprises, le personnel n’est pas censé utiliser les ressources mises à leur disposition pour une utilisation personnelle. Estimez-vous heureux déjà d’avoir des visiteurs entre 9h00 et 18h00 !

    3) Vous voulez révolutionner le monde et on est tous passés par là avant vous (nous les vieux) et comme nous vous deviendrez parents, vous aurez des enfants, un break Renault, des traites pour l’appartement et vous utiliserez IE pour pas vous faire chier avec « cette merde d’informatique ».

    Pour le moment, remettez-vous en question, arrêtez de penser que vous êtes les maîtres du monde, respectez un peu plus les autres et on vous respectera un peu plus aussi.

    Pensez à cette phrase : le liberté s’arrête où commence celle des autres.

    • Le 31 janvier 2010 à 14:27, par Cerdic En réponse à : Changez de navigateur !

      Pensez à cette phrase : le liberté s’arrête où commence celle des autres.

      Tout à fait.

      Et on exerce notre liberté en disant qu’on se fout de ces visiteurs qui ne sont de toutes façons même pas censés venir surfer sur nos sites aux heures de travail.

      Après, si ils viennent quand même sur les sites avec leur vieil IE6, et râlent ensuite auprès de leur service informatique qu’y pouvons nous ?

      Je me permets juste de faire remarquer que la standardisation des navigateurs (et des techniques html, css et js) a commencé il y a 5 ans, et que ces mêmes DSI qui se plaignent aujourd’hui d’avoir le couteau sous la gorge et viennent pleurer sur le coût de la migration ont fait preuve d’un manque de discernement qui confine à l’aveuglement en continuant pendant tout ce temps à développer des applications non portables basées sur l’obsolète IE6.

      Autrement dit, nous cessons de prendre à notre charge le coût de support de ces navigateurs (qui n’est pas facturable au client, de fait) que ces SI ont fait porter sur nous pendant tout ce temps, faute de vouloir prendre à leur charge les coûts de migration qui leur échouaient.

      Le temps à fait son œuvre, la balle est maintenant dans le camp de ces mêmes SI qui se retrouvent acculés. Chacun son tour.

    • Le 31 janvier 2010 à 14:31, par Cerdic En réponse à : Changez de navigateur !

      Vous voulez révolutionner le monde et on est tous passés par là avant vous (nous les vieux) et comme nous vous deviendrez parents, vous aurez des enfants, un break Renault, des traites pour l’appartement et vous utiliserez IE pour pas vous faire chier avec « cette merde d’informatique ».

      Pour être complet : j’ai des enfants, une citroën (ça vaut le break renault en terme d’indice ’vieux con’ non ?), des traites pour payer ma maison.

      Mais ça ne m’empêche pas de continuer à essayer de changer le monde, et de ne pas utiliser IE.

      Chacun est toujours libre de ses choix s’il accepte d’en payer le prix. Ne sois pas jaloux de ceux qui ont ce courage.

    • Le 31 janvier 2010 à 14:34, par Maïeul En réponse à : Changez de navigateur !

      Cher Monsieur (ou Madame),

      il m’arrive rarement de répondre sur un forum qui n’est pas le mien, surtout à des gros troll. Ceci dit, je ferais aujourd’hui. Car rien ne m’exaspère plus que les donneurs de leçon qui regarde les autres avec condescendance.

      1) Pour les petits jeunes qui n’y connaissent rien en développement de programmes

      Dès le début, ca commence bien « les petits jeunes ». Et si moi je vous traitais de « vieux cons » ? C’est quoi cette insulte à la noix ?

      refaire un intranet qui soit compatible avec les dernières versions des navigateurs coute TRES cher

      On vous parle pas d’intranet là. A priori, ce plugin est là pour des sites publics. Effectivement en intranet on s’en fiche que cela ne soit disponibles que pour un logiciel qui ne respecte pas les standards.

      Vous ne réfléchissez pas plus loin que le bout de votre souris, changer un intranet ne coute pas seulement en développement, il y’a aussi l’intégration sur de nouvelles machines (changer tout le parc) acheter les dernières versions des logiciels utilisés, former les utilisateurs et en dernier (j’en ai surement oublié) éponger les pertes et différents manques à gagner du fait du manque de rentabilité des premiers mois des utilisateurs.

      N’oubliez pas que votre ordi à 2€ que vous achetez chez le chinois du coin coute plus de 3000€ pour une entreprise

      parce que vous croyez réellement que les développeurs de SPIP et de ces plugins bossent sur un ordi à deux euros ? et je suis désolé, mais installer un navigateur correcte, respectant les standards, type FF :

      1) ne nécessite pas de changement de matériel par rapport à un ordi sur IE 6

      2 ) n’a strictement aucun coup de licence

      Si vous n’avez pas compris, je ne peux rien pour vous.

      Je pense que vous aussi n’avez pas compris qu’on n’impose pas d’utiliser ce plugin, et que de plus ce plugin n’interdit pas de consulter un site sur IE6. Il le déconseille simplement.

      Vous avez des sites Internet et vous avez des visiteurs qui vous font l’honneur de visiter votre site et qui par la même occasion vous donnent la possibilité de garder votre emploi, de manger ou tout simplement de gonfler votre égo.

      Parce que là ce n’est pas vous qui gonflez votre égo en donnant des leçons ?

      Est-ce que çà serait trop vous demander d’avoir un minimum de respect pour ces personnes ? Vous en avez marre de vous faire chier pour IE6 et eux ne peuvent pas changer de navigateur ou ne comprennent rien à l’informatique.De toute façon s’il était possible pour eux de changer, çà serait déjà fait !

      Ne peuvent pas ou ne savent pas qu’ils peuvent ? Passons pour les entreprises, qui pourraient au moins installer un FF chez eux, Mais pour un particulier, ce plugin ne fait que donner un message qui propose d’installer autre choses. Libre à eux de le faire ou pas.

      Et pour moi, respecter une personne ce n’est pas lui dire « tout va très bien madame la marquise ». Quand je signale à une personne qu’elle a la possibilité de changer de navigateur pour quelquechose de plus conformes aux standards, sans coût supplémentaire, je pense que je la respecte mieux qu’en fermant ma g***

      Je vous rappelle que dans les entreprises, le personnel n’est pas censé utiliser les ressources mises à leur disposition pour une utilisation personnelle. Estimez-vous heureux déjà d’avoir des visiteurs entre 9h00 et 18h00 !

      Fors heureusement, la vie ne se limite pas à l’entreprise. Sauf pour vous apparemment.

      Vous voulez révolutionner le monde et on est tous passés par là avant vous (nous les vieux) et comme nous vous deviendrez parents, vous aurez des enfants, un break Renault, des traites pour l’appartement et vous utiliserez IE pour pas vous faire chier avec « cette merde d’informatique ».

      Allez, recommencez votre leçon de morale. Mais comprenez bien qu’on s’en fiche de votre age ou du notre ...

      Pour ma part, j’espère bien ne pas avoir de break renault, et utilisez IE est là meilleur manière de se faire chier avec « cette merde d’informatique ». Voire par exemple les conseils des gouvernements belge.

      Pour le moment, remettez-vous en question, arrêtez de penser que vous êtes les maîtres du monde,

      Nous ne pensons pas être les maîtres du monde. Par contre Microsoft à la fâcheuse tendance à se prendre pour la maitresse des standard informatique et ainsi à les violer allégrement. Personnellement, je ne souhaite pas qu’il y est de maitre du monde. Que ce soit moi ou un autre.

      Et vous aussi vous devriez vous remettre en question, Monsieur le donneur de leçon.

      respectez un peu plus les autres et on vous respectera un peu plus aussi.

      Encore une fois, est-ce un irrespect de signaler qu’on utilise un logiciel remplaçable et non conforme aux standards ? Pour le moment, l’irrespect viens de votre part, vous qui nous traitez avec mépris du haut de votre « sagesse ancêstrale » qui a fait mai 68 ou le programme du CNR (changez le monde avec vous dit. J’ignore votre age, donc je donne ces deux exemples)

      Pensez à cette phrase : le liberté s’arrête où commence celle des autres.

      Il est vrai que ne pouvoir utiliser qu’un seul navigateur est un signe évident de liberté.

    • Le 31 janvier 2010 à 16:18, par tetue En réponse à : Changez de navigateur !

      Au delà du paternalisme condescendant et très rigolo dont vous faites preuve, vous avez grandement raison, mais vous vous trompez d’ennemi. Puisque vous chérissez la liberté, pourquoi n’utilisez-vous pas un navigateur libre ??

      (voir ma réponse complète, au même commentaire, directement sur mon blog)

    • Le 15 janvier 2011 à 18:55, par Perline En réponse à : Changez de navigateur !

      C’est drôle, je ne l’avais pas vu passer ce troll-là, un signe ?
      Rien à rajouter à tous ces excellents arguments, bien entendu.

      Juste pour raconter une anecdote de mes 20 ans, lors d’une grève. Ça se passe dans un amphi bourré à bloc (dans une école où les grèves sont, a minima, rarissimes).
      Le prof d’optique, qui nous avait dit « Je préfère une France aux mains des nazis plutôt qu’aux mains des gauchistes », m’avait interpellée, suite à une intervention de ma part :
      -  Vous dites ça parce que vous êtes jeune, vous verrez à mon âge...
      Je lui avais répondu :
      -  A mon âge, vous étiez comme moi ?
      -  (blanc)... Non.
      -  Et bien moi, au vôtre, je ne serai pas comme vous.
      -  (blanc)...

      Plus de 35 ans plus tard, il est clair que j’avais vraiment raison. Je suis comme moi, pas comme lui.
      Et l’âge n’a rien à voir.

      Ceux qui opposent les âges (comme d’autres critères) pour justifier d’une meilleure vision de la vie, de la société, du monde, me sont toujours aussi méprisables.

      Seuls ceux qui argumentent, échangent, sur les questions elles-mêmes peuvent faire avancer le monde.

      On est toujours plus intelligents à plusieurs que seul

      .

    Répondre à ce message

  • Le 8 janvier 2010 à 10:51, par Perline En réponse à : IE8 n’est plus en bêta

    Et la phrase à changer pourrait donc être pour noie_fr.php

    <a href="http://www.microsoft.com/windows/internet-explorer/default.aspx">Internet Explorer&nbsp;8</a>
    • Le 27 janvier 2010 à 21:08, par filnug En réponse à : IE8 n’est plus en bêta

      C’est une bonne remarque. Ce serait parfait de modifier au moins la version française en proposant de télécharger ie8 (exit ie7) ou d’autres navigateurs comme safari, FF, etc.

      Peux-t-on modifier la source sur spip zone ? Merci !

    • Le 31 janvier 2010 à 17:51, par tetue En réponse à : IE8 n’est plus en bêta

      @Perline et filnug : ce n’est certes pas visible sur les captures d’écran de cet article, mais c’est évidemment corrigé depuis longtemps (Changeset 28389) et le message a encore été simplifié aujourd’hui (Changeset 34820).

    • Le 15 janvier 2011 à 17:19, par Valéry En réponse à : Changez de navigateur !

      Un an plus tard, Google Chrome est à 14% des parts de marché : il faut peut être à son tour l’ajouter dans le message ?

    Répondre à ce message

  • Le 24 mars 2010 à 17:30, par ? En réponse à : Changez de navigateur !

    Ce site internet : http://www.servicesgratis.net/ie/
    propose une campagne de sensibilisation pour les utilisateurs d’IE.

    — > Pour y participer : http://www.servicesgratis.net/ie/webmaster.php

    • Le 24 mars 2010 à 17:58, par tetue En réponse à : Changez de navigateur !

      La campagne que tu mentionne n’apporte rien de plus.
      Ce serait peut-être intéressant si tu en faisais un plugin prêt à l’emploi...

    Répondre à ce message

  • Le 13 avril 2009 à 21:59, par ? En réponse à : Changez de navigateur !

    Je pense qu’il serait judicieux de préciser dans le message que des problèmes éventuels d’affichage peuvent subvenir. Parce que c’est bien de ça qu’il s’agit. Soit on a du temps à perdre et on fixe la css pour _tous_ les navigateurs, et auquel cas ce plugin est juste pour sensibiliser, soit on ne veut plus se casser la tête pour ie en particulier (c’est mon cas), et il faut clairement préciser que le « navigateur obsolète *blabla* à mettre à jour *blabla* ou à remplacer *blabla* fait que l’affichage du site peut ne pas correspondre à ce à quoi il devrait et sembler bizarre, décalé, *blabla* pas beau »

    Sinon, c’est class d’avoir un truc tout fait en plugin (au cas où vous l’auriez pas compris je suis assez faignant). Un grand merci.

    PS : pour le moment je modifies dans lang/, mais à la prochaine maj, ça va sauter.

    Répondre à ce message

  • Le 1er mars 2009 à 15:25, par val En réponse à : Changez de navigateur !

    Personnellement, j’ai tenté de mettre un texte dans une div id « noie », mais le texte ne disparaît pas. il apparaît sur tous les navigateurs :(

    En introduisant le texte dans div id=« noie », celui-ci devrait être masqué sur Firefox, non ?

    Merci

    • Le 13 avril 2009 à 19:17, par ? En réponse à : Changez de navigateur !

      ne met rien dans le div. Tu mets juste dans ton squelette :

      <div id="noie></div>

      et pas plus. Et dans le footer c’est bien, c’est affiché malgré tout en haut de page. Très bien amha.

    Répondre à ce message

  • Le 28 février 2009 à 14:17, par arno2 En réponse à : Changez de navigateur !

    Excellent initiative.

    Ils disent qu’il faut placer le message à un autre endroit de la page : placer le bloc div#noie à l’endroit voulu de votre squelette, par exemple :

    Q : Dans quel fichier du dossier squelettes ?

    Même chose pour une autre campagne, avec l’insertion d’une autre noisette pour afficher la campagne « Trop cool pour IE » :

    Q : Dans quel fichier du dossier squelettes ?

    Merci pour votre aide, je débute.

    • Le 1er mars 2009 à 02:21, par Loiseau2nuit En réponse à : Changez de navigateur !

      @arno2 (c’est pas bien de plagier le pseudo d’ARNO* :P )

      Dans quel fichier du dossier squelettes ?

      Perso, je l’ai mis dans mon inc-pied.html. Comme cela ce n’est pas le premier texte que lisent les robotss d’indexation, ce qui évite de « polluer » tes résultats de recherche.

      Ensuite, une fois placé dans ton pied de page, tu peux tout à fait positionner ta #noie en absolute en top=0px ; pour qu’elle apparaisse en haut de ta page ;)

    • Le 1er mars 2009 à 10:37, par ? En réponse à : Changez de navigateur !

      @Loiseau2nuit : les robots d’indexation ne voient pas ce texte puisqu’il s’agit d’un commentaire HTML

    • Le 1er mars 2009 à 11:34, par Loiseau2nuit En réponse à : Changez de navigateur !

      Pourtant c’est bien après avoir vu ce message apparaitre dans un des résultats Google d’un de mes sites que j’ai pris la décision de le mettre en pied de page à l’avenir.

      Je pense que certains arrivent à les lire quand même, ces commentaires ne sont que conditionnels après tout :/

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Formidable, le générateur de formulaires

    23 janvier 2012 – 1968 commentaires

    Un générateur de formulaires facilement configurable pour les non-informaticiens et facilement extensible pour les développeurs. Introduction L’objectif était de créer un plugin permettant de générer des formulaires. Historiquement, 2 plugins (...)

  • Notation d’éléments SPIP

    25 juillet 2008 – 351 commentaires

    Ce plugin propose un système de notation des éléments de SPIP depuis l’espace public.

  • Formulaire de contact avancé

    23 mars 2009 – 1368 commentaires

    Un formulaire de contact configurable, avec de multiples options.

  • ORR v2

    21 mai 2013 – 89 commentaires

    ORR, le plugin d’Organisation des Réservations et des Ressources passe en version 2, avec quelques nouveautés attendues. Je ne reprendrai pas les explications données dans la version 1. Les nouveautés : 1. Gestion des autorisations Le (...)

  • Agenda 2.0

    3 novembre 2008 – 1020 commentaires

    Voici la version pour SPIP 2.0 du Plugin Agenda pour SPIP 1.9.2, avec une interface remaniée pour encore plus de plaisir. Pour une documentation concernant l’utilisation d’Agenda 3 pour SPIP 3, veuillez pour l’instant vous référer à SPIP 3, Agenda (...)