SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano

278 Plugins, 195 contribs sur SPIP-Zone, 90 visiteurs en ce moment

Accueil > Administration et BDD > Archives Distributions SPIP spécifiques > SPIP 1.7 en .php

SPIP 1.7 en .php

24 janvier 2004 – par dani – 11 commentaires

Toutes les versions de cet article : [English] [Español] [français]

2 votes

Ceci est une ARCHIVE, peut-être périmée. Vérifiez bien les compatibilités !

SPIP 1.7 avec des extensions de fichier en .php. Distribution multilingue complète et monolingue en français.

Vous trouverez ci-desosus les distributions en .php de la version 1.7 de SPIP. Elles ne diffère de la distribution officielle que par le fait que les extensions de fichiers .php3, ainsi que toutes les références à ces fichiers, ont été converties en .php.

C’est particulièrement utile pour les hébergeurs qui n’acceptent pas les extensions .php3 ou qui ont un comportement différent avec celles-ci, tels que free.fr, ainsi que pour l’installation en local dans bon nombre de configurations par défaut, en particulier avec Apache 2.0.

N’oubliez pas, si vous avez un fichier mes_fonctions.php3, de le renommer le en mes_fonctions.php.

Il vous suffit de télécharger l’un des fichiers ci-dessous :

  • SPIP-v1-7-PHP.zip pour la version multilingue,
  • SPIP-v1-7-PHP-fr.zip pour la version monolingue en français. Suivez ensuite la procédure habituelle d’installation, à partir de l’étape 2. de l’installation manuelle.

Par ailleurs, rappelons que dans cette contrib, Ben propose un script pour faire la conversion d’une distribution.

Retour en haut de la page

Tout afficher

Vos commentaires

  • Le 6 mars 2005 à 14:25, par joelle En réponse à : > SPIP 1.7 en .php

    Bonjour,
    Merci bien pour votre livraison php, car comme j’ai installé Apache2..
    Tout à bien foctionné, j’ai pu configurer la Base Mysql spip, mais là j’obtiens : Parse error : parse error, unexpected T_ABSTRACT, expecting T_STRING in /Library/WebServer/Documents/spip/ecrire/inc_objet_base.php on line 13 !
    Cette erreur est-elle due aux diverses version de php ?
    J’ai installé Apache2, avec Mysql 4.1.8 et php5.

    • Le 8 avril 2005 à 17:09, par jp En réponse à : > SPIP 1.7 en .php

      moi, aussi, apache2+php5
      même problème

    • Le 8 avril 2005 à 18:14, par jp En réponse à : > SPIP 1.7 en .php

      ligne 13 et 16
      remplacer abstract par abstract1

    Répondre à ce message

  • Le 25 mai 2004 à 00:21, par Courcy En réponse à : > SPIP 1.7 en .php

    Pour ma part merci beaucoup.

    Répondre à ce message

  • Le 21 mai 2004 à 15:43, par ? En réponse à : > Il est temps pour SPIP de passer en .php

    Il est urgentissime de passer au PHP !!

    plus ou attend, plus il y a des sites sous SPIP référencés dans les moteurs de recherche en PHP3

    il faut un jour ou l’autre passer en php, et ce jour-là : tous les référencements seront perdus

    restercen php3 (alors que le php5 sort) devient franchement ridicule comme comportement de la part des développeurs et ça ne donne pas confiance dans le produit

    Répondre à ce message

  • Le 11 février 2004 à 18:42, par ? En réponse à : > SPIP 1.7 en .php

    Et pourquoi la version officielle utilise-t-elle les extensions .php3 ?

    • Le 22 mars 2004 à 17:25, par tofm2 En réponse à : > Pour en finir avec les extensions .php3

      Bonjour

      Je suis propriétaire d’un enseble de serveurs sur lequel je souhaite faire tourner spip. Il s’agit de serveurs linux mandrake tout ce qu’il y a de plus basique.

      [root@msi ecrire]# rpm -qa | grep apache
      apache2-common-2.0.47-6.3.92mdk
      apache2-2.0.47-6.3.92mdk
      apache2-mod_ssl-2.0.47-6.3.92mdk
      apache2-modules-2.0.47-6.3.92mdk
      apache2-mod_disk_cache-2.0.47-6.3.92mdk
      apache2-mod_proxy-2.0.47-6.3.92mdk
      apache-conf-2.0.47-8mdk
      apache2-mod_php-2.0.47_4.3.2-2mdk
      apache2-mod_perl-2.0.47_1.99_09-3mdk
      apache2-mod_suexec-2.0.47-2mdk
      apache2-mod_cache-2.0.47-6.3.92mdk

      [root@msi ecrire]# rpm -qa | grep php
      php-ini-4.3.3-1mdk
      mod_php-4.3.3-2mdk
      php-imap-4.3.2-3mdk
      php-gd-4.3.2-4mdk
      libphp_common432-4.3.3-2mdk
      apache2-mod_php-2.0.47_4.3.2-2mdk
      php-mysql-4.3.2-3mdk

      [root@msi ecrire]# rpm -qa | grep SQL
      MySQL-common-4.0.15-1mdk
      MySQL-client-4.0.15-1mdk
      MySQL-4.0.15-1mdk

      Ces serveurs executent sans aucun problème n’importe quel code en .php/mysql/html et tout le toutime. Seulement, les dernières versions de spip NE MARCHENT PAS ! et j’ai pourtant bien configuré apache pour qu’il execute le .php3 (voir article correspondant)

      Ca m’a enervé, alors j’ai écrit un petit script (cnvp3) pour qu’il convertisse TOUS les liens .php3 en .php AINSI que TOUS les noms de fichiers .php3 en .php. Ce script bash est le suivant :

      # !/bin/bash

      echo
      echo « Convertir les fichiers .php3 en .php »
      echo
      echo « Repertoire de travail : »
      read reptrav
      echo

      php3files=/var/tmp/php3files
      htmlfiles=/var/tmp/htmlfiles

      find $reptrav -name *.php3 > $php3files
      find $reptrav -name *.html > $htmlfiles

      echo « On change les liens .php3 en .php dans les fichiers php3 »
      echo `wc $php3files -l | cut -d’/’ -f1`« fichiers .php3 a modifier »
      echo
      cat $php3files | while read i
      do
      sed s/« .php3 »/« .php »/ $i > $i« _new »
      mv -f $i« _new » `echo $i | sed s/« .php3 »/« .php »/`
      rm -f $i
      done

      echo « On change les liens .php3 en .php dans les fichiers html »
      echo `wc $htmlfiles -l | cut -d’/’ -f1`« fichiers .html a modifier »
      echo
      cat $htmlfiles | while read i
      do
      sed s/« .php3 »/« .php »/ $i > $i« _new »
      mv -f $i« _new » $i
      done

      rm -f $php3files
      rm -f $htmlfiles

      Ce script devrait normalement faire que SPIP fonctionne.

      Or il n’en est rien ; quand je l’applique à la dernière archive de spip fraichement décompréssée, j’obtiens ça dans le browser :

      Parse error : parse error in /var/www/html/SPIP-v1-7r/ecrire/inc_lang.php on line 379

      Fatal error : Call to undefined function : utiliser_langue_visiteur() in /var/www/html/SPIP-v1-7r/ecrire/inc_presentation.php on line 9

      D’où ma question, comment fait on, et surtout comment se fait il que spip fonctionne encore en .php3 alors que php en arrive à la version 5

      J’ai eu beau tourner la question dans tous les sens, rien à faire.

      Appel à contribution

      et pourquoi ne pas laisser tout simplement tomber .php3 pour attaquer sérieusement avec du php4 ou 5, nous sommens en 2004 que diable...

    • Le 23 mars 2004 à 01:14, par dani En réponse à : > Pour en finir avec les extensions .php3

      et pourquoi ne pas laisser tout simplement tomber .php3 pour attaquer sérieusement avec du php4 ou 5, nous sommens en 2004 que diable...

      il restait quelques hébergeurs important encore en .php3 (l’autre, altern, ...), mais bonne nouvelle : ils vont migrer.

      c’est en discussion, rdv sur spip-dev

    • Le 24 mars 2004 à 10:11, par tofm2 En réponse à : > Pour en finir avec les extensions .php3

      Oui, mais moi, en l’occurence, l’hébergeur, c’est moi même, et les caractéristiques de mon serveur apache (pourtant, tout ce qu’il y a de plus bateau) ne permettent plus de faire fonctionner du .php3, c’est extrèmement dommage, .....et chiant

    • Le 12 avril 2004 à 13:41, par pydieng En réponse à : > Pour en finir avec les extensions .php3

      La version multilingue 1.7.1 en .php est disponible.

    • Le 16 avril 2004 à 15:01, par tofm2 En réponse à : > Pour en finir avec les extensions .php3

      Super, ça marche sur ma config décrite ci-dessus

      merci de vos efforts

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Agenda 2.0

    3 novembre 2008 – 923 commentaires

    Voici la version pour SPIP 2.0 du Plugin Agenda pour SPIP 1.9.2, avec une interface remaniée pour encore plus de plaisir. Pour une documentation concernant l’utilisation d’Agenda 3 pour SPIP 3, veuillez pour l’instant vous référer à SPIP 3, Agenda (...)

  • Mosaïque

    21 septembre 2012 – 31 commentaires

    Ce plugin permet d’organiser les images du portfolio par simple glisser-déposer des vignettes d’une mosaïque accessible depuis la page d’édition de l’article. Dépendances Ce plugin nécessite les plugins Champs extra et Saisies pour fonctionner. (...)

  • elFinder

    1er avril – commentaires

    Ce plugin permet de parcourir l’arborescence de son site SPIP grâce au gestionnaire de fichiers Elfinder. Principe Ce plugin permet aux administrateurs de parcourir l’arborescence d’un site SPIP à travers un outil ressemblant à un gestionnaire de (...)

  • Critère {mots}

    6 août 2009 – 251 commentaires

    Permettre de sélectionner facilement des objets SPIP ayant un ou des mots clefs en communs.

  • Fulltext

    14 mars 2009 – 168 commentaires

    Ce plugin permet d’une part d’exploiter le mode de recherche FULLTEXT de MySQL et d’améliorer ainsi énormément les recherches par rapport au fonctionnement natif de SPIP, et d’autre part d’indexer le contenu de certains (...)