SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

286 Plugins, 197 contribs sur SPIP-Zone, 160 visiteurs en ce moment

Accueil > Vie de SPIP et autour de SPIP > SPIP-core > SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

3 juillet 2012 – par L’équipe de SPIP-Contrib – 18 commentaires

6 votes

une faille CRITIQUE nous a été signalée, elle concerne les branches
2.0, 2.1 et 3.0. Nous vous encourageons à mettre à jour RAPIDEMENT vos sites SPIP, ou à défaut à les protéger au moyen de l’écran de sécurité.

Les autres changements apportés à la version 3.0.3 :
-  Amélioration des performances sous SQLite
-  Correction d’un bug sur la modification de l’email par un redacteur
-  Petit changement d’ergonomie dans l’interface d’amdinistration des plugins afin de mettre plus en avant les plugins activables

L’utilisation de l’écran de sécurité mis à jour protège de toutes les failles qui nous ont été signalées dans toutes les versions de SPIP. Vous êtes encouragés à télécharger la version la plus récente de l’écran de sécurité (1.1.3 du 03 juillet 2012) et à la déposer dans votre répertoire config/ (cf. http://www.spip.net/fr_article4200.html).

Toutefois, si vous avez la possibilité, nous vous recommandons fortement de mettre à jour SPIP avec les nouvelles versions.
N’hésitez pas à utiliser les différents moyens mis à disposition par la communauté pour obtenir de l’aide lors de cette mise à jour :
-  Liste spip-user : http://listes.rezo.net/mailman/listinfo/spip
-  Forum : http://forum.spip.org/
-  IRC : http://spip.net/irc

Nous rappelons à toutes et tous que le meilleur moyen pour signaler des failles, ou des suspicions de failles est d’envoyer un email à spip-team@rezo.net. C’est ce qu’Arnault a fait et nous le remercions.

Comment mettre à jour ?

1. par spip_loader.php : si vous avez déjà installé spip_loader, rendez-vous à l’adresse http://VOTRE_SITE/spip_loader.php pour installer la dernière version de SPIP.
Attention cependant : lisez bien les instructions ici : http://www.spip.net/fr_download#spip_loader pour ne pas être surpris par un passage non voulu de SPIP2 à SPIP3

2. par copie des fichiers : SPIP 3.0.3 est disponible à l’adresse http://files.spip.org/spip/stable/spip-3.0.zip

3. par SVN : si vous êtes dans la branche 3 faites simplement un « svn up » svn ://trac.rezo.net/spip/branches/spip-3.0 la version 3.0.3 est aussi disponible sous
la branche : svn ://trac.rezo.net/spip/branches/spip-3-stable et sous le tag svn ://trac.rezo.net/spip/tags/spip-3.0.3

Les versions 2.0.21 et 2.1.16 sont téléchargeables ici : http://files.spip.org/spip/archives/

Dernière modification de cette page le 21 octobre 2012

Retour en haut de la page

Vos commentaires

  • Le 9 septembre 2015 à 12:42, par Nora En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    bjr
    comment restaurer ma base de donnée qui est sous spip2 vers spip3
    merci

    • Le 9 septembre 2015 à 20:21, par b_b En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Salut, il ne faut pas faire ça, d’ailleurs la page de restauration de dump doit l’indiquer si je me souviens bien. Il faut d’abord mettre à jour ton spip 2, faire une sauvegarde, et là tu pourras l’importer dans spip 3.

    Répondre à ce message

  • Le 4 février 2013 à 17:10, par François En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    Bonjour,

    J’ai le même genre de problème suite à une mise à jour de spip2.0.9 vers spip 3.0.5. J’obtiens un message d’erreur 1146, table manquante auteurs_messages. De plus j’ai dans ma base de données, différentes tables correspondant à l’ancien squelette evaweb.
    Faut-il tenter une réparation ? Effacer les tables dans phpmyadmin ? créer la table ?

    Merci pour vos suggestions

    François

    Répondre à ce message

  • Le 13 juillet 2012 à 11:23, par Maïeul En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    pourrais tu ouvrir un ticket pour signaler ton problème, en détaille toutes les étapes suivies ? C’est un bug à mon avis. Si tu avais une copie de la base avant, ce serait le top.

    http://core.spip.org/issues

    • Le 13 juillet 2012 à 12:15, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Ça marche, et j’ai une copie de la base.

    • Le 4 février 2013 à 17:30, par François En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Bonjour,

      J’ai le même genre de problème suite à une mise à jour de spip2.0.9 vers spip 3.0.5. J’obtiens un message d’erreur 1146, table manquante auteurs_messages. De plus j’ai dans ma base de données, différentes tables correspondant à l’ancien squelette evaweb.
      Faut-il tenter une réparation ? Effacer les tables dans phpmyadmin ? créer la table ?

      Merci pour vos suggestions

      François

    Répondre à ce message

  • Le 16 juillet 2012 à 19:23, par Benoit En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    Bonjour,

    Est-ce qu’on doit s’inquieter si on tourne encore sous la branche 1.9 ?
    merci.

    Benoit

    Répondre à ce message

  • Le 18 juillet 2012 à 16:54, par Luc En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    Bonjour, je ne sais pas si c’est un bug à proprement parler, mais le dépôt de plugins péclotte depuis 3.0.3, et si je tente d’accéder le fichier de Spip Zone, on me répond effrontément que le XML est mal formé, petite ponctuation intempestive dans le document ?

    Répondre à ce message

  • Le 12 juillet 2012 à 00:42, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

    La mise à jour a fonctionné (spip_loader) après quelques bidouilles :
    après l’exécution de spip_loader, je n’ai pas eu l’affichage du bouton pour mettre à jour la base, j’ai donc cliqué sur « réparer la base », ce qui a réglé les problèmes d’erreurs SQL.
    En revanche mes auteurs ont perdu leurs articles liés ! Or dans la table auteurs_articles il y a toujours les liens corrects entre auteurs et articles. En réattribuant chaque article à chaque auteur, ça remarche (c’est fastidieux mais je n’ai même pas 20 articles sur le site) même si pourtant ça ne change rien dans la base, ce qui reste donc un mystère pour moi...

    • Le 12 juillet 2012 à 12:08, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Juste après avoir posté ce message, j’ai remarqué qu’il y avait une table auteurs_liens qui ne contenait que les premiers articles que j’avais commencé à réattribuer. J’ai donc exécuté quelques requêtes SQL pour aller plus vite. Tout fonctionne à présent, mais comment m’assurer que j’ai une base bien correcte ? Je constate que sur une base propre de SPIP 3 il n’y a plus de tables auteurs_messages, auteurs_articles etc. or j’ai toujours ces tables dans ma base... Y-a-til un script à exécuter ? Si oui faut-il que j’efface le contenu de auteurs_liens avant de l’exécuter ? (je précise qu’il s’agissait d’une mise à jour de spip 2.1 vers spip 3.0.3).

    • Le 13 juillet 2012 à 00:36, par Maïeul En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      hum, il eu fallut réparer avant la base et faire ensuite une install propre.

      Faites une sauvegarde de votre base tel quel, et si vous y tenez, supprimez les tables auteurs_xxx qui ne servent plus à rien.

      Pouvez vous préciser : la réparation de la base vous a été proposé par SPIP ? Et après la réparation, il n’y a pas eu d’étape de mise à jour de la base ?

    • Le 13 juillet 2012 à 11:20, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Réparer la base avant ? Je n’avais aucun problème donc je n’y ai pas songé.
      Je n’ai pas eu l’étape de mise à jour de la base et la réparation ne m’a pas été proposée, je l’ai effectué en me disant que ça allait forcément créer les tables manquantes... Peut-on trouver le script de mise à jour de la base quelque part ? Bon c’est vrai que maintenant tout marche donc rien de grave a priori...

    • Le 13 juillet 2012 à 11:53, par Cerdic En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Non mais STOP les bidouilles...
      C’est au moment où la mise à jour n’était pas proposée qu’il aurait fallu demander de l’aide. Maintenant ta base est dans un état indéterminé... : les vieilles tables pas supprimées, des nouvelles créées mais sans migration des données, des champs manquants sur certaines tables....

      Aurais-tu fait une sauvegarde de ta base AVANT la migration comme il est systématiquement conseillé de le faire ? Si par bonheur c’est le cas, le plus sage serait de repartir de là, et voir pourquoi SPIP ne propose pas la mise à jour de la base.

      Sinon tu peux tenter de forcer la mise à jour en modifiant à la main la table spip_meta et en ajoutant/modifiant la meta « version_installee » avec la valeur « 15829 », puis en supprimant le fichier tmp/meta_cache.php.

      Si tu n’as pas de version initiale de la base, ouvrir un ticket ne servira pas à grand chose, car impossible de reproduire et corriger ton problème...

    • Le 13 juillet 2012 à 12:12, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      Stop les bidouilles, moi je veux bien mais en attendant j’ai un site en ligne foireux si je ne bidouille pas...
      Remettre l’ancienne base en ligne pour voir ce qui déconne, c’est bien gentil mais mon site public n’est pas un environnement de test. Il se trouve que j’’avais fais le test de la mise à jour en local avant et ça a bien marché, donc je n’avais pas à m’inquiéter outre mesure (et donc oui j’ai une sauvegarde de l’ancienne base).
      Merci pour le truc pour forcer la mise à jour, je vais plutôt tenter ça.

    • Le 13 juillet 2012 à 12:29, par Alex En réponse à : SPIP 3.0.3, 2.1.16 et 2.0.21 : à l’étape 303, épate-la

      La bid... :) la manip a bien fonctionné, la base est maintenant bien à jour et les tables obsolètes sont supprimées. Merci !

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Metas +

    3 décembre – commentaires

    Améliorez l’indexation de vos articles dans les moteurs et leur affichage sur les réseaux sociaux grâce aux métadonnées Dublin Core, Open Graph et Twitter Card. Installation Activer le plugin dans le menu dédié. Dans le panel de configuration, (...)

  • Import ICS 2 (agenda distant)

    2 août – 35 commentaires

    La version 2 du plugin « import ICS » en reprend la principale fonctionnalité, à savoir l’ajout automatique d’évènements distants dans la liste des évènements d’un site. À la différence de la première version, elle ne dépend pas du plugin « Séminaire » et est (...)

  • Newsletters

    16 janvier 2013 – 374 commentaires

    Ce plugin permet de composer des Info-lettres. Par info-lettre, on désigne ici le contenu éditorial qui va être composé et envoyé par courriel à une liste d’inscrits. Le plugin permet de composer une info-lettre à partir d’un modèle pré-composé, (...)

  • CKeditor 3.0

    4 octobre 2009 – 1217 commentaires

    CKeditor est l’évolution de l’éditeur WYSIWYG : FCKeditor, avec ce plugin vous pourrez utiliser cet éditeur à la place de l’éditeur de spip tout en laissant le choix à vos auteurs de l’éditeur qu’ils préfèrent utiliser. Attention : cet éditeur WYSIWYG (...)

  • GIS 4

    11 août 2012 – 1284 commentaires

    Présentation et nouveautés La version 4 de GIS abandonne la libraire Mapstraction au profit de Leaflet. Cette librairie permet de s’affranchir des librairies propriétaires tout en gardant les mêmes fonctionnalités, elle propose même de nouvelles (...)

Ça spipe par là