SPIP-Contrib

SPIP’s friends

Home > _Archives > Accès CVS Spip avec TortoiseCVS

Accès CVS Spip avec TortoiseCVS

Saturday 27 December 2003

Tout est dans le titre....


View online : Forums Spip

36652 discussions

  • Comme indiqué sur le site atypik.biz, vous pouvez utiliser librement les fichiers, html, css, png, ... Si vous souhaitez une personnalisation, une contribution est demandée. Si elle est mineure et que cela est demandé gentiment ;o) je me ferais un réel plaisir à faire la modif contre un échange de lien du genre ’Design offert par Atypik.biz’.
    A vous lire.
    Pascal

    Reply to this message

  • 2

    Super contrib, très facile d’utilisation !

    Au fait, je ne vois pas la nécessité de supprimer le couple mot.php3 / mot.html.
    Car cela ne permet pas de visualiser les mots-clés.
    Quand je fais : http://mon_site.org/mot.php3?id_mot=n
    Je ne vois qu’un bouton “modifier”, avec l’id du mot-clé mais pas sa description.
    Je ne probablement pas tout compris...
    Merci d’avance pour votre réponse.
    A+ Laurent
    P.S. Je suis en SPIP 1.6

    • Et bien si en tapant dans ton brouteur mot.php3?id_article=x ou x varie de 1 au nombre de mots clés tu réalises rapidement que tu peux obtenir la liste de tous les mots clés utilisés pour le site : ceux pour les mots de passe et ceux pour d’autres utilisations un courageux h acker n’a plus qu’a tous les essayé.......

    • Il faut alors garder le couple mots.php3/.html et ajouter dans la boucle MOTS du squelette mots.html, le critère {id_groupe!=2}
      (si 2 est le numéro du groupe “acces multiple”).

      C’est expliqué dans l’article (limitations).

    Reply to this message

  • 1

    j’ai trouvé un petit bug en jouant avec le squelette. Si un article a plusieurs mots clés associés, l’affichage en mode archive marche pas (le mois est répété). si vous êtes dans ce cas comme moi changer
    <BOUCLE_recup_mot_01(MOTS){id_article}> par <BOUCLE_recup_mot_01(MOTS){id_mot}}> et ça passe.

    la modif est a faire pour chaque boucle “recup_mot”

    • Merci pour cette info, la mise à jour est faite. Téléchargement directement sur le Atypik [.biz].

    Reply to this message

  • 3

    j’ai un autres problème

    Quand j’utilise le QCM et que je quitte le net sans le remettre à zéro, si je vais chez un copain, en lui montrant le QCM les réponse de mes questions de la veille était toujours en ligne.

    Comment faire pour réinitialiser d’office le QCM surtout quand une autre machine l’ouvre ?

    Merci

    • Je constate que lorsque j’utilise le bouton “recalculer” le résultat est exactement ce que j’attend.

      Comment coder le lien ou bouton “réinitialiser” du QCM pour obtenir le résultat attendu ?

    • esaye déjà d’ajouter &recalcul=oui dans le lien

    • marche pas chez moi

    Reply to this message

  • 4

    Salut et ... Merci

    Génial comme idée :-)

    Mais si l’installation a fonctionné, si la syndication a fonctionné, si j’ai fait une jolie boucle qui m’affiche ce que je veux, si ....

    J’ai un pb d’url vers les post du forum.

    L’url des articles est par ex. http://viewtopic.php?t=11
    Il pointe bien vers le topic adéquat, mais il a oublié l’url du forum en passant ???

    J’ai donc édité ton fichier backend, mais avant de le massacrer, je voudrais un conseil.

    Les 2 lignes suivantes font référence à l’url de base :

    $url_base = “http://$HTTP_HOST”.substr($SCRIPT_NAME, 0, strpos($SCRIPT_NAME, “backend.php”)); #URL de base du forum phpbb

    //$url_base = ’http://127.0.0.1/forums/’; #URL de base du forum phpbb

    Ma question : comment coder “en dur”, sans faire de bétise, l’url de mon forum ?

    • Comme il est dit dans le PS:

      Si l’url calculée par ce script ne convient pas, éditer ce fichier pour définir la variable $url_base. Cette variable est importante puisqu’elle définie l’url de tous les liens, ce serait dommage qu’elle soit fausse ;)

    • J’avais bien lu le PS et bien compris qu’il fallait éditer la variable $url_base, MAIS je demandais une aide complémentaire pour que ça fontionne toujours !!

      L’url de mon forum étant :
      http://www.augfrance.com/MediaMomes/MM2003/Forum_phpBB/

      Dois je remplacer tout le contenu de
      $url_base = “http://$HTTP_HOST”.substr($SCRIPT_NAME, 0, strpos($SCRIPT_NAME, “backend.php”)) ; #URL de base du forum phpbb

      $url_base = “http://www.augfrance.com/MediaMomes/MM2003/Forum_phpBB/

      Ton script se débrouillera avec le backend.php ??

      Merci de ces précisions.
      Bertrand

    • Oui, voilà, c’est ça :-)

    • Merci de cette confirmation ;-)

    Reply to this message

  • Jean-Luc GARNIER

    Bonjour,

    J’ai intégré sans aucun problème ce menu (excellent !) mais je souhaite pouvoir, lors de l’accès à une (sous-)rubrique, déplier le menu afin qu’il affiche l’arborescence ayant conduit à cette rubrique. Cela donnerait un truc dans le genre “vous êtes içi..”

    Comment forcer le dépliement ?

    Merci d’avance pour toute aide..

    Jean-Luc

    Reply to this message

  • 2

    Bonjour je n’arrive pas a afficher de tableau apres les 5- .... :-/ Une solution.. ;-) merci.

    • J’avais le même problème que j’ai réglé comme suit:

      remplacer les cinq tirets par un autre ensemble de signes, non utilisés par Spip (pour ma part, j’ai choisi §§.

      Modifier le script en conséquence:

      $page=split(’§§’,$texte);

      Comme cela, on peut appeler le script sans désactiver les fonctions SPIP avec:

      [(#TEXTE|decouper_en_page|propre)]

      Chez moi cela fonctionne très bien

    • Je ne comprends pas pourquoi, j’ai fait cette manip et chez moi ca ne passe pas.

      Ce que j’ai fait: remplacer dans le fichier mes_fonctions.php3 les deux occurences de:

      $page = split(’-----’, $texte);

      par $page = split(’§§’, $texte);

      et ensuite j’ai modifié les séparateurs dans mon articel (donc en mettant des §§ au lieu de ----- à chaque fois que je voulais un saut de page)

      et enfin j’ai appelé
      (#TEXTE
      dans mon squelette.

      Résultat: j’ai mon sommaire qui est bien découpé mais par contre dans mon texte, au lieu d’avoir un beau saut de page, j’ai un malheurexu §§ :-((

      Je n’arrive pas à voir ce que je fais de pas correct.
      Si l’un de vous voit mon erreur, please let me know.

      Mercu d’avance,
      steevy.

    Reply to this message

  • Le fichier FA2.php3 contient une faute, il faut remplacer “site publique” par “site public”.

    Reply to this message

  • 1
    mathieu

    Jean-Claude,

    J’ai le même problème... sauf qu’en ce qui me concerne ça marche nul part :-(

    1/ j’installe le backend du fichier zip (sinon Parse error)

    2/ je teste avec http://www.mondomain.tld/forum/backend.php?mode=screen et ça marche !

    3/ j’essaye de syndiquer le site et rien ! ou plutot “Attention : la syndication de ce site a rencontré un problème ; le système est donc temporairement interrompu pour l’instant. Vérifiez l’adresse du fichier de syndication de ce site”... pourtant tous les paramètre tapés dans l’interface sont ok !

    PS: aucun soucis avec la syndication d’autres sites...

    Help...

    • il m’est arrivé la même chose et j’ai recommencé mais en automatique...
      Du coup tout bon...
      Comprend po!

    Reply to this message

  • Désolé, mais tu ne réponds pas avec la question en terme “simplifiés” avec une démarche méthodique pour les neophytes.
    J’ai un blog et je cherche à faire des archives, genre (articles du 07/2003, du 08/2003...etc)
    Maintenant, je crois que c’est que ce que tu me propose de faire, encore faut il comprendre ta démarche...
    Par exemple,les lignes: $id_annee=intval($GLOBALS[’id_annee’]);
    $id_mois=intval($GLOBALS[’id_mois’]);,
    ou les met on?

    Merci d’etre plus simple dans la démarche à suivre...

    Reply to this message

Any message or comments?

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document