SPIP-Contrib

SPIP’s friends

Home > _Archives > Accès CVS Spip avec TortoiseCVS

Accès CVS Spip avec TortoiseCVS

Saturday 27 December 2003

Tout est dans le titre....


View online : Forums Spip

36637 discussions

  • 10

    Bonjour,
    j’ai l’impression que la fonction Zoom a sauté, que ce soit en renseignant l’article ou la variable à mon INCLURE... (SPIP 3.2.5, plugin mis à jour, et cache vidé)...

    • J’ai l’impression qu’il nous manque des infos pour t’en dire plus... :p

    • Bonjour b_b,
      sur un site sous spip 3.2.5, tous les plugins mis à jour et cache vidé, j’affiche une carte pour laquelle la fonction zoom n’est pas prise en compte, quoique je fasse (renseigner le point géolocalisé, ou forcer lors de l’appel dans le fichier) : https://urlz.fr/aFgR

    • On avance ;)

      Aucun problème avec le zoom de la carte chez moi, je peux bien zoomer et dézoomer avec les boutons + & - ou au double clic.

      Sinon, ton site ne charge pas les typos qui lui sont nécessaires à cause d’un paquet d’erreurs de mixed content, cf :

      Blocage du chargement du contenu mixte actif (mixed active content) « http://lenovocafe.fr/squelettes/css/fonts/Simple-Line-Icons.woff2?v=2.2.2 »

    • Il s’agit d’un problème de zoom à l’affichage de la carte elle-même, je voudrais un zoom 17, mais c’est toujours le même zoom qui est appliqué. J’ai même forcé lors de l’inclusion, mais rien n’y fait...

      1. [(#INCLURE{fond=modeles/carte_gis,zoom=17})]
    • As-tu bien vidé le cache de ton site depuis la dernière mise à jour de GIS (censée corriger ce bug) ?

    • Pas de mise à jour disponible, vidé le cache, désactiver Cache Cool, re-vidé le cache, et toujours le même problème. Zoom=X ne semble pas fonctionner...

    • Ça semble encore être un effet de bord de la modification dont je parlais dans ce commentaire : https://contrib.spip.net/GIS-4#comment502183-502163

      J’ai contacté l’auteur de celle-ci, on va voir comment corriger la boulette.

    • Pour référence, voici le code que tu utilises pour afficher la carte, merci moi :p

      <BOUCLE_localisation(ARTICLES){gis}{lang}{id_article}{0,1}>
      <div class="map_associated">
      [(#INCLURE{fond=modeles/carte_gis, autocenterandzoom=oui, zoom=17, zoom_molette=non, scale=oui, fullscreen=oui, overview=oui, id_article})]
      </div>
      </BOUCLE_localisation>
    • b_b,
      oui, c’est ma boucle, est-elle effectivement correcte ? Si j’ai bien compris ton effet de bord, j’ai donc modifié mon paramètre pour zoom=12, et malheureusement aucun changement.

    • Bonjour,
      j’ai modifié une nouvelle fois (zoom=16) et rien n’y fait, plugin GIS mis à jour. Des pistes pour que la commande fonctionne ? Est-ce un problème de balise ?

    Reply to this message

  • Hello
    J’ai un petit souci : j’ai pu sans souci faire apparaître un bouton pour un plugin dans la barre principale avec

    1. $barre->ajouterAvant('guillemets', array(

    mais je n’arrive pas à l’insérer dans un sous-menu avec par exemple

    1. $barre->ajouterApres('barre_code', array(

    le bouton barre_code étant présent si le plugin Enluminures typographiques est activé.

    Reply to this message

  • 1
    Jmtconseils

    Bonjour,
    J’ai des auteurs avec plusieurs adresses géolocalisées. Je bute sur l’affichage de la bonne adresse (issue de la table gis) sur la carte, liée au point courant.
    Voici le code de mon fichier json/inc-bulle :

    <BOUCLE_carte (AUTEURS){gis}{id_auteur}{tout}>
    <h4><a href="#URL_AUTEUR">#PRENOM [(#NOM_FAMILLE|majuscules)]</a></h4> 
                <p>#ADRESSE_GIS<br>
                #CODE_POSTAL_GIS #VILLE_GIS</p>
    </BOUCLE_carte>

    _Avec ce codage, toutes les adresses s’affichent et je ne trouve pas la solution.

    Merci pour l’aide

    • Bonjour,
      Si tu est dans une boucle englobante GIS {id_gis} dans ta boucle ne le fait pas ?

    Reply to this message

  • 1

    La doc indique de déclarer les formulaires à protéger dans le fichier d’options. Certains plugins le font ailleurs : dans le fichier PHP contenant les fonctions CVT. Ça évite de créer un fichier d’option.
    Par exemple la branche V1 du plugin mailsubscriber pour le formulaire newsletter_subscribe. Rq : dans la branche trunk de ce même plugin, toute protection a disparu.

    Est- ce suffisant de déclarer le formulaire a nospam dans le fichier php du CVT ?

    • Quand je déclare sa nospamabilité dans le fichier php du CVT du formulaire j’ai l’impression que c’est bien pris en compte car un input hidden avec name=_jeton est créé dans le form.
      Alors j’ajoute bien cette possibilité dans la doc ?

    Reply to this message

  • 1

    Bonjour,

    J’utilise le plugin pour gérer des abonnements (Dans l’idée du suivi de personnes ayant accès à mes contenus).
    Je créé un visiteur et le rattache à un abonnement.
    C’est le fait d’être connecté en public qui lui permet de lire les contenus.
    J’ai créé une page reprenant des infos sur son compte (identifiant et mail + formulaire de contact).
    Je voudrais pouvoir insérer des infos sur l’abonnement (date de fin, nom de l’abonnement,...)

    Comment faire ?

    Merci d’avance

    • Et bien comme n’importe quels autres boucles, dans tes squelettes… la table des abonnements, la table des offres… Si tu as “créé une page”, c’est bien que tu crées tes squelettes, donc tu fais pareil que pour n’importe quel autre objet de SPIP. Sans plus de précision je ne vois pas trop quoi répondre de plus :)

    Reply to this message

  • 9

    Bonjour, et merci pour cet excellent plugin!

    Quand je l’installe sur mon site le texte dans la bulle est précédé d’un paragraphe vide <p></p> ce qui crée un espace disgracieux en début de bulle (en bas aussi).

    Sauriez-vous comment me débarrasser de ces balises génantes?

    Merci,
    Abel

    Reply to this message

  • 2

    Bonsoir,

    Je ne sais pas si c’est dû à SPIP 3.3.0, mais les styles inline des tracés ne semblent pas totalement appliqués aux paths :
    -  l’opacité de la couleur est à 1 par défaut, au lieu de 0.5 annoncé
    -  la couleur de remplissage fill n’est pas appliquée, elle reste à none
    -  l’opacité de remplisssage ne semble pas présente du tout dans le style

    Cordialement,
    françois

    • Tu peux fournir l’adresse d’une page qui expose le problème ?

      PS : quand tu dis “styles inline”, tu parles de ceux générés à partir des données que tu as saisi dans l’espace privé pour un tracé ?

    • Rien en ligne, tout en local :-((

      Et oui, je parle bien de ceux générés à partir des données saisies dans l’espace privé pour un tracé. A noter que l’affichage côté privé ne reflète pas non plus les valeurs saisies dans les propriétés du tracé.

    Reply to this message

  • 1

    Bonjour!

    Je suis en train de tester ce plugin et ça fonctionne bien.
    J’ai cependant une contrainte et j’aimerais savoir comment la contourner.
    J’ai un gros fichier kml (50Mo) que j’aimerais importer. Sur mon serveur de test, j’ai modifié ces deux variables de php.ini:

    post_max_size = 60M
    upload_max_filesize = 60M

    Quand j’essaie de téléverser mon fichier kml, je suis redirigé vers une page complètement vide et surtout, mon fichier n’a pas été importé.
    Note: si je créé un article et que je joins le fichier, tout se passe bien.
    Une idée pour procéder autrement et arriver à mes fins?

    • C’est certainement un problème de limite mémoire, le script qui s’occuper de convertir le kml pour l’importer en base doit en consommer trop, bref tu atteins les limites de ton hébergement...

    Reply to this message

  • 4

    Bonjour,
    Prévoyez-vous une adaptation du plugin liée à l’arrêt du service APIXU, remplacé par Weatherstack à compter du 14 octobre ?
    Je vous remercie

    • Oui, je vais regarder ça rapidement pour voir si on peut utiliser cette nouvelle API. Il faudra suivre l’évolution du plugin pour savoir quand cela sera disponible. Je ferais aussi une communication sur ce forum.

    • Bonjour, depuis quelques jours l’affichage des données ne fonctionne plus :
      “Aucune donnée n’a été renvoyée par le service APIXU mais le service n’a pas monté d’erreur.
      Veuillez contacter l’équipe de développement du plugin.”

      Est-qu’il faut remplacer APIXU par un autre fournisseur ?

      Merci

    • Oui c’est exact, il faut se rabattre sur un autre service.

      APIXU est apparu il y a pas très longtemps comme l’API gratuite du service World Weather Online qui après des années de gratuité était devenu entièrement payant. APIXU laisse la place maintenant à Weatherstack qui comme dit la publicité est vachement mieux !
      Ce nouveau service a toujours une option gratuite mais réduite aux conditions temps réel; donc plus de prévisions gratuites. Effectivement c’est beaucoup mieux surtout quand la première offre avec prévisions est à 49,99$ par mois !

      L’API a aussi changé, je l’adapterais à l’occasion pour ne pas perdre l’existant mais ce service a dès lors plus trop d’intérêt. Je vais rajouter aussi Dark Sky qui offre une option gratuite ce qui étoffera un peu les services encore gratuits.

      Mais ce que l’on peut constater depuis des années c’est la multiplication de ces services météo et en même temps l’appauvrissement de l’offre gratuite. Ça doit être un effet de la bienveillance capitaliste...

    Reply to this message

  • 1

    Bonjour,

    Est-ce que Rôles de documents sera compatible avec SPIP 3.3 ?
    En local je constate qu’avec SPIP 3.3.0-dev le menu de choix du rôle ne se déplie pas. À moins que ce ne soit un souci avec Chosen ?

    Merci,
    françois

    • Ça le sera forcément plus tard mais pour l’instant ce n’est pas du tout le cas et il ne faut pas essayer de l’utiliser avec (sauf pour dev pour aider à en faire une branche compatible :p). Il y a plein de changement des images avec les nouveaux logos en documents, et donc il y a possiblement pas mal de choses à revoir.

    Reply to this message

Any message or comments?

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document