SPIP-Contrib

SPIP’s friends

Home > English > Antifa-Spip

Antifa-Spip

Monday 2 February 2004

The Antifa Freiburg wrote some skeletons for SPIP and released them under the GPL. Please have a look and give us some feedback: webmistress at antifa-freiburg dot de
Antifa-SPIP

35968 discussions

  • 2
    Liberté

    Bonjour,

    Je ne trouve pas ce plugin dans la gestion des plugins, sous Spip 3.2.1.

    J’ai essayé avec: Modération de modifications, modifications, Modération, Proposer des Modifications, dupliquer.

    Pourriez-vous me dire son nom actuel?

    Reply to this message

  • 2

    mais un rédacteur restreint ne peut pas modifier un document joint dans l’article proposé.

    est ce qu’il y a un moyen pour l’autoriser.

    Reply to this message

  • 2

    Foundation/Zoundation s’appuient sur la grille float. Est-ce qu’il ne serait pas intéressant de prévoir une évolution qui permettrait de choisir la grille que l’on souhaiterait utiliser ?

    • On pourrait imaginer que le plugin intègre les 3 versions css et que le fichier de configuration du plugin soit chargé d’identifier la version choisie
    • Modifier les fonctions balise_blockgrid_grid() et balise_colonnes_grid() pour que le plugin retourne .row ou .grid-x etc... // .columns ou .cell etc...
    • et pour zoundation, remplacer les déclarations en dur genre
      1. <div class="column column-block">

      par des déclarations genre

      1. <div class="#COLONNES{arguments...}">

      qui renverraient le nommage de classe adapté à la version de grille choisie dans la config de foundation ?

    Mais c’est peut-être une approche naïve et que les choses sont un peu plus compliquées que cela...
    En tout cas, c’est vraiment un chouette outil

    • Bonjour,

      On pourrait mais il ne faut pas casser les sites actuelle.
      Regarde pour le faire évoluer sur la zone si cela te dit ;)

      Je n’ai pas le temps pour le moment.

    • Foundation/Zoundation s’appuient sur la grille float. Est-ce qu’il ne serait pas intéressant de prévoir une évolution qui permettrait de choisir la grille que l’on souhaiterait utiliser ?

      En effet, ce serait intéressant. Cela ne prendra que quelques heures de travail gratuit :). Dommage, je suis a court d’heure de travail gratuite.

      et pour zoundation, remplacer les déclarations en dur genre

      Il y a des déclarations en dur dans Zoundation ? Si c’est le cas c’est une erreur, je veux bien savoir ou elles se trouvent.

      Mais c’est peut-être une approche naïve et que les choses sont un peu plus compliquées que cela...

      Il faut que la grille “float” soit la grille par défaut.
      On ne peut pas simplement modifier la balise #COLONNES car la façon de générer les class CSS n’est pas vraiment pareil entre la grille X/Y et la grille float.
      L’idéal sera d’avoir des balises spécifiques.

    Reply to this message

  • 2

    bonjour,
    je viens d’installer SPIP 3.2.2 j’ai massicot 0.8.1 et PHP Version 7.0.33-0+deb9u1
    J’ai un pb lorsque je vais sur une vignette, modifier que je scrolle j’obtiens
    j’ai en dessous d’enregistrer , avant la saisie du mot clé

    Notice: Undefined variable: id_vignette in /var/www/stcleophas/plugins/massicot/massicot/massicot_pipelines.php on line 204

    • c’est une petite erreur. Pas très grave, mais c’est pas normal que ton hébergeur affiche publiquement les erreurs.

      je laisse bystrano corriger l’erreur s’il a le temps

    • Merci mais c’est ma faute.
      les erreurs étaient visible car sur ces 2 sites j’avais oublier de supprimer la vision des erreurs dans mes_options.php
      Ton message m’y a fait penser.

    Reply to this message

  • 1
    Delorimier

    Je cherche à ajouter automatiquement un seul mot-clé (toujours le même) aux articles enregistrés par un formulaire public, sans que le mot-clé soit visible dans le formulaire lui-même.

    Reply to this message

  • 6

    Bonjour,
    Merci pour ce gros travail sur le plugin.
    Maintenant que le plugin passe par #INSERT_HEAD, les ajouts sont les derniers avant la fin du head alors qu’auparavant, j’arrivais à placer les métas Open Graph dans les premiers ligne du head.
    Pourtant mon #INSERT_HEAD est placé avant d’autres insertions, Comment faire pour que les métas Open graph soient placées plus haut dans le head ?
    Depuis le changement, Facebook ne lit pas toujours bien ses métas et j’ai un problème avec Hootsuite qui ne récupère pas mes images correctement : il arrive même que Hootsuite récupère le pixel Piwik au lieu de l’image désignée. Mon “inclure” Matomo/Piwik est pourtant censé se placer après #INSERT_HEAD
    Par contre les métas twitter sont bien lues par twitter alors que se sont les dernières le mon head

    • La position des <meta> dans le <head> n’est pas censée avoir d’impact fonctionnellement. Et je n’ai rien vu de spécial d’indiqué de ce côté là dans les documentations d’open graph ou de twitter.
      Tu as vu des indications allant dans ce sens quelques part ?

      Facebook ne lit pas toujours bien ses métas

      Quel est le problème exactement ? Ça concerne toutes les metas, ou juste une partie (et si oui, lesquelles) ?
      Tu as testé avec l’outil de debug de facebook (et si oui, quel est le retour) ?

    • A priori Facebook s’arrête sur les métas “de base” en haut de <head> et ne descend pas jusqu’au métas open graph

      En haut de sa page debug il indique 3 alertes :

      • Propriété déduite : La propriété og :image doit être spécifiée de manière explicite, même si une valeur peut être déduite à partir d’autres balises.
      • Propriétés étrangères spécifiées : Les propriétés suivantes sont spécifiées sur la page web mais ne sont pas prises en charge pour le type ’og :type’ : fb:page_id spécifié
      • [fond jaune]Propriétés manquantes : Les propriétés requises suivantes manquent : og:url, og:type, og:title, og:image, og:description, fb:app_id[/fond jaune]

      Ensuite Facebook les construit bien “À partir des balises brutes, nous avons construit les propriétés suivantes Open Graph”

    • On va avoir besoin d’une URL là :)

    • Déjà sur le lien debug :)

    • Le robot de facebook a l’air d’être tatillon et de s’arrêter à la 1ère erreur, ou un truc comme ça. Quand je passe ta page au validateur w3c, il montre effectivement beaucoup d’erreurs
      C’est peut-être lié au doctype que tu utilises, ça ressemble au problème indiqué ici

      En tout cas, il n’y a pas de raison de changer la position des metas, ce serait une rustine pour contourner un problème qui n’a rien à voir.

    • Merci pour tes réponses.

      J’ai enfin pu trouver le temps d’essayer de régler le problème : j’ai trouvé un bout de code qui e baladait dans le <head> au lieu d’être en fin de <body>. Du coup, Facebook voit bien les données Open Graph dans le <head>. Facebook ne voit pas toujours tout du premier coup, néanmoins il remonte les éléments principaux : titre, url, images, author, publisher, description...

      Le validateur w3c voit toujours des erreurs dont certaines impossibles à régler comme le fait qu’il n’aime pas le prefix dans <html xmlns="http://www.w3.org/1999/xhtml" prefix="og: http://ogp.me/ns# fb: http://www.facebook.com/2008/fbml">, un bout de code qu’on est pourtant obligé d’avoir.

      On verra les autres erreurs sur la prochaine version du site.

      En tous les cas merci

    Reply to this message

  • Patrick

    Bonjour,
    J’utilise ce plugin depuis quelque temps avec bonheur.
    J’ai voulu tester en même temps le plugin “cibloc”.
    J’ai constaté alors un décalage des photos sur la gauche, avec déformation, lors du zoom.
    Une fois le plugin “cibloc” désactivé, tout est rentré dans l’ordre.
    Je voulais signaler le fait ici pour information.
    Encore merci pour ce plugin.

    Reply to this message

  • 5

    Si on a plusieurs url’s (alias) pour un secteur, serait-il possible de pouvoir en attribuer plusieurs dans le champs “Url du secteur” ?

    • C’est un contexte particulier, vous pouvez nous en dire plus ?

    • Ben dans ma configuration nGinx (vhost), mes deux domaines pointent sur le même dossier web:
      sousdomaine1.mondomaine.com -> /clients/web1/
      sousdomaine2.mondomaine.com -> /clients/web1/

      Coté DNS, ces instances pointent également sur le même serveur en IPv6 et IPv4.

      Dans Spip, au travers de la configuration du plugin Multidomaine, je ne peux renseigner que un seul domaine pour un secteur.

      Pourrait-on pas implémenter la possibilité de séparer par des virgules les différents domaines dans le champ “Url du secteur” pour qu’il les interprète ?

    • Bonjour,

      En fait tu veux afficher le même site sur 2 domaine ?
      Je vois pas l’avantage car google va dire que tu dupliques le site.

    • Exact. Pas grave. J’inderdit l’exploration du site aux moteurs de recherche mais j’aimerais continuer d’utiliser encore quelques mois les anciennes urls.

    • Ok dans ce cas pourquoi ne pas faire un autre secteur et tu double ton squelette pour faire ton idée ?

    Reply to this message

  • 12

    Bonjour,
    J’ai effectué ce matin la MAJ vers Pages 1.3.8. et là surprise mon site ne s’affichait plus, plus d’accès à l’interface privée non plus. J’ai donc par ftp remis la version Pages 1.3.7. et miracle tout est revenu.
    Je ne sais pas où se situe le problème. Je suis sous SPIP 3.2.1. Escal 4.2.33.
    Merci de votre aide.
    Yann

    • Il faudrait activer l’affichage des erreurs.

    • Quand je regarde mon fichier error_log je trouve ceci sur plusieurs lignes à l’heure où j’ai installé la MAJ :
      [Thu Jan 17 09:18:29 2019] [warn] [client 90.107.58.69] mod_fcgid: stderr: PHP Fatal error: Cannot redeclare autoriser_rubrique_creerarticledans() (previously declared in /var/www/vhosts/maisondesprovinces.fr/httpdocs/plugins/auto/autorite/v0.10.20/inc/autoriser.php:254) in /var/www/vhosts/maisondesprovinces.fr/httpdocs/plugins/auto/pages/v1.3.8/pages_autorisations.php on line 197

    • Bonjour,

      https://zone.spip.net/trac/spip-zone/changeset/113485/spip-zone devrait résoudre ton problème.
      Merci du signalement.

    • Merci beaucoup ! :-)

      Yann

    • Euh, en mettant à jour j’ai cette erreur : Impossible de lire certaines descriptions XML

      Erreur dans les plugins : auto/pages/v1.3.9

    • Pour le XML, ya que le numéro qui a changé dedans, donc je ne vois pas pourquoi ça péterait plus que le précédent. Super bizarre
      https://zone.spip.net/trac/spip-zone/changeset/113485/spip-zone

    • Je vois qu’il n’y a que 2 fichiers modifiés. Je peux essayer juste de remplace le fichier pages_autorisations.php sans toucher le fichier xml.
      Yann

    • Bonjour,
      Je viens d’avoir la même expérience, sur un SPIP 3.2.1 avec la version 1.3.8 du plugin Pages : même message d’erreur (Impossible de lire certaines descriptions XML). ça ne semble donc pas venir de la correction d’aujourd’hui.

    • Alors en remplaçant juste l’ancien fichier pages_autorisations.php par le nouveau et sans remplacer le fichier XML ça fonctionne. dès qu’on met le nouveau fichier XML ça foire. J’ai donc essayé en modifiant dans l’ancien fichier XML le numéro de version pour indiquer 1.3.9 ainsi que le https pour le lien SPIP en ligne 8 et ça marche. Plus d’erreur et la version du plugin indique bien 1.3.9

      Je ne vois pas ce qu’il peut y avoir sur le fichier XML livré avec la MAJ qui pose problème !

      Yann

    • Bonjour, La version 10 corrige le problème pour activé le plugin

    • Merci !

      Yann

    • Merci beaucoup, l’installation se fait désormais sans problème.

    Reply to this message

  • J’aimerais installer un .scss équivalent à perso. css
    et j’aimerais pouvoir changer couleur du site par couleur de l’auteur un peu partout
    J’ai besoin de conseils pour faire cela dans les règles. Merci

    Reply to this message

Any message or comments?

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document