Home > Editeurs WYSIWYG avant SPIP 1.9 > Intégration de l’éditeur Wysiwyg FCKEDITOR 2.0 à SPIP 1.8.x

Intégration de l’éditeur Wysiwyg FCKEDITOR 2.0 à SPIP 1.8.x

Monday 29 August 2005

On espère des nouvelles à chaque mise à jour !


View online : Intégration de l’éditeur Wysiwyg FCKEDITOR 2.0 à SPIP 1.8.1-d et 1.8.2

37898 discussions

  • 1
    Caroline

    Bonjour, est-ce qu’une mise à jour pour Spip 4.0 est prévue ? J’ai du mal à gérer mon site sans cet excellent plugin :)

    Reply to this message

  • bonjour
    spip 4.0.0
    je voudrais simplement que l’image soit au maximum en 1280px sur un ordinateur et n’ envoyer que 480 px sur un mobile. C’est a dire que si l’image est de 980px elle reste en 980px sur l’ordinateur et est en 480 sur le mobile.
    cependant , si je met image max a 1280px l’image d’origine par exemple de 980px se retrouve affichée agrandie a 1280Px malgré un max-width:100%;( juste deux breakpoint 480 et 1280)
    si je met 640 en image max avec des breakpoint je me retrouve avec une image plus petite et un lien vers l’image.
    Comment faire ?
    merci

    Reply to this message

  • Bernard

    Bonjour,
    Le plugin fonctionne très bien. Super!
    Je voudrais agrandir la taille des smiley, mais je ne sais pas où insérer le code :
    .smiley
    font-size: 1.2em;
    line-height: 1;

    Merci d’avance.

    Reply to this message

  • Bonjour,
    En version 4.3.4 la répétition d’événements est impossible. On peut créer un événement mais impossible d’ajouter des répétitions.

    Reply to this message

  • Je n’arrive pas à créer un pdf.
    Ce qui est curieux c’est que l’on voit, au début de la page en partie un affichage de menus de la partie côté privé !
    J’ai bien la version adaptée, avec remise à jour, au cas où, v1.0.12,
    En survolant le lien j’ai bien le lien

    http://domaine.tld/spip.php?page=article_pdf&id_article=65

    Merci de votre aide.

    Reply to this message

  • William

    Merci pour cette contrib qui m’a permis en 2021 de convertir une base d’un SPIP 3.2 pour passer en SPIP 4 avec succès

    Merci

    Reply to this message

  • Bonjour,
    Je débarque sous spip et je dois migrer un wp dessus.
    J’installe bien le plugin mais il n’y a rien dans
    menu ’configuration / migration depuis wordpress’ lancer la conversion.
    Je suis sous spip 3.2.11

    Reply to this message

  • Bonjour,

    J’aimerai personaliser un champs cree par le plugin, en lui ajoutant un attribut specifique. Pour ce faire, je comptais utiliser le pipeline “crayons_determine_input_mode_type_” et retourner un tableau.

    J’ai determine comment faire cela en lisant attentivement le code. Malheureusement, une ligne plus loin dans le code m’empeche de faire cela avec la limitation suivante (dans crayons_html.php, ligne 200):

    $user_inmode = $f($type, $champ, $sqltype);
    if (in_array($user_inmode, ['ligne', 'texte'])) {
            $inmode = $user_inmode;
    }

    Donc bien que l’on ait un pipeline sophistique pour pouvoir personaliser nos inputs avec des attributs supplementaires, ce filtre ne nous permet que de choisir entre “ligne” et “texte”.

    Est-ce possible de laisser passer les tableaux, en plus de “ligne” et “texte”?

    Reply to this message

  • Bonjour

    Je tente d’inclure une vidéo depuis une instance PeerTube installée chez nous. Quelles seraient les modifications à faire pour que le plugin accepte ce type de plateforme ?

    Je suis prête à faire le développement et à contribuer le code moyennant de me mettre sur la voie (je ne sais pas trop d’où partir).

    Reply to this message

  • 1

    Bonjour, et merci pour cette version adaptée à Spip 4.
    Dans Spip 3.2 il y avait une option “Déposer dans le portfolio” et “Retirer du portfolio”.
    Dans la version 4 cette option n’existe plus. Aussi comment faire pour que, sous la galerie Galleria ne s’affiche pas le portfolio, avec les mêmes images que celles de la galerie ?
    Merci

    • Je me réponds :
      “Suppression de la notion de Portfolio : pour cette version 4.0 uniquement ajout d’une constante _LEGACY_MODE_IMAGE_DOCUMENT qui permet de conserver le fonctionnement historique (distinction portfolio et images).
      Le plugin de rétro-compatibilité) permet d’activer ces deux constantes.” vu sur https://blog.spip.net/O-mega-c-est-SPIP-4-0-alpha.html
      Aussi comme il n’y a plus cette notion de portfolio et que Galleria fonctionne avec cette notion, la solution est d’installer le plugin “Modèles de documents SPIP 3.2” https://plugins.spip.net/historique_spip32_documents.html
      Les auteurs de Galleria ont ils une autre solution ?

    Reply to this message

Any message or comments?

Avant de faire part d’un problème sur un plugin X, merci de lire ce qui suit :

  • Désactiver tous les plugins que vous ne voulez pas tester afin de vous assurer que le bug vient bien du plugin X. Cela vous évitera d’écrire sur le forum d’une contribution qui n’est finalement pas en cause.
  • Cherchez et notez les numéros de version de tout ce qui est en place au moment du test :
    • version de SPIP, en bas de la partie privée
    • version du plugin testé et des éventuels plugins nécessités
    • version de PHP (exec=info en partie privée)
    • version de MySQL / SQLite / PostgreSQL
  • Si votre problème concerne la partie publique de votre site, donnez une URL où le bug est visible, pour que les gens puissent voir par eux-mêmes.
  • En cas de page blanche, merci d’activer l’affichage des erreurs, et d’indiquer ensuite l’erreur qui apparait.

Merci d’avance pour les personnes qui vous aideront !

Par ailleurs, n’oubliez pas que les contributeurs et contributrices ont une vie en dehors de SPIP.

Who are you?
[Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document