SPIP-Contrib

Toutes les contributions à SPIP

Accueil > Contribs à ranger > Nouvelle version de Bones Kubrick

Nouvelle version de Bones Kubrick

lundi 30 mai 2005

Le squelette adapté du theme Kubrick de Michael Heilemann vient de passer en version 1.8.
Il est disponible sur Spip-Contrib et vous pouvez participer à son développement sur Spip-Zone.

Les nouveautés de cette version :
-  internationalisation.
-  utilise le code de SPIP 1.8.
-  nouveaux forums breves et articles.
-  amélioration de l’esthétique (si par exemple, il n’y pas de breve, rien n’apparait).
-  utilise Nice Titles.
-  gestion des mots clefs, des inscriptions au site, proposition de site web.


Voir en ligne : démo sur Bones

36246 discussions

  • 1

    J’arrive à faire à peu près ce que je veux. Merci pour ce modèle élégant.
    C’est dommage d’avoir des ! important dans le fichier css du plugin car cela oblige à pas mal de hacks pour adapter les styles par défaut du modèle (par exemple avoir une couleur d’accent différente pour les :hover et pour les .on

    • Bonjour,
      généralement j’utilise en tout dernier recours ces règles, et sans avoir vérifié je pense que ça vient du thème Phantom lui-même...
      Ce sont quelles règles exactement ?

    Répondre à ce message

  • 2

    Bonjour,

    Nous rencontrons un problème à l’inscription à une newsletter avec double opt-in. La validation ne se fait pas lorsque l’on clique sur le bouton sur le mail de confirmation. On a ce message :

    You asked to subscribe to the newsletter XXXX with the address gilles.lachouette7@yopmail.com.
    An email was sent to this address for confirmation.

    Sur cette url : http://robomatix.net/imagesforum/spip/mail_subcribers-lists-190415-0907.png , une image avec les liste en attente général et de la newsletter. On voit que le statut des courriels est différent : « Not subscribed » pour l’une et waiting pour la liste de la newsletter.

    Seul lachouette7 compte, les autres ont été mis à la poubelle...

    Une idée pour résoudre cela.

    Spip 3.2.1

    MailShot 1.27.5 - stable

    Newsletters 1.6.1 - stable

    MailSubscribers 2.11.5 - stable

    PHP 5.6

    Toute aide sera grandement apprécié !

    Merci d’avance.

    Gilles L

    • Dans une tentative de comprendre ce qui se passe, j’ai trouvé plus ou moins là où ça se joue. Mais je ne suis pas sur de moi.

      Dans le fichier SPIP\plugins\auto\mailsubscribers\v2.11.5\newsletter\subscribe.php à la ligne 166, il y a le commentaire suivant :

      // une adresse en prepa reste en prepa tant qu’un email n’a pas ete valide

      Qu’est ce que cela veut dire exactement ?

      Merci de vos éclaircissements

      GillesL

    • Finalement, j’ai trouvé tout seul ! En fait les actions concernées étaient surchargée par des fichiers dans le dossier action du dossier squelettes. Je les ai récrites pour que ça marche avec la nouvelle version du plugin. Et voilà !

    Répondre à ce message

  • 2

    Bonjour,

    Sur de hébergement type cpanel, ou on peut donc activer au choix via l’admin
    j’ai eut quelques surprises souvent suivant ce qui est utilisé par des plugins.

    Actuellement j’utilise ça, il doit y avoir des choses inutiles :

    https://lite.framacalc.org/spip_php_extensions

    • Hello !

      Merci pour la liste !
      En lisant ton document, je vois « yaml », tu ne l’actives pas ? Je ne sais pas si le plugin YAML le nécessite ou pas…

      Pour spip_loader.php, tu as besoin de l’extension « zip » pour pouvoir télécharger les zip et les décompresser pour leur installation. De même pour SVP je crois.

      En fait… Il faudrait un plugin qui liste toutes les fonctions PHP utilisées/appelées dans le code source de SPIP et ainsi… de voir les modules associés.
      Peut-être que Lister les fonctions PHP de SPIP pourrait aider. Je ne sais pas… Faudrait que je me replonge là-dedans. ;-)

    • Hello,
      Pour yaml et zip , je vais les rajouter à la liste, la ce jeu est sur une mutualisation spip, donc je n’utilise pas svp et spip_loader, du coup ce n’étais pas activé.

      sinon je cherchais justement si y’avais pas une sorte de linter qui pourrais faire ça, y’a des outils d’audit de code pour php, mais un peut compliqué a mettre en place pour spip actuellement, peut être ce sera plus simple si composer est utilisé un jour.

    Répondre à ce message

  • 3

    Bonjour,

    Il y a à priori un souci avec la saisie de carte !
    cela ne fonctionne pas la ou elle est utilisée du moins selon ce que j’ai pu voir. En tout cas la recherche ne marche pas et il y a des erreurs JS.
    le souci semble lié à la fonction geocode qui ne reçois plus dans son query les valeurs de « departement » et « country_code ».
    En supprimant les deux lignes tout fonctionne correctement (fichier siaisies/carte.html ligne 90 & 93)

    Est ce que j’ai loupé quelque chose ou c’est bien un bug à corriger ?

    Merci pour votre travail

    • Salut, le problème est-il toujours d’actualité ? De mon côté, je n’observe pas de bug lors de la recherche avec le saisie carte.

    • Bonjour,

      Oui le problème est toujours d’actualité, et vous ne remarquez pas le souci sur la recherche dans l’interface privée car elle n’exploite pas saisie. Dès que vous exploitez saisie il y a des erreur JS qui apparaissent du fait de l’inexistance des champs query.departement et query.country_code

    • Salut,

      vous ne remarquez pas le souci sur la recherche dans l’interface privée car elle n’exploite pas saisie

      Je ne comprends pas cette remarque, GIS utilise bien saisies, et quand je parle de la recherche, c’est bien de celle proposée par la saisie carte de GIS. Sans plus d’infos je ne pourrai pas t’aider, dans quel contexte utilises-tu la saisie carte ? Dans un dev perso ou dans le formulaire editer_gis ? Quelle est la configuration de GIS que tu utilises (affichage des champs d’adresses ou non, etc) ?

    Répondre à ce message

  • baloo

    Bonjour,
    si je met dans un modele : #LOGO_SITE * je vois bien le logo dans le texte de l’espace privé

    le code généré étant

    <a href="..">
    <img class="spip_logo spip_logos" alt="Lien vers : Paroisse catholique Saint Jean-Baptiste du Lez .Une paroisse qui accueille" src="../local/cache-vignettes/L144xH184/siteon37-3aab4.jpg?1555778122" width="144" height="184">
    
    </a>

    si je met dans le modele #LOGO_SITE je ne vois pas le logo dans le texte de l’espace prive

    cela viendrait de balises « code » qui se rajoute automatiquement ?

    <code class="echappe-js">
    
    <img src='../local/cache-vignettes/L144xH184/siteon37-3aab4.jpg?1555778122' alt='' class='spip_logo spip_logos' width='144' height='184' onmouseover='' onmouseout='' >;

    sachant que j’utilise le plugin adaptive images est-ce que cela peut venir de la ?
    est-ce que le rajout d’une balise peut remédier au pb ?

    merci

    Répondre à ce message

  • avec le fichier standard backend et inc-item-rss de squelettes-dist et le plugin . Lorsque j’ai <embxx|center> d’un pdf dans le texte , j’obtiens

    <content:encoded><div class='rss_texte'><!--[if !IE]><!--><iframe src="spip.php?page=pdfjs&id_document=2191" width="490" height="600" class="lecteurpdf lecteufpdf-2191 spip_documents spip_documents_center" name="pdf_2191" allowfullscreen></iframe><!--<![endif]-->
    <!--[if IE]><iframe src="IMG/pdf/lefichier.pdf" width="490" height="600" class="lecteurpdf lecteufpdf-2191 spip_documents spip_documents_center" name="pdf_2191" allowfullscreen></iframe><![endif]--></div>
                    
                    </content:encoded><enclosure url="https://nomsite/IMG/pdf/lefichier.pdf" length="375840" type="application/pdf"/>

    ce qui peut poser un problème de récupération des informations.
    Savez comment il faudrait gérer ce cas dans le backend pour que cela soit correct
    merci

    Répondre à ce message

  • Bonjour
    Je dépose ce message car je m’arrache un peu les cheveux avec un site (SPIP 3.0.13 ) et Mailshot (1.27.5) hébergé chez OVH : j’ai paramétré Sparkpost qui fonctionne très bien avec Mailshot chez un autre hébergeur, (1&1 Ionos pour ne pas le citer) mais chez OVH, le fonctionnement semble totalement aléatoire, quoi que j’ai essayé : souvent l’envoi (à une liste de plus de 200 abonnés) une fois lancé ne progresse pas : il reste à 0 sur 200 abonnés.
    J’ai essayé de limiter la cadence sans résultat. Quand je recoche Envoi rapide, ça fonctionne en relançant un autre envoi, mais la fois suivante, ça ne fonctionnera pas si j’ai laissé sur Envoi rapide.
    IL semble très difficile de trouver une logique au fonctionnement des envois.
    Est-ce que d’autres ont un exemple de configuration chez OVH qui fonctionne ? Merci.

    Répondre à ce message

  • Bonjour,

    J’utilise les QCM depuis plusieurs années. Depuis déjà quelques temps, certains utilisateurs des jeux me disent que les corrections des QCM ne s’affichent pas sur leur ordinateur. Quelle peut-être l’origine de ce souci. Pour ma part, les corrections s’affichent très bien sous windows 10 et avec le navigateur Mozilla Firefox. Merci pour vos idées et bon week-end, Thierry

    Répondre à ce message

  • 3

    vu que le plugin n’a pas été modifié pour les der,ières versions de spip
    je note ici les petite requête anti chars à lancer dans mysql

    DELETE FROM `spip_referers` WHERE `spip_referers`.`referer` like '%.ru%' ;
    DELETE FROM `spip_referers` WHERE `spip_referers`.`referer` like '%porn%' ;
    DELETE FROM `spip_referers` WHERE `spip_referers`.`referer` like '%pizza%' ;
    DELETE FROM `spip_referers` WHERE `spip_referers`.`referer` like '%buy%' ;
    DELETE FROM `spip_referers` WHERE `spip_referers`.`referer` like '%fuc%' ;
    • Peux-tu expliquer un peu plus ton message ? Il me semble que le plugin fonctionne bien avec les dernières versions de spip, et je ne vois pas trop en quoi les requêtes sql que tu listes ici peuvent aider les autres utilisateurs.

    • Bonsoir,
      le plugin n’est apparemment pas indexé par SVP, je n’avais pas vu qu’il était compatible car il n’y avait pas de maj disponible dans la page des plugins.
      J’ai donc lancé des requêtes sql qui permettent d’effacer rapidement les spams referers, tout simplement :) Merci pour ton plugin très pratique et qu’il faut activer en copiant le lien donné sur cette page.

    • Je venais juste de corriger mon précédent message après avoir compris que tu proposais une méthode manuelle pour supprimer les referers, j’avais lu un peu trop vite, Si le plugin n’apparait pas dans le gestionnaire de plugins, il faut ajouter le dépôt « externals » comme indiqué plus haut. Je suis content de savoir que ce petit plugin sert encore :)

    Répondre à ce message

  • 1

    Bonjour,

    Dans l’origine des visites, chez moi 311sites j’ai : <3 visites (email) > sans bouton spam
    Comment faire pour enlever cette ligne ?
    Je ne peux pas pas vérifier les 311 sites. Ils ne sont pas listés même si j’appuie sur les 3 + .

    • Bonjour,
      Les liens en provenance de messageries en ligne sont en grande partie regroupés sous cette ligne et ce plugin ne permet pas de faire le tri parmis ceux-ci de façon efficace, il faudrait pour cela modifier le plugin « statistiques » du noyau de spip, mais ces liens ont en fait assez peu de chance d’être des spams.

      Le problème ici tient peut-être du fait que le nombre total de sites est erroné et n’exclue pas les sites marqués comme spam à cause d’un bug qui sera corrigé dans la version 0.2.8.

    Répondre à ce message

Un message, un commentaire ?

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document