SPIP-Contrib

SPIP’s friends

Home > Pequeño Manual del Usuario de SPIP

Pequeño Manual del Usuario de SPIP

Tuesday 10 February 2004

Germán, del proyecto atarraya, propone un manual del usuario SPIP en español, que ya se plebiscita en la lista spip-es.


View online : Pequeño Manual del Usuario de SPIP

37502 discussions

  • Je cherche une fonctionnalité de “pré-réservation” sans paiement immédiat pour une boutique existante (avec les plugins bank / produit / transaction / facture paramétrés)
    Le but est que le jour J du lancement de la vente les acheteurs (inscrits) retrouvent leur commande et choisissent leur moyen de paiement pour finaliser la transaction.
    Il me semble qu’il n’est pas possible pour un acheteur de modifier le mode de transaction une fois qu’il a cliqué sur “payer par chèque” (par exemple).

    Je pourrais avoir un formulaire formidable de pré-réservation mais alors les acheteurs devraient recommencer tout le processus d’achat des produits lors de l’activation des moyens de paiement en ligne.

    Merci
    dd

    Reply to this message

  • Bonjour
    J’utilise ce plugin avec un nouveau site (spip 3.2) et un thème html5up (Spectral)
    J’ai repris d’anciens articles et rubriques contenant cycle2 pour des images en album.

    J’ai été surpris que dans une rubrique,
    -  le modèle <albumN|cycle> permet bien d’afficher les images de l’album
    mais que dans un article (de cette meme rubrique)
    -  le modèle <albumN|cycle> n’affiche pas les images de ce même album

    le mode inclure indique dans les 2 cas

    plugins/auto/sjcycle/v3.4.20/modeles/album_cycle.html
    plugins/auto/sjcycle/v3.4.20/modeles/article_cycle.html

    mais seul dans la rubrique les images s’affichent

    Je ne me souviens plus en spip 2.X comment se comportait de telles configs,

    que dois-je en penser ?
    Merci

    Reply to this message

  • Bonjour,

    Les versions 1.3.1 et 1.3.2 ne récupèrent pas la couleur choisie dans le formulaire de paramétrage.

    La couleur accentuée est systématiquement remplacée par la couleur par défaut : #f56a6a

    Et effectivement, dans main.css qui a remplacé main.scss, on constate par exemple que les lignes :
    ====
    _button/scss:23 color: _palette(accent) !important;
    ====
    sont systématiquemt remplacé par la couleur par défaut en dur.
    ====
    mains.css:1501 : color: #f56a6a !important;
    ====

    Reply to this message

  • 1

    Bonjour

    Sur ce site https://physique-chimie.enseigne.ac-lyon.fr/spip/ on affiche quelques videos dans une noisette grâce au plugin Video(s) et le raccourci

    #MODELE{video,document=#ID_DOCUMENT}

    Mais dès que l’on active le plugin ciwidget l’affichage des videos issues de Youtube est dégradé : affichage d’une vignette au lieu de la video + titre + texte

    Une idée de l’origine du problème ?

    • Bonjour,
      Le plugin Vidéos surcharge le modèle “video” de SPIP et le plugin CIWIDGET surcharge également le modèle “video” de SPIP.
      Pour rendre prioritaire le modèle du plugin Vidéos, une solution consiste à remplacer, dans le fichier paquet.xml du plugin Videos, la ligne :

      <utilise nom="figure" compatibilite="[0.2.8;["/>

      par :

      <utilise nom="figure" compatibilite="[0.2.8;["/>
      <utilise nom="ciwidget" compatibilite="[1.0.0;["/>

    Reply to this message

  • 1

    Bonjour,
    (je ne vois pas mon message écrit hier, alors je le reposte)
    Mon site est sous SPIP 3.2.9
    J’ai installé la version 3.0.1 et cela ne fonctionne pas. La version 2.0.3 fonctionne mais enlève le crédit de ma photo.
    Le crédit est indiqué avec un développement fait par un ami (je ne suis assez doué pour ma part...) placé dans “squelettes/modeles/doc.html” :

    [] [(#ENV{mode_force,#MODE}|=={image}|oui) #SET{fichier,#URL_DOCUMENT} #SET{width,#LARGEUR} #SET{height,#HAUTEUR} #SET{url,#ENV{lien}} ] [(#ENV{mode_force,#MODE}|=={image}|non) [(#SET{fichier,[(#LOGO_DOCUMENT|extraire_attribut{src})]})] [(#SET{width,[(#LOGO_DOCUMENT|extraire_attribut{width})]})] [(#SET{height,[(#LOGO_DOCUMENT|extraire_attribut{height})]})] #SET{url,#ENV{lien,#URL_DOCUMENT}} ][][ (#ENV{largeur,0}|ou{#ENV{hauteur,0}}) #SET{fichier,#GET{fichier}|image_reduire{#ENV{largeur,0},#ENV{hauteur,0}}} #SET{width,#GET{fichier}|largeur} #SET{height,#GET{fichier}|hauteur} #SET{fichier,#GET{fichier}|extraire_attribut{src}} ]
    
    []#TYPE_DOCUMENT - [(#TAILLE|taille_en_octets|texte_backend)][(#GET{url}|?{})]
    [
    (#TITRE)
    ]
        [(#DESCRIPTIF|PtoBR)[(#NOTES|PtoBR)]][ (Crédit © (#CREDITS|PtoBR))]
    
    #FILTRE{trim} 

    Pour mon exemple, j’ai balisé <doc2719|alt=c'est le plus beau de tous les enfants du monde> dans mon article d’essais divers http://www.patcatnats.fr/spip.php?article867.
    Merci pour votre attention à mon message et éventuelle correction et surtout merci pour votre travail.
    Patrice

    • effectivement ce n’est pas prévu pour lé’instant. La version 3.3 de spip devrait le proposer, normalement.

    Reply to this message

  • 2

    Bonjour,
    et grand merci
    Cela fonctionne très bien sauf pour les champs extra obligatoire
    Je suis sous spip 3.1, champ extras3.13.2, Réservation Événements 2.1.1
    J’ajoute le champ “Tél” comme obligatoire
    Il apparait bien dans le formulaire comme “obligatoire”
    Mais l’enregistrement ce réalise même s’il est vide

    Erreur de ma part ?
    Par avance merci
    Bruno

    • Bonjour Bruno,

      effectivement la validation des champs extras reservation fonctionnait pas. C’est corrigé dans la version 2.1.2

      Rainer

    • Bonjour,
      Merci, après mise à jour cela marche

      Bonne journée
      Bruno

    Reply to this message

  • 2

    Bonjour,

    Avec un Spip 3.2.9, Mailsubcribers 2.15.4 et Spip Bonux 2.3.6 , je ne parviens pas à utiliser l’import d’un fichier CVS afin qu’il envoie des messages de confirmations aux adresses importées, pour obtenir le consentement.

    Le double OPT-IN est activé dans la configuration.
    Quelle que soit la configuration :

    • uniquement un mail par ligne
    • ou avec la colonne “statut” et “listes” (la valeur de “statut” ayant été testé avec “prop” et “prepa”)

    Quelqu’un aurait une piste svp ?

    • quelqu’un a rapporté un bgu similaire il y a peu. Je ne connais pas le dossier, mais essaye de mettre à jour bonux en 3.7.2

    • Merci pour le retour, mais il y avait une erreur dans mon descriptif, pardon.
      SPIP Bonux est déjà en version 3.7.2 - stable et pas en 2.3.6 comme je le disais

    Reply to this message

  • 3

    Le plugin a l’air très bien.
    Malheureusement pour moi (sur un SPIP 3.1), le div.row englobant n’est pas créé. Mais j’ai bien les div.spip_colonne.
    Pour info, j’ai installé Raccourci colonne et SCSS PHP, mais pas HTML5up.
    Je comptais gérer les colonnes avec bootstrap en personnalisant spip_colonne.js.

    • Je ne vois pas comment t’aider, tu as un lien ? le row est créé en js, quel message de console as-tu?

      Et sinon, il est toujours judicieux de se mettre à la dernière version stable SPIP :)
      ++
      touti

    • Merci pour ta réponse rapide.
      J’ai suivi les conseils de Philippe (plus bas dans ce forum), j’ai intégré le fichier spip_colonne.js dans mon squelette, et là, ça fonctionne… Je ne sais pas pourquoi.
      J’ai stylé les css en bootstrap dans le fichier js, ça marche très bien.

      Le seul bug que je ne comprends pas, c’est lorsque les colonnes commencent toutes par un intertitre (h3), la présence d’une balise <p></p> vide en début de toutes les colonnes sauf la première…

    • Résolu en séparant bien les balises dans le champ texte.
      Après des tests, ce bug ne vient pas du plugin.

      <colonne>
      
      Titre (le h3)
      
      Texte
      
      </colonne>
      
      ...

    Reply to this message

  • 5

    Bonjour Maieul,
    Je rencontre des soucis avec la toute dernière version.
    Ca fait 24h que je me casse la tête sur un nouveau bug sur les sites de mes clients, pour enfin réaliser que cela provient de la dernière mise à jour...
    J’ai regardé les modifs et commentaire sur Git.
    Le problème est le suivant :
    J’utilise des champs extras sur des événements, j’utilise la fonction “afficher_si” sur nombre de ces CA, et même en cascade...
    Désormais quand je modifie un événement, des données (des CAs) sont supprimées de la BDD, alors qu’ils sont liés à des champs bien affiché... C’est très impactant comme soucis...

    Je déduis donc que le nouveau comportement d’afficher_si qui “reset” les datas des champs non affichés, semble également vider des champs affichés ...
    Je vais ajouter des afficher_si_avec_post" => True à gogo pour voir si ca aide mais malgré tout, je pense qu’il y a une coquille qqpart.
    Merci de ton assistance.
    JuL

    • hum. C’est vraiment très très étonnant ton affaire.

      Pourrais tu m’exporter tes champs extras ?

      en attendant je vais supprimer le tags, par précaution. Mais j’avais testé chez moi.

    • Je peux pas les exporter aux formats YAML car je les déclare en php dans mon plugin. Il sont très nombreux et il y a plein de php autour donc tu pourras pas faire un test facilement.

    • envoi moi ton php alors :)

    • en tout cas je viens de retester, et je ne reproduis pas...

    • Suite et fin de l’épisode

      pour info, on a debuger un cas de bug sur les afficher_si, qui peut
      expliquer le bug que tu as eu en janvier.

      Cela se produisait si un champ A était conditionné par la valeur d’un
      champ B qui se trouvait dans un autre fieldset.

      la dernière version de saisies 3.47.3 corrige cela.

    Reply to this message

  • Bonjour

    Ce qui serait vraiment cool c’est qu’on puisse aussi utiliser des vidéos hébergées par Peertube qui est de plus en plus utilisé dans les académies.

    Reply to this message

Any message or comments?

Who are you?
[Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document