SPIP-Contrib

Toutes les contributions à SPIP

Accueil > Contribs à ranger > SPIP préinstallé sur Free

SPIP préinstallé sur Free

mercredi 16 mars 2005

L’hébergeur gratuit free propose à présent d’installer automatiquement une sélection de 11 logiciels PHP/MySQL gratuits.

SPIP fait partie de la sélection !

Présentation rapide

Free utilise la dénomination de “modules” pour ces logiciels pré-installés.

Il est même possible de demander la mise à jour automatique du “module” en cas de nouvelle version !

Texte de présentation de free :

Les “modules” enfichables sont des applications dynamiques, grand public courament utilisées, adaptées et optimisées par Free, pour l’hebergement Free.

Attention : Avant de pouvoir vous en servir, vous devez impérativement avoir activé votre compte pour les pages personnelles ainsi que la base de données (fonctionnelle) associée.

A noter

À cette date (15 mars 2005), ce systeme est en phase de lancement. Durant les premieres semaines, les activations seront manuelles. Elles seront effectuées au moins toutes les 24h.

L’installation d’un “module” ne se fera pas si un dossier porte le meme nom que le dossier par défaut du module (“/spip”).
De meme, l’installation ne fonctionnera pas si votre base de données n’est pas créée et fonctionnelle, ou si le nom d’une table deja presente est identique a celui d’une table en cours d’installation (préfixe des tables : “spip_”).

En savoir plus

-  Questions/Réponses (“Comment ca marche ?”, “Retenter l’installation ?”, “Desinstaller un module ?”, “Redirection automatique de la racine vers un répertoire du site”)
-  Gérer son espace web free
-  Formulaire d’activation des modules


Voir en ligne : Formulaire d’activation des modules sur free

36081 discussions

  • 2
    Naema

    Je rejoins l’avis de beaucoup : très, très joli jeu d’icônes ! Merci beaucoup. Une suggestion si vous comptez poursuivre le développement : prévoir un changement de couleur (via un filtre automatique (type |couleur_inverser, je ne sais pas si c’est possible ?) pour les icônes les plus foncées (article, message en taille 16 par ex.) de façon à conserver le contraste lorsque l’utilisateur a défini des couleurs d’environnement déjà foncées (par ex.j’ai ajouté, via mes_options, des couleurs à la définition des couleurs personnalisées d’interface, en gris très foncé). En tous cas le set de 3 plugins est vraiment un « plus » pour l’interface, merci encore.

    • Hello,
      Merci pour le commentaire :)

      Le développement de ces plugins est arrêté, en dehors des corrections de bugs et éventuelles petites améliorations rapides à faire.

      Effectivement il faudrait pouvoir ajuster en certains endroits la luminosité des icônes en fonction de la couleur de fond, mais c’est assez compliqué en l’état sans surcharger des squelettes du privé. Idéalement il faudrait utiliser des icônes au format svg afin d’avoir complètement la main sur les couleurs dans le CSS.

      Je m’intéresse plus au projet de refonte globale de l’espace privé, qui finira bien par arriver un jour. En attendant, il y a un successeur spirituel au plugin, mais qui est complètement expérimental et pas fini : https://github.com/tcharlss/griseus2000 (attention j’insiste : pas utilisable en vrai :p)

    • Ps : quand je dis que le dev est arrêté, je parle pour moi. Libre à qui le souhaite de contribuer bien sûr.

    Répondre à ce message

  • Ne sachant si d’autres ont eu le même souci, voici le problème rencontré : en Spip 3.2.3 avec Php 7.2.13, l’installation du plugin s’est déroulée sans encombre... jusqu’à l’installation du plugin Orthotypographie - et là, un premier bug (élargissement extrême des fenêtres de navigation, et y compris les autres sites que je visitais, tels que contrib.net !) ; mise à jour du plugin Orthotypo et je crois que cela a été fatal : gros plantage php (page blanche), non résolue ni par la suppression des deux plugins via FTP, ni par le redémarrage de mon site (via l’hébergeur). Il a fallu que je ré-installe entièrement SPIP (avec spip-loader + réinstallation de l’intégralité des dossiers personnalisés). Grand dommage. J’ai réinstallé Orthypo, mais pas Agrandir la page, tant pis. Je partage au cas où, pour information dans les futurs développement de ce plugin.

    Répondre à ce message

  • 3

    Y’a t’il une raison technique/fonctionnelle qui empêcherait l’attribution de COULEURs aux objets groupe_mots ? => en SPIP 3.2 les premiers tests semblent OK pour cet objet...

    Répondre à ce message

  • 2

    Bonjour,

    Sur un site, j’ai une majorité d’événements d’une journée et quelques fois des événements annuels. J’aimerais savoir s’il est possible de construire une boucle qui ne prendrait en compte que les événements d’une durée de moins de 3 mois ?
    Sauriez-vous me dire comment ou m’orienter ?
    En vous remerciant

    • Hello,

      Une boucle comme :
      <BOUCLE_vevent(EVENEMENTS){par date_debut}{age_fin<=0}{age_debut>=-16}{unique}>...

      sélectionne les évènements relatifs à la date actuelle. Donc dans cet exemple qui ont une date de fin entre maintenant et dans 16 jours

    • Hello,

      Une boucle comme :
      <BOUCLE_vevent(EVENEMENTS){par date_debut}{age_fin<=0}{age_debut>=-16}{unique}>...

      sélectionne les évènements relatifs à la date actuelle. Donc dans cet exemple qui ont une date de fin entre maintenant et dans 16 jours

    Répondre à ce message

  • 2

    Bonjour,

    J’ai migré spip de la version 1.9.2 à la version 3.2. Tous fonctionne correctement excepté mon mini-calendrier.
    Mon problème est qu’une grande partie de événement n’apparait pas dans le mini-calendrier. J’appelle mon calendrier avec ceci :

    1. #CALENDRIER_MINI{#ENV{date},date,#URL_PAGE{jour}}

    J’ai comparé les entrées dans la DB entre un événement qui fonctionne et un autre non. Aucun changement de valeur qui pourrait être la cause, rien dans les logs.

    Je ne sais plus où chercher. Pouvez-vous m’aider ?

    • Avec ceci le problème est corrigé :

      [(#CALENDRIER_MINI{#ENV{date},
      date,
      #URL_PAGE{page-jour},
      #URL_PAGE{calendrier_mini_event.json,id_rubrique}})]

      Mais un autre problème est toujours présent. Le mois de décembre dans mon mini-calendrier charge en boucle et n’affiche pas les événements. Il y a plusieurs mois qui ont ce problème (environ 1 sur 2). Merci de m’aider.

    • Je répond un peu tard, mais j’ai eu le même problème. Le calendrier tourne en boucle quand il y a des accents dans le titre de l’événement. Un bug ?

    Répondre à ce message

  • Bonjour !
    Plugin intéressant, malheureusement, je perds mes sous-menu quand le plugin Responsive Nav est activé. Les menus sont bien là, car ils apparaissent en partie selon la largeur de l’écran. J’ai tenté de déactiver le « overflow:hidden », mais ça ne change rien. Auriez-vous une idée ?

    Voir : https://www.veganequebec.net/

    Merci !

    Répondre à ce message

  • Bonjour

    j’ai le plaisir d’informer, si ça na pas déjà été fait ailleurs, que ce plugin fonctionne parfaitement avec mlmmj :)

    Il suffit de configurer les adresses d’abonnement et de désabonnement (en genéral maliste+subscribe@domain.tld et maliste+unsubscribe@admin.tld)

    Répondre à ce message

  • 1

    Voilà ma requete SQL :

    SELECT `nom`, `valeur`, `maj` FROM `spip_formulaires_reponses_champs` AS f
    WHERE `id_formulaires_reponse` IN
    (
    SELECT `id_formulaires_reponse`
    FROM `spip_formulaires_reponses_champs` AS ff
    WHERE `nom`= ’selection_1’ AND `valeur`= ’03’
    )

    On dit ça comment en spip ?

    • Bon, niveau SQL j’aurais fait une jointure plutôt tqu’une requete imbriqué.

      Mais peu importe, en SPIP on ferais

      <BOUCLE_champs(FORMULAIRES_REPONSES_CHAMPS){nom=selection_1}{valeur=03}>
      <BOUCLE_reponses(FORMULAIRES_REPONSES) {id_formulaires_reponse}>
      #VOIR_REPONSE{xxx}
      </BOUCLE_reponses>
      </BOUCLE_champs>

      Donc
      1. On boucle en demandant toutes les entrées qui répondent au critère nom=selection_+ et valeur=03
      2. A l’intérieur de cette boucle, on boucle sur toutes les réponses dont l’id_formulaires_reponse} correspond
      3. Et là, on utilise #VOIR_REPONSE (mais c’est propre à Formidable, qui est dérogatoire par rapport à SPIP)

      ps : merci à l’avenir de répondre en dessous du message, et de ne pas rouvrir un fil de discussion à chaque fois

    Répondre à ce message

  • Bonjour, j’essaye de bien assimiler vos informations.

    Je suis allé faire un tour dans la BDD, j’ai vu que les réponses se trouvaient bien dans la table formulaires_reponses_champs

    Cette table a les champs suivants :
    maj
    id_formulaires_reponses_champ
    id_formulaires_reponse
    nom
    valeur

    -  nom : contient le nom système des champs du formulaire,
    Par exemple, celui qui m’intéresse se nomme « seccion_1 »
    -  valeur : contient la valeur fournie par celui qui a rempli le formulaire [en l’occurrence, il s’agit d’une liste de sélection avec des valeurs prédéfinies].
    Dans mon cas, je peux par exemple choisir la valeur : « 03 » qui correspond au département de l’Allier.
    [Ultérieurement, j’ai intérêt à jouer sur la valeur de la rubrique comme variable d’environnement. Un seul squelette secteur, et un numéro de rubrique correspondant au département.]

    Or vous m’indiquez les critères :
    valeur=XXX Cela signifie-t-il bien, la valeur de l’enregistrement qui m’intéresse. Ex. valeur=03
    champ=yyy > nom=seccion_1 où « champ » est le nom du champ de la table, et « yyy » la valeur que je veux sélectionner ?

    Exemple pour mon test :


    J’ai plus de mal pour la suite.
    « remonter à l’idenfiant de la réponse »
    « puis de boucler sur celle ci. »
    C’est peut être ce concept spipien d’environnement qui joue dans l’inclusion des boucles et évite des variables ??

    Mais, alors…
    Je récupère quel id ? et pour passer par la Boucle formulaire_reponse [ce qui suppose une jointure] ? ou rester dans une boucle formulaire_reponses_champs ?
    c’est à dire :
    SELECT id_formulaires_reponses_champ / id_formulaire_reponse ??
    FROM formulaires_reponses_champs
    WHERE nom LIKE ’03’

    J’ai bien relu les bases de la doc, mais pas encore assimilé le Spipien.
    J’ai espoir que mes tribulations puissent servir à d’autres..
    Merci

    Répondre à ce message

  • 2

    Bonjour,
    Sur des sites SPIP 3.2.3 avec massicot 0.8.6 - stable j’ai un effet de bord très embêtant : lorsque j’active massicot je n’ai plus la possibilité de mettre les documents dans le portfolio : le bouton « Déposer dans le portfolio » n’est plus visible.

    <button type="submit" class="submit btn ajax">Déposer dans le portfolio</button>

    pour son pendant « enlever du portfolio » : idem.

    merci

    • Salut,

      La version 0.8.7, qui vient de sortir, devrait corriger ce problème. Merci pour le signalement !

    • Merci ! Ça fonctionne.

    Répondre à ce message

Un message, un commentaire ?

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document