SPIP-Contrib

Toutes les contributions à SPIP

Accueil > Contribs à ranger > Squelettes dixminutes.ouvaton.org

Squelettes dixminutes.ouvaton.org

jeudi 14 septembre 2006

Après que plusieurs personnes m’en ai fait la demande, je me suis décidé à diffuser les squelettes SPIP pour dix minutes v3. J’étais parti pour les améliorer encore un peu, mais c’était il y a plus d’un an... depuis, spip 1.9 est sorti... Bref, les voici !

Ces squelettes ont été optimisés pour spip 1.8. la version qui tourne sur le site est la 1.8b2g.

Ils ne fonctionnent probablement pas en spip 1.9, mais je n’ai pas essayé. Le systeme de pagination de ces squelette est d’ailleurs un gros bricolage de code php, la version 9 de spip propose désormais sa propre balise #PAGINATION, ce qui est nettement mieux.
Ils fonctionnent bien avec firefox, safari et internet explorer 6. Sous ie6, Le menu de gauche défile avec la page alors qu’il est fixé dans les autres navigateurs.

Si quelqu’un utilise ces squelettes ou les améliore, il sera bien gentil de me le signaler ;-)

ps : dix minutes est la version 3 (completement remaniée) des squelettes splog, dispos sur spip contrib


Voir en ligne : Squelettes dix minutes ici

36149 discussions

  • 2

    Bonjour,
    Je viens de faire la mise à jour et j’ai ce message juste sous le bandeau d’en-tête (dans l’espace administrateur)

    Erreur dans les plugins : /home/monidentifiant/www/plugins/auto/formidable/v3.36.3/formidable_pipelines.php

    Quelqu’un peut me dire ce que cela veut dire et pourquoi j’ai ça ?

    • Le cache der SPIP a-t-il bien été vidé ?

    • je ne pense pas que ce soit un problème de cache. On dirait plutot que le ficheir de pipelines a mal été installé.
      Est-ce que tu peux regarder si le fichier est bien présent ?

    Répondre à ce message

  • 2

    Bonjour,

    En faisant la mise à jour de « Formidable », le plugin « NoSPAM » était demandé.

    Avec le couteau suisse j’avais pourtant activé :
    Sécurité -> Lutte contre le SPAM

    Les deux sont-ils compatibles ? je ne comprends pas pourquoi ce plugin supplémentaire ?

    Merci d’avance si quelqu’un pouvait m’expliquer cela.

    Répondre à ce message

  • 1

    Tickets est installé sur http://programmer.spip.net (en SPIP 3.2.3 SVN [24210]) je constate qq problemes :
    -  1) il n’y a pas d’accés aux tickets dans le menu Editer (mais un accés direct à la page https://programmer.spip.net/ecrire/?exec=tickets donne bien la liste des tickets)
    -  2) les balises cadres dans les tickets s’affichent mal dans le public : exemple là https://programmer.spip.net/Expliciter-le-cas-de-figure-ou-il-y-a-plusieurs-fonctions-dans-un-fichier?var_mode=recalcul On voit le html <span class="kw2">function</span> inc_patates_eplucher<span class="br0">&#40;</span><span class="re0">$nb</s...
    -  3) dans le paramétrage du plugin, onglet « classification », il y a des liens dont c’est le html qui est visible : Les groupes qui peuvent actuellement être liés aux tickets sont les suivants : ⚠️ <a href=https:// programmer.spip.net /ecrire/?exec= groupe_mots &id_groupe=19> Sévérité</a>, <a href= https://programmer.spip etc etc etc

    Répondre à ce message

  • 2

    Bonjour,
    J’ai réussi à colorer mes titres d’articles avec :

    <BOUCLE_art(ARTICLES){tout}>
    [.inner#ID_ARTICLE h1 {color:(#COULEUR); }]
    </BOUCLE_art>

    Si je tente

    <BOUCLE_art(ARTICLES){tout}>
    [.inner#ID_ARTICLE h1 {color:(#COULEUR{parent,recursif}); }]
    </BOUCLE_art>

    ça ne fonctionne pas même si j’ai attribué une couleur à la rubrique parente
    (j’ai bien installé le plugin Déclarer le parent 1.3.5 - dev)

    Vive le noir & blanc.

    • Salut,

      Je ne reproduis pas cette erreur.
      Dans le 2e exemple l’article n’a pas de couleur, mais la rubrique parente oui, c’est ça ?
      Est-ce que tu as polyhiérarchie ? Si oui, l’article est enfant direct ou indirect ?

    • Merci de ta réponse. Oui c’est ça l’article est enfant d’un secteur qui lui a une couleur. Je n’ai pas polyhiérarchie.
      Je continue mes tests.

    Répondre à ce message

  • Bonjour,

    Merci pour ce plugin, je souhaite l’intégrer à mes sites mais je rencontre quelques soucis, je propose des améliorations si vous me le permettez :
    1/ Sortir le CSS du javascript pour faciliter la personnalisation
    2/ Créer un modele html pour la barre de manière à pouvoir la personnaliser facilement
    3/ Dans la configuration, permettre d’avoir la barre en bas de l’écran.

    En vous remerciant.
    JuL

    Répondre à ce message

  • Bonjour,

    j’ai testé le code sur mon site et lorsque je charge la page actualités, le script me dit qu’aucun article chargé

    j’ai essayé en y ajoutant un id_rubrique via une rubrique de mon site et toujours rien

    une explication ?
    faut-il parametrer kke chose en spip pour que l’ajax fonctionne ? car ce n’est pas la 1re fois que j’essaye d’utiliser de l’ajax et je me suis toujours pris un mur

    Répondre à ce message

  • 4

    Bonjour,
    J’ai passé mon site de test sous php 7.3 et voici les erreurs du plugin :

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/compiler.php on line 1197

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/compiler.php on line 1197

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/compiler.php on line 1197

    Deprecated : Function create_function() is deprecated in /home/evidence/www/plugins-dist/textwheel/engine/textwheel.php on line 199

    Deprecated : The each() function is deprecated. This message will be suppressed on further calls in /home/evidence/www/ecrire/iterateur/data.php on line 130

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/iterateur.php on line 305

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/iterateur.php on line 305

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/iterateur/data.php on line 497

    Deprecated : Function create_function() is deprecated in /home/evidence/www/ecrire/public/iterateur.php on line 305

    • create_function () est obsolete depuis 7.2 d’ou la mpontagne de message d’erreur

      Cependant malgre l’affichage destructuré par ces messages, le plug-in,semble fonctionner ainsi que SPIP

    • william

      apres un mois d’utilisation, pas de soucis sur le fonctionnement du site, ni celui de CS.
      mais toujours les messages d’erreurs.
      Des que j’ai du temps je plonge dans le code et je supprime les appels aux fonctions obsoletes pour voir le resultat.

    • Bonjour,

      Dans mes options.php il faudrait ajouter ceci.

      error_reporting(E_ALL ^ E_NOTICE ^ E_DEPRECATED);
      define('SPIP_ERREUR_REPORT', E_ALL ^ E_NOTICE ^ E_DEPRECATED);

      Quand bien même les display_error devrait être a off sur un site en production

    • Pat

      Toutes ces lignes concernent le code de SPIP et non du CS.
      Il me semble que les versions récentes corrigent ce problème, non ?
      Quelles lames du CS utilises-tu ?

    Répondre à ce message

  • 8

    Je comprends pas trop comment fonctionne les css de ce squelette. Je dois avoir une incompatibilité quelque part car pour voir les couleurs en surimpression des logos d’articles je dois enlever ceci de spip.css du plugin phantom :

    "/* on remet a 0 les couleurs des articles pour ceux dont l'id pourrait correspondre */
    .tiles article.style1 > .image:before,
    .tiles article.style2 > .image:before,
    .tiles article.style3 > .image:before,
    .tiles article.style4 > .image:before,
    .tiles article.style5 > .image:before,
    .tiles article.style6 > .image:before { background-color: transparent; }"

    Sinon je ne vois pas les couleurs.

    Répondre à ce message

  • Hello,

    je cherche à ajouter mon nouvel objet éditorial à la liste des objets automatiquement restreints.

    En effet, la doc précise

    Si un visiteur n’est pas identifié ou s’il n’est pas autorisé, alors l’intégralité de la rubrique (ce qui inclut les sous-rubriques, les articles, les liens ...) ne sera pas visible par ce visiteur.

    Acces Restreint 3.0 propose deux pipelines qui pourraient faire l’affaire mais
    -  accesrestreint_objet_restreint() n’est jamais appelé semble t-il
    -  accesrestreint_liste_objets_exclus() : lui je suis pas sûr de comprendre ça logique

    bref je sèche…

    Répondre à ce message

  • Sur le local spip3.2.3 le pluging s’installe et fonctionne sans pb ( base mysql)
    Sur le distant j’ai une erreur qui me dit que la table ne s’est pas créée sur la base mysql
    pourtant sur les liens entrants je vois apparaître le bouton « spam » et la rubrique liste noire.
    Je mets la copie d’écran
    Merci de m’aider

    Répondre à ce message

Un message, un commentaire ?

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document