Aveline v2

Aveline est une collection de noisettes hautement paramétrables, compatibles avec les thèmes Z et à inclure dans vos pages avec le noiZetier.

Compatibilité

Cette version 2 du plugin Aveline s’utilise, sous SPIP 3, avec la version 2 du noizetier, la version 2 de Zpip-vide et la version 1 de Zpip-dist.

Cette version, comme la précédente, est compatible avec les thèmes Z pour Zpip v1.

Cette version n’est pas compatible avec Zpip 2 (toujours en développement) ni avec Z-core.

Cette version 2 d’Aveline nécessite dorénavant le plugin Calendrier Mini 2.0.

Nouveautés

Cette version 2 conserve les mêmes fonctionnalités que la version 1. Il s’agit toujours d’une collection de noisettes Z.

Les icônes des noisettes ont été modifiées au profit des icônes FatCowRetro assurant ainsi une cohérence graphique avec le reste de l’interface privée de SPIP 3.

Le mini-calendrier des évènements a été réécrit et utilise dorénavant le plugin Calendrier Mini. Un mini-calendrier des articles et un mini-calendrier des brèves ont été ajoutés.

Des noisettes additionnelles sont disponibles pour prendre en compte le fait que les mots-clés et les documents peuvent être activés sur presque tous les objets SPIP.

Discussion

24 discussions

  • 1

    Bonjour,
    J’ai intégré mes icônes de partage Facebook via une noisette aveline (code libre). J’ai mis à jour ce matin Aveline et coïncidence ou pas, depuis plus d’icônes (je n’avais pas vérifié si les icônes étaient encore présentes avant de mettre à jour Aveline) ! Quelqu’un a-t-il rencontré le même problème. Merci et bonne journée,
    FJ

    • Rebonjour,
      Désolé pour la « fake news »... Le problème ce n’est pas Aveline mais Firefox... Je suppose le bloqueur de publicité ou autre...
      Merci
      FJ

    Répondre à ce message

  • 1

    Bonjour,
    J’ai un site avec spip 3.2, et dernières versions d’Agenda, MiniCalendrier, Full calendar Facile, Zpip, Aveline, NoiZetier, etc.

    Pour les articles, j’ai mis une noisette qui liste les événements de l’article.

    Si des articles n’ont pas d’événements liés, ils s’affichent en page blanche, même chose pour la rubrique de l’article. (mais le reste du site ok)
    Dès que je met un événement dans l’article, l’article s’affiche normal, et sa rubrique aussi.

    Si je supprime la noisette « liste d’événements » de l’article (sans événements), il s’affiche alors correct.

    Si je met une noisette « liste d’événements » avec paramètre « tous les événements », là ça marche car j’ai d’autres événements ailleurs.

    Quand je désactive Aveline, j’ai l’article qui s’affiche au lieu de la page blanche, donc a priori ça viendrait plutôt d’Aveline et noisettes que les événements en eux-mêmes a priori ?
    (j’ai posté aussi sur https://contrib.spip.net/Agenda-2-0 dans le doute)

    Je vois pas quoi faire...?

    • si je met l’option non pour « Afficher les évènements passés s’il n’y pas d’évèments futurs ou en en cours ? » dans la noisette, alors là ça remarche.
      C’est quand il y a « oui », et pas d’événements, qu’il y a page blanche (idems pour les rubriques d’ailleurs)

    Répondre à ce message

  • 3

    Bonjour,
    pour le squel Articles, la noisette « contenu principal » semble avoir eu un bug (je sais pas depuis quand), je ne pouvais plus la modifier, j’avais un message « article-contenuprincipal est introuvable Renommez-là ou supprimez là ».
    Alors je l’ai supprimée, pensant pouvoir la recréer, mais en fait elle a disparu de la liste des noisettes pour Articles.
    du coup pour les articles de ce site, soit le reste des champs s’affichent (événements), soit y a une page complètement blanche, soit y a un message d’erreur (Fatal error : Allowed memory size of 205520896 bytes exhausted (tried to allocate 130968 bytes) in /home/users3/o/oss2181/www/plugins-dist/textwheel/inc/notes.php on line 223 )
    (heureusement, c’est un site en cours de création)
    Les autres pages marchent.
    url temporaire du site (on va migrer bientôt vers autre hébergeur) https://oss2181.phpnet.org/

    Apparemment, c’est la seule noisette qui pose un problème.

    là j’ai spip 3.2 et NoiZetier 2.7.14, dernières versions de tous les autres plugins

    Sur un autre site en spip 3.2, j’ai aussi le même message d’erreur sur la noisette contenu-principal de l’article, mais là je me garde bien d’y toucher.

    J’avais cru que ça venait du NoiZetier, mais en parcourant les fichiers des plugins, j’ai vu que c’est dans Aveline que sont définies les pages article-contenuprincipal.html, alors sans doute que ça concerne plutôt Aveline.

    -  En attendant, est-ce possible que je substitue la version Aveline 2.5.12 par la version précédente ?

    merci pour toute info utile.

    • J’ai tenté en désinstallant/résinstallant NoiZetier, puis aussi Aveline, mais j’ai tjs ce problème de noisette « contenu principal » des articles disparue.
      J’ai tenté aussi de remettre la version 2.5.11, en changeant le N° de version de paquet.xml, mais ça n’a rien changé non plus.
      Personne n’a eu un problème similaire ? Toutes vos noisettes sont bien rangées ? ;-)

      Là je coince, je vois pas quoi faire, des idées ? merci :-)

    • Je précise que sur un autre site avec des plugins similaires je n’ai pas ce problème
      mais il est resté en spip 3.1.7 et Aveline 2.5.11

      N’y aurait-il pas une interférence néfaste de la noisette contenu principal articles avec le plugin dist txtwheel ?
      la ligne 223 est en rapport avec les Note apparemment...

    • RESOLU,
      C’est revenu. Je sais pas si c’est à force de désactiver Aveline, NoiZetier et Zpip-vide, ou si c’est parce que j’ai supprimé une noisette article-contenuprincipal.html (issue de la version précédente) que j’avais mise dans mon dossier squelettes, mais toujours est-il que ça marche à nouveau ! :-)

    Répondre à ce message

  • 2

    jr,

    en mettant à jour spip 3.1.6 vers 3.2, j’ai eu un gros bug.
    j’avais pourtant mis à jour tous les plugins, qui étaient notés compatibles 3.2

    Après la mise à jour, le contenu de mon site ne s’affichait plus du tout sur la partie publique, il n’y avait que le bandeau et le pied, alors que tout était ok sur la partie privée.
    J’ai fait divers tests (vider cache, supprimer dossier tmp), mais c’est en désactivant les plugins que je me suis rendu compte que c’était Zpip-dist v1 1.7.31 et/ou Zpip-vide 2.1.7 - qui faisaient planter le contenu public.
    Je les ai donc désactivés (ainsi que mes squelettes et le thème utilisé), et là le contenu s’affiche avec les squelettes DisT : http://ricochets.cc/, ce qui est mieux qu’une page sans les contenus.

    Pour info, j’ai Aveline 2.5.12 et Zen-Garden 2.6.4
    je n’ai pas de messages d’erreurs, ni dans partie publique, ni dans partie privée.

    voici la liste de mes plugins : https://app.box.com/s/axg62tkc49rhfkzlq1yr332ne797tjeo
    saisie écran d’un article sans contenus : https://app.box.com/s/c7ndkysras0ssyf8men5crmsewyh52gw
    copie d’ecran du var_mode=inclure : https://app.box.com/s/8ex3m1fxe59iprgr0u3w5v68f2w65jif
    si besoin d’info, demandez-moi

    et voir sur la page de Zpip où j’ai échangé sur ça, et où un aidant m’a dit que mon bug concernait a priori plutôt Aveline

    merci pour toute aide utile

    • En attendant une solution, j’ai désactivé Aveline, et activé Zspip, le thème, et mes squelettes persos, ce qui me permet d’avoir le site avec son look au lieu de la DIST.
      Il me manque bien sûr les si précieuses noisettes, mais au moins le site est plus « joli ».

      Au passage, j’ajoute que j’espère que Aveline sera transposé pour d’autres systèmes de squelettes (comme Spip-R), car je trouve qu’actuellement c’est le meilleur moyen pour personnaliser l’injection des contenus dans un site assez « finement » sans avoir à coder.

    • RESOLU : c’était en fait le plugin noiZetiers qui s’était désactivé lors de la mise à jour spip apparemment, et je ne m’en était pas rendu compte (il n’apparaissait pas dans la liste des plugins inactifs).
      Des fois, on ne pense pas aux trucs les plus simple... Désolé pour le dérangement...

    Répondre à ce message

  • 1

    Bjr, (je re-post car pas sûr que mon message ait bien été envoyé ?)

    en mettant à jour spip 3.1.6 vers 3.2, j’ai eu un gros bug.
    j’avais pourtant mis à jour tous les plugins, qui étaient notés compatibles 3.2

    Après la mise à jour, le contenu de mon site ne s’affichait plus du tout sur la partie publique, il n’y avait que le bandeau et le pied, alors que tout était ok sur la partie privée.
    J’ai fait divers tests (vider cache, supprimer dossier tmp), mais c’est en désactivant les plugins que je me suis rendu compte que c’était Zpip-dist v1 1.7.31 et/ou Zpip-vide 2.1.7 - qui faisaient planter le contenu public.
    Je les ai donc désactivés (ainsi que mes squelettes et le thème utilisé), et là le contenu s’affiche avec les squelettes DisT : http://ricochets.cc/, ce qui est mieux qu’une page sans les contenus.

    Pour info, j’ai Aveline 2.5.12 et Zen-Garden 2.6.4
    je n’ai pas de messages d’erreurs, ni dans partie publique, ni dans partie privée.

    voici la liste de mes plugins : https://app.box.com/s/axg62tkc49rhfkzlq1yr332ne797tjeo
    saisie écran d’un article sans contenus : https://app.box.com/s/c7ndkysras0ssyf8men5crmsewyh52gw
    copie d’ecran du var_mode=inclure : https://app.box.com/s/8ex3m1fxe59iprgr0u3w5v68f2w65jif
    si besoin d’info, demandez-moi

    et voir sur la page de Zpip https://contrib.spip.net/Le-Squelette-Zpip#forum494573
    où j’ai échangé sur ça, et où un aidant m’a dit que mon bug concernait a priori plutôt Aveline

    merci pour toute aide utile

    • ton message contenait trop de lien, l’antispam l’avait modéré.

      je viens de publier celui-là

    Répondre à ce message

  • 4

    Bonjour,
    j’ai depuis la dernière màj , lorsque je vide le cache et affiche l’index du site (sur 2 sites), le message d’erreur rose en haut à droite :

    1 Erreur(s) dans le squeletteNuméro Message squelette boucle Ligne
    1 Filtre affiche_sep= non défini plugins/auto/aveline/v2.5.10/inclure/breve-resume.html / 30

    Que faut-il faire ?
    merci d’avance

    • C’est étrange, affiche_sep est une variable d’environnement transmise au squelette.

      Quelle est la version de SPIP ? La liste des plugins installés ?

      L’erreur a lieu sur quelle page ? A partir de quelle noisette parente ?

    • merci de ton attention : voici les infos demandées :
      SPIP 3.1.3 [23214]
      Liste plugins :
      Agenda 3.18.3 - stable
      API de vérification 1.6.2 - stable
      Article PDF 0.4.10 - stable
      Aveline 2.5.10 - stable
      cimobile : détection et aiguillage des téléphones mobiles 1.2 - stable
      Compositions 3.5.9 - stable
      Des jeux dans vos articles 3.4.1 - test
      En travaux 3.1.29 - stable
      Facteur 3.4.10 - stable
      FB Antispam 1.2.3 - test
      Formidable 3.3.2 - stable
      Google Analytics 0.4.9 - stable
      Import-Export 1.3.1 - stable
      iTwX Mobile pour cimobile 3.4 - test
      Le Couteau Suisse 1.9.12 - stable
      Maparaan 1.0.3 - stable
      Menu animé déroulant 1.0.10 - stable
      Menus 1.6.6 - stable
      Mini Calendrier 2.4.1 - stable
      NoiZetier 2.5.0 - stable
      NoSPAM 1.5.16 - stable
      Onglets dans le texte 2.0.1 - dev
      Saisies pour formulaires 2.18.5 - stable
      Social tags 1.0.14 - stable
      SPIP Bonux 3.4.2 - stable
      Squelette Maparaan 1.0.1 - stable
      YAML 1.5.2 - stable
      Zen-Garden 2.6.3 - stable
      Zpip-dist v1 1.7.29 - stable

      L’erreur a lieu sur index mais que la 1re fois après vidage du cache , cela disparaît ensuite lors de la navigation, même en revenant sur index.
      « Noisette parente » : je ne sais déterminer cela : comment dois-je faire STP ?
      merci d’avance.

    • Peux tu essayer la version 2.5.11 qui sera dispo en zip d’ici quelques heures ?

    • Bonjour
      et merci Joseph : c’est IMPECCABLE ! Tout va très bien. :-)

    Répondre à ce message

  • 2

    Bonjour,
    J’ai fait des recherches, mais ce n’est pas simple d’utilisation sur ce forum. A moins de n’avoir rien compris au fonctionnement des portfolios, je suis tombé sur un comportement bizarre d’une noizette Aveline :
    Lorsque j’appelle l’affichage d’un portfolio intégré dans une brève spécifique via la noizette « Afficher le portfolio de la brève », le portfolio s’affiche dans toutes les brèves ! C’est normal ou j’ai zappé un truc ?
    Bien à vous et bonne journée
    Frédéric

    • Avec le noiZetier, on modifie la structure de la page brève en général et pas d’une brève en particulier. Vous avez donc ajouter le port-folio (quand il y en a un) sur l’ensemble des brèves.

      Si vous souhaitez créer des variantes d’affichage (avec ou sans portfolio), il vous faut le plugin Compositions. Vous pourrez alors dans le noiZetier créer une variante de squelette, i.e. une composition, puis associer cette variante à certaines brèves seulement.

      Cordialement

    • Bonjour et merci de votre réponse rapide,
      Ben oui, comme quoi bien lire les intitulés ça sert :)
      J’ai mal interprété « Noisettes spécifiques à la page brève : »... Je l’avais compris comme « Noisettes spécifiques à cette breve : »... Ce qui change tout !!!
      Autant pour moi. Notez que j’ai contourné le « problème » en créant une noizette « Code SPIP libre » !
      Merci de votre réponse
      Le site en question : http://ecolephoto.joncour.fr
      Frédéric

    Répondre à ce message

  • 2

    Bonjour,
    j’ai en spip 3.1.1, Aveline 2.5.7 - stable et NoiZetier 2.5.0 - stable et un squelette qui n’affiche pas les descriptifs d’articles et de rubriques.
    Alors j’ajoute une noisette « Code Spip libre »
    Dans cette noisette (sous article ou rubrique) j’ai pensé ajouter simplement le code :
    #DESCRIPTIF
    ou (#DESCRIPTIFid-article)
    (pour la page article)
    mais cela ne marche PAS : pourquoi svp ?
    merci d’avance !

    • Il faut une boucle parente !!

      <BOUCLE_art(ARTICLES){id_article}>
      #DESCRIPTIF
      </BOUCLE_art>
    • A oui c’est beaucoup mieux , merci Joseph !

    Répondre à ce message

  • 1

    Bonjour,
    je vois que Zpip dist n’est plus maintenu (http://contrib.spip.net/Le-Squelette-Zpip), et qu’il est remplacé par SPIPr-dist.
    Mais est-ce que SPIPr-dist est compatible sans modifications avec un site créé avec Aveline/Zpip/Thèmes de Spip-contrib ?

    -  Là, je vois par ailleurs que la composition d’articles que j’ai créée (basée sur le squelette articles en gardant ses noisettes) ne marche pas normalement, car les noisettes de navigation et extra ne s’affichent pas, seules les noisettes de contenu s’affichent. Peut-être est-ce du à l’obsolecence de Zpip par rapport au plugin composition ?

    Merci pour tout éclairage sur cette question.

    j’ai Spip 3.1, Aveline 2.5.7, Compositions 3.5.3 (c’est pas la dernière version, c’est peut-être ça le problème ?), Zpip-dist v1 1.7.29, Zpip-vide 2.1.6, Zen garden

    • Je m’auto répond pour le 2e point, ma composition d’articles s’affiche comme il faut à présent, j’avais juste une balise mal fermée dans du code spip d’une noisette....

    Répondre à ce message

  • 5

    Bonjour

    Merci pour ce plugin qui m’est très utile.

    J’ai un problème avec la noizette « Liste d’évènements ».

    La balise <h3 class="h3 vevent id_#ID_EVENEMENT"> générée par le squelette « evenement-resume.html » semble être refermée trop tôt (ligne 28).

    De ce fait les données structurées de type hcalendar (balisage : microformats.org) ne sont pas reconnues.

    Un déplacement de cette fermeture </h3> entre les lignes 53 et 54 du squelette d’origine (avant la fermeture de la balise </li>) semble résoudre le problème.

    Par contre je ne sais pas si le déplacement de la fermeture de la balise ne cause pas d’autres soucis dans l’architecture du plugin.

    Encore Merci pour ce plugin.

    Christian

    • Re-bonjour

      Désolé j’ai posté un peu vite et surtout sur le mauvais forum.

      Il suffit de déplacer la class « vevent » dans la balise <li class="vevent item">

      Je reposte sur le bon forum

      Merci

      Christian

    • Faut-il donc déplacer la classe vevent du h3 ligne 17 au li de la ligne 16 ?

    • Oui le déplacement dans <li ...> fonctionne, et ne modifie pas l’habillage de la noisette.

      Merci pour la réactivité

    • Correction effectuée. version 2.5.3

    • Version 2.5.3 installée et testée —> OK

      Merci beaucoup

      Christian

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 12 novembre 2017