SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

290 Plugins, 198 contribs sur SPIP-Zone, 116 visiteurs en ce moment

Accueil > Administration et BDD > Forms & Tables > Forms&Table 2.5

Forms&Table 2.5

21 septembre 2012 – par cri-tech – 183 commentaires

10 votes

Gestion et administration de formulaires éditables. Ce plugin permet également la publication de sondages et enquètes, la collecte des réponses dans la base de données et le téléchargement au format csv.
Ce plugin est une adaptation de la version pour SPIP 2.1 (Form&Table2.0).
Les fonctionnalités sont inchangées, pour plus d’information, merci de consulter la rubrique ad hoc.
Il est incompatible avec les versions antérieures de SPIP, mais une migration des données est possible lors du passage de SPIP2 à SPIP3

Passage de SPIP 2.X à SPIP3.0 avec le plugin Table&Form2.0

Pour conserver les formulaires créés sous SPIP 2.0, ne désinstallez pas le plugin en cliquant sur le bouton de désinstallation présent dans la page de gestion des plugins. Pour information, ce bouton porte l’étiquette suivante : « Supprime les données et désactive le plugin ».
Pour conserver les données :
-  Dans le dossier plugins, supprimez le dossier « forms_et_tables_2_0 »
-  Dans le dossier plugins, ajoutez le dossier du plugin modifié : « forms_et_tables_2_5 »
-  Activez ce plugin dans la page de gestion des plugins

Avertissement

Bien que compatible SPIP 3.0, cette version du plugin n’utilise pas entièrement l’API SQL et n’est donc pas compatible PostgreSQL ou SQLite

Remarque :
Cette version du projet n’est pas compatible avec les versions 2.X de SPIP.

Remarque 2 :
Ce projet a été initialement développé par le SEM http://icp.ge.ch/sem/cms-spip/spip.php?article900 et a été adapté par le service informatique de la communauté de communes du Pays de Gex http://www.cc-pays-de-gex.fr

Voir en ligne : https://plugins.spip.net/forms

Dernière modification de cette page le 2 avril 2018

Retour en haut de la page

Tout afficher

Vos commentaires

  • Le 3 avril à 11:53, par Théo En réponse à : Forms&Table 2.5

    Bonjour,
    J’utilise SPIP 3.0.26 et Formulaires et Tables 0.5.6.
    Je ne vois pas de mise à jour dans « Gestion des plugins »…
    Comment se fait-il ?

    Répondre à ce message

  • Le 15 avril 2016 à 21:02, par Théo En réponse à : Forms&Table 2.5

    Moi aussi j’aimerais passer à SPIP 3.1 mais voilà « Forms&Table 2.5 » version 0.5.6 n’est pas compatible.

    Et si je le désactive pour y installer « Formidable »… ?

    • Le 15 avril 2016 à 21:03, par Théo En réponse à : Forms&Table 2.5

      Existerait-il un autre plugin ?

    • Le 2 mai 2016 à 16:34, par Julien En réponse à : Forms&Table 2.5

      SVP, il faut mettre à jour ce Froms&Table 2.5 !

      Les autres plugins de formulaires ne rivalise pas avec celui-ci !

    • Le 2 mai 2016 à 17:04, par Théo En réponse à : Forms&Table 2.5

      Même à jour 1.1.0, il ne passe pas avec « Vérifier ses plugins pour le passage à SPIP 3.1 » :(

    • Le 2 mai 2016 à 17:34, par Julien En réponse à : Forms&Table 2.5

      Ben, si on change la version dans plugin.xml, il s’installe correctement et il est « utilisable ». Après quand on crée un champs dans la création d’un formulaire et qu’on le valide, impossible de l’éditer et de le modifier ensuite. Surement à cause de la version de jQuery qui a migré à la 1.11

      Faudrait qu’un expert se penche sur le sujet :)

    • Le 23 août 2016 à 10:40, par inaden En réponse à : Forms&Table 2.5

      Bonjour à tous
      Si vous aller voir sur http://contrib.spip.net/Formidable-le-generateur-de-formulaires Vous verrez que formidable a intégré form et tables.
      Je vais essayé le transfert et je vous tiens au courant d’ici quelques heures (jours ?).
      Par contre, je ne serait pas contre un captcha efficace !

    • Le 5 septembre 2016 à 06:34, par PRX En réponse à : Forms&Table 2.5

      Bonjour,
      c’est un peu du bricolage ce plugin, il n’est pas labellisé 3.1 et pourtant il passe sans souci l’upgrade mais surtout : IMPOSSIBLE de modifier un champ validé !!!!!!
      Y a t-il encore quelqu’un sur ce plugin ?
      @Inaden : quel est le résultat de vos tests SVP ?
      merci d’avance.

    • Le 5 septembre 2016 à 09:54, par cri-tech En réponse à : Forms&Table 2.5

      Bonjour,

      Nous avions fait une migration de ce projet pour le rendre compatible de la version 2.0 à 2.5 puis vers la version 3.0

      Nous n’avons plus le temps de maintenir ce projet.
      J’ai noté le problème avec jQuery mais je ne vous promet rien concernant la date de correction.

      Cordialement,
      cri-tech

    • Le 5 septembre 2016 à 13:20, par Pierre KUHN En réponse à : Forms&Table 2.5

      Bonjour,

      Vous l’indiquez compatible spip 3.1 alors que les dossiers de la zone ne l’indique pas. Une erreur ?

    • Le 7 septembre 2016 à 11:56, par PRX En réponse à : Forms&Table 2.5

      Bonjour,
      je ne suis pas le développeur mais ce plugin n’est PAS compatible 3.1 à cause de l’absence de la fonction modifier des champs établis en version antérieure.

      Si « cri-tech » veut bien consacrer un peu de temps à m’expliquer 1 fois, je veux bien essayer de le maintenir ce plugin.

    • Le 7 septembre 2016 à 12:01, par inaden En réponse à : Forms&Table 2.5

      Bonjour
      En fait le plugin formidable s’installe à la place et récupère (sur spip 3.1) les formulaires créés avec form et tables ainsi que les messages.

    • Le 7 septembre 2016 à 12:23, par PRX En réponse à : Forms&Table 2.5

      Merci Inaden ; puis-je nous aider SVP sur ce transfert car ce n’est pas documenté sauf erreur de ma part ?
      J’ai installé Formidable en gardant Forms et Tables (sous Spip 3.1) et quand je vais sous Editions>Formulaires, il n’y rien : message : « Il n’y a pour l’instant aucun formulaire. », sauf un bouton permettant d’importer un fichier xml de Forms et Tables mais sous Forms et Tables il n’y a rien pour exporter....
      Bref, je n’ai pas compris comment reprendre mes formulaires. Merci de tes lumières.

    • Le 7 septembre 2016 à 12:36, par PRX En réponse à : Forms&Table 2.5

      en fait pour être exact, cela se passe tout seul sur 2 sites sur 3 : (activation de Formidable : constat que les formulaires et données sont bien en Edition >formulaires et déactivation / desintallation de Forms et Tables) sauf pour 1 sur lequel cela ne marche pas du tout ...pourquoi ?

    • Le 7 septembre 2016 à 12:40, par PRX En réponse à : Forms&Table 2.5

      Alors la solution de transfert est :
      -  déactiver le cache, hyper important
      -  desinstallation de Formidable en gardant Forms et Tables,
      -  reinstaller Formidable
      -  constater que dans Editions>Formilaire on a bien les formulaires et données
      -  deactiver puis supprimer qq temsp après Form set Tables

    • Le 7 septembre 2016 à 12:51, par inaden En réponse à : Forms&Table 2.5

      Ah... je vois que vous avancez vite.
      Peut-être par mesur de précaution, supprimer forms et table par FTP une fois qu’il est désactivé et non par l’interface.

      À tout hasard... aucune solution de captcha ???!!! :-)

    • Le 7 septembre 2016 à 13:05, par PRX En réponse à : Forms&Table 2.5

      et pour finir , remettre dans chaque Formulaire, l’accusé de réception dans « configurer les traitements », qui ne se fait pas en auto. Le résultat est vraiment sympa.

      Je n’ai pas de solution de capcha sauf NoSPAM 1.5.15 pour les forums, je n’ai pas de spameur pour le moment.

      Solutions :
      -  poster cette demande dans le forum de Formidable car je ne la vois pas,
      -  complexifier un peu vos formulaires : cela mettra les rigolos en difficulté.

    • Le 7 septembre 2016 à 16:39, par inaden En réponse à : Forms&Table 2.5

      Bonne idée PRX. Je vais de ce pas poster ma demande sur le forum de formidable.
      Et merci pour ta contribution.

    • Le 22 janvier à 16:12, par bruno31 En réponse à : Forms&Table 2.5

      Bonjour PRX

      Dans ta procédure de migration, tu parles bien de « désinstaller » FORMIDABLE puis de le réinstaller. Une simple « désactivation » ne serait pas suffisante ? C’est cela ?

      Le problème, c’est qu’une désinstallation supprime les formulaires et données existants et créés dans FORMIDABLE.

      Mon problème, c’est que j’ai FORMIDABLE et FORM&TABLE installés conjointement.
      J’essaye de passer à SPIP3.1 et je suis coinçé avec FORM&TABLE.
      Je passerai bien à du FORMIDABLE only, mais je crois que la problèmatique du téléversement de fichier n’a pas été réglé ?

    • Le 22 janvier à 16:18, par Maïeul En réponse à : Forms&Table 2.5

      Salut Bruno,

      pour le téléversement de fichier avec Fomidable, voir l’article Envoyer des fichiers avec un formulaire Formidable.

      Par ailleurs je pense que Form & table est compatible 3.1, il faut juste que tu modifie la borne dans paquet.xml

    • Le 22 janvier à 18:13, par bruno31 En réponse à : Forms&Table 2.5

      Bonjour Maïeul

      C’est une excellente nouvelle que l’on puisse enfin envoyer des fichiers avec FORMIDABLE. Je vais étudier cela.

      Effectivement, on arrive à installer Form&table simplement en modifiant la balise compatibilité dans paquet.xml
      mais comme il est souligné plus haut, on ne plus modifier les champs d’un formulaire. Un souci de jquery probablement.
      Mais la bonne nouvelle, c’est que cela permet de continuer d’utiliser un formulaire existant.

    • Le 2 avril à 07:47, par Sebastián En réponse à : Forms&Table 2.5

      J’ai fini avec la version 3.2.0 et travaille également les Form & table (en changeant la version Paquet.xml)

    Répondre à ce message

  • Le 8 novembre 2017 à 17:55, par oil En réponse à : Forms&Table 2.5

    Savez vous comment dans un squelette, je peux récupérer l’identifiant du formulaire utilisé par le rédacteur dans son article (dans le #TEXTE donc) ?

    exemple :
    (remplacer ici ’=12’) :

    1.  <BOUCLE_reponseshead(FORMS_DONNEES){tout_voir}{tout}{id_form=12}{0,1}>

    Répondre à ce message

  • Le 5 avril 2017 à 09:59, par Jmtconseils En réponse à : Forms&Table 2.5

    Dans le cas d’un site multilingue, il n’y a pas de traduction sur le texte de téléchargement :
    « Parcourir » et « Aucun fichier sélectionné » reste en français.

    Comment changer cela ? Je ne vois pas le texte dans le code HTML.
    Voici l’exemple http://ow.ly/mn9k30azZVb

    Merci par avance.

    Répondre à ce message

  • Le 5 mars 2017 à 09:14, par Zrta En réponse à : Forms&Table 2.5

    Bonjour à tous :

    que je change zone UTC dans la partie privée

    Répondre à ce message

  • Le 16 avril 2016 à 19:27, par inaden En réponse à : Forms&Table 2.5

    Bonjour
    Je cherche désespérément un captcha ou un moyen d’intégrer un captcha aux formulaires que je génère avec ce plugins... et rien à faire.
    Quelqu’un sait-il s’il en existe un ou sur quels fichiers je pourrais coller un captcha et son traitement.
    Merci d’avance.
    Denis

    Répondre à ce message

  • Le 12 mars 2016 à 14:08, par inaden En réponse à : Forms&Table 2.5

    Bonjour à tous

    Le plugins fonctionne bien et lorsque j’ajoute un champ de chargement de pièce jointe, celle-ci est bien « loadée » sur le serveur dans IMG/protege/formX/ avec X comme numéro du formulaire. Et je reçois dans le mail de réception du formulaire ceci

    Votre photo : IMG/protege/form4/bureau.jpg http://mon_site/ecrire/?exec=forms_telecharger&id_donnee=6&champ=fichier_1

    Le problème, c’est que si le chemin de la photo est correcte, le lien http://mon_site/ecrire/?exec=forms_telecharger&id_donnee=6&champ=fichier_1 ouvre une fenètre avec un lien d’image brisé. Idem depuis la consultation en ligne du formulaire.
    Je n’ai pas vu de log d’erreur apache lors du clic sur le lien, et le chemin est correctement inscrit dans la BDD

    Donc 2 questions.

    Quelqu’un a-t-il une idée du problème ?
    Quelqu’un sait-il quel fichier gère l’envoi par mail du formulaire que je puisse changer le lien dedans et le remplacer par le chemin du document ?

    Merci d’avance pour votre aide.

    • Le 13 mars 2016 à 10:19, par inaden En réponse à : Forms&Table 2.5

      Ah oui, je suis sur spip 3.0.19 et sur Formulaires et Tables 0.5.6 - stable

    Répondre à ce message

  • Le 26 février 2016 à 12:34, par markouch En réponse à : Forms&Table 2.5

    Bonjour, apparemment, le plugun n’est pas compatible avec spip 3.0.17 (version du plugin : 056). En effet, je crée un simple champ Téléphone - pour récupérer des numéros en vue de la mise en place d’un service de SMS - et, au test du formulaire, lorsque je valide, dans l’espace public, j’ai une erreur avec une réponse incompréhensible « champs perso invalide », et ce, quel que soit le format du numéro de téléphone saisi ...

    Etant donné qu’il n’y a pas de mode d’emploi, je suis sec : merci à qui pourra m’aider.

    Répondre à ce message

  • Le 25 janvier 2016 à 16:40, par ablink En réponse à : Forms&Table 2.5

    Est-ce qu’une mise à jour de ce plugin est prévue pour être compatible avec SPIP 3.1 ??

    • Le 28 janvier 2016 à 15:15, par stephenking999 En réponse à : Forms&Table 2.5

      Bonjour,
      Tout mon site Edition999 fonctionne sur ce plugin, est-ce qu’une mise à jour 3.1 est prévue ou bien dois-je passé par Formidable.
      Merci de vos réponse.

    • Le 15 février 2016 à 13:06, par Julien En réponse à : Forms&Table 2.5

      Même question. Mais j’aimerais bien éviter de devoir changer plugin.

    • Le 15 février 2016 à 14:23, par Pierre KUHN En réponse à : Forms&Table 2.5

      Pourquoi ne pas vouloir changer de plugins ?

    • Le 18 février 2016 à 11:26, par stephenking999 En réponse à : Forms&Table 2.5

      J’ai testé le plugin Formidable et le problème c’est qu’il n’accepte pas l’ajout de documents dans le formulaire et mon site d’édition est basé là-dessus.
      http://www.edition999.info

    Répondre à ce message

  • Le 11 décembre 2015 à 05:53, par PRX En réponse à : Forms&Table 2.5

    Bonjour,
    je souhaiterai que la personne qui a rempli le formulaire puisse avoir un N° unique en retour dans son email (pour faire un « RMA » = N° de retour atelier ).

    Je pensais mettre le N° du formulaire rempli (« Id » que l’on voit dans le tableau des réponses).
    Comment intégrer ce N° Id dans la réponse email SVP ?

    Merci d’avance.

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Passer un site SPIP sous https://

    23 février 2017 – 42 commentaires

    Comment migrer simplement votre site SPIP de http:// vers https:// Le protocole https:// devient de plus en plus courant : C’est mieux pour la vie privée de tous La plupart des grands sites l’a déjà adopté Certains navigateurs commencent à afficher (...)

  • SPIP 3.2, Agenda et FullCalendar

    6 juin – 20 commentaires

    Nous avions publié un article sur la manière d’utiliser FullCalendar avec SPIP 3.0 afin d’afficher des évènements sous forme d’Agenda. La version de FullCalendar a changé avec SPIP 3.2. Le présent article est donc un tutoriel adapté à SPIP 3.2. Pour (...)

  • Grappes 1.0

    23 novembre 2012 – 36 commentaires

    Présentation et nouveautés Cette version 1.0 du plugin Grappes est un portage pour SPIP 3.x. Le plugin permet de grouper des objets de SPIP dans des grappes. Les objets du core (articles, rubriques, auteurs, etc.) sont pris en charge, ainsi que (...)

  • PHANTOM (HTML5UP)

    18 juillet – commentaires

    Squelette SPIP pour intégrer le modèle Phantom de HTML5UP. https://html5up.net/phantom Installation A l’activation, le plugin installe aussi les plugins suivants : crayons, favicon, metasplus+, Couleur d’objet, champs extras, SPIP reset centre (...)

  • Cycle2

    7 août 2014 – 119 commentaires

    La seconde version de la librairie Javascript « jQuery Cycle », qui permet de produire des diaporamas, se nomme « Cycle2 » : http://jquery.malsup.com/cycle2/. Voici cette nouvelle librairie mise en plugin pour SPIP. Si vous utilisez déjà « jQuery (...)