Galleria (fr)

Une galerie d’image qui utilise la librairie javascript Galleria.

Description

Ce plugin vous permet d’ajouter des galeries d’images à vos articles. La galerie créée utilise la librairie javascript Galleria. Le plugin propose un modèle nommé <galleria>.

Utilisation

Pour créer une galerie d’image ajoutez une balise <galleria##> dans un article, où ## est l’ID d’un article.Les images de la galerie sont celles liés à l’article.

Options

Les options les plus courantes du modèle sont :
-  width
-  height
-  lightbox :true
-  transition :[fade|flash|pulse|slide|fadeslide|doorslide]
-  theme : le nom d’un theme Galleria
-  pagesize : le nombre d’image par page

Ex : <galleria22> une galerie dans l’article 22 ; <galleria22|lightbox=true> activation de l’effet lightbox

Pour plus d’options et de personnalisation de la galerie reportez-vous directement au site de Galleria

Bug connu

Lorsqu’on ajoute plusieur galerie dans un même article, la galerie ne fonctione pas correctement. (bug fermé avec la version 1.3.1)

Références

version 2.0.0
SPIP minimum 3.2 librairie JQuery n’est plus compatible avec les versions <3.2
version Galleria 1.5.7 site de Galleria
version de SPIP pour développement 3.2
svn svn://zone.spip.org/spip-zone/_plug...

Retro compabilité

version 1.3.5
SPIP 1.9.2>= et <3.2.0 librairie JQuery
version Galleria 1.2.9 site de Galleria
version de SPIP pour développement 2.1.11
svn svn://zone.spip.org/spip-zone/_plug...
ouverture avec lightbox/open with lightbox
ouverture avec lightbox/open with lightbox

updated on 2 October 2019

Discussion

74 discussions

  • Nouvelle URL du site Galleria :
    https://galleria.io/

    Reply to this message

  • juste pour dire que le site de galleria a apparemment changé. C’est https://galleria.io/ maintenant

    Reply to this message

  • la fougale

    Bonjour
    Je n’arrive pas a creer une gallerie avec ce plugin, avec pour seul résultat l’affichage des images de manière classique spip.
    Je suis sur un serveur local (linux Lamp), GD2 est activé, sous spip 3.1, le plugin 1.3.4.
    Avez vous une idée du problème
    merci

    Reply to this message

  • 3

    Bonjour à tous,
    Confronté à l’erreur “Could not extract a stage height from the CSS. Traced height : 0px,” sur la partie
    publique et de façon aléatoire j’ai parcouru les forums où la solution semble être de poser l’extension “wait=true”. Ma question de béotien : où mettre ce script( fichier css, js, html?) sachant que j’utilise le thème classique.
    Merci d’avance et bravo pour votre disponibilité

    • Bonjour,
      Merci encore pour votre motivation.
      Votre solution “wait=true” est de quel nature
      c’est du
      - html pur
      - squellette spip
      Pouvez-vous donner plus de référence ?

    • OSTEOKIN

      Bonjour et merci pour le retour,
      J’ai vu cette option sur le site répertoriant les erreurs Galleria :
      http://galleria.io/docs/references/errors/
      Ils préconisent cette option (WAIT) surtout pour les diaporamas cachés dans des onglets ou blocs dépliants.
      A priori on peu mettre cette option dans un CSS sauf que sans thème particulier il n’y en a pas.
      Je n’ai plus l’erreur en ce moment sur les articles à diaporama visible (sans onglet ni bloc) mais je vais en avoir l’utilité prochainement.
      Merci encore pour votre écoute

    • Bonjour,
      Votre option wait de Galleria n’est prise en charge par mon plugin.
      La version actuelle est la 1.2.9 , votre option est posterieure.
      Je pense à upgrader la version mais les nouvelle version utilisent une version plus récente de JQuery que celle de SPIP.
      Je cherche le meilleur moyen de le faire.

    Reply to this message

  • 4

    Utilisation plugin Galleria, j’ai le message suivant
    Aucune photo n’est encore insérée dans cet album
    Voilà le lien sur la page
    http://roch-jaja.nursit.com/spip.php?page=album&id_article=6
    Merci d’avance
    Cordialement

    • Bonjour,
      Votre erreur vient d’un message de SPIP concernant SA gallerie de photo. En effet SPIP a aussi une gallerie de photo , le portfolio .
      Cela n’a rien a voir avec mon plugin.
      Il faut retoucher votre maquette pour retirer ce message.

      Cordialement

    • Merci
      J’avoue ne pas comprendre (utilisateur bien ordinaire) mais je vais tenter un post du côté de chez SPIP
      Cordialement

    • En fait le probleme est independant de mon plugin. (desactive le , le message est la)
      il faut retirer de message de la maquette (le terme squellette dans spip)
      bonne chance

    • Bonjour
      Merci de ton aide.
      Effectivement le message vient de “novoslider67|controlNav=false”.
      Désolé du dérangement. Je vais poster du côté de SPIP car je suis bien incapable d’aller modifier du squelette !
      Cordialement

    Reply to this message

  • 1

    Bonjour

    Le bug annoncé comme fermé avec la version 1.3.1 est présent alors que j’ai la version 1.3.3. C’est normal?

    Reply to this message

  • 1

    Hello

    J’adore cette galerie, très propre et responsive mais j’ai un petit souci : si on affiche une galerie avec responsive=true, on ne peut plus gérer la largeur des images avec width=500 par exemple.

    N’y aurait-il pas moyen de définir une largeur maximale des images tout en gardant le côté responsive ?

    • Bonjours, et merci
      Je n’ai pas essayé la combinaison responsive et width ; mais je pense que celà viens de la librairie originale http://galleria.io/
      Essayez une page statique avec la librairie galleria et ces 2 options , pour etre sur que celà ne viens pas du plugin.

      galleria version 1.2.9

      Cordialement

    Reply to this message

  • 2
    Pringels Pierre

    A quand l’adaptation à SIP3.1 ?
    Nous en faisons un usage important, voir :
    http://www.photoclubrebecq.be/spip/

    • une personne nous a signalé qu’il était deja compatible 3.1, il suffisait juste de changer la borne. Je viens de le faire sur la zone. La nouvelle version sera disponible bientôt.

    • Pringels Pierre

      Un grand merci :-)

    Reply to this message

  • 4

    J’ai créé un petit diaporama de quatre photos. On peut les faire défiler toutes les quatre sans problème. Par contre, en-dessous, il n’y a que trois vignettes : la dernière n’est pas affichée.

    Une idée de ce qui se passe (je suis sous SPIP 3.0) ?

    Merci d’avance pour tout indice.

    • Je n’ai pas eu ce problème. Je n’ai pas d’element pour vous aider.

    • Merci de votre réponse rapide. N’étant pas expert, je peux juste vous donner les indications suivantes :
      -  le site en construction est visible à http://maitrisedeparis.com/index.php
      -  il est sous SPIP 3.0, avec Sarka-SPIP 4.5.2

    • Je ne vois pas de probleme .
      peut-etre avez vous un temps de chargement lent?
      ca arrive

    • Merci, mais non, ce n’est pas ça. Comme palliatif, j’ai mis deux fois la dernière image. On peut donc faire maintenant défiler cinq images (les deux dernières identiques, donc), mais il n’y a que quatre vignettes (ce qui donne la même apparence que votre copie d’écran).

      C’est peut-être lié à un plugin, mais la plupart sont indispensables au site (Sarka-SPIP, par exemple) et quand j’en désactive un, des erreurs sont affichées.

      Et quand je désactive les autres (comme Albums, par exemple), l’anomalie demeure : pas de vignette pour la dernière image.

      Mystère donc, mais sans gravité (voir le palliatif évoqué ci-dessus).

    Reply to this message

  • 1

    Bonjour,

    Je viens d’installer le plugin galleria et tout marche presque bien sauf le contour des images dans l’espace public. En effet, quand je suis dans l’espace privé, les images s’affichent sans marge que ce soit l’image principale ou les images dans les images déroulant en bas (celles-ci sont d’ailleurs centrées et on voit l’image en entier) (voir pièce jointe), par contre dans l’espace publique, il apparaît une bordure blanche autour de chaque image et les images déroulant en bas ne sont plus centrées.
    Est-ce que quelqu’un aurait une solutions? Est-ce que je peux passer par les attributs de galleria ou est-ce que je dois passer par du css (j’ai essayé, je n’y arrive pas). En fait je voudrais faire disparaître toutes les bordures blanches, même dans le lightbox si possible.

    Voici l’adresse du site web pour comprendre mon problème.
    http://darangerard.com/spip/spip.php?article73

    Je vous remercie par avance

    Reply to this message

Comment on this article

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document

Follow the comments: RSS 2.0 | Atom