SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

289 Plugins, 197 contribs sur SPIP-Zone, 134 visiteurs en ce moment

Accueil > Thèmes > Initializr

Initializr

20 août 2012 – par touti – commentaires

6 votes

Ce thème reprend la page de démo http://www.initializr.com/try en l’adaptant à la sauce ZPIP pour SPIP3

Thème très simple (en développement car il dépend de 2 plugins non stables) est en deux colonnes qui s’adaptent à la taille de l’écran, cela sert de base de travail pour faire du responsive design et en comprendre rapidement le fonctionnement en html5.

Pour en savoir plus, merci de consulter la page http://www.html5-css3.fr/html5/initializr-generateur-template-html5-boilerplate

Le thème s’installe comme n’importe quel thème ZPIP . Il nécessite les plugins Zcore et Z5 que vous pouvez trouver zippés ou sous SVN.

-  Le plugin Z5 (zpip_html5 en dev branches/V2) pour SPIP3 http://files.spip.org/spip-zone/zpip_html5_spip3.zip
-  Le plugin Z-core (en dev) pour SPIP3 http://files.spip.org/spip-zone/z-core.zip

Copies d’écran

Ecran de moins de 480px


Ecran au dessus de 480px

Voir en ligne : http://plugins.spip.net/initializr

P.-S.

Et puisque vous utilisez le HTML5 de SPIP3, pensez à activer l’option « Permettre le HTML5 » dans la configuration avancée de votre site. Ceci essentiellement pour avoir les bons attributs HTML5 dans les divers formulaires. (login, contact, etc)
Par exemple [(#HTML5) required='required' autofocus='autofocus']

Dernière modification de cette page le 21 juin 2013

Retour en haut de la page

Vos commentaires

  • Le 5 mai 2015 à 22:03, par magatst En réponse à : Initializr

    rien depuis 2012 ! ça avait l’air pourtant prometteur ??

    Répondre à ce message

  • Le 1er novembre 2012 à 20:34, par goudron kabyle En réponse à : Initializr

    Est-ce qu’on peut trouver une version squelette de InitializR, personnellement installer ZPip et un autre plugin ça fait beaucoup.

    • Le 2 novembre 2012 à 02:16, par touti En réponse à : Initializr

      Non ça n’existe pas. Mais, faut essayer, après tu comprendras pourquoi c’est ainsi ! Quand c’est plus simple à distinguer, c’est plus simple à comprendre et à modifier !

    • Le 2 novembre 2012 à 23:54, par goudron kabyle En réponse à : Initializr

      Merci @touti

    Répondre à ce message

  • Le 26 août 2012 à 21:26, par polatouche En réponse à : Initializr

    Merci à toi pour la mise à jour. Tout s’installe bien maintenant.
    La lecture de la page du plugin Z5 : http://contrib.spip.net/Zpip-dist-en-HTML5
    me fait poser des questions sur la possibilité d’utiliser ce plugin en prod...

    Un avis à ce sujet ?

    • Le 26 août 2012 à 22:48, par touti En réponse à : Initializr

      Hé bien, après enquête personnelle, la notification « obsolète » sur le plugin Z5 a été faite pour la branche/V1 en février 2012.
      Puis, le plugin Z5 a été retravaillé et mis à jour en juin 2012, j’ai posé aujourd’hui 26 aout 2012 un sabot avec la branche/V2.
      On ne devrait plus toucher à cette version V2 lors des développements mais au dossier trunk pour les modifs et mises à jour futures !

      A toi de voir avec ces infos, attends peut-être la rentrée car les choses devraient surement bouger du côté de z-core qui est aussi en dev !
      ++
      touti

    • Le 27 août 2012 à 13:26, par polatouche En réponse à : Initializr

      Merci pour cette info, je vais faire dans le style « il est urgent d’attendre »…

    Répondre à ce message

  • Le 22 août 2012 à 17:47, par polatouche En réponse à : Initializr

    Bonjour,

    « Le thème s’installe comme n’importe quel thème ZPIP . Il nécessite les plugins Zcore et Z5 qui s’installent automatiquement avec et dépendent de SPIP3. »

    Pour info :

    Problème d’installation sur un SPIP SPIP 3.0.4 [19781] :

    Le dépot de plugins standard est installé : SPIP-Zone - Plugins

    Mais il ne contient pas le plugin Z5 et donc l’installation ne se fait pas.

    Il faudrait mettre Z5 dans le dépot SPIP-Zone, ou indiquer où se trouve Z5…

    Merci d’avance !

    • Le 26 août 2012 à 20:45, par touti En réponse à : Initializr

      Ok, j’ai modifié le thème car effectivement les 2 plugins qu’il nécessite ne sont pas stables .
      Merci de la remarque.

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Article PDF

    9 juin 2007 – 364 commentaires

    Présentation d’un plugin fournissant une version PDF de l’article en cours

  • Slick

    17 mai 2017 – 17 commentaires

    Intégration à SPIP du carrousel Slick : https://kenwheeler.github.io/slick/ Fonctions de Slick Son utilisation permet d’afficher une liste d’éléments défilants, en l’occurrence ici une série de photographies. Par les configurations proposées, il est (...)

  • GIS 4

    11 août 2012 – 1438 commentaires

    Présentation et nouveautés La version 4 de GIS abandonne la libraire Mapstraction au profit de Leaflet. Cette librairie permet de s’affranchir des librairies propriétaires tout en gardant les mêmes fonctionnalités, elle propose même de nouvelles (...)

  • Réservation d’événements

    16 mars 2015 – 346 commentaires

    Ce plugin permet d’offrir aux visiteurs de s’inscrire pour un évènement du plugin Agenda et de gérer les réservations enregistrées. Installation Le plugin s’installe comme n’importe quel plugin. il nécessite : Agenda API de vérification Facteur (...)

  • Acces Restreint 3.0

    11 décembre 2008 – 819 commentaires

    Le plugin accès restreint permet de définir et de gérer des zones de l’espace public en accès restreint. Cette version du plugin a été redévelopée et optimisée tout spécialement pour SPIP 2.0. Il en découle une amélioration des performances sur les gros (...)