Manuel de rédaction du site

Ce plugin installe une icône d’aide permettant d’afficher depuis n’importe quelle page de l’espace privé le manuel de rédaction du site. Ce manuel est un article du site. Il a pour but d’expliquer aux rédacteurs l’architecture du site, dans quelle rubrique ranger quoi, comment encoder et installer une vidéo... Bref tout ce que vous voulez et qui est spécifique à votre site.

Installation

Comme tous les autres plugins, cf. https://www.spip.net/fr_article3396.html

Le plugin nécessite [1] les plugins SPIP Bonux (si Spip2), Saisies (Spip2 et Spip3) et Yaml (Spip2 et Spip3).
Il utilise [2] les plugins Palette et Pages.

Création du manuel

Écrire votre manuel d’utilisation dans un article. Soit dans une rubrique qui ne sera pas affichée dans le site public (par exemple verrouillée avec le plugin accès restreint). Ou bien en utilisant le plugin Page Unique.

Lors de l’affichage du manuel, le plugin applique un effet toggle de jquery sur les intertitres (h3). Si vous utilisez les Enluminures Typographiques pour le Porte Plume, l’effet sera aussi appliqué aux titres de 2e niveau (h4).

Blocs de texte génériques

Depuis la version 0.6, le plugin fournit des blocs de texte que l’on peut insérer directement dans le texte de l’article du manuel. Tous ces blocs peuvent être regroupés sous un sous-titre FAQ par exemple sous la forme <faq|b=nom_du_bloc>. On peut aussi les insérer sans la question : <faq|b=nom_du_bloc|q=non>.

Les blocs sont définis dans un fichier similaire à un fichier de langue, mais dont le nom commence par « faq- ». Les blocs définis par défaut dans ce plugin se trouvent donc dans le fichier faq-manuelsite_fr.php. Les autres plugins peuvent donc proposer leurs propres blocs. Il faut alors rajouter un paramètre au code d’insertion : <faq|p=nom_du_plugin|b=nom_du_bloc>.

L’insertion de ces codes :

produira donc :

Tous les codes des blocs disponibles sont listés dans la colonne de gauche dans la page d’édition du manuel. Les contenus correspondants s’affichent au survol de la souris.

Comme dans les chaînes de langue, on peut insérer dans les blocs des paramètres s’écrivant sous la forme @le_paramètre@ : <faq|b=nom_du_bloc|params=p1:v1;p2:v2>. Par exemple, <faq|b=thumbsites|q=non|params=rubrique:Liens> affichera

Enfin, petite astuce, dans le cadre d’une mutualisation, on peut créer un plugin qui ne servira qu’à fournir des blocs de texte. En activant ce plugin sur chacun des sites de la mutualisation, on aura accès à l’ensemble des éléments de cette FAQ partagée.

Cette collection de textes est évidemment à enrichir... Faites vos demandes dans le forum ou participez directement via l’espace de développement svn.

Configuration du plugin

Affichage du manuel

Une icône est affichée dans le coin haut gauche du navigateur. Si cliquée, le manuel est chargé en ajax et s’ouvre « par dessus » l’espace privé sur la largeur définie dans la configuration.

L’article du manuel peut être créé dès l’installation du site par le webmaster. Si les crayons sont activés dans l’espace privé, le manuel est directement modifiable... Cela permet au webmaster de le rédiger au fur et à mesure de l’avancement du site et de l’installation des fonctionnalités.

Notes

[1Dépendances obligatoires !

[2Dépendances optionnelles

Discussion

23 discussions

  • 7
    Jaseur Boreal

    Comment rendre multilingue le "Manuel de rédaction du site" ?

    Bonjour,
    les rédacteurs étrangers d’un site multilingue s’expriment dans plusieurs langues et ne maitrisent pas toujours le français. Pour le premier "accueil" des rédacteurs étrangers qui pratiquent le Letton, l’Anglais, le Russe, ... le "Manuel de rédaction du site" avec traduction serait bien utile et pratique.

    Je n’ai pas encore réussi à le concevoir pour d’autres langues, certains l’ont-il déjà réalisé multilingue ?.

    Si vous avez des idées et solutions, bien merci. »

    • utiliser la syntaxe des blocs multilingues dans l’article ne suffit pas ?

      <multi>
      [fr] En francais
      [en] In English
      </multi>

      Qu’as tu essayé ?

    • Jaseur Boreal

      Bonsoir,
      Merci Maïeul pour les réponses.
      ,
      C’est « Écrire une nouvelle traduction » d’un article une fois que celui-ci est fait qui est d’habitude le processus utilisé.

      Pour l’article « Guide de rédaction » du site, comme il semble être unique, je ne sais pas trop comment faire.
      Je vais tester la formule avec le code dans l’article « Guide de rédaction » du site,

      <multi>
      [fr] En francais
      [en] In English
      [lv] Latvian
      </multi>

      Est-ce que l’affichage différencié des langues se produira coté privé « rédacteur » ?
      Le Guide est déjà un article d’une certaine longueur, cela risque de multiplier par 3 sa longueur.

      Y a-t-il d’autres solutions ?

      merci pour toutes vos suggestions et exemples.

    • je ne suis pas auteur dudit plugin, donc je ne peux pas dire. Mais si vous n’arrivez pas avec les traductions d’article c’est que ce n’est pas prévu pour. Cela ne devrait cependant pas être trop dur.

      Mais la solution que je propose devrait fonctionner en attendant (c’est un comportement standard de SPIP)

    • Jaseur Boreal

      Bonsoir,

      Cela semble fonctionner pour les lignes d’écritures relativement simples.

      Mais avec l’explication des tableaux dans SPIP cela se complique ....

      A quel moment mettre les balises multi et les [fr] dans un tableau de trois lignes et quatre colonnes .... on s’emmèle les variations de solutions ...
      c’est en essai ...
       ;-)

    • pourquoi tu ne fais pas tout simplement

      <multi>
      [fr]
      
      le table fr
      
      [en]
      
      le tableau en
      
      </multi>

      J’ai un peu regardé pour gérer via la traduction d’article : il y a pas mal de chose à modifier pour s’assurer que les traductions n’apparaissent pas côté public ...

    • Jaseur Boreal

      Merci de la suggestion,
      c’est vrai que sous cette forme c’est plus simple à gérér
      Bon week-end

    • Bonjour,

      Je reviens sur cette discussion : l’idée de gérer par les balises < multi > a ses limites :
      -  gestion lourde quand on doit gérer 4 langues,
      -  impossibilité de segmenter les fichiers joints par langue (PDF de manuel et testimoniaux par exemple), d’écrire d’intro par langue, etc.

      — > Ne serait-il pas possible de réserver un article par langue à Manuel Site ? Si c’est une bonne solution, cela dit...

      Ce plugin est une merveille, je ne peux plus m’en passer... une version multilingue du plugin, c’est mon voeu de cette année ;-)

    Répondre à ce message

  • 1

    Ce plugin semble ne plus fonctionner avec spip 3.1.13
    La page de configuration n’existe plus :
    « Fichier configurer_manuelsite introuvable »

    Importé à partir d’une copie de l’archive trouvée sur : http://plugins.spip.net/manuelsite.html

    • Oups, je l’avais mal téléchargé. Il fonctionne très bien en fait.

      Désolé...

    Répondre à ce message

  • 2

    J’utilise la lame « blocs dépliables » du couteau suisse
    Pas de problème partie publique ou partie privée... excepté dans l’article « manuel de rédaction du site » : les blocs sont inopérants (les blocs ne se déplient pas).
    Une piste ???
    SPIP 3.0.20 et CS à jour...

    • Un petit up : pas de piste à proposer ? En PJ, un fichier image qui explique le dysfonctionnement observé :
      les blocs dépliables du couteau suisse se déplient bien dans l’espace privé (et l’espace public, mais pas dans le manuel de rédaction du site

      Un conflit qqpart ? Une histoire de pipeline ?

      Merci (beaucoup) d’avance

    Répondre à ce message

  • Bravo pour ce plugin. C’est une solution élégante et bien faite qui répond bien à la question : comment apporter simplement une documentation complémentaire aux rédacteurs du site.

    Un grand merci !
    Peetdu

    Répondre à ce message

  • 1

    depuis la mise à jour 3.0.17 de SPIP, le bouton du manuel, affiché habituellement en haut à gauche de l’Espace privé, à disparu.

    Pour être bien sûr, j’ai, bien entendu vidé le cache de spip, cache des images compris.

    Merci d’avance,

    Répondre à ce message

  • 1

    Bonjour,

    J’ai un curieux « Au secours : help2. » qui s’affiche en dessous de l’intro du manuel, juste avant le contenu de l’article du manuel, et qui pointe vers un lien bizarre : .../ecrire/?exec=_edit&new=oui... C’est normal, docteur ? (Manuel 0.9.3 sur un SPIP 2.1.23)

    Merci !

    • Je confirme, même problème ici. C’est un peu gênant.
      Le lien « help2 » est une chaîne de langue qui n’existe pas. Il est défini d’après l’option du formulaire de configuration qui n’a pas non plus de chaîne de langue correspondante : « label formu ».
      A mon avis, c’est donc une option encore en développement qui n’a rien à faire sur la version stable.

    Répondre à ce message

  • 3

    J’ai toujours utilisé ce plugin.

    depuis de actualiser a la version 0.9.0 il ne fonction plus (avant j’utilisait la version 69661). Je ne vois plus le icon an haut a gauche.

    Il y a d’autre webmasters avec le même probleme ?

    Merci

    Répondre à ce message

  • 5
    Raphaël

    Bonjour,

    Ce petit plugin est très pratique et je l’ai utilisé sur plusieurs sites. Cependant, je viens de tenter de l’installer sur un nouveau site avec SPIP 3.0.7 et j’ai deux petits bugs :

    Sur la page de configuration du plugin, après avoir validé les changements, j’ai ce message d’erreur :

    Fatal error : Call to undefined function lire_config() in /home/www/c140b23ef45a091456f5d65c44ad8a39/web/plugins/auto/manuelsite/v0.9.1/formulaires/configurer_manuelsite.php on line 106

    Sur le petit manuel (la bouée de sauvetage), avant le contenu proprement dit, j’ai ce message :

    Warning : Division by zero in /home/www/c140b23ef45a091456f5d65c44ad8a39/web/ecrire/inc/filtres_images_lib_mini.php on line 873

    Warning : Division by zero in /home/www/c140b23ef45a091456f5d65c44ad8a39/web/ecrire/inc/filtres_images_lib_mini.php on line 873

    Warning : Division by zero in /home/www/c140b23ef45a091456f5d65c44ad8a39/web/ecrire/inc/filtres_images_lib_mini.php on line 873

    Savez-vous comment corriger cela ?

    Merci de votre aide.

    • Fatal error : Call to undefined function lire_config() in /home/www/c140b23ef45a091456f5d65c44ad8a39/web/plugins/auto/manuelsite/v0.9.1/formulaires/configurer_manuelsite.php on line 106

      Le commit suivant http://zone.spip.org/trac/spip-zone/changeset/71243 devrait réparer cette erreur donc il va falloir mettre à jour le plugin (attendre le nouveau zip si besoin)

      Pour les autres erreurs, peut on avoir une capture d’écran ? Est ce que ton article de manuel a des images ? As tu GD2 d’activé pour la réduction d’images ?

    • Ok suite au message de Pierre KUHN j’ai pu voir le problème des erreurs PHP et patcher par : http://zone.spip.org/trac/spip-zone/changeset/71262

      Ca devrait régler ce problème

    • Raphaël

      Bonjour,

      Merci pour cette réaction très rapide ! Je viens de faire la mise à jour et les erreurs ont disparu.

      Il y a cependant encore un petit détail concernant la largeur de la boîte. A la base, la largeur est bien celle que j’indique dans la configuration du plugin. Mais lorsque je déplie un intertitre, la boîte s’étend sur toute la largeur de la plus grande ligne (sans faire un paragraphe sur plusieurs lignes)...

    • Salut

      Moi j’ai plus de message d’erreur et j’ai pas le dernier soucis évoquer, tu vides tes caches ?

    • Raphaël

      En effet, j’ai tout rechargé et cela fonctionne. Merci beaucoup.

    Répondre à ce message

  • 5

    Bonjour

    Depuis le dernier commit, le plugins sauvegarde pas l’article souhaiter, chez vous aussi ?

    Répondre à ce message

  • 4

    Aucun problème, jusqu’ici, mais je tenais a dire : Merci et félicitations pour ce plugin ;-)

    Voila @+

    • Après quelques semaines d’utilisation spip 3.0.5 ..., je remarque dans mes log des erreurs de ce genre :

      Sep 29 21:59:46 127.0.0.1 (pid 1096) :Pri:WARNING: table_objet(faq) calculee sans verification
      Sep 29 21:59:46 127.0.0.1 (pid 1096) :Pri:ERREUR: Erreur mysql 1146
      Sep 29 21:59:46 127.0.0.1 (pid 1096) :Pri:ERREUR: Table 'test_spip3.faqs' doesn't exist - SHOW CREATE TABLE `faqs`
      Sep 29 21:59:46 127.0.0.1 (pid 1096) :Pri:!INFO: trouver_table: table inconnue '' 'faqs'

      une idee de ou ça peut venir ?

    • Hello

      C’est un problème de log un peu trop verbeux de spip. Sans conséquence sur le fonctionnement. Voir cette discussion : http://thread.gmane.org/gmane.comp.web.spip.zone/29221/focus=29236

    • ok merci de ta réponse, j’avais pourtant fait des recherche , mais je ne suis pas tombé sur ce fil.

      Ce qui m’étonne, dans ce cas précis c’est que je dois avoir une trentaine de plugins installé sur le site de test et je n’ai des log d’erreur que sur celui la, hors le thread parle d’une généralité de spip, j’aurais donc due avoir plus d’erreurs, mais bon, a par moi qui regarde les logs ^^, faut relativiser !

      merci encore pour le plugin et bonne journée ;-)

    • Moi, j’en ai sur d’autres plugins... Donc attendons la correction dans le core et ensuite on verra...

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 1er novembre 2017