Thickbox

Le plugin Thickbox pour SPIP, qui permet d’afficher une image avec un effet de présentation à la mode.

Voici le plugin Thickbox pour SPIP.

Présentation

Il s’agit d’une adaptation du code original de Cody Lindley qui permet d’afficher une image avec un effet de présentation à la mode qui se met en route lorsque l’image est cliquée. Sur le même principe, on peut également afficher des fenêtre dites « modales », c’est à dire des pop-up HTML.

Le script se déclenche sur les images par exemple appelées dans un texte par <doc53|center>.

Sur le portfolio de SPIP, ca fonctionne directement comme une galerie d’images (précédant, suivant diaporama etc).

Installation

Installer le plugin

L’installation du plugin s’effectue comme pour tous les autres plugins. Il suffit de récuperer le zip, de le décompresser dans son répertoire "plugins", puis d’aller l’activer dans la page de gestion des plugins.

-  Installer un plugin

Toutes les informations

Télécharger le script

Discussion

97 discussions

  • 1

    Bonjour à tous,
    Je bloque depuis quelques heures sur un problème...
    J’utilise spip avec evaweb depuis peu, et je découvre tout doucement les fonctionnalités.
    J’ai assez vite, par nécessité, installé thickbox, et tout allait bien jusqu’à ce que je mette un menu déroulant horizontal qui m’est très utile mais me pose problème :

    Le menu s’affiche par-dessus les thickbox.

    J’ai déjà cherché sur le net, il semble que je ne sois pas le seul à avoir le problème, mais je n’ai pas trouvé de réponses franchement satisfaisante.

    Merci beaucoup de votre aide, je suis certain que la solution ne doit pas être difficile à trouver...

    • Si ton problème n’est pas encore résolu, dans le répertoire du plugin ouvre thickbox.css, trouve #TB_window et mets la valeur du z-index à 10000. Ca devrait le faire...

    Répondre à ce message

  • Bonjour à tous,
    J’utilise thickbox avec un sarkaspip sans problème (activation pour les articles dans la config de sarka) mais là avec un site tout neuf (avec zspip) je ne trouve pas comment avoir thickbox dans mes articles.

    Ça fonctionne sans pb pour le portfolio mais pas pour les images des articles.

    Faut-il modifier mon squelette article ?

    Répondre à ce message

  • Bonjour,

    J’aimerais savoir s’il est possible de comptabiliser le nombre de clics sur les images svp ?
    Merci

    Répondre à ce message

  • Christian

    Bonjour,
    Qui sais comment supprimer l’affichage du poids de la photo (voir photo exemple) tout en affichant le titre de l’image.
    merci

    Répondre à ce message

  • 1

    Bonjour,

    Qui peux m’aider pour installer le plug tickbox ca fé une semaine que j’essaie de comprendre ... et je n’y arrive pas quelqu’un peux m’expliquer clairement ...
    Je suis nouvelle ....

    Merciii

    Répondre à ce message

  • tarentaise

    Bonjour,

    j’utilise le plugin Thickbox sur plusieurs sites mais actuellement je bute sur un petit souci.

    Je dois faire en sorte qu’une fenêtre Thickbox s’ouvre au chargement d’une page pour afficher une vidéo de présentation. J’ai beau chercher je ne trouve pas la solution.

    Si quelqu’un a déjà réaliser cela ....

    D’avance merci

    Répondre à ce message

  • Bonjour à tous !

    J’ai un soucis avec le compteur de ThickBox et une pagination ajaxée...

    Je précise que je tiens à ce plugin qui est le seul à offrir un zoom sur les images (mis à part CloudZoom, mais c’est différent), et c’est précieux ;)

    Mon problème :

    Une fois la page chargée (page 1), lorsqu’on clique sur une image, le compteur affiche le nombre de documents affichés sur cette page, et non le #GRAND_TOTAL (nombre total de documents joints à l’article)...

    Par contre, si on clique sur une autre page, alors le nombre total de documents tiens compte des pages précédentes... Mais toujours pas des suivantes...

    ET ! Si on reviens à une page précédente, alors c’est le nombre de documents précédents + le nombre contenu dans cette page !?

    Le problème est visible ici : adriandoura.com
    Bref... c’est dommage :(

    Après avoir recherché dans tous ces messages et via Google, merci à ceux qui m’apporteraient un début de solution...

    Répondre à ce message

  • 5
    mbourlier

    Bonjour,
    Je suis sous SPIP 2.1.8, squelette Sarka 3.0.4 et j’aimerais utiliser un plugin multimédia pour que les images des albums de ma galerie soient visibles sous forme de diaporama. J’en ai essayé plusieurs, sans aucun résultat ; puis je suis revenu à Thickbox V2. Il y a du mieux, mais encore des choses bizarres et obscures.
    Dans le seul album en ligne actuellement http://www.michel-bourlier.fr/accueil/spip.php?page=album&id_article=15, il me faut cliquer sur chaque image du caroussel pour faire augmenter le nombre d’images dans l’album ! ! ! Et puis ensuite, je peux avoir un diaporama, mais une image sur deux ! ! !
    Je dois dire que je suis éberlué et ne comprends rien du tout à ce qui se passe.
    L’un ou l’une d’entre-vous pourrait-il ou elle me venir en aide ,
    Merci d’avance
    Cordialement
    M. BOURLIER

    • mbourlier

      Suite...
      De plus, ce ne sont que les images impaires ! ! ! Je ne comprends pas du tout !
      Help me please !

    • mbourlier

      C’est toujours pareil ! J’ai essayé d’autres plugins, tels Médiabox, Fancybox et je n’arrive pas à obtenir d’affichage original. Il n’y a que Thickbox qui donne un pseudo résultat dans l’espace privé, mais dans l’espace public, toujours le même problème : il faut cliquer sur chaque image du carrousel pour pouvoir afficher un diaporama qui ne correspond pas à la réalité !
      N’y a-t-il personne qui puisse m’aider ?
      Y a-t-il d’autres plugins qui ne posent aucun souci de mise en place et de fonctionnement ?
      Cordialement

      M. BOURLIER

    • mbourlier

      Ça marche !
      Bizarrement, j’ai mis en place le plugin Nyroceros, puis appliqué dans album, article et rubrique l’effet Thickbox ! ! !
      J’ai aussi redimensionné les photos peu être un peu lourdes.
      En espérant que cela pourra aider

      Cordialement
      M. BOURLIER

    • bonjour j’ai le meme probleme que toi

      je suis sous multiflex et je n’arrive plus à avoir thickbox sur les images du portfolio en public
      je ne comprend pas ta résolution

      « puis appliqué dans album, article et rubrique l’effet Thickbox »

      peux tu m’en dire plus

      merci

    • mbourlier

      Bonjour,
      Voici ma configuration :
      Spip 2.1.10, squelette Sarkaspip 3.0.7 et plugins nyrocéros et Thickbox tous deux activés. C’est par hasard que j’ai réussi à obtenir quelque chose et n’ose plus modifier quoi que se soit ! Donc, dans CFG, Nyrocéros configuré comme suit : en général .nyroceros et en galerie .galerie.nyroceros ; Ensuite dans la configuration de Sarkaspip, le plugin Nyrocéros est configuré avec les valeurs nécessaires à Sarkaspip et toujours dans la configuration de sarkaspip, pour album, rubrique et article, l’effet "Thickbox est sélectionné. Cela se fait dans la configuration de Sarkaspip. Comme tu es sous multiplex (squelette ?), je ne sais si tu as quelque chose d’identique. Sinon et c’est peut-être ce qui a débloqué les choses, j’ai réduit la taille de mes images avec Picasa à 480 x 360. Avant cette réduction et ces réglages, tout fonctionnait en interface privée mais plantait dans l’interface publique. Voilà ! Bon courage.
      Cordialement
      M. BOURLIER

    Répondre à ce message

  • Ernchemillois

    Bonjour, j’utilise ce plugin pour créer un site http://www.aspach-chemille.eu , le problème : J’ai une image map créé avec GIMP mais il ne veut pas faire un effet thicbox sur cette image, d’une cela est il possible, et de deux si oui comment !! merci.

    Le code utilisé :

    <map name="map">
    <!-- #$-:GIMP Image Map plug-in by Maurits Rijk -->
    <!-- #$AUTHOR:YGodreau -->
    <area shape="circle" coords="97,120,13" href="squelettes/images/chemille.jpg" type="image/jpeg" />
    <area shape="circle" coords="160,106,11" href="squelettes/images/aspach.png" type="image/jpeg" />
    </map>

    Répondre à ce message

  • 1

    Hello,
    Ne fonctionne pas avec spip 2.1.8...
    Quelqu’un aurait il une idée du pourquoi ça ne marche pas ?

    Merci

    • Bonjour,
      Effectivement, ça ne marche plus avec spip 2.1.8. Je n’ai pas encore trouvé de solution.... Si quelqu’un en a une, ce serait bien.
      Merci.

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 12 novembre 2017