Plugin Barre Typographique Enluminée - comments Plugin Barre Typographique Enluminée 2011-02-20T10:13:09Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment441336 2011-02-20T10:13:09Z <p>Bonjour,</p> <p>Merci pour ce plugin qui fonctionne parfaitement sur les articles, mais voulant utiliser l'encadrement sur un article qui doit apparaitre dans la page d'accueil (sommaire) ça ne marche pas (le [( qui apparaissent au début du texte à encadrer), en revanche le texte est encadré dans le lien article). C'est quoi le problème??<br class="autobr" /> spip 2.1.8 plugin Giseh INSERT-HEAD ajoutée aux fichiers sommaire.html et article.html</p> Plugin Barre Typographique Enluminée 2008-04-09T11:51:15Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment404960 2008-04-09T11:51:15Z <p>J'ai un petit souci. Lorsque j'encadre un texte et que je le regarde dans la partie admin tout est ok, mais des que je le met en ligne le texte n'est plus encadré. De plus il apparait toutes les balises dans le résumé des articles, cela disparait lorsque j'affiche l'article entierement. (pour ceux qui ne m'ont pas compris, voila le site en question : raptorsangers.free.fr) <br class="autobr" /> Merci</p> Plugin Barre Typographique Enluminée 2007-07-04T13:02:17Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment395699 2007-07-04T13:02:17Z <p>Le plugin fonctionne parfaitement dans la partie privée... mais pas dans la partie publique.</p> <p>Ainsi lorsque mon article est enregistré je vois bien la mise en page dans la partie privée, mais certains éléments ne sont pas pris en charge dans la partie publique (en particulier les différents niveaux de titre) une fois l'article publié.</p> <p>Par contre la version impriée (plugin correspondant) prend en charge les titres... mais perd une autre partie de la mise en forme (encadrement...)</p> <p>J'utilise le plugin accèsgroupe... est-ce que ça peut avoir un lien ??</p> <p>Par ailleurs je souhaiterais que la mise en page obtenue soit reprisse dans le fichier pdf que j'obtiens à l'aide du plugin correspondant... avez vous une idée du chemin à suivre (mais il faudrait peut-être que je pose la question à l'auteur du plug in en question !)</p> <p>quoi il en soit merci pour le plugin fourni !</p> Plugin Barre Typographique Enluminée 2007-06-22T14:56:05Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment395288 2007-06-22T14:56:05Z <p>Il faut aujourd'hui utiliser la Barre Typographique V2 disponible sur <a href="http://files.spip.org/spip-zone/" class="spip_out" rel='nofollow external'>SPIP-Zone</a> et le plugin Enluminures Typographiques également sur <a href="http://files.spip.org/spip-zone/" class="spip_out" rel='nofollow external'>SPIP Zone</a>.</p> <p>La doc de ces plugins est en cours de réécriture mais est visible dans l'espace privé de SPIP-Contrib.</p> <p>Cordialement</p> Plugin BTE et recherche de SPIP 2007-06-02T11:32:22Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment394498 2007-06-02T11:32:22Z <p>+1 pour les liens cassés ! Est-ce que quelqu'un sait où se trouve les nouvelles versions indiquées dans l'article ?</p> Plugin Barre Typographique Enluminée 2007-06-02T01:28:35Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment394481 2007-06-02T01:28:35Z <p>Bonjour,</p> <p>Je suis en spip 1.9.2 ... et je tourne en rond sur le site pour trouver la bonne version de ce plugin...</p> <p>Soit-dit en passant, la recherche qui me conduit ici concerne le rendu html du code spip, notamment les balises <hn> avec ces puces images que j'aimerais bien éliminer.</hn></p> <p>Votre plugin réalise t-il ce miracle ?</p> <p>Et si oui, quelle version télécharger ?</p> <p>Le seul zip que je trouve concerne la v 1.9.1 !</p> <p>Merci pour votre éclairage.<br class="autobr" /> :)</p> Plugin BTE et recherche de SPIP 2007-05-25T10:30:03Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment394193 2007-05-25T10:30:03Z <p>Bonjour, j'utilise SPIP 1.9.1-8245</p> <p>J'ai quatre plugins d'installés :<br class="autobr" /> “Accès restreint”, “Corbeille”, “Mailcrypt” et “Barre typo Enluminée pour 1.9.1 et suivantes”</p> <p>Je me suis aperçu que j'avais un problème avec la BTE et la recherche de SPIP.<br class="autobr" /> Quand “Barre typo Enluminée” est activé les mots recherchés ne sont pas encadrés par le code SPIP de surlignage (<span<br class="autobr" /> class="spip_surligne">xxx).<br class="autobr" /> Quand “Barre typo Enluminée” est désactivé le surlignage fonctionne car le code SPIP de surlignage est présent.</p> <p>Au départ j'ai cru à une erreur de ma part dans mes squels car la même distribution sans mes squelettes fonctionnait très bien. En fait ce deuxième SPIP, bien qu'il interroge la même base, n'avait pas la même config puisque sans aucun plugin.</p> <p>J'ai désactivé le plugin mais le rédacteur c'est déjà habitué à la BTE qui laisse aussi ses codes propriétaires.<br class="autobr" /> J'ai bien noté que la BTE “n'est plus et ne sera plus maintenu” et qu'elle “est désormais remplacé par 2 plugins”</p> <p>- Le lien de SPIPContrib “Plugin Barre Typographique V2” pointe sur une page absente (erreur 404) <br />- Idem pour “Plugin Enluminures typographiques pour 1.9.2 et suivantes”</p> <p>Y a-t-il une solution sans upgrader en 1.9.2 ?</p> Mise en exposant : conflit avec plugin Couteau suisse 2007-05-23T23:07:35Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment394148 2007-05-23T23:07:35Z <p>Ce problème semble avoir été résolu avec la version récente du Couteau Suisse. L'as-tu constaté ?</p> Plugin Barre Typographique V2 2007-05-07T13:38:00Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393654 2007-05-07T13:38:00Z <p>Beuh :-(</p> <p>Les versions typo standard 2.1.2 et typo enluminée 1.7.1 sont exclusives on ne peut avoir que l'une OU l'autre ...</p> Plugin Barre Typographique V2 2007-05-07T13:18:40Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393653 2007-05-07T13:18:40Z <p>Mille mercis, car j'avais la version 1.9.1 d'Enluminures Typographiques qui etait systématiquement exclue ... d'où ma question ...<br class="autobr" /> ;-)</p> Plugin Barre Typographique V2 2007-05-07T12:25:27Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393650 2007-05-07T12:25:27Z <p>Tout simplement parce que la V2 est une simple amélioration de l'ergonomie de la Barre Typo standard de SPIP et que pour avoir les raccourcis typographiques de la BTE, il faut aussi le plugin <a href="http://zone.spip.org/trac/spip-zone/browser/_plugins_/_stable_/enluminures_typographiques_v2" class="spip_out" rel='nofollow external'>Enluminures Typographiques</a></p> Plugin Barre Typographique V2 2007-05-07T12:05:38Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393649 2007-05-07T12:05:38Z <p>Bonjour,</p> <p>Dans la V2, l'item “enrichir le texte” n'est plus disponible ?<br class="autobr" /> Cela génère des [( )] partout où il était utilisé ...<br class="autobr" /> Pourquoi ?</p> Mise en exposant : conflit avec plugin Couteau suisse 2007-05-06T08:12:19Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393612 2007-05-06T08:12:19Z <p>Si on installe en parallèle le plugin couteau suisse, il y a manifestement conflit d'affichage et la mise en exposant devient plutôt moche : l'exposant est affiché à mi-hauteur du caractère adjacent...</p> Mode prévisualisation est automatique ? 2007-04-17T16:39:44Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment393072 2007-04-17T16:39:44Z <p>Salut !</p> <p>Avec la version 1.7.1 la prévisualisation s'enclenche d'elle-même, dès qu'on apporte une modification à un article. Est-ce voulu ? (J'aimerais mieux que la mode prévisualisation ne s'enclenche que si elle est demandée par l'utilisateur.)</p> Plugin Barre Typographique Enluminée pour les rubriques ? 2007-04-08T09:11:13Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392764 2007-04-08T09:11:13Z <p>Tout d'abord, c'est génial.</p> <p>Je suis en train de fouiller dans les plugins et j'en découvre un autre <a href="http://www.spip-contrib.net/Barre-Typographique-pour-les" class="spip_out" rel='nofollow external'>Barre typographique pour les rubriques</a>. Je l'installe, c'est cool ca fonctionne.</p> <p>Mais, il y a un “mais”, il n'hérite pas des ajouts de BTE !</p> <p>Est-il envisageable que la berre type des rubriques dispose aussi des améliorations apportées par BTE ?</p> Plugin Barre Typographique Enluminée 2007-04-01T19:01:18Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392591 2007-04-01T19:01:18Z <p>C'était ça.</p> <p>Encore un grand merci pour ce plugin.</p> Plugin Barre Typographique Enluminée 2007-04-01T11:52:48Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392583 2007-04-01T11:52:48Z <p>Voir <a href="http://zone.spip.org/trac/spip-zone/changeset/10421" class="spip_out" rel='nofollow external'>Version 1.6.1</a></p> Plugin Barre Typographique Enluminée 2007-04-01T11:47:25Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392582 2007-04-01T11:47:25Z <p>Le bug est en principe corrigé dans les dernière version (1.7).</p> Plugin Barre Typographique Enluminée 2007-04-01T09:41:50Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392578 2007-04-01T09:41:50Z <p>Salut,</p> <p>Un véritable MUST. J'ai juste un problème avec les tableaux : <br />- Les titres ne sont plus des titres mais de simples cellules mises en gras</p> <p>Si je désactive le plugin, j'ai bien des <code><th></code>. Si je l'active, je trouve des <code><td> <strong class="spip">Produit</strong> </td></code>.</p> <p>J'utilise SPIP 1.9.2 [8782] et la version 1.6 | stable du plugin.</p> <p><i>Je ne gère pas encore les titres de niveaux 4 et 5 car je suis en train de modifier le design de mon site. C'est déjà OK en local, il ne me reste plus que les tableaux (j'ai d'ailleurs découvert grâce à toi que l'on pouvait fusionner des cellules, très pratique) </i></p> Plugin Barre Typographique Enluminée 2007-03-28T19:42:44Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392501 2007-03-28T19:42:44Z <p>Ben, tu as cliqué sur le titre du plugin pour lire la doc qui l'accompagne ?</p> <p>Et mieux encore, tu installe le plugin cfg et tu suis le lien en bas de la doc de la BTE.</p> Plugin Barre Typographique Enluminée 2007-03-28T19:31:16Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392500 2007-03-28T19:31:16Z <p>oups ... le code html a été traduit. <br />- je parlais donc des intertitres h4 <br />- puis des paragraphe class=“spip” <br />- et enfin des li class=“spip”</p> Plugin Barre Typographique Enluminée 2007-03-28T19:29:36Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392499 2007-03-28T19:29:36Z <p>Bravo pour ce super plugin !</p> <p>Un truc très intéressant est la possibilité de mettre plusieurs niveaux de titre, ce qui est génail d'un point de vue sémantique. <br class="manualbr" />En fait j'aimerait commencer les intertitre à partir de</p> <h4> pour que cela respecte mes squelettes. Que dois entrer dans mes_options.php ? <p>Et y a t il un moyen de ne plus avoir</p> <p class="spip">,</p> <li class="spip"> etc. qui ne me sert à rien vu que ma feuille de style des squelettes gère ça ? <p>Merci de votre aide,<br class="manualbr" />@bientôt,<br class="manualbr" />Olivier</p></li></h4> Plugin Barre Typographique Enluminée ne s'affiche pas 2007-03-25T18:04:10Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392404 2007-03-25T18:04:10Z <p>Bon, comme d'hab pas de réponse, alors j'ai essayé aux grands maux les grands remèdes :</p> <ul class="spip"><li> suppression de tous les fichiers du site <strong>(sauf bien sûr les dossiers /IMG, /squelettes et /plugins)</strong>,</li><li> réinstallation du site et ...</li><li> ça marche.</li></ul> <p>Ouf. J'espère que ça pourra être utile à quelqu'un.</p> Plugin Barre Typographique Enluminée ne s'affiche pas 2007-03-24T18:27:52Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392384 2007-03-24T18:27:52Z <p>Bonjour,<br class="autobr" /> J'ai installé Spip d'abord sur un répertoire spip et puis à la racine du site. J'ai essayé d'installer la barre typo, et malgré que tout semble s'être bien passé, elle ne s'affiche pas. Sur un autre site, j'ai la même version de spip, installé cette fois directement, et là tout fonctionne normalement. Je n'ai aucune idée de la façon de résoudre ce problème et ça serait vraiment bien si quelqu'un avait une idée.</p> Plugin Barre Typographique Enluminée 2007-03-20T12:04:10Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392234 2007-03-20T12:04:10Z <p>Bonjour,</p> <p>Il suffit d'éditer le fichier inc/barre.php livré avec le plugin en s'inspirant de l'existant.</p> <p>a+</p> <p>GLG</p> Plugin Barre Typographique Enluminée n'apparaît pas 2007-03-18T18:54:40Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392172 2007-03-18T18:54:40Z <p>J'ai le même problème. Quelqu'un a une solution ?</p> Comportement étrange de l'éditeur de tableaux 2007-03-18T16:12:55Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392158 2007-03-18T16:12:55Z <p>Je confirme.<br class="manualbr" />Même problème chez moi sur SPIP 1.9.2 et Firefox 2.0.0.2 / Ubuntu Linux.</p> Plugin Barre Typographique Enluminée 2007-03-17T23:34:29Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392146 2007-03-17T23:34:29Z <p>Merci et bravo. Et moi qui disais ce matin encore que le seul point faible de spip était la trop grande simplicité de sa barre typographique...</p> <p>Installation sans souci sur spip 1.9.2... J'ai testé quelques fonctions tout va bien... J'attend les retours d'informations de mes rédacteurs pour crier victoire.</p> Plugin Barre Typographique Enluminée 2007-03-17T12:48:05Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392128 2007-03-17T12:48:05Z <p>Serais-il possible de juste rajouter quelques raccourcis par moi meme(mes propres moyent) ??</p> Plugin Barre Typographique Enluminée 2007-03-17T11:54:31Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392127 2007-03-17T11:54:31Z <p>Bonjour,<br class="autobr" /> je viens d'installer ce plugin qui fonctionne correctement en temps que rédacteur.<br class="autobr" /> J'ai un spip 1.9 et un squelette beespip.<br class="autobr" /> Par contre dès que je visualise monsite tout est en vrac.<br class="autobr" /> Plus de mise en page dès que je décoche ce plugin tout redevient normal.<br class="autobr" /> cordialement<br class="autobr" /> sylvain</p> Plugin Barre Typographique Enluminée 2007-03-16T23:30:19Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392117 2007-03-16T23:30:19Z <p>Intéressant !</p> <p>Je dois avouer ne pas avoir testé cet aspect du traitement typo.</p> <p>Ceci dit, je viens de regarder sur un site sans voir de problème.</p> <p>Tu peux préciser ce qui ne va pas, voire m'envoyer une copie d'écran (real3t sur gmail) ?</p> Plugin Barre Typographique Enluminée 2007-03-16T14:29:42Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392099 2007-03-16T14:29:42Z <p>J'ai installé ce plugin .... quelle merveille !!!</p> <p>J'ai seulement un probléme avec la visualisation de l'historique des modifications ...<br class="autobr" /> (articles_versions) les articles n'apparaissent pas toujours bien formatés ... bref on perd toute la mise en page ... sauf pour les tableaux et les listes à puces ....</p> <p>Une idée ? ... Des idées ? ..</p> <p>Merci d'avance</p> Plugin Barre Typographique Enluminée. pipeline 2007-03-15T10:03:55Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392057 2007-03-15T10:03:55Z <p>Bonjour,</p> <p>Bravo pour ce plugin qui est excellent et je dois dire que c'est une très bonne idée d'avoir intégré les pipelines de la Barre Extensible.</p> <p>Par contre je me suis demandé pourquoi le point d'entrée pour la construction des toolboxes «BarreTypoEnrichie_toolbox» n'a pas été implémenté dans le code de la BTE (dans barre.php pour être précis) alors que le point d'entrée est déclaré dans typo_options.php ?</p> <p>Comme j'en avais besoin pour transformer en plugin un petit ajout que j'avais fait dans la BTE, j'ai modifié barre.php de la BTE en ajoutant les lignes de code de la barre extensible pour ce point d'entrée.</p> <p>Cela fonctionne très bien et donne la possibilité d'ajouter des fonctions à la BTE proprement (sans devoir modifier le code de la BTE et ajouter les icones utilisée à chaque nouvelle version) et simplement.</p> Plugin Barre Typographique Enluminée n'apparaît pas 2007-03-14T12:07:03Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392030 2007-03-14T12:07:03Z <p>Le plugin s'affiche bien dans la bien dans le liste des plugin, coché et validé... il n'apparait pas.</p> <p>Ma config : SPIP 1.9.2 [10299]</p> Comportement étrange de l'éditeur de tableaux 2007-03-13T22:02:40Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment392016 2007-03-13T22:02:40Z <p>Bonjour,</p> <p>Bravo pour ce plugin fort sympathique, mais j'ai quelques soucis avec l'éditeur de tableaux.<br class="autobr" /> Lorsque je sélectionne un tableau existant et que je souhaite l'éditer, je me retrouve avec des cellule vidées de leur contenu dans la fenetre popup qui s'ouvre.<br class="autobr" /> Inversement quand je crée un tableau et que je l'enregistre, le contenu (sauf le titre et le résumé) disparait également (je me retrouve avec des |<strong> </strong>|....).<br class="autobr" /> Enfin, lorsque j'essaie de supprimer une ligne, ceci vide encore une fois tous le contenu des autres celulles (mais la ligne disparait bien apres avoir validé 2 fois).</p> <p>Dans la console d'erreur javascript, j'ai</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code>ancien_tableau.t[0] has no properties (table.js Ligne : 424) </code></pre></div> <p>J'utilise Firefox 2.0 sous linux, SPIP 1.9.2 <br class="autobr" /> Barre Typo Enluminée pour 1.9.1 et suivantes<br class="autobr" /> Version : 1.6 | stable</p> <p>Une idée ?<br class="autobr" /> Je vais voir pour tester depuis une autre poste sous IE pour voir si le problème est le meme.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-12T11:38:33Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391953 2007-03-12T11:38:33Z <p>il est ou ton modèle de tableau ?</p> <p>merci</p> Plugin Barre Typographique Enluminée 2007-03-12T07:08:20Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391950 2007-03-12T07:08:20Z <p>Avec grand plaisir !</p> <p>Pour le souligné, c'est définitivement non. Pour 2 raisons :</p> <ul class="spip"><li> l'une typographique : le souligné coupe le jambage des lettres et rallenti la lecture (en souligné, dans pas mal de polices, q et g ont le même aspect, le souligné passant sur la partie horizontale du bas du g).</li><li> l'autre propre au web : seuls les liens doivent être soulignés dans une page web</li></ul> Plugin Barre Typographique Enluminée 2007-03-11T22:15:58Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391946 2007-03-11T22:15:58Z <p>Juste pour dire un grand MERCI pour cette contrib.<br class="autobr" /> Pour moi il manque seulement le souligné, mais bon ...<br class="autobr" /> On tous les cas ça me rend un grand service, voila c'est dit.<br class="autobr" /> MKO.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T18:03:32Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391926 2007-03-10T18:03:32Z <p>Dans article_preview.html, en supprimant les 2 lignes de charset, ça va mieux. Mais j'ai testé les cars accentués (en minuscules). Seuls certains ne passent pas :</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code>- "à" donne "? " - "ë" donne "�« " - "û" donne "� »" - "€" donne "�‚�" </code></pre></div> <p>Les autres cars accentués sont OK.</p> <p>Malheureusement la prévisu de mon tableau à partir d'Excel affiche mal les caractères accentués maintenant. Je vais chercher pourquoi...</p> <p>Cependant tout rentre dans l'ordre, lorsque l'article est enregistré. C'est juste un pb de la prévisualisation.</p> « ne par forker » Kessako ? 2007-03-10T17:56:09Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391925 2007-03-10T17:56:09Z <blockquote class="spip"> <p>« ne par forker » Kessako ?</p> </blockquote> <p>Tu as lu la note de bas de page associée ?</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T17:22:50Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391924 2007-03-10T17:22:50Z <p>La BTE est à jour sur la zone pour corriger ces 2 bugs (il faudra sans doute attendre demain pour le zip).</p> <p>Le 2e, il semblerait qu'il faille tout bêtement supprimer les infos de charset.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T17:22:07Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391923 2007-03-10T17:22:07Z <p>Pour être plus précis, le pb de la prévisu se pose quand j'insère du texte. Ou alors avec des textes déjà présents dans les articles. Exemple :</p> <p>Un résumé avec des accents, même si ça n'est pas du français correct</p> <p>Etonnament je récupère des tableaux Excel via un modèle qui permet de les afficher sous forme de tableau spip. Et dans ce cas, les caractères sont rendus correctement via la prévisu.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T17:21:31Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391922 2007-03-10T17:21:31Z <p>Pour être plus précis, le pb de la prévisu se pose quand j'insère du texte. Ou alors avec des textes déjà présents dans les articles. Exemple :</p> <p>Un résumé avec des accents, même si ça n'est pas du français correct</p> <p>Etonnament je récupère des tableaux Excel via un modèle qui permet de les afficher sous forme de tableau spip. Et dans ce cas, les caractères sont rendus correctement via la prévisu.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T17:07:19Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391919 2007-03-10T17:07:19Z <p>En fait il faut remplacer “<i>charset=UTF-8</i>” par “<i>charset=#CHARSET</i>” dans <strong>tableau_edit.html</strong>. Les caractères s'affichent normalement dans la popup tableau, puis dans le texte généré.</p> <p>Par contre la prévisualisation affiche en UTF-8 au lieu de ISO-8859-1, donc avec des caractères bizarres, qui vont décontenancer mes rédacteurs. Là je n'ai pas trouvé comment faire... Dans <strong>article_preview.html</strong>, j'ai essayé de mettre ISO-8859-1 en dur à la place de <i>lire_meta('charset')</i> pour voir. Mais ça revient au même.</p> Plugin Barre Typographique Enluminée (charset) 2007-03-10T16:46:19Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391918 2007-03-10T16:46:19Z <p>Soit plus précis.</p> <p>Avec quel texte est-ce que ça te génère des caractères bizarres ?</p> <ul class="spip"><li> des accents ? éèçàù ? <ul class="spip"><li> tapés au clavier</li><li> avec les boutons d'insertion de caractères spéciaux ?</li></ul></li><li> des flèches —> <—> <— ?</li><li> autre chose ?</li></ul> Plugin Barre Typographique Enluminée (charset) 2007-03-10T16:18:49Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391917 2007-03-10T16:18:49Z <p>La BTE utilise UTF-8 et j'ai un site en ISO-8859-1. Ca génère des caractères bizarres. Comment l'adapter ?</p> Plugin Barre Typographique Enluminée 2007-03-10T12:40:21Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391906 2007-03-10T12:40:21Z <p>Tu peux récupérer la partie tes tags par la procédure suivante</p> <p>dans le fichier mes_options.php sous le répertoire config copie les fonctions du fichier typo_enrichie.php</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code>change le nom de function BarreTypoEnrichie_pre_propre($texte) {.......} en function avant_propre($texte){... } et celui de function BarreTypoEnrichie_post_propre($texte) {..} en function apres_propre($texte) {..} je n'ai pas gardé function BarreTypoEnrichie_post_typo($texte) , function BarreTypoEnrichie_nettoyer_raccourcis_typo($texte) et function BarreTypoEnrichie_header_prive($texte) mais c'est à voir..</code></pre></div> <p>rajoute end ébut de fichier :</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code>function ereg_remplace($cherche_tableau, $remplace_tableau, $texte) { global $flag_pcre; if ($flag_pcre) return preg_replace($cherche_tableau, $remplace_tableau, $texte); $n = count($cherche_tableau); for ($i = 0; $i < $n; $i++) { $texte = ereg_replace(substr($cherche_tableau[$i], 1, -1), $remplace_tableau[$i], $texte); } return $texte; } </code></pre></div> <p>Chez moi cela marche .. tu peux rajouter tes propres raccourcis ou en enlever.. mais bon tu n'auras plus la barre typo enrichis</p> Passage BT enrichie à BTE 2007-03-10T10:49:23Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391904 2007-03-10T10:49:23Z <p>J'ai fait une mise à jour de l'article. En version 1.5 de la BTE, ce n'est plus forcément nécessaire de modifier sa feuille de style.</p> Passage BT enrichie à BTE 2007-03-10T10:09:17Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391902 2007-03-10T10:09:17Z <p>Y'a t'il des choses particulières à faire lorsqu'on passe de la BT enrichie (1.9.1) à la BTE (1.9.2) comme modifier les css ?</p> <p>merci et merci pour cet outil</p> Plugin Barre Typographique Enluminée 2007-03-10T08:28:57Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391899 2007-03-10T08:28:57Z <p>Tu es sûr d'avoir bien pris la dernière version disponible sur la zone ?</p> <p>Et d'avoir enlever le plugin jquery qu'il ne faut plus mettre en place en 1.9.2 ?</p> Plugin Barre Typographique Enluminée 2007-03-10T07:40:39Z https://contrib.spip.net/Plugin-Barre-Typographique-Enluminee#comment391897 2007-03-10T07:40:39Z <p>“ne par forker” Kessako ?</p> <p>Je viens de passer en 1.9.2 et le plugin barre typographique enrichie ne fonctionnait plus. J'ai remis mes titres normalement... Va falloir recommencer la mise en page... Si j'avais su. Mais bon, ça semble bien foutu et riche en possibilités. Pour éviter les chipos, prévoir la compatibilité simultanée avec spip 1.9.3 etc.</p>