Nyroceros - comments Nyroceros 2017-12-22T15:35:11Z https://contrib.spip.net/Nyroceros,2909#comment495015 2017-12-22T15:35:11Z <p>Bonjour,</p> <p>Super extension que j'utilisais sur des sites en SPIP 2.xx. Quand je suis passé en SPIP 3.2, elle a disparue ! Normal, elle n'est plus compatible et pour cause, elle est intégrée dans la Mediabox. Après avoir longuement cherché comment remplacer nyroceros, essayé plusieurs extensions qui ne faisait pas l'affaire, j'ai trouvé ça :<br class="autobr" /> <a href="https://contrib.spip.net/MediaBox" class="spip_url auto" rel="nofollow">https://contrib.spip.net/MediaBox</a><br class="autobr" /> Tout est expliqué et j'ai juste eu à adapter le contenu de mon article (en gros, remplacer “nyroModal” par “mediabox”, et retoucher le script d'appel) pour retrouver mon super diaporama !!! :-)</p> Nyroceros 2011-05-06T22:29:29Z https://contrib.spip.net/Nyroceros,2909#comment445256 2011-05-06T22:29:29Z <p>Je me réponds à moi-même ! Après bien des galères et je ne sais pas par quel mystère, j'arrive à un résultat. J'ai installé les plugins Nyrocéros et Thickbox et dans la configuration de l'album du squelette Sarka, j'ai appliqué l'effet Thickbox. Je précise aussi que j'ai réduit la taille des photos, ce qui a peut-être aussi eu une influence.<br class="autobr" /> Voilà, si ça peut aider.<br class="autobr" /> En attendant mieux.<br class="autobr" /> Merci aux développeurs.<br class="autobr" /> Cordialement<br class="autobr" /> M. BOURLIER</p> Nyroceros 2011-04-08T09:56:13Z https://contrib.spip.net/Nyroceros,2909#comment443913 2011-04-08T09:56:13Z <p>Suite...<br class="autobr" /> J'ai essayé conformément aux indications de Xdiz de placer le balisage dans l'article de la forme</p> <div class="coloration_code cadre"><div class="spip_spip cadre"><div class="spip"><ol><li class="li1"><div class="de1">/cadre>span class="nyroceros"><img131<span class="re50">|center</span>></span</div></li> </ol></div></div></div> <p>pour chaque image contenue dans l'album, en vain. Cela ne modifie rien du tout !<br class="autobr" /> Je suis désespéré, car j'y bosse depuis trois jours pour des prunes !<br class="autobr" /> Quelqu'un pourra t-il m'aider ?</p> <p>Cordialement<br class="autobr" /> M BOURLIER</p> Nyroceros 2011-04-08T09:30:43Z https://contrib.spip.net/Nyroceros,2909#comment443909 2011-04-08T09:30:43Z <p>Bonjour à la collectivité,</p> <p>Je suis sous SPIP 2.1.8 et squelette Sarka 3.0.4. J'aurais aimé afficher mes albums se trouvant en galerie sous forme de diaporama. J'ai essayé tous les plugins disponibles, en vain. Les deux qui me donnent un peu quelque chose, mais sans être satisfaisant sont Thickbox V2 et Nyroceros. Ils fonctionnent parfaitement bien dans l'interface privée ; dès que je teste dans l'interface publique, c'est très bizarrre !<br class="autobr" /> Le carrousel est bien présent, mais dès que je clique sur la 1ère image, je n'ai qu'une seule image dans le diaporama. J'ai essayé de cliquer sur toutes les images du carrousel et là, le nombre d'images disponibles augmente, mais multiplié par deux. La fonction diaporama est alors disponible, mais affiche les images impaires ! ! ! Curieux, non ?<br class="autobr" /> Et cela est valable aussi bien pour Thickbox que pour Nyroceros !</p> <p>Quelqu'un peut-il m'aider ?<br class="autobr" /> Pour vous faire une idée, voici le lien vers le seul album disponible sur mon site <a href="http://www.michel-bourlier.fr/accueil/spip.php?page=album&id_article=15" class="spip_url spip_out auto" rel="nofollow external">http://www.michel-bourlier.fr/accueil/spip.php?page=album&id_article=15</a> (il ne sert à rien d'en créer d'autres tant que le problème n'est pas résolu !)</p> <p>Merci d'avance pour votre aide<br class="autobr" /> Cordialement<br class="autobr" /> M. BOURLIER</p> Nyroceros 2011-01-25T18:42:33Z https://contrib.spip.net/Nyroceros,2909#comment440060 2011-01-25T18:42:33Z <p>Salut, non mais on a ajouté cette fonctionnalité <a href='https://contrib.spip.net/MediaBox' class="spip_in" hreflang="fr" rel='nofollow'>au plugin mediabox</a>.</p> Nyroceros 2011-01-25T18:40:56Z https://contrib.spip.net/Nyroceros,2909#comment440059 2011-01-25T18:40:56Z <p>Bonjour</p> <p>Est-il possible d'utiliser ce plugin en “splashbox” pour l'ouvrir au chargement d'une page ?</p> <p>Merci</p> Nyroceros 2010-12-22T15:49:03Z https://contrib.spip.net/Nyroceros,2909#comment438414 2010-12-22T15:49:03Z <p>J'ai tenté cette manip... sans résultat en ce qui concerne le titre s'affichant avec l'image du diaporama.</p> <p>Cela dit, j'ai regardé le site que tu me donnes, et je constate, de la même manière, que lorsque la visionneuse démarre, le titre s'affiche, mais pas le descriptif.<br class="autobr" /> Il me semble donc que l'affichage du descriptif n'est pas pris en charge par jquery;nyromodal-1.5.0.js du plugin.<br class="autobr" /> par contre, comme c'est du jquery, je connais absolument pas. Quelqu'un a-t'il une idée ?</p> Nyroceros 2010-12-21T14:02:50Z https://contrib.spip.net/Nyroceros,2909#comment438374 2010-12-21T14:02:50Z <p>Sur mon site, la vignette est mise directement dans le texte de l'article : <tt><docXX|center></tt></p> <p>Si elle est en portfolio, il faut copier le fichier inc-documents.html dans /squelettes et le modifier comme ceci :</p> <div class="precode"><pre dir="ltr" style="text-align: left;" class="spip"><code><span class="re15"><B_documents_portfolio></span> <div id="documents_portfolio"> <h2><span class="re30"><:info_portfolio:></span></h2> <span class="re11"><BOUCLE_documents_portfolio</span><span class="re12">(DOCUMENTS)</span><span class="re13"> <span class="re41">{id_article}</span> <span class="re41">{mode=document}</span><span class="re41">{extension IN png,jpg,gif}</span> <span class="re41">{par num titre, date}</span><span class="re41">{doublons}</span><span class="re41">{vu=non}</span></span><span class="re10">></span><span class="re4">[</span> <a href="<span class="re4">(</span><span class="re1">#URL_DOCUMENT</span><span class="re4">)</span>" type="<span class="re1">#MIME_TYPE</span>" onclick="location.href='<span class="re4">[</span><span class="re4">(</span><span class="re1">#URL_ARTICLE</span> <span class="re50">|parametre_url</span><span class="re40">{id_document,<span class="re1">#ID_DOCUMENT</span>}</span> <span class="re4">)</span><span class="re4">]</span>#documents_portfolio';return false;"<span class="re4">[</span> class="<span class="re4">(</span><span class="re1">#EXPOSER</span><span class="re4">)</span>"<span class="re4">]</span><span class="re4">[</span> title="<span class="re1">#TITRE</span> - <span class="re4">(</span><span class="re1">#DESCRIPTIF</span><span class="re50">|attribut_html</span><span class="re4">)</span>"<span class="re4">]</span>><span class="re4">[</span><span class="re4">(</span><span class="re1">#FICHIER</span> <span class="re50">|image_reduire</span><span class="re40">{0,100}</span> <span class="re50">|inserer_attribut</span><span class="re40">{class,spip_logos}</span> <span class="re50">|inserer_attribut</span><span class="re40">{alt,<span class="re4">[</span><span class="re1">#TITRE</span> - <span class="re4">(</span><span class="re1">#DESCRIPTIF</span><span class="re50">|attribut_html</span><span class="re4">)</span><span class="re4">]</span>}</span><span class="re4">)</span><span class="re4">]</span></a> <span class="re4">]</span><span class="re15"></BOUCLE_documents_portfolio></span> </div> <span class="re15"></B_documents_portfolio></span></code></pre></div> Nyroceros 2010-12-21T10:20:30Z https://contrib.spip.net/Nyroceros,2909#comment438358 2010-12-21T10:20:30Z <p>Merci tout d'abord de cette aide inespérée</p> <p>J'ai mis ce code à la place de la version initiale dans un fichier doc.html que j'ai placé dans /squelettes/modeles/doc.html</p> <p>Cela ne semble rien changer (comme si la surcharge n'était pas prise en compte).<br class="autobr" /> J'ai vidé le cache, mais peut-être y a t'il une autre démarche à faire pour la prise en compte effective des modifs.</p> Nyroceros 2010-12-21T08:36:43Z https://contrib.spip.net/Nyroceros,2909#comment438349 2010-12-21T08:36:43Z <p>Bonjour,</p> <p>Il faut ajouter la balise #DESCRIPTIF dans le fichier /modeles/doc.html :</p> <div class="coloration_code cadre"><div class="spip_spip cadre"><div class="spip"><ol><li class="li1"><div class="de1"><dt><span class="re4">[</span><a href="<span class="re4">(</span><span class="re1">#GET</span><span class="re40">{url}</span><span class="re4">)</span>"<span class="re4">[</span> class="<span class="re4">(</span><span class="re1">#ENV</span><span class="re40">{lien_class}</span><span class="re4">)</span>"<span class="re4">]</span> title='<span class="re1">#TITRE</span> - <span class="re1">#DESCRIPTIF</span>'<span class="re4">[</span> <span class="re4">(</span><span class="re1">#ENV</span><span class="re40">{lien}</span><span class="re50">|?</span><span class="re40">{'',type="<span class="re1">#MIME_TYPE</span>"}</span><span class="re4">)</span><span class="re4">]</span>><span class="re4">]</span><img src='<span class="re1">#GET</span><span class="re40">{fichier}</span>' width='<span class="re1">#GET</span><span class="re40">{width}</span>' height='<span class="re1">#GET</span><span class="re40">{height}</span>' alt='<span class="re1">#TITRE</span> - <span class="re1">#DESCRIPTIF</span>' /><span class="re4">[</span><span class="re4">(</span><span class="re1">#GET</span><span class="re40">{url}</span><span class="re50">|?</span><span class="re40">{</a>}</span><span class="re4">)</span><span class="re4">]</span></dt></div></li> </ol></div></div></div> <p>Visible sur mon site <a href="http://www.kerudo.net" class="spip_out" rel='nofollow external'>www.kerudo.net</a></p> Nyroceros 2010-11-12T16:10:38Z https://contrib.spip.net/Nyroceros,2909#comment436793 2010-11-12T16:10:38Z <p>J'aimerai pouvoir avoir le descriptif de l'image, en plus du titre (si celui-ci existe) en haut de l'image du diaporama (voire en bas, si cela est envisageable).<br class="autobr" /> Y'a t'il une notice quelque part pour régler ces choses.</p> Nyroceros 2010-08-14T22:03:09Z https://contrib.spip.net/Nyroceros,2909#comment433287 2010-08-14T22:03:09Z <p>Oui il faut mettre des liens vers toutes les images ; ce que je fais de mon côté, c'est de mettre ces liens dans une boucle à part, avec uniquement des <code><a href=#URL_DOCUMENT></a></code>, qui n'affichent rien mais qui lancent tout de même la galerie.</p> Nyroceros 2010-07-15T18:13:39Z https://contrib.spip.net/Nyroceros,2909#comment432652 2010-07-15T18:13:39Z <p>Bonjour,</p> <p>J'utilise actuellement ce plugin pour une galerie photo. Le soucis est que ma galerie photo est paginée (quatre photos par page). Le diaporama de Nyrocéros ne me permet de voir que les quatre photos de la page et non toutes celles de l'article (réparties par page donc).</p> <p>Y a-t-il une solution pour que le diaporama m'affiche toutes les photos du portfolio de l'article en question?</p> <p>Merci d'avance</p> Nyroceros 2010-05-01T17:39:22Z https://contrib.spip.net/Nyroceros,2909#comment430042 2010-05-01T17:39:22Z <p>Je rentre un souci dont je ne vois pas l'issue.</p> <p>J'ai installé nyroceros et lorsque je veux l'atteindre par cfg, il me dit que seul le webmestre peut faire des modifications...</p> <p>Oui, mais comment je fais ?????????? J'ai bien vérifié que j'étais enregistré en webmestre, je n'ai pas de souci pour accéder aux autres applications, mais là, je coince !</p> <p>Est-ce que quelqu'un a une solution à me proposer ?</p> Nyroceros 2010-04-21T14:24:31Z https://contrib.spip.net/Nyroceros,2909#comment429630 2010-04-21T14:24:31Z <p>Très bon plugins</p> Nyroceros 2010-03-29T20:09:24Z https://contrib.spip.net/Nyroceros,2909#comment428385 2010-03-29T20:09:24Z <p>je me réponds, repris un autre cfg.zip sur un site opérationnel, plus de pb.</p> Nyroceros 2010-03-29T19:19:32Z https://contrib.spip.net/Nyroceros,2909#comment428382 2010-03-29T19:19:32Z <p>Salut,</p> <p>merci pour ce nice plugin en production sur plusieurs site. Mais là, problème, je viens de l'installer avec le dernier spip, 2.0.10 14698, et ça plante cfg.</p> <p>ça affiche quelques lignes de la page puis<br class="autobr" /> erreur parametre interne: ' cf piece jointe</p> <p>le source s'arrête là également...</p> Nyroceros 2010-02-03T10:29:03Z https://contrib.spip.net/Nyroceros,2909#comment425988 2010-02-03T10:29:03Z <p>même soucis, j'ai essayer votre méthode mais ca n'enleve pas la bande transparente en bas de l'image.</p> <p>ya une autre solution? marci:)</p> Nyroceros 2010-01-25T10:54:10Z https://contrib.spip.net/Nyroceros,2909#comment425608 2010-01-25T10:54:10Z <p>Oui, ça se passe dans le fichier plugins/nyroceros/js/jquery.nyroModal-1.5.0.js</p> <p>chercher dans ce fichier (CTRL+F) <br class="autobr" /> «addImageDivTitle: true, // Indicate if the div title should be inserted»<br class="autobr" /> il faut à <strong>false</strong></p> quelle balise et où mettre la balise 2010-01-22T13:43:43Z https://contrib.spip.net/Nyroceros,2909#comment425522 2010-01-22T13:43:43Z <p>Dans l'édition de l'article vous pouvez entourer votre image d'une balise span avec la classe nyroceros.<br class="autobr" /> Exemple:</p> <p><code><span class="nyroceros"><img8|center></span></code></p> Nyroceros 2009-12-10T05:45:41Z https://contrib.spip.net/Nyroceros,2909#comment424146 2009-12-10T05:45:41Z <p>De quelle façon peut on supprimer la bande en surimpression en bas de l'image.</p> <p>Y a t'il un paramètre facilement modifiable pour cela et dans quel fichier ?</p> <p>Merci pour vos retours !!</p> quelle balise et où mettre la balise 2009-10-10T08:55:20Z https://contrib.spip.net/Nyroceros,2909#comment421466 2009-10-10T08:55:20Z <p>bonjour,</p> <p>je viens de découvrir ce plugin en recherchant un diaporama photo.<br class="autobr" /> je l'ai installé mais ensuite je ne comprends pas bien la démarche à suivre : <br />- faut-il mettre mettre la balise #INSERT_HEAD ? <br />- que signifie #documents_portfolio .nyroceros et où faut-il insérer ce code ? <br />- que siginife .nyroceros et où faut-il le mettre ?</p> <p>Merci pour ce plugin et les infos.</p> <p>cordialement,</p> <p>fabien</p> Nyroceros 2009-09-17T03:29:59Z https://contrib.spip.net/Nyroceros,2909#comment420650 2009-09-17T03:29:59Z <p>Le mode diaporama ne fonctionne pas et je ne vois pas le bando de controle. <br class="autobr" /> J'utilise SPIP 2.0.9 et le dernier plugin Nyroceros basé sur NyroModal1.5.0.</p> <p>Quelqu'un a-t-il une idée ?</p> <p>Merci</p> Nyroceros 2009-09-16T19:29:02Z https://contrib.spip.net/Nyroceros,2909#comment420641 2009-09-16T19:29:02Z <p>Bonjour</p> <p>Comment faire pour donner une taille maximal sur un lien du type [(#LOGO_RUBRIQUE_NORMAL||image_reduire<i>100,100</i>|inserer_attribut<i>class,nyroceros left</i>)] par ce que sur firefox c'est trop la taille de l'écran.</p> <p>Merci d'avance</p> comment utiliser ce plugin 2009-09-15T11:17:01Z https://contrib.spip.net/Nyroceros,2909#comment420572 2009-09-15T11:17:01Z <p>Bonjour,</p> <p>Pour pouvoir le configurer, il faut installer le plugin cfg. Il est alors possible de définir les éléments qui déclenche l'ouverture de nyrocéros. Par défaut, il s'agit d'une <i>class</i> .nyrocéros.<br class="autobr" /> D'autres détails sont configurables.</p> comment utiliser ce plugin 2009-06-12T09:54:09Z https://contrib.spip.net/Nyroceros,2909#comment417312 2009-06-12T09:54:09Z <p>Bonjour tous,</p> <p>Y a t'il une explication quelque par sur l'utilisation de ce plugin comment l'intégrer au niveau du squelette...<br class="autobr" /> Merci</p> Nyroceros 2009-05-19T11:26:16Z https://contrib.spip.net/Nyroceros,2909#comment416541 2009-05-19T11:26:16Z <p>Bonjour nico4peace,</p> <p>J'ai eu un problème similaire que j'ai résolu - après avoir beaucoup chipoté - en supprimant le target=“_blank” qui traînait dans mes liens. Peut-être cela vous aidera-t-il ?</p> <p>TICa</p> Nyroceros 2009-05-16T17:20:34Z https://contrib.spip.net/Nyroceros,2909#comment416486 2009-05-16T17:20:34Z <p><strong>Nyroceros</strong> n'apparaît pas dans la liste des <i>plugins</i> de <strong>spip-contib.net</strong> qui peuvent être installés automatiquement. Il faudrait peut-être affecter le présent article de quelques mots-clés pour déclencher l'inclusion de <strong>Nyroceros</strong> dans la liste (?).</p> <p>Voir: <a href="http://www.spip-contrib.net/spip.php?page=rss_plugins_spip_2" class="spip_out" rel='nofollow external'>La liste des plugins de spip-contrib</a></p> Nyroceros 2009-05-09T08:11:28Z https://contrib.spip.net/Nyroceros,2909#comment416154 2009-05-09T08:11:28Z <p>Bonjour,</p> <p>Je viens de passer mon site sous spip 2.0.7 et j'ai eu le même souci cité plus bas concernant les boutons suivants et précédents qui ne s'affichaient pas (même en roll over sur les cotés de l'image) j'ai consulté les exemple en ligne et je me suis apperçu qu'un paramêtre était rajouté dans le code des image. A savoir <strong>rel=“gal”</strong> ... J'ai donc rajouté ce paramètre dans mon squelette et depuis les boutons suivants et précédents apparaissent bien.</p> <p>Voilà ... en espérant que celà puisse aider certains.</p> Nyroceros 2009-04-08T13:56:42Z https://contrib.spip.net/Nyroceros,2909#comment415190 2009-04-08T13:56:42Z <p>J'utilise Thickbox v2 avec spip 2.0 mais c'est la cata, Nyroceros est-il mieux adapté ?</p> Nyroceros 2009-02-11T16:29:04Z https://contrib.spip.net/Nyroceros,2909#comment413295 2009-02-11T16:29:04Z <p>Bonjour,</p> <p>Le plugin est convainquant mais j'utilise actuellement thickbox2 et je vois pas encore toutes les différences qu'il peut y avoir entre les deux.<br class="autobr" /> C'est qui le plus fort ? :)</p> <p>ZiWaM</p> Nyroceros 2009-01-30T23:41:20Z https://contrib.spip.net/Nyroceros,2909#comment412877 2009-01-30T23:41:20Z <p>Coucou Eric,</p> <p>C'est mieux comme ça non ?</p> Nyroceros 2009-01-30T23:37:46Z https://contrib.spip.net/Nyroceros,2909#comment412876 2009-01-30T23:37:46Z <p>il faut balader sa souris sur les bords en haut à droite ou à gauche, à ce moment les flèches apparaissent. ds la config on peut aussi cocher l'option mode diaporama pour voir les images défiler automatiquement .</p> Passer d'une image à une autre 2009-01-30T09:06:20Z https://contrib.spip.net/Nyroceros,2909#comment412850 2009-01-30T09:06:20Z <p>Bonjour,</p> <p>Je ne trouve pas la possibilité de passer d'une image à une autre. Il me faut à chaque fois cliquer sur une image.</p> <p>Je suis sous spip 2.0.3, gd2 actif</p> <p>Procédure:</p> <p>- mise à jour du plugin. <br />- vidange du /tmp. <br />- vidange des caches.</p> <p>Merci de votre aide</p>