Mise à jour automatique des plugins - comments Mise à jour automatique des plugins 2020-09-09T19:02:40Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment506283 2020-09-09T19:02:40Z <p>Super !<br class="autobr" /> Merci beaucoup</p> Mise à jour automatique des plugins 2020-04-23T12:45:19Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment504835 2020-04-23T12:45:19Z <p>Bonjour Roland,<br class="autobr" /> Le mieux, c'est de procéder autrement pour permettre une mise à jour des plugins :<br class="autobr" /> Il faut aller dans : Gestion des Plugins > Ajouter des plugins > Dépôt. <br class="autobr" /> Puis faire le dépôt.<br class="autobr" /> Quand on revient ensuite sur la liste des plugins du site, une nouvelle icône apparaît : on peut alors mettre à jour les plugins !</p> Mise à jour automatique des plugins 2020-04-23T11:21:51Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment504834 2020-04-23T11:21:51Z <p>Bonjour Roland. <br class="autobr" /> Il y a des changements actuellement du côté de spip, c'est peut-être la raison, je vais me pencher sur la question.<br class="autobr" /> Merci pour le retour !</p> Mise à jour automatique des plugins 2020-04-23T09:48:57Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment504832 2020-04-23T09:48:57Z <p>Suite de mon exploration...<br class="autobr" /> je gère 4 sites tous avec la même version de Spip (3.2.7) <br />- site CR : même problème + CS « Problème sur : le serveur distant » + disparition du bouton “Ajouter un plugin” <br />- site CD : même problème + CS « Problème sur : le serveur distant » <br />- site lrnd : aucun problème mais le message du CS « Problème sur : le serveur distant » est affiché <br />- site NR : pas de plugin installé pourtant... J'ai donc installé un plugin en test (nospam) sans aucun problème; puis j'ai installé le Couteau Suisse. Le message CS « Problème sur : le serveur distant » est affiché. J'ai donc ajouté la lame “Mises à jour automatiques” et... mes plugins installés auparavant sont réapparus mais tous inactifs !!! Test en ré-activant un plugin (Crayons) => OK. Mais... la lame “Mises à jour” me dit que le CS est inactif alors qu'il est actif puisque je m'en sers !</p> <p>Je n'y comprends plus rien...</p> <p>Mais je vais aller vérifier mes versions php.</p> Mise à jour automatique des plugins 2020-04-23T09:20:19Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment504830 2020-04-23T09:20:19Z <p>Bonjour,<br class="autobr" /> même problème...<br class="autobr" /> Dans la config. du CS, je vois ce message : “Problème sur : le serveur distant”. Cela viendrait donc du serveur ?<br class="autobr" /> D'autres auraient-ils le même problème ?<br class="autobr" /> Merci.</p> Mise à jour automatique des plugins 2019-04-15T19:29:37Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment500864 2019-04-15T19:29:37Z <p>Bonjour,<br class="autobr" /> La lame “Mise à jour automatique des plugins” semble ne pas fonctionner.<br class="autobr" /> En cas d'essai de mise à jour, le plugin ne trouve pas le fichier distant .zip.<br class="autobr" /> (comportement avec un SPIP 3.2.4 Couteau Suisse 1.10.15, et les autres plugins mis à jour la semaine dernière et tous désactivés, la cache vidé, PHP7.0)</p> Mise à jour automatique des plugins 2019-04-15T19:20:20Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment500863 2019-04-15T19:20:20Z <p>Bonjour,<br class="autobr" /> Sur la lame “Mise à jour automatique” —> sur les plugins qu'il me faudrait mettre à jour, j'obtiens <br class="autobr" /> “erreur : impossible de charger <a href="https://files.spip.net/spip-zone/" class="spip_url spip_out auto" rel="nofollow external">https://files.spip.net/spip-zone/</a>[plugin].zip”.<br class="autobr" /> Faut-il une manipulation sur le server ou autre, ou bien est-ce un bug ?<br class="autobr" /> (avec un SPIP 3.2.4, Couteau Suisse 1.10.15, les autres plugins mis à jour la semaine dernière et tous désactivés, le cache vidé).<br class="autobr" /> Merci</p> Mise à jour automatique des plugins 2017-09-23T20:16:48Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493512 2017-09-23T20:16:48Z <p>OK Merci beaucoup !</p> <p>La page que tu mets en lien à du être complétée depuis mon dernier passage. A l'époque je n'avais rien compris au fonctionnement des dépôts ;)</p> Mise à jour automatique des plugins 2017-09-23T19:42:48Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493509 2017-09-23T19:42:48Z <p>Dans l'espace de gestion des plugins, tout simplement. Il faut juste déclarer le flux distant (une valeur par défaut est fourni), et ensuite dès qu'une mise à jour est disponible, il y un symbole double flèche et on clique dessus.</p> <p>On peut ensuite cocher les plugins à mettre à jour ou bien demander de tous les cocher, puis cliquer sur mettre à jour les plugins.</p> <p>(Cela marche uniquement avec les plugins installé dans auto).</p> <p><a href="https://www.spip.net/fr_article3396.html" class="spip_url spip_out auto" rel="nofollow external">https://www.spip.net/fr_article3396.html</a></p> Mise à jour automatique des plugins 2017-09-23T19:38:14Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493508 2017-09-23T19:38:14Z <p>Ah oui ? Et c'est intégré où ? je suis en SPIP 3.1.6 et je suis toujours passé par le couteau suisse pour mettre à jour mes plugins. Il existe un autre moyen ?</p> Mise à jour automatique des plugins 2017-09-23T19:35:40Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493507 2017-09-23T19:35:40Z <p>Le mainteneur du plugin n'a plus l'air actif. Cependant comme c'était une modif simple, je l'ai envoyé sur la zone. Donc la prochaine version 1.9.13 devrait résoudre ce problème.</p> <p>Cela étant, c'est une fonctionnalité intégrée par défaut en SPIP 3.0 et ultérieur.</p> Mise à jour automatique des plugins 2017-09-23T19:27:33Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493506 2017-09-23T19:27:33Z <p>Bonjour Thierry,</p> <p>la réponse à ta question se trouve juste en dessous (voir question et réponse d'Eric en date du 9 mai 2017).</p> <p>Cordialement</p> Mise à jour automatique des plugins 2017-09-23T19:24:52Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493505 2017-09-23T19:24:52Z <p>En effet, ça marche !<br class="autobr" /> Merci !<br class="autobr" /> Quelqu'un sait quand cette correction sera intégrée dans une mise à jour du plugin ?</p> Mise à jour automatique des plugins 2017-09-17T11:55:26Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment493416 2017-09-17T11:55:26Z <p>Bonjour,</p> <p>Après une mise à jour du Couteau suisse, pourquoi j'obtiens le message suivant, dans le tableau des Mises à jour automatiques, en face de chaque plugin présents dans le couteau suisse :</p> <p>La révision distante n'a pas pu être trouvée.</p> <p>Merci pour vos avis,</p> <p>Amicalement,</p> <p>Thierry</p> Mise à jour automatique des plugins 2017-05-29T08:49:49Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment492395 2017-05-29T08:49:49Z <p>J'ai trouvé la solution... Il suffit de modifier dans la lame \plugins\auto\couteau_suisse\outils\maj_auto_action_rapide.php à la ligne 351<br class="autobr" /> <code>if(strncmp($url_origine, 'http://', 7)!==0) $url_origine='';</code><br class="autobr" /> par<br class="autobr" /> <code>if(strncmp($url_origine, 'https://', 7)!==0) $url_origine='';</code></p> Mise à jour automatique des plugins 2017-05-27T09:06:53Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment492378 2017-05-27T09:06:53Z <p>Même problème sur spip 2.1 et 3.1 depuis la dernière mise à jour<br class="autobr" /> La révision distante n'a pas pu être trouvée<br class="autobr" /> Solution ? merci<br class="autobr" /> JPH</p> Mise à jour automatique des plugins 2017-05-09T09:32:05Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment492154 2017-05-09T09:32:05Z <p>Bonjour,</p> <p>Suite aux nombreuses mise-à-jour des différents plugins de ces dernières semaines, je constate qu'aujourd'hui, la lame mise à jour automatique ne trouve pas le serveur...</p> <blockquote class="spip"> <p>Mini Calendrier (v2.4.1)<br class="autobr" /> La révision distante n'a pas pu être trouvée.</p> </blockquote> <p>Cela est indiqué pour tous les plugins...</p> Mise à jour automatique des plugins 2016-03-25T21:20:52Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486746 2016-03-25T21:20:52Z <p>Bonjour Eric,</p> <p>je suis resté à la 3.0 (mais bon j'ai l'écran de sécurité donc ça devrait pas poser de problème) et j'ai toujours la même erreur.</p> <p>Par contre je me suis aperçu que quand j'essaie la mise à jour automatique, ça plante, mais si je refais la même tentative juste après, la mise à jour à l'air de fonctionner. Peux-tu essayer chez toi?</p> Mise à jour automatique des plugins 2016-03-17T10:16:03Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486657 2016-03-17T10:16:03Z <p>Le problème a changé ?... Est-ce à cause de la mise-à-jour vers spip 3.1.1 ??.... J'ai maintenant le message que le fichier n'a pas été trouvé sur le serveur (or, ici, le nom de fichier zip sur la zone de téléchargement est correctement orthographié). Une fois le fichier récupéré sur la zone et installé par ftp, le message retourné dans le tableau de la lame 'mise-à-jour automatique' est : “La révision distante n'a pas pu être trouvée.”</p> <p>???</p> Mise à jour automatique des plugins 2016-03-13T12:24:52Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486619 2016-03-13T12:24:52Z <p>Bonjour,</p> <p>ah oui effectivement c'est peut-être la source du problème. J'ai aussi noté que lorsque je supprime le dépot et que je le réenregistre, je peux faire une mise à jour automatique avant que le bug ne se reproduise.</p> <p>Pourrait-il sinon s'agir du poids des plugins ou du dépot trop important pour la mémoire allouée par le serveur? Je suis chez 1&1 et j'ai moins de 100mo de mémoire.</p> <p>Théo</p> Mise à jour automatique des plugins 2016-03-10T12:02:19Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486579 2016-03-10T12:02:19Z <p>Bonjour, sur le dépôt... Par exemple, j'ai un plugin qui se nomme machin.zip et ensuite, il devient machin_v3.zip pour ensuite redevenir machin.zip...</p> Mise à jour automatique des plugins 2016-03-10T11:41:37Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486578 2016-03-10T11:41:37Z <p>Je ne comprends pas où tu vois ce changement, sur ton serveur ou sur le dépot?<br class="autobr" /> Merci.</p> Mise à jour automatique des plugins 2016-03-09T06:42:06Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486560 2016-03-09T06:42:06Z <p>Je remarque que les plugins changent souvent de nom (de dossier). C'est une des raisons qui explique le message d'erreur. Peut-être faut-il mettre sur pied une normalisation ?...</p> Mise à jour automatique des plugins 2016-03-08T15:27:29Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486550 2016-03-08T15:27:29Z <p>Bonjour,</p> <p>même problème pour moi depuis le passage à spip 3.1</p> <p>Théo</p> Mise à jour automatique des plugins 2016-02-18T10:11:15Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment486045 2016-02-18T10:11:15Z <p>J'ai fréquemment ce message qui s'affiche pour différents plugins...</p> <p>'Le fichier « <a href="http://files.spip.org/spip-zone/boutonstexte-v2.zip" class="spip_url spip_out auto" rel="nofollow external">http://files.spip.org/spip-zone/boutonstexte-v2.zip</a> » est introuvable !'</p> Mise à jour automatique des plugins 2016-02-15T16:27:55Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment485924 2016-02-15T16:27:55Z <p>J'ai l'erreur, mes formulaires font erreur 500 maintenant<br class="autobr" /> Comment corriger ?</p> Mise à jour automatique des plugins 2015-12-02T09:32:06Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment484775 2015-12-02T09:32:06Z <p>Bonjour, j'ai remarqué que le texte 'OLD' s'ajoute maintenant en regard des différents plugins... Est-ce parce que j'ai activé l'option 'ajouter des plugins' (spip 3.0.21) ?</p> Mise à jour automatique des plugins 2015-03-23T09:43:27Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment480495 2015-03-23T09:43:27Z <p>Dans Rubrique ou Article, c'est finalement pareil :-(</p> <p>De la façon que j'avais mis, je n'avais en fait que des “ancres”. Ce qui n'est pas pareil que d'avoir des pages distinctes. Comme avec les onglets qui, eux, fonctionnent :-)</p> <p>Donc avec un séparateur de pages (++++) entre les textes d'un même article je n'ai que « Page précédente 1 2 3 Page suivante » en tête et en pied de l'article. Ça fonctionne dans l'espace privé mais pas “en ligne”… :-(</p> Mise à jour automatique des plugins 2015-03-22T11:00:03Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment480460 2015-03-22T11:00:03Z <p>Mais j'étais dans la Rubrique ! et pas dans un article… c'est pour ça que ça ne marchait pas :-(</p> <p>D'ailleurs les 4 ++++ ne m'ont pas servis. J'ai seulement mis des intertitres (avec 3 accolades).</p> <p>Les onglets fonctionnent :-)</p> <p>Il est vraiment super cet outil ;-)</p> Mise à jour automatique des plugins 2015-03-22T10:05:50Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment480459 2015-03-22T10:05:50Z <p>Oups… dans quel fichier cette balise #TEXTE ?</p> <p>Mes paramètres (par défaut, d'origine) :</p> <blockquote class="spip"> <p> <strong>Activer la balise #CS_DECOUPE</strong> : NON</p> <p><strong>Votre choix</strong> :<br class="autobr" /> ✔︎ Edition des contenus<br class="autobr" /> ✔︎ Messages de Forum</p> </blockquote> Mise à jour automatique des plugins 2015-03-21T22:20:01Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment480456 2015-03-21T22:20:01Z <p>Comment ça ne fonctionne plus ? Ça ne découpe pas ? <br class="autobr" /> Si c'est bien ça la panne, il faut chercher le code du squelette en question et voir comment est traitée la balise #TEXTE...</p> Mise à jour automatique des plugins 2015-03-21T11:53:24Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment480441 2015-03-21T11:53:24Z <p>Bonjour,</p> <p>J'ai désactivé mes plugins (sauf Sarka-SPIP 3.4.5, Z-core 2.4.3, Zen-Garden 2.6.2). Je n'ai donc que Le Couteau Suisse 1.9.7 activé avec les 3 précédents utiles pour mon squelette.</p> <p>Je n'ai qu'une lame activée : Découpe en pages et onglets.</p> <p>J'ai inséré un séparateur de page ou d'onglet (++++) entre les textes d'un même article. J'enregistre et je n'ai que “Page précédente 1 2 3 Page suivante” en tête et en pied de l'article. Les pages défilent lorsque je clique sur 1, 2, ou 3 etc.</p> <p>Mais lorsque je vais sur “Voir en ligne” ça ne fonctionne plus et sur “Voir le site” non plus… :(</p> <p>Quelqu'un aurait-il déjà rencontré ce problème ?</p> Mise à jour automatique des plugins 2015-03-02T09:06:41Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment479861 2015-03-02T09:06:41Z <p>Attention, la maj v3.0.20 du plugin Facteur n'est pas renseignée pour la lame mise-à-jour automatique du plugin « Le Couteau Suisse »... Ce qui provoque une erreur avec le plugin Formidable pour l'envoi des formulaires...</p> <p>Fatal error : Call to undefined function facteur_mail_html2text() in /var/www/vhosts/monsite.truc/httpdocs/plugins/auto/formidable/traiter/email.php on line 114</p> <p>Je remonte l'info auprès du plugin facteur et de formidable.</p> <p>Merci</p> Mise à jour automatique des plugins 2014-04-07T14:45:24Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment474840 2014-04-07T14:45:24Z <p>Il semblerait que MAJ automatique s'embrouille les pinceaux entres les mise-à-jours des plugins sous spip2.x et spip3.x...</p> <p>J'ai ainsi quelques plugins marqués : mise-à-jour disponible et cela continuellement... En effet, les versions de mise-à-jour proposées par MAJ Automatique concerne Spip3.x alors que mon site est sous Spip2.x</p> <p>Y aura-t-il une mise-à-jour de la lame mise-à-jour automatique :-)</p> <p>Sinon, c'est un plugin qui me permettait une maintenance efficace jusqu'ici...</p> Mise à jour automatique des plugins 2013-10-15T18:53:02Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment471578 2013-10-15T18:53:02Z <p>Merci pour ce retour.<br class="autobr" /> Mais je n'ai aucune idée de comment faire...<br class="autobr" /> Je viens d'installer Tortoise, mais après c'est au delà de mes compétences.<br class="autobr" /> Tant pis, peut-être que le développeur du plugin réagira à mon commentaire.</p> Mise à jour automatique des plugins 2013-10-15T12:33:33Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment471573 2013-10-15T12:33:33Z <p>Bonjour tu as eu raison de poster ce commentaire sur la page du plugin en question car la reconstruction des fichiers zip s dû subir quelques ratés, ça dépend pas de nous mais du serveur de SPIP...<br class="autobr" /> La solution serait de commiter une petite modif sur SVN pour relancer la reconstruction de l'archive zip...</p> Mise à jour automatique des plugins 2013-10-15T12:19:11Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment471572 2013-10-15T12:19:11Z <blockquote class="spip"> <p>Bonjour</p> <p>lorsque j'utilise la lame de mise à jour automatiques du couteau suisse, le plugin est toujours marqué comme étant à mettre à jour.<br class="autobr" /> En fait, il semblerait qu'il y ait une version 68379 disponible mais pas publiée dans le zip mis en téléchargement sur cette page.<br class="autobr" /> Je ne sais pas comment faire pour actualiser le zip avec la dernière version.<br class="autobr" /> Si quelqu'un peut m'aider...</p> <p>En vous remerciant.</p> </blockquote> <p>J'ai publié ce commentaire sur le plugin <a href="http://contrib.spip.net/Squelettes-SPIP-Reset" class="spip_out" rel='nofollow external'>“SPIP Reset”</a>.<br class="autobr" /> Mais peut-être est-il mieux adapté ici...</p> Mise à jour automatique des plugins 2013-08-12T12:00:47Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment470026 2013-08-12T12:00:47Z <p>Heu… en effet, je suis sur free ;-(<br class="autobr" /> Mais pourtant au début cela fonctionnait.<br class="autobr" /> Donc, je vais re-télécharger les plugins directement dans : plugins/auto<br class="autobr" /> Merci.</p> Mise à jour automatique des plugins 2013-08-12T11:05:25Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment470025 2013-08-12T11:05:25Z <p>Salut. Est-ce que par hasard ton serveur a les droits pour consulter des pages distantes ? Free par exemple ne les donne pas...</p> Mise à jour automatique des plugins 2013-08-12T10:26:26Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment470021 2013-08-12T10:26:26Z <p>Bonjour,</p> <p>Dans “Le Couteau Suisse (1.8.133)”, j'ai activé “Mises à jour automatiques” mais pour chaque plugins actifs, j'ai ce message : “<strong>La révision distante n'a pas pu être trouvée.</strong>”</p> <p>Merci d'avance si quelqu'un pouvait m'explique comment débloquer cela.</p> <p>SPIP 2.1.10 [17657]</p> Mise à jour automatique des plugins 2013-05-13T14:31:17Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment467875 2013-05-13T14:31:17Z <p>Au cas où, je cite la doc du <a href='https://contrib.spip.net/Le-Couteau-Suisse' class="spip_in" hreflang="fr" rel='nofollow'>Couteau Suisse</a> :</p> <blockquote class="spip"> <p>Pour le pire des cas, il existe un lien permettant de réinitialiser complètement le plugin, en désactivant l'ensemble des outils et en supprimant toutes les variables stockées dans la base de données. Voici ce lien : <br class="manualbr" /><code>ecrire/?exec=admin_couteau_suisse&cmd=resetall</code></p> </blockquote> Mise à jour automatique des plugins 2013-05-13T12:35:05Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment467867 2013-05-13T12:35:05Z <p>Salut,<br class="autobr" /> Il s'agit d'une installation initiale.<br class="autobr" /> Pour aller un peu plus loin, dans error.log j'ai les lignes suivantes :<br class="autobr" /> <b>Warning</b>: Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br /> <br /> <b>Warning</b>: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in <b>Unknown</b> on line <b>0</b><br /> La version de notre serveur php est 5.3.2-1ubuntu4.19<br class="autobr" /> c'est peut-être lié.<br class="autobr" /> Merci de ton aide.</p> Mise à jour automatique des plugins 2013-05-13T12:32:12Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment467866 2013-05-13T12:32:12Z <p>Salut, quelles lames as-tu activé sur le Couteau Suisse ? S'agit-il d'un mise à jour ? Ou d'une installation initiale ?</p> Mise à jour automatique des plugins 2013-05-13T11:24:15Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment467860 2013-05-13T11:24:15Z <p>Après avoir déplacer le rép /plugins/auto/couteau_suisse, la partie ecrire/ s'affiche à nouveau mais avec l'erreur :<br class="autobr" /> Erreur dans les plugins : /plugins/auto/couteau_suisse/v1.8.133/cout_pipelines.php</p> Mise à jour automatique des plugins 2013-05-13T11:20:36Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment467859 2013-05-13T11:20:36Z <p>Bonjour,<br class="autobr" /> J'ai le même soucis de la page blanche après avoir activé le plug-in Couteau Suisse pour toute la zone ecrire/ (spip 3.0.8, couteau-suisse 1.8.133)</p> Mise à jour automatique des plugins 2013-04-07T20:28:20Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment466904 2013-04-07T20:28:20Z <p>Pour la dernière question, c'est normal : la lame conserve l'info 24h en cache, sauf en cas d'actualisation forcée.</p> <p>Pour la première, peut-être faudrait-il voir ça en privé...</p> Mise à jour automatique des plugins 2013-04-07T19:56:40Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment466903 2013-04-07T19:56:40Z <p>Je viens de migrer en 1.8.121 Révision : 71749 et le problème subsiste<br class="autobr" /> Avant de lancer la lame du couteau suisse pour la maj des autres plugins, j'avais vidé le cache et supprimé manuellement /tmp/couteau-suisse</p> <p>Chose bizarre, la maj en 1.8.121 n'était pas visible par la lame du couteau suisse mais était visible sur la page de gestion des plugins.</p> Mise à jour automatique des plugins 2013-04-07T15:49:35Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment466901 2013-04-07T15:49:35Z <p>Je ferai ma maj ce soir. <br class="autobr" /> Hébergeur OVH avec serveur dédié en Ubuntu et Plesk 11<br class="autobr" /> Merci :)</p> Mise à jour automatique des plugins 2013-04-07T14:38:56Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment466900 2013-04-07T14:38:56Z <p>Bonjour, merci beaucoup pour ce retour très précis. Quel est ton hébergeur ?</p> <p>je viens de déceler un petit dysfonctionnement dans $_REQUEST corrigé dans la révision 71737 du plugin (prochain paquet vers 17h). Cela réglera-t-il ton problème ?</p> <p>A propos des délais, le plugin est prévu pour une consultation d'environ 20 secondes maxi. Tout dépend de la réponse des serveurs distants, à condition d'avoir les droits de sortie !</p> <p>La manière de fonctionner est un peu différente avec ?exec=admin_plugin qui consulte en CRON de temps en temps. Le Couteau Suisse n'a pas de CRON, il consulte seulement quand on lui demande, offrant même un lien d'actualisation forcée et un détail plus précis sur les révisions de code.</p> Mise à jour automatique des plugins 2013-04-07T12:17:17Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment466894 2013-04-07T12:17:17Z <p>J'ai ce problème de page blanche qui bloque sur ecrire/?exec=charger_description_outil.</p> <p>J'ai essayé plein de choses séparément ou simultanément : <br />- vider le cache <br />- supprimer toutes les anciennes versions du couteau suisse en old ou en bck <br />- mettre à jour par la lame du couteau suisse <br />- mettre à jour par la page ecrire/?exec=admin_plugin <br />- supprimer manuellement le couteau suisse puis réinstallé par ftp <br />- supprimer manuellement le répertoire tmp/couteau-suisse</p> <p>Et rien de change. Le seul moyen que j'ai de mettre à jour mes plugins sans passer par ftp est de passer par la page ecrire/?exec=admin_plugin. Le problème c'est que la liste des plugins à mettre à jour sur la commande exec=admin_couteau_suisse&cmd=descrip&outil=maj_auto est bien plus longue que ce que je vois sur la page de gestion des plugins</p> <p>Je suis en spip 3.0.7 (20352) avec écran sécurité 1.1.5<br class="autobr" /> Couteau suisse en 1.8.20, Révision : 71737<br class="autobr" /> Serveur dédié</p> <p>Je suis preneur de bonne(s) idée(s) :)</p> Mise à jour automatique des plugins 2013-02-10T13:08:07Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment465190 2013-02-10T13:08:07Z <p>Eh oui Free ne permet pas je crois les accès distants. Ceci doit expliquer toutes ces erreurs...</p> Mise à jour automatique des plugins 2013-02-10T09:25:22Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment465184 2013-02-10T09:25:22Z <p>Bonjour, <br class="autobr" /> Je recommence à zéro mon site (tous les plugin comme la version de spip sont les dernières) et souhaite configurer la mise à jour automatique.</p> <p>La lame du couteau suisse m'invite à installer dans le dossier lib 2 fichiers : <br />- > distant_action_charger_plugin.php <br />- > distant_inc_charger_plugin.php</p> <p>Le problème : cela ne fonctionne pas. <br class="autobr" /> 1) Suffit-il bien de télécharger et de les mettre dans le dossier lib.? (ce que j'ai fait)<br class="autobr" /> 2) Les deux dossiers portent le même nom une fois téléchargé... cela peut-il être à l'origine du pb?<br class="autobr" /> 3) Je suis chez free.... cela peut-il expliquer que la maj ne fonctionne ?</p> <p>— - <br class="autobr" /> Dans un même registre :</p> <p>L'adresse du dépôt des plugin pré-configurée pour ajouter des plugins (<a href="http://plugins.spip.net/depots/principal.xml" class="spip_url spip_out auto" rel="nofollow external">http://plugins.spip.net/depots/principal.xml</a> ) est incorrecte? Quelqu'un pourrait-il m'en indiquer une svp?</p> <p>Merci pour tout ! <br class="autobr" /> Nico</p> Mise à jour automatique des plugins 2012-10-16T23:21:29Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment462294 2012-10-16T23:21:29Z <p>Au mieux, il suffirait peut-être de refaire l'installation du plugin par SPIP pour que le statut “OLD” passe en “SVP” ?</p> Mise à jour automatique des plugins 2012-10-16T14:57:46Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment462282 2012-10-16T14:57:46Z <p>Je ne pense pas mais j'ai pu mettre la plus part des plugins à jour ..en individuel seulement mais bon c'est une belle innovation ..et je ne sais si je pourrai m'en servir longtemps car les gestionnaires du serveurs ne nous laissent pas toutes les possibilités..</p> <p>Par exemple j'ai eu des problèmes plus particulièrement avec des plugin signalés OLD (Crayon 16/08/2012 OLD) mais cela ne vient pas de la car SPIP mentions légales (9/05/12 SVP)</p> <p>Je met à jour le plus gros ..pour le reste je verrai quand j'auri plus de temps .<br class="autobr" /> Cordialement</p> Mise à jour automatique des plugins 2012-10-16T13:51:28Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment462276 2012-10-16T13:51:28Z <p>Bonjour, ne s'agirait-il pas d'une archive encore non constituée ? Il y a toujours un délai d'une heure entre une mise à jour de code et la disponibilité de l'archive associée...</p> Mise à jour automatique des plugins 2012-10-15T16:51:45Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment462238 2012-10-15T16:51:45Z <p>Le plugin fonction après mise à jours de Couteau suisse 1.8.101 mais pas pour tout les plugins</p> <p>Par exemple pour Crayon, il ne fonctionne pas alors que pour Spipbonux il fonctionne c'est assez curieux..</p> <p>Mais</p> Mise à jour automatique des plugins 2012-08-30T19:00:42Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment460762 2012-08-30T19:00:42Z <p>J'ai réussi à mettre un plugin à jour mais pour faire simple</p> <p>J'ai bien supprimé le dossier tmp/couteau-suisse/<br class="autobr" /> Je n'ai pas trouvé /tmp/charger_*.php</p> <p>Mais ensuite pour conttinuer il faut à nouveau supprimer le dossier tmp/couteau-suisse/</p> <p>et avec plusieurs plugin à la fois cela ne fonctionne pas</p> Mise à jour automatique des plugins 2012-08-30T17:43:21Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment460759 2012-08-30T17:43:21Z <p>Bonsoir</p> <p>Oui sur la dernière releaselebouton est bien revenu</p> <p>mais le problème persiste à la page<br class="autobr" /> ecrire/?exec=charger_description_outil</p> <p>elle reste blanche</p> <p>Et je ne fais qu'une mise à jour à la fois..</p> Mise à jour automatique des plugins 2012-08-30T16:01:39Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment460753 2012-08-30T16:01:39Z <p>Bonjour,</p> <p>Exact pour le 2e point, un petit bug JS retirait à tort le bouton de validation.</p> <p>Est-ce la dernière release du plugin corrige bien le problème ?</p> <p>Pour le 1er point, je ne vois pas quoi répondre.</p> Mise à jour automatique des plugins 2012-08-30T11:54:05Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment460740 2012-08-30T11:54:05Z <p>Bonjour</p> <p>2 Points sur la version précédente de Couteau suisse, je ne suis pas arrivé à faire les mises à jour automatique..j'avais un écran blanc et rien ne se passait avec une seule mise à jour à la fois.</p> <p>Je viens de mettre couteau suisse à jour et là je coche une mise à jour mais je n'ai pas de bouton pour valider les mises à jour à faire..</p> <p>Je suis sous Spip 3.0.4 et l'installation de couteau suisse en automatique s'est déroulé normalement</p> <p>Merci de votre réponse</p> Mise à jour automatique des plugins 2012-08-27T02:24:43Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment460650 2012-08-27T02:24:43Z <p>Bonjour, cette lame est désormais compatible avec SPIP 3.0 qui permet de mettre à jour plusieurs plugins en même temps. Son développement n'est pas tout à fait terminé, mais les retours sont toujours les bienvenus.</p> Mise à jour automatique des plugins 2012-05-14T13:20:47Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment457142 2012-05-14T13:20:47Z <p>Bonjour,</p> <p>Merci pour votre réponse.<br class="autobr" /> La version est PHP Version 4.4.3-dev</p> <p>Voici le lien : <a href="http://boxepiedspoings.free.fr/infos.php" class="spip_url spip_out auto" rel="nofollow external">http://boxepiedspoings.free.fr/infos.php</a></p> Mise à jour automatique des plugins 2012-05-14T11:28:58Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment457138 2012-05-14T11:28:58Z <p>Certaines fonctions sont désactivées chez free, notamment les accès distants. Pour avoir des informations sur la version de php installée créez un fichier infos.php avec :</p> <div class="precode"><pre dir="ltr" style="text-align: left;" class="php"><code><span class="kw2"><?php</span> <a href="http://www.php.net/phpinfo" rel='nofollow'><span class="kw3">phpinfo</span></a><span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="sy1">?></span></code></pre></div> <p>Quelques infos : <a href="http://www.free.fr/assistance/947-fonctions-php-interdites.html" class="spip_url spip_out" rel='nofollow external'>http://www.free.fr/assistance/947-f...</a></p> Mise à jour automatique des plugins 2012-05-14T08:51:45Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment457132 2012-05-14T08:51:45Z <p>Bonjour,</p> <p>Mon site est chez Free. Je suis passé ce matin de la version 2.1.10 à la version 2.1.13 de SPIP. Je pensais ainsi résoudre le problème du Couteau suisse qui, depuis peu, affichait un message d'erreur quand je voulais modifier les paramètres des lames. La mise à jour automatique envoyait le message unable to connect to zone.spip.org:80<br class="autobr" /> Suite à la lecture de ce forum, j'ai téléchargé la nouvelle version du plugin Couteau suisse et j'ai supprimé dans tmp le répertoire couteau_suisse. Je peux de nouveau paramétrer les lames (ouf !), y compris celle de la mise à jour à distance, mais à la place du bouton radio apparaît un point d'interrogation et le message en face : “La révision distante n'a pas pu être trouvée”.<br class="autobr" /> Le problème doit venir de Free. Sur un site chez OVH tout fonctionne normalement.<br class="autobr" /> J'ajoute que j'ai aussi un problème avec le plugin Formidable d'envoi de formulaires paramétrables. Cela vient sans doute de la même cause.</p> Mise à jour automatique des plugins 2012-04-26T07:44:35Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456594 2012-04-26T07:44:35Z <p>Bonjour<br class="autobr" /> Merci beaucoup pour cette réponse rapide!<br class="autobr" /> Cordialement<br class="autobr" /> Patrick</p> Mise à jour automatique des plugins 2012-04-26T06:05:09Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456591 2012-04-26T06:05:09Z <p>Bonjour,<br class="autobr" /> Je me suis renseigné sur les newsgroups de pages.perso.Free et c'est effectivement un bloquage de Free.<br class="autobr" /> Il y a de l'espoir, il faut attendre une mise à niveau prévue du php. (techniquement je ne sais pas ce que cela veut dire)<br class="autobr" /> Donc mise à jour à la main en attendant...<br class="autobr" /> Olivier</p> Mise à jour automatique des plugins 2012-04-25T22:21:15Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456590 2012-04-25T22:21:15Z <p>Bonsoir<br class="autobr" /> J'ai exactement le même problème sur 2 sites, je suis également chez Free sous la version 2.1.13; <br class="autobr" /> comment savoir si c'est réellement une limitation de Free et surtout, comment y remédier?<br class="autobr" /> Merci<br class="autobr" /> Cordialement</p> Mise à jour automatique des plugins 2012-04-12T21:30:22Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456238 2012-04-12T21:30:22Z <p>Oui, il y a juste que la connexion distante a échoué. C'est peut-être une limitation de Free ?</p> Mise à jour automatique des plugins 2012-04-12T06:33:38Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456210 2012-04-12T06:33:38Z <p>Bonjour,<br class="autobr" /> Merci de cette piste.<br class="autobr" /> Je viens d'activer la lame “Comportement du CS” et coché “activer les logs” uniquement.<br class="autobr" /> Pas de changement.<br class="autobr" /> Où va s'écrire le log ?<br class="autobr" /> Je mets en PJ une photo de la fin du prive_spip.log trouvé dans tmp\ si des fois des lignes sont plus claire pour vous que pour moi...<br class="autobr" /> Encore merci pour l'aide.<br class="autobr" /> Olivier</p> Mise à jour automatique des plugins 2012-04-11T22:38:41Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456208 2012-04-11T22:38:41Z <p>il est possible que les connexions distantes ne soient pas permises... La lame «Comportements du Couteau Suisse» permet de les désactiver...</p> Mise à jour automatique des plugins 2012-04-11T10:53:37Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment456192 2012-04-11T10:53:37Z <p>Bonjour,<br class="autobr" /> J'ai 2 sites chez Free, SPIP 2.1.12-[18732], Couteau Suisse 1.8.61-[60119]<br class="autobr" /> Et les 2 m'indiquent depuis quelques mois un “Problème sur : le serveur distant”<br class="autobr" /> La lame “Mises à jour automatiques” me rend l'erreur :<br class="autobr" /> Fatal error: fsockopen() [<a href='https://contrib.spip.net/function.fsockopen' rel='nofollow'>function.fsockopen</a>]: unable to connect to zone.spip.org:80 in /mnt/151/sda/4/2/asulgv/ecrire/inc/distant.php on line 615</p> <p>Donc je passe du temps à télécharger mes plugins, les décompresser sur mon disque, et les copier par FTP sur mes sites.<br class="autobr" /> J'ai désactivé tous mes plugins et laissé seul le CS avec le même résultat.</p> <p>MERCI à vous si vous pouvez m'indiquer une piste pour retrouver le fonctionnement super de ces màj en 1 click !!!</p> Mise à jour automatique des plugins 2012-02-17T08:21:07Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment454570 2012-02-17T08:21:07Z <p>Bonjour, j'utilise le plugin Couteau Suisse depuis longtemps et j'en suis très satisfait. Cependant il y a deux petites améliorations qui, à mon sens, serait utile.<br class="autobr" /> Dans la lame «mise à jour automatique» peut on afficher le libellé des modifications de la nouvelle révision (autrement il faut cliquer droit, ouvrir un nouvel onglet, lire et enfin mettre à jour ou pas. Un peu long quand il y a beaucoup de plugin à mettre à niveau ...) et autre amélioration qui serait très pratique, la possibilité de mettre à jour plusieurs plugin en même temps (un vieux rêve ....).</p> <p><a href="http://www.latoniccia.fr" class="spip_out" rel='nofollow external'>Latoniccia CLub Plongée</a></p> Mise à jour automatique des plugins 2011-12-13T12:44:28Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment452821 2011-12-13T12:44:28Z <p>Bonjour à tous.</p> <p>Merci pour ce retour. Je viens de publier une correction sur le plugin. Cet accès sqlite était expérimental, je pense qu'on pourra totalement s'en passer désormais. Mes excuses pour ces bugs pas graves du tout, mais qu'on aurait pu éviter.</p> <p>Le nouveau paquet ZIP sera dispo vers 14h05.</p> Mise à jour automatique des plugins 2011-12-13T08:41:13Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment452807 2011-12-13T08:41:13Z <p>Bonjour à tous,</p> <p>j'ai un gros bug depuis la dernière MAJ, impossible de faire fonctionner la MAJ automatique...</p> <p>Fatal error: Uncaught exception 'PDOException' with message 'could not find driver' in /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php:293" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php:293</a> Stack trace: #0 /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(293" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(293</a>): PDO->__construct('sqlite:') #1 /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(232" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(232</a>): version_svn_courante2('../plugins/auto...') #2 /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(99" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php(99</a>): plugin_get_infos_maj('auto/multiviewe...', false, '../plugins/') #3 /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/inc/cs_outils.php(235" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/inc/cs_outils.php(235</a>): maj_auto_action_rapide() #4 /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/inc" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/inc</a> in /var/virtual_www/motardsenbalade.net/<a href="http://www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php" class="spip_url spip_out auto" rel="nofollow external">www.motardsenbalade.net/htdocs/plugins/auto/couteau_suisse/outils/maj_auto_action_rapide.php</a> on line 293</p> Mise à jour automatique des plugins 2011-09-30T23:39:12Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450310 2011-09-30T23:39:12Z <p>En fait, les concepteurs de ce squelette ont prévu des limitations natives sur les lames du Couteau Suisse :</p> <p>- <a href="http://zone.spip.org/trac/spip-zone/browser/_squelettes_/soyezcreateurs_net/plugins_2.1/plugins/soyezcreateurs/soyezcreateurs_options.php?rev=52006#L140" class="spip_url spip_out" rel='nofollow external'>http://zone.spip.org/trac/spip-zone...</a></p> <p>Pour contrarier ce comportement, la constante <strong>_CS_OUTILS_CACHES </strong> peut cependant être invalidée ou définie en amont dans config/mes_options.php.</p> Mise à jour automatique des plugins 2011-09-30T14:50:47Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450296 2011-09-30T14:50:47Z <p>Ouai ou bien changer de squelette....</p> Mise à jour automatique des plugins 2011-09-30T14:49:43Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450294 2011-09-30T14:49:43Z <p>Effectivement !<br class="autobr" /> Du coup, je désactive le SoyezCreateurs, je fais mes MAJ auto, et je réactive le squelette. Ça peut marcher, comme ça ?</p> Mise à jour automatique des plugins 2011-09-30T14:30:25Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450293 2011-09-30T14:30:25Z <p>Bonjour,</p> <p>La lame Mise à jour automatique n'est pas compatible avec le plugin SoyezCréateurs.<br class="manualbr" />Je viens de mettre à jour l'article ici présent en conséquence.</p> Mise à jour automatique des plugins 2011-09-30T14:28:22Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450292 2011-09-30T14:28:22Z <p>Essaye en virant le soyezcreateur pour voir ;)</p> Mise à jour automatique des plugins 2011-09-30T14:22:27Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450291 2011-09-30T14:22:27Z <p>Oui, effectivement, j'ai le squelette Soyezcreateurs, et un certain nombre d'autres plugins<br class="autobr" /> Mais ce qui est bizarre, c'est qu'à un moment, je disposais bien de ces options. Je pense que ça a disparu lors d'opération de sauvegardes/restauration qui n'ont peut-être pas été faites dans les règles de l'art...<br class="autobr" /> Pour info, j'ai désinstallé puis réinstaller le Couteau Suisse, mais ça n'a rien changé</p> Mise à jour automatique des plugins 2011-09-30T14:16:39Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450290 2011-09-30T14:16:39Z <p>Bonjour</p> <p>Aurais tu par hasard installer d'autre plugins ou un squelette particulié ?</p> Mise à jour automatique des plugins 2011-09-30T13:42:39Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment450289 2011-09-30T13:42:39Z <p>Bonjour,</p> <p>J'ai installé le Couteau Suisse, et j'ai l'impression qu'il me manque beaucoup de lames, notamment dans la rubrique Administration, où je n'ai que la Corbeille et “Site en travaux”. Il me manque par exemple la lame de Mise à jour automatique des plugins</p> <p>SPIP : 2.1.11 [18566]<br class="autobr" /> Couteau Suisse : 1.8.43.03 [51616]</p> Mise à jour automatique des plugins 2011-09-14T10:04:05Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment449734 2011-09-14T10:04:05Z <p>Bonjour,<br class="autobr" /> J'ai rencontré ce matin un souci lors de la mise à jour du formulaire de contact avancé (<a href="http://www.spip-contrib.net/Formulaire-de-contact-avance#forum449714" class="spip_out" rel='nofollow external'>voir échange ici</a>). Il semble qu'il y ait un problème de pointage vers le bon fichier.<br class="autobr" /> (moi, je l'aime bien, le couteau suisse ;-))</p> Mise à jour automatique des plugins 2011-09-01T23:22:31Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment449132 2011-09-01T23:22:31Z <p>Bonjour.</p> <p>Après la découverte de ce bug : <br />- L'annomalie a été close : <a href="http://core.spip.org/issues/2166" class="spip_url spip_out auto" rel="nofollow external">http://core.spip.org/issues/2166</a> <br />- SPIP a été modifié : <a href="http://core.spip.org/projects/spip/repository/revisions/18317" class="spip_url spip_out auto" rel="nofollow external">http://core.spip.org/projects/spip/repository/revisions/18317</a></p> <p>Ton erreur devrait sans doute disparaitre après mise à jour de SPIP ?</p> Mise à jour automatique des plugins 2011-09-01T06:53:20Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment449094 2011-09-01T06:53:20Z <p>Bonjour, <br class="autobr" /> Je me permet de relancer ma requête. <br class="autobr" /> Auriez-vous trouver une solution à mon problème via la liste spip-dev ?<br class="autobr" /> Merci beaucoup</p> Mise à jour automatique des plugins 2011-07-09T06:28:59Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment447578 2011-07-09T06:28:59Z <p>Bonjour,<br class="autobr" /> J'ai SPIP 2.1.10 [17657] et suis chez ovh.</p> <p>Sinon je ne suis pas abonné à la liste spip-dev., débutant, je risquerai de la “parasiter.”<br class="autobr" /> Merci pour avoir transmis la question.</p> Mise à jour automatique des plugins 2011-07-08T17:09:38Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment447565 2011-07-08T17:09:38Z <p>Bonjour, je ne reproduis pas ton problème... Quelle version de SPIP as-tu ?</p> <p>Il semble que ce bug est propre à SPIP. Je redirige ta demande sur la liste spip-dev. Y es-tu abonné ?</p> Mise à jour automatique des plugins 2011-07-08T07:49:37Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment447544 2011-07-08T07:49:37Z <p>Bonjour, <br class="autobr" /> Je n'arrive plus à mettre à jour aucun plugin via le couteau suisse. <br class="autobr" /> Idem, il m'est impossible d'en installer de nouveau (possible que via le FTP).<br class="autobr" /> Le message qui s'affiche est celui-ci :</p> <p><strong>Fatal error: Call to undefined function: bouton_suivant() in /homez.341/apened/www/spip/ecrire/action/charger_plugin.php on line 265</strong></p> <p>Quelqu'un pourrait-il m'aider à résoudre ce problème ?<br class="autobr" /> Merci beaucoup.</p> Mise à jour automatique des plugins 2011-07-02T13:16:17Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment447363 2011-07-02T13:16:17Z <p>Il est probablement que Wamp n'autorise pas les consultations distantes ? Les logs de SPIP (tmp/prive_spip.* notamment) en parlent-ils ?</p> Mise à jour automatique des plugins 2011-07-02T11:55:52Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment447359 2011-07-02T11:55:52Z <p>Re Bonjour,</p> <p>La lame “Mise à jour automatique” ne donne pas de description. On reste en attente longue de localhost.<br class="autobr" /> Les ecrire/?exec=charger_description_outil&outil=maj_auto&cs=reportall<br class="autobr" /> fournies à Gérard en mai ne débouchent qu'au bout de tres longtemps sur une blank page.</p> <p>SPIP 2.1.10 test en local avec Wamp (Apache: 2.2.11 Version de PHP: 5.3.0 )<br class="autobr" /> Couteau Suisse Version locale : 1.8.41.03 Révision : 49007<br class="autobr" /> Sur site c'est OK.</p> <p>Je redémarre ce thread car il me semble que l'on a dévié sur le post de Gérard ?</p> <p>Pas tres gênant. Je vais sur mon site pour relever les mises a jour possibles. Juste que je ne comprends pas ce qui se passe en local.</p> <p>Merci</p> Mise à jour automatique des plugins 2011-05-30T20:26:06Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment446245 2011-05-30T20:26:06Z <p>Bon Oui il faut des fameuses lunettes pour lire le texte ci-dessus. Le voici en claire :</p> <div class="precode"><pre dir="ltr" style="text-align: left;"><code>COUTEAU-SUISSE. [#5957]. -------------------------------------------------------------------------------- COUTEAU-SUISSE. [#5957]. INIT : cout_options, /ecrire/?exec=charger_description_outil&outil=maj_auto&cs=reportall COUTEAU-SUISSE. [#5957]. inclusion des fonctions de cout_lancement.php pour initialisation COUTEAU-SUISSE. [#5957]. #### 1er PASSAGE [#3c44] ################################# - $forcer = 0 [#3c44] PHP v5.2.10 - MYSQL v5.0.51a - base SPIP v15828 - code SPIP v15375 COUTEAU-SUISSE. [#5957]. [#3c44] cs_initialisation() : Passage #1 COUTEAU-SUISSE. [#5957]. [#3c44] -- cs_metas_pipelines = header_css_prive, header_css, header_js_prive, header_js, pre_description_outil, pre_boucle, boite_infos, fichier_distant, affiche_milieu, affiche_droite, affiche_gauche, pre_typo, bt_toolbox, porte_plume_barre_pre_charger, porte_plume_lien_classe_vers_icone, nettoyer_raccourcis_typo, insert_head, arbo_creer_chaine_url, propres_creer_chaine_url COUTEAU-SUISSE. [#5957]. [#3c44] -- 10 outil(s) actif(s) = soft_scroller, cs_comportement, couleurs, decoration, previsualisation, ecran_securite, maj_auto, SPIP_liens, type_urls, boites_privees COUTEAU-SUISSE. [#5957]. [#3c44] cs_initialisation() : Sortie car les metas sont presents COUTEAU-SUISSE. [#5957]. PUIS : cout_options, initialisation terminee COUTEAU-SUISSE. [#5957]. -- fichier '../tmp/couteau-suisse/mes_spip_options.php' deja inclu par config/mes_options.php COUTEAU-SUISSE. [#5957]. -- inclusion de '../tmp/couteau-suisse/mes_options.php' COUTEAU-SUISSE. [#5957]. FIN : cout_options, cs_spip_options = 1, cs_options = 1, cs_fonctions_essai = 0 Notice: Undefined index: spip_lang in D:\_HOME\#IMP\Aset\Site-en-Local\ecrire\inc\lang.php on line 269 COUTEAU-SUISSE. [#5957]. INIT : exec_charger_description_outil_dist() - Preparation du retour par Ajax sur div#cs_infos COUTEAU-SUISSE. [#5957]. chargement de cout_utils.php COUTEAU-SUISSE. [#5957]. inclusion de config_outils.php Notice: Undefined index: nom in D:\_HOME\#IMP\Aset\Site-en-Local\plugins\auto\couteau_suisse\cout_utils.php on line 71 Notice: Undefined offset: 1 in D:\_HOME\#IMP\Aset\Site-en-Local\ecrire\inc\filtres_mini.php on line 27 COUTEAU-SUISSE. [#5957]. -- description_outil2(maj_auto) - Appel de config_outils.php : nb_outils = 69 COUTEAU-SUISSE. [#5957]. -- appel de charger_fonction('description_outil', 'inc') et de description_outil(maj_auto) : COUTEAU-SUISSE. [#5957]. inclusion de cout_pipelines.php COUTEAU-SUISSE. [#5957]. INCL : ../tmp/couteau-suisse/mes_fonctions.php</code></pre></div> Mise à jour automatique des plugins 2011-05-30T20:19:14Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment446243 2011-05-30T20:19:14Z <p>- Je sais pas trop à quoi sert le lien “forcer l'actualisation distante” j'ai cliqué dessus (dans la version en ligne) après quelques secondes la page s'est rafraichie sans changement apparent. <br />- Si tu m'as bien suvit, ce lien n'est pas visible dans ma version de développement. <br />- Version SPIP 2.1.10 pour les deux versions <br />- Le premier lien que tu propose donne une page totalement blanche après un bon moment d'attente. <br />- Le deuxième lien donne le texte ci-joint. Celà peut-il nous aider.</p> <p>Merci pour ton aide</p> <p>Gérard</p> Mise à jour automatique des plugins 2011-05-29T20:44:03Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment446182 2011-05-29T20:44:03Z <p>Tout fonctionne en ligne, même quand tu cliques sur “forcer l'actualisation distante” ? Quelle version de SPIP as-tu ?</p> <p>Un lien de test (seulement pour tester l'affichage !) peut ressembler à : <br />- <code>ecrire/?exec=charger_description_outil&outil=maj_auto</code></p> <p>Voire à : <br />- <code>ecrire/?exec=charger_description_outil&outil=maj_auto&cs=reportall</code></p> Mise à jour automatique des plugins 2011-05-29T20:06:42Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment446176 2011-05-29T20:06:42Z <p>Bonjour,</p> <p>Depuis que j'ai fais la mise à jour du couteau Suisse (vers CS 1.8.40.04) dans ma version de développement (sous EasyPHP) la lame “mise à jour automatique” ne fonctionne plus !<br class="autobr" /> Que cette lame soit active ou inactive si je clic dessus, je constate qu'en bas de page une petite roulette tourne durant quelques minutes puis rien rien ne s'affiche...</p> <p>Dans ma version en ligne (vers.CS 1.8.33.05) tout fonctionne parfaitement et donc j'hésite à faire la mise à niveau du CS étant donné le problème décrit ci-dessus.</p> <p>Quelqu'un a t-il une idée.</p> <p>Bonne semaine</p> <p>Gérard</p> Mise à jour automatique des plugins 2011-03-04T09:13:12Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment442006 2011-03-04T09:13:12Z <p>Dans la mesure ou SoyezCréateurs cache les lames par cette ligne : <a href="http://zone.spip.org/trac/spip-zone/browser/_squelettes_/soyezcreateurs_net/plugins_2.1/plugins/soyezcreateurs/soyezcreateurs_options.php#L134" class="spip_url spip_out auto" rel="nofollow external">http://zone.spip.org/trac/spip-zone/browser/_squelettes_/soyezcreateurs_net/plugins_2.1/plugins/soyezcreateurs/soyezcreateurs_options.php#L134</a></p> <p>Il suffit dans son config/mes_options.php de reprendre cette ligne et d'y mettre autre chose pour être prioritaire sur le masquage des lames.</p> Mise à jour automatique des plugins 2011-03-04T08:59:14Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment442005 2011-03-04T08:59:14Z <p>N'est-ce pas un jugement un peu arbitraire ? Tout le monde n'a pas de serveur SVN sur son hébergement.... <i>SoyezCréateurs</i> nécessite-t-il un serveur SVN ?</p> <p>Il existe sur le CS un pipeline <strong>pre_description_outil</strong> qui permet d'avoir accès à la description/configuration d'un outil avant affichage et traitement de tous les raccourcis. Ne serait-il pas «plus sympa» d'ajouter plutôt un message d'avertissement concernant le squelette spécifique <i>SoyezCréateurs</i> sur certaines lames, au lieu tout simplement de les interdire ?</p> Mise à jour automatique des plugins 2011-03-04T07:05:23Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment441999 2011-03-04T07:05:23Z <p>SoyezCréateurs invalide volontairement un certains nombre de lames du CouteauSuisses jugées :</p> <ul class="spip"><li> incompatibles avec une fonctionnalité de SoyezCréateurs (exemple, la lame sommaire automatique)</li><li> ou dangereuse (ex : mise à jour automatique ; la seule mise à jour efficace de SPIP est par SVN)</li></ul> Mise à jour automatique des plugins 2011-03-04T06:25:48Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment441997 2011-03-04T06:25:48Z <p>Bonjour</p> <p>Mets à jour ton squelettes et tu verras que la lame sera autoriser.<br class="autobr" /> Maj tous tes plugins par la page de chargement et vide le tmp.</p> <p>Elle dois réapparaitre, je l'ai sur un de mes sites.</p> Mise à jour automatique des plugins 2011-03-03T22:11:34Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment441992 2011-03-03T22:11:34Z <p>Je m'en doutais. Peut-être devrais-tu alors en parler aux auteurs. Certaines lames sont en effet invalidées par ce squelette.</p> Mise à jour automatique des plugins 2011-03-03T12:05:16Z https://contrib.spip.net/Mise-a-jour-automatique-des-plugins#comment441957 2011-03-03T12:05:16Z <p>Bonjour,</p> <p>J'utilise le jeu de squelette syezcreateurs.</p>