Essayez SPIP 2.1-RC - comments Essayez SPIP 2.1-RC 2012-01-05T17:04:37Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment453286 2012-01-05T17:04:37Z <p>La fonction a changé de nom en 2.1.</p> <p>Dans Spip Listes version 1.9.3 (build 2.0109),<br class='autobr' /> dans spiplistes_api_presentation.php, ligne 871, remplacer : <br class='autobr' /> $info = plugin_get_infos(spiplistes_get_meta_dir($prefix));</p> <p>Par:</p> <p>$get_infos = defined('_SPIP20100')?charger_fonction('get_infos','plugins'):'plugin_get_infos';<br class='autobr' /> $info = $get_infos(spiplistes_get_meta_dir($prefix));</p> Essayez SPIP 2.1-RC 2011-08-16T18:20:05Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment448651 2011-08-16T18:20:05Z <p>Salut, <br class='autobr' /> tu as réussi a résoudre ton probleme avec la fonction 'plugin_get_infos' ou pas??? J4ai le meme souci et je n'arrive pas a corriger le probleme... <br class='autobr' /> Merci</p> Essayez SPIP 2.1-RC 2011-08-16T17:49:07Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment448649 2011-08-16T17:49:07Z <p>Salut,</p> <p>@sylvain : J'ai pas compris où il faut que je rajoute la ligne dont tu parles. Est ce que tu peux etre un peu plus précis?</p> <p>@RealET : ca veut dire quoi qu'une fonction est déplacée? On fait comment pour la remettre a sa place?</p> <p>Merci pour une blonde qui s'accroche!</p> Essayez SPIP 2.1-RC 2011-01-21T14:10:40Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment439839 2011-01-21T14:10:40Z <p>J'ai le même problème <a href="http://ccsf.cilal.net/spip.php?article375" class='spip_out' rel='external'>ici</a> .</p> <p> Voir en bas de page : <strong>Parse error: syntax error, unexpected '?' in /home/cilal/public_html/ccsf.cilal.net/ecrire/public/assembler.php(606) : eval()'d code on line 30</strong></p> <p>Cela est arrivé depuis que j'ai mis spip à jour . j'ai dû mettre à jour de nombreux plugins .</p> <p>Je suis allé voir le fichier assembler.php , en voilà un morceau :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="php"><code><span class="co1">// http://doc.spip.org/@assembler</span> <span class="kw2">function</span> assembler<span class="br0">&#40;</span><span class="re0">$fond</span><span class="sy0">,</span> <span class="re0">$connect</span><span class="sy0">=</span><span class="st_h">''</span><span class="br0">&#41;</span> <span class="br0">&#123;</span> <span class="kw2">global</span> <span class="re0">$flag_preserver</span><span class="sy0">,</span><span class="re0">$lastmodified</span><span class="sy0">,</span> <span class="re0">$use_cache</span><span class="sy0">,</span> <span class="re0">$contexte</span><span class="sy0">;</span> <span class="re0">$contexte</span> <span class="sy0">=</span> calculer_contexte<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="re0">$page</span> <span class="sy0">=</span> <a href="http://www.php.net/array"><span class="kw3">array</span></a><span class="br0">&#40;</span><span class="st_h">'contexte_implicite'</span><span class="sy0">=></span>calculer_contexte_implicite<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="re0">$page</span><span class="br0">&#91;</span><span class="st_h">'contexte_implicite'</span><span class="br0">&#93;</span><span class="br0">&#91;</span><span class="st_h">'cache'</span><span class="br0">&#93;</span> <span class="sy0">=</span> <span class="re0">$fond</span> <span class="sy0">.</span> <a href="http://www.php.net/preg_replace"><span class="kw3">preg_replace</span></a><span class="br0">&#40;</span><span class="st_h">',\.[a-zA-Z0-9]*$,'</span><span class="sy0">,</span> <span class="st_h">''</span><span class="sy0">,</span> <a href="http://www.php.net/preg_replace"><span class="kw3">preg_replace</span></a><span class="br0">&#40;</span><span class="st_h">'/[?].*$/'</span><span class="sy0">,</span> <span class="st_h">''</span><span class="sy0">,</span> <span class="re0">$GLOBALS</span><span class="br0">&#91;</span><span class="st_h">'REQUEST_URI'</span><span class="br0">&#93;</span><span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="co1">// Cette fonction est utilisee deux fois</span> <span class="re0">$cacher</span> <span class="sy0">=</span> charger_fonction<span class="br0">&#40;</span><span class="st_h">'cacher'</span><span class="sy0">,</span> <span class="st_h">'public'</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="co1">// Les quatre derniers parametres sont modifies par la fonction:</span> <span class="co1">// emplacement, validite, et, s'il est valide, contenu & age</span> <span class="re0">$res</span> <span class="sy0">=</span> <span class="re0">$cacher</span><span class="br0">&#40;</span><span class="re0">$GLOBALS</span><span class="br0">&#91;</span><span class="st_h">'contexte'</span><span class="br0">&#93;</span><span class="sy0">,</span> <span class="re0">$use_cache</span><span class="sy0">,</span> <span class="re0">$chemin_cache</span><span class="sy0">,</span> <span class="re0">$page</span><span class="sy0">,</span> <span class="re0">$lastmodified</span><span class="br0">&#41;</span><span class="sy0">;</span> <span class="co1">// Si un resultat est retourne, c'est un message d'impossibilite</span> <span class="kw1">if</span> <span class="br0">&#40;</span><span class="re0">$res</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><span class="kw1">return</span> <a href="http://www.php.net/array"><span class="kw3">array</span></a><span class="br0">&#40;</span><span class="st_h">'texte'</span> <span class="sy0">=></span> <span class="re0">$res</span><span class="br0">&#41;</span><span class="sy0">;</span><span class="br0">&#125;</span> <span class="kw1">if</span> <span class="br0">&#40;</span><span class="sy0">!</span><span class="re0">$chemin_cache</span> <span class="sy0">||</span> <span class="sy0">!</span><span class="re0">$lastmodified</span><span class="br0">&#41;</span> <span class="re0">$lastmodified</span> <span class="sy0">=</span> <a href="http://www.php.net/time"><span class="kw3">time</span></a><span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span></code></pre></div> <p>la ligne 30 est une ligne de commentaire : <strong>// Cette fonction est utilisee deux fois<br class='autobr' /> </strong></p> <p>Si quelqu'un voit, il en sera remercié .</p> <p>PS : Tiens , mon gravatar ne s'affiche plus ?!</p> Essayez SPIP 2.1-RC 2010-11-26T12:07:14Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment437485 2010-11-26T12:07:14Z <p>Merci beaucoup Jean-Charles, je me heurtais exactement au même problème sur mon petit <a href="http://www.voilier-corse.fr" class='spip_out' rel='external'>site</a> que j'essaie -difficilement- de migrer sous spip pour plus de simplicité (je gère actuellement tout manuellement). ça fait des heures que je cherchais la solution (je suis chez nfrance comme hebergeur, sur un petit mutualisé).</p> <p>Allez, ça avance !</p> Essayez SPIP 2.1-RC 2010-06-08T09:49:25Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment431324 2010-06-08T09:49:25Z <p>Bonjour,</p> <p>J'ai eu le même souci.<br class='autobr' /> Résolu depuis que j'ai ajouté une ligne dans le fichier htaccess, à la racine du site :</p> <p>AddType x-mapp-php5 .php</p> <p>qui permet d'utiliser la dernière version de php 5 (chez 1and1).<br class='autobr' /> Bon courage à toi<br class='autobr' /> A+</p> Essayez SPIP 2.1-RC 2010-05-20T07:04:30Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment430712 2010-05-20T07:04:30Z <p>Bonjour à tous,</p> <p>J'utilise la version 2.1 de spip avec le squelette sarkaspip 3 et depuis quelques jours j'ai de très gros soucis avec la page de gestion des plugins : ils n'apparaissent plus. Il y a les onglets, le nombre de plugins installés ou présents mais rien dans la liste. La page se charge sans rien.</p> <p>Auriez vous des pistes pour m'aider à rétablir cela.</p> <p>Par avance, je vous en remercie.</p> <p>JP</p> Essayez SPIP 2.1-RC 2010-04-13T09:54:01Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment429129 2010-04-13T09:54:01Z <p>Je viens de mettre la 2.1 et plusieurs mauvaises surprises :<br class='autobr' /> spipbb ne fonctionne plus</p> <p>et par ailleurs j'ai ce message d'erreur</p> <p>Parse error: syntax error, unexpected '&' in /home/collectf/public_html/elemac.fr/ecrire/public/assembler.php(604) : eval()'d code on line 21</p> <p>je cherche le plugin responsable.....</p> Essayez SPIP 2.1-RC 2010-04-10T18:40:13Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428961 2010-04-10T18:40:13Z <p>Merci beaucoup, avec les dernières versions de spip-listes et pages uniques, ça marche nickel. C'est vraiment gentil d'avoir pris le temps de me répondre et ça m'a bien aidée. Bonne soirée à vous.</p> Essayez SPIP 2.1-RC 2010-04-10T16:09:19Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428956 2010-04-10T16:09:19Z <p>merci cerdic, je devrai mieux lire les messages :)</p> <p>pour romilou : le plugin page a été mise à jour , téléchargez le dernier zip</p> Essayez SPIP 2.1-RC 2010-04-10T15:55:47Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428953 2010-04-10T15:55:47Z <p>Bah j'ai des problèmes avec les 2 du coup... vous êtes aussi spécialiste du plugin page unique ?</p> Essayez SPIP 2.1-RC 2010-04-10T15:50:57Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428952 2010-04-10T15:50:57Z <p>D'accord, je fais ça et je vous redis si c'est bon. Merci</p> Essayez SPIP 2.1-RC 2010-04-10T15:50:14Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428951 2010-04-10T15:50:14Z <p>c'est le plugin “pages uniques” qui est en cause, là, pas spip-listes.</p> Essayez SPIP 2.1-RC 2010-04-10T15:48:30Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428950 2010-04-10T15:48:30Z <p>a , oui mais non</p> <p>en fait il peut y avoir plusieur version de spip liste 193. essaiyer de récuperer le dernier zip et de le mettre</p> Essayez SPIP 2.1-RC 2010-04-10T15:45:46Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428947 2010-04-10T15:45:46Z <p>J'ai <strong>spip_liste_1_9_3,</strong> y a t'il une version plus récente ?<br class='autobr' /> Je viens de voir que quand je vais dans la gestion des plugins sur mon espace privé, je n'ai plus la liste de mes plugins mais un message d'erreur :<br class='autobr' /> <strong>Fatal error: Call to undefined function: plugin_get_infos() in /homez.184/ujsfnorm/www/plugins/pages/base/pages_installation.php on line 17</strong></p> Essayez SPIP 2.1-RC 2010-04-10T15:40:08Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428944 2010-04-10T15:40:08Z <p>avez vous bien la dernière version à jour du plugin ? parceque normalemt c'est censé marché avec la toute dernier</p> Essayez SPIP 2.1-RC 2010-04-10T15:24:12Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428943 2010-04-10T15:24:12Z <p>a, ca je connais le pb ! j'essaie de résoudre le pb et te préviens quand c'est bon et compatible 2.1</p> Essayez SPIP 2.1-RC 2010-04-10T15:18:09Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428942 2010-04-10T15:18:09Z <p>Bonjour,</p> <p>je vois que tu parles de “<strong>Call to undefined function plugin_get_infos()</strong>” dans <strong>spip listes</strong>.<br class='autobr' /> J'ai cette erreur mais je ne comprends pas bien ce qu'il faut faire pour résoudre le problème, pourrais-tu me dire ce que je dois faire ?</p> Essayez SPIP 2.1-RC 2010-04-09T16:27:39Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428894 2010-04-09T16:27:39Z <p>Après avoir installé le plugin “inscription2”, voilà le message qui apparaît sur l'écran dans la partie publique:</p> <p>Warning: Invalid argument supplied for foreach() in C:\wamp\www\spip.2.1\plugins\auto\inscription2_192\inscription2_mes_options.php on line 24</p> Essayez SPIP 2.1-RC 2010-04-09T04:53:40Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428855 2010-04-09T04:53:40Z <p>Je complète :</p> <p>Lorsque /ecrire/ ?exec=config_fonctions (c'est le bouton Configurations>Fonctions avançées)<br class='autobr' /> dans le log :</p> <blockquote class="spip"> <p>include() [<a href='https://contrib.spip.net/function.include'>function.include</a>]: Failed opening 'lang/ecrire_fr.php' for inclusion (include_path='.:/Applications/MAMP/bin/php5/lib/php') in /usr/local/www/book/ecrire/inc/traduire.php on line 37</p> </blockquote> <p>Et le ftp en question, c'est le pack FTP de cette page. Et le fichier y est bien.</p> <p>Ressemble à une erreur de chemin (path).</p> <p>Autre précision: Message d'erreur également sur manque de mémoire, toujours pour cette même page :</p> <blockquote class="spip"> <p>PHP Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 10316 bytes) in /usr/local/www/book/ecrire/inc/filtres_images_lib_mini.php on line 251</p> </blockquote> <p>Après correction du <i>memory_limit</i>, plus aucun message d'erreur.</p> <p>Peut-être que la première (fichier manquant) avait comme condition la seconde ?</p> Essayez SPIP 2.1-RC 2010-04-08T16:33:46Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428834 2010-04-08T16:33:46Z <p>Le fichier est bien dans le zip, c'est sans doute ton transfert par ftp qui a oublié des fichiers.</p> Essayez SPIP 2.1-RC 2010-04-08T16:25:58Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428833 2010-04-08T16:25:58Z <p>Erreur rencontrée sur le pack récupéré ici aujourd'hui:</p> <p>Lorsque /ecrire/?exec=config_fonctions<br class='manualbr' />dans le log :</p> <blockquote class="spip"> <p>include(lang/spip_fr.php) [<a href='https://contrib.spip.net/function.include'>function.include</a>]: failed to open stream: No such file or directory...</p> </blockquote> <p>Important ?</p> <p>En tout cas pas bloquant.</p> <p>PS: ne serait-il pas plus ( raisonnable | efficace ) d'utiliser un svn update pour suivre les corrections ?</p> Essayez SPIP 2.1-RC 2010-04-08T16:08:26Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428832 2010-04-08T16:08:26Z <p>Confirmé !</p> Essayez SPIP 2.1-RC 2010-04-08T16:07:55Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428831 2010-04-08T16:07:55Z <p>Suite de la remarque sur “répondre ...”. J'ai l'impression que la rupture (lors du clic sur la barre typo) fait perdre le fil de la discussion (le message n'apparaît pas en suite du fil).</p> Essayez SPIP 2.1-RC 2010-04-08T16:04:07Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428830 2010-04-08T16:04:07Z <blockquote class="spip"> <p>Call to undefined function plugin_get_infos()</p> </blockquote> <p> En effet, déplacée. Ainsi que ajax_retour(). Je viens de corriger SL dans ce sens.</p> <p>Au fait, lorsque je fais un “répondre...” dans ce forum, le textarea apparaît via ajax. Si dans ce bloc je sélectionne du texte et clic sur le bouton <strong>quote</strong>, ça recharge complètement la page et le formulaire est à rechercher en bas de page. Curieux ! Un évènement oublié ?</p> Essayez SPIP 2.1-RC 2010-04-07T17:46:01Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428778 2010-04-07T17:46:01Z <p>Elle n'a pas changé de nom, elle a juste été déplacée.</p> <p>Je viens de commiter les correctifs.</p> Essayez SPIP 2.1-RC 2010-04-04T16:38:13Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428658 2010-04-04T16:38:13Z <p>J'ai un message d'erreur du plugins spipliste:<br class='autobr' /> Fatal error: Call to undefined function plugin_get_infos() in /home/www/sagc/www/plugins/auto/spip-listes_1_9_3/inc/spiplistes_api_presentation.php on line 871</p> <p>et le plugins GuestBook et marqué en erreur dans les plugins (alors qu'il fonctionne très bien)</p> <p>Sinon tous va bien et elle est très stable</p> Essayez SPIP 2.1-RC 2010-04-02T07:57:24Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428589 2010-04-02T07:57:24Z <p>Bonjour, et merci encore pour le formidable travail réalisé avec spip.<br class='autobr' /> J'ai l'impression que les boucles dans les css passant par le moteur de spip ne fonctionnent plus sous spip 2.1,<br class='autobr' /> par exemple cette boucle :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="spip"><code><span class="re11"><BOUCLE_chargement</span><span class="re12">(RUBRIQUES)</span><span class="re13"><span class="re41">{tout}</span></span><span class="re10">></span> #fond_rubrique_<span class="re1">#ID_RUBRIQUE</span><span class="re40">{ background: url(<span class="re4">[</span>IMG/<span class="re4">(</span><span class="re1">#LOGO_RUBRIQUE_NORMAL</span><span class="re50">|fichier</span><span class="re4">)</span><span class="re4">]</span>) no-repeat 0px 0px transparent; }</span> <span class="re15"></BOUCLE_chargement></span></code></pre></div> <p>`<br class='autobr' /> Fonctionne sous spip 2.01 mais pas avec spip 2.1<br class='autobr' /> Par contre, les #SET, et autres #GET fonctionnent eux normalement.<br class='autobr' /> ...<br class='autobr' /> Avez-vous rencontré ce problème ? est-il identifié ?</p> Essayez SPIP 2.1-RC 2010-03-28T22:54:41Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428338 2010-03-28T22:54:41Z <p>[Hors sujet]</p> <p>Bonjour Sylvain,</p> <p>A propos de:</p> <blockquote class="spip"> <p>J'utilise beaucoup les variables #LANG et #ENV lang pour tester et afficher quelque chose selon le résultat du test avec un $_GET['lang'] fixé dans mes_options.php selon le nom de domaine et ce $_GET['lang'] ne semble pas être pris en compte.</p> </blockquote> <p>peux-tu élaboré ta technique par exemple en indiquant une remarque dans la page suivante: <a href="http://www.spip-contrib.net/MultilinguismeExemple6" class='spip_url spip_out auto' rel='nofollow external'>http://www.spip-contrib.net/MultilinguismeExemple6</a> (en particulier pour comparer avec l'Idée N°3).</p> <p>Merci d'avance</p> Essayez SPIP 2.1-RC 2010-03-28T13:53:10Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428328 2010-03-28T13:53:10Z <p>Par contre, j'ai une erreur quand j'essaie d'administrer le plugin Lecteur multimedia :<br class='manualbr' />Call to undefined function plugin_get_infos()<br class='manualbr' /><strong>[Edit]</strong> : Résolu en cherchant dans le couteau suisse (Merci Pat, en plus on apprend en utilisant cet outil !)<br class='manualbr' />ligne rajoutée :<br class='autobr' /> _$get_infos = defined('_SPIP20100')?charger_fonction('get_infos','plugins'):'plugin_get_infos';</p> <p>Mais ensuite une autre fonction n'est pas définie :<br class='manualbr' />affiche_bloc_plugin</p> <p>Cette fonction a changé de nom ?</p> <p>Je peux remplacer par quoi ?</p> Essayez SPIP 2.1-RC 2010-03-28T13:48:05Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428327 2010-03-28T13:48:05Z <p>Hum, autant pour moi, une erreur de frappe dans mon fichier...<br class='autobr' /> Pour mes problèmes sur le $_GET['lang'], c'était donc une erreur de ma part...</p> <p>Désolé pour le bruit</p> Essayez SPIP 2.1-RC 2010-03-28T12:43:39Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428325 2010-03-28T12:43:39Z <p>Hello,</p> <p>j'ai essayé une mise à jour depuis 2.0.10 et il a fallu que je supprime mon vieux fichier connect.php (spip_connect_version = 0.4) pour pouvoir me connecter à l'admin, je ne sais pas si c'est normal...</p> <p>J'ai un petit souci avec mes squelettes : j'utilise beaucoup les variables #LANG et #ENV<i>lang</i> pour tester et afficher quelque chose selon le résultat du test avec un $_GET['lang'] fixé dans mes_options.php selon le nom de domaine et ce $_GET['lang'] ne semble pas être pris en compte.<br class='manualbr' />Quelque chose a changé dans l'utilisation de ces variables ?</p> <p>Beau boulot !</p> Essayez SPIP 2.1-RC 2010-03-28T12:10:35Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428324 2010-03-28T12:10:35Z <p>J'ai fait les mêmes tests (mêmes bases de donnée) avec <strong>easyphp</strong> et en ligne sur les serveurs du village et je n'ai plus de message d'erreur...Je pense donc que le soucis vient avec l'utilisation de<strong> wampserver</strong>. <br class='autobr' /> Par contre l'installation directe de la 2.1 ne fonctionne pas sur mes installations, seule une mise à jour depuis une 2.0.10 fonctionne. <br class='autobr' /> En installation directe j'obtiens une erreur:<br class='autobr' /> htaccess inopérant</p> <blockquote class="spip"> <p> Avertissement: la configuration de votre serveur HTTP ne tient pas compte des fichiers .htaccess. Pour pouvoir assurer une bonne sécurité, il faut que vous modifiez cette configuration sur ce point, ou bien que les constantes _DIR_TMP & _DIR_CONNECT (définissables dans le fichier mes_options.php) aient comme valeur des répertoires en dehors de C:/Program Files/EasyPHP5.2.10/www.</p> </blockquote> <p>Après cela il m'est impossible de me connecter à l'espace privé et j'obtiens une erreur 404 sur le site public.</p> Essayez SPIP 2.1-RC 2010-03-28T09:58:31Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428313 2010-03-28T09:58:31Z <p>Les plugins utilisés pour ce test sont : “Autorité”, “cfg”, “couteau_suisse” et “spip-bonux”.</p> Essayez SPIP 2.1-RC 2010-03-27T18:49:21Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428298 2010-03-27T18:49:21Z <p>C'est tout bon...<br class='autobr' /> Super, l'intégration de la médiathèque au niveau de la création d'article...<br class='autobr' /> Merci Cédric pour la surprise... Y en a d'autres comme ça ??? <br class='autobr' /> Merci à tous pour ce sacré boulot.</p> Essayez SPIP 2.1-RC 2010-03-27T18:14:40Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428297 2010-03-27T18:14:40Z <p>Effectivement sous SPIP 2.1.0-rc [15528] avec EasyPHP-5.3.2, c'est bon.<br class='autobr' /> je poursuis... A+</p> Essayez SPIP 2.1-RC 2010-03-27T15:27:39Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428283 2010-03-27T15:27:39Z <p>Très stable pour une rc1. A part quelque problème de compatibilité de plugins (guestbook...) le reste fonctionne comme avant. Aucun changement vu sur le site public: les ancien squelettes fonctionnent sans problème.</p> <p><a href="http://www.sagc-montagne-escalade.org" class='spip_out' rel='external'>http://www.sagc-montagne-escalade.org</a></p> Essayez SPIP 2.1-RC 2010-03-27T14:41:39Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428281 2010-03-27T14:41:39Z <p>Quels plugins utilise-tu ? Ce warning dénonce un appel incorrect de la fonction _chemin()</p> Essayez SPIP 2.1-RC 2010-03-27T14:37:00Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428280 2010-03-27T14:37:00Z <p>Ce bug a été corrigé par <a href="http://trac.rezo.net/trac/spip/changeset/15462/branches/spip-2.1/ecrire/public/cacher.php" class='spip_url spip_out auto' rel='nofollow external'>http://trac.rezo.net/trac/spip/changeset/15462/branches/spip-2.1/ecrire/public/cacher.php</a><br class='autobr' /> Il faut que tu télécharge à nouveau le zip pour bénéficier de la correction.</p> Essayez SPIP 2.1-RC 2010-03-27T13:25:11Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428276 2010-03-27T13:25:11Z <p>J'ai donc fait de nouveaux tests :</p> <p>A partir d'une base vierge, que ce soit sous WampServer 2.0i [11/07/09] (php 5.3.0) ou EasyPHP-5.3.2, le passage à la phase 4 de l'initialisation fut laborieux. Dans les deux système j'ai maintenant cette erreur :</p> <p>“Warning: substr() expects parameter 1 to be string, array given in C:\Program Files\EasyPHP-5.3.2\www\100327_audio_2-1-rc\ecrire\public\cacher.php on line 234”</p> <p>Quel est le niveau requis de php pour la 2.1 ?<br class='autobr' /> Avez-vous une idée d'où peut provenir cette erreur ?</p> Essayez SPIP 2.1-RC 2010-03-26T11:13:30Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428232 2010-03-26T11:13:30Z <p>Installée et testée avec <strong>wampserver 2.0</strong>. Tout semble fonctionner correctement si ce n'est une erreure au moment de vider le cache et sur certaines actions au niveau des plugins :<br class='autobr' /> <i>“Warning: strlen() expects parameter 1 to be string, array given in C:\wamp\www\dmf\ecrire\inc\utils.php on line 589” </i></p> Essayez SPIP 2.1-RC 2010-03-25T12:42:11Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428183 2010-03-25T12:42:11Z <p>J'ai effectué de nouveaux tests. Désolé pour le bruit, seule la nouvelle version de Wampserver semble en cause (ou son paramétrage !) : les fichiers compressés ne s'ouvrent pas. Je ne vois pas ou est le problème, en tout cas ce ne sont ni SPIP ni les plugins qui sont en cause. A+ Ch</p> Essayez SPIP 2.1-RC 2010-03-25T11:51:01Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428180 2010-03-25T11:51:01Z <p>Bonjour<br class='autobr' /> Bravo pour votre travail.<br class='autobr' /> Je l'ai installé en manuel sur un site utilisé pour tester les mises à jour: SPIP 2.04 et Ahuntsic (version 1er décembre 2009).</p> <p>J'ai oublié de vider le cache avant.</p> <p>A la mise en route, erreurs d'exécution de squelettes, puis cela s'est tassé.</p> <p>J'ai installé Accès Restreint pour le tester, les erreurs de squelettes sont revenues.<br class='autobr' /> Je n'ai pas pu vider le cache (erreur).<br class='autobr' /> J'ai désactivé Accès Restreint et Ahuntsic, le cache est depuis indiqué vide et erreur d'exécution lorsque je le vide. Ahuntsic est toujours visible bien que désactivé.</p> <p>Erreur de squelette<br class='autobr' /> Numéro message squelette boucle Ligne<br class='autobr' /> 1 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-edito.html _articles_edito 24<br class='autobr' /> 2 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-edito.html _articles_edito2 64<br class='autobr' /> 3 Filtre #URL_RUBRIQUE non défini squelettes/inc/inc-sommaire-edito.html _rubriques_edito 12<br class='autobr' /> 4 Filtre #URL_ARTICLE non défini squelettes/inc/inc-sommaire-articles.html _article_langue 11</p> <p>Erreur lorsque je demande à vider le cache (indiqué comme vide) :</p> <p>Fatal error: unlink(../tmp/cache//chargeur/acces_restreint_3_0/action/.ok) [<a href='https://contrib.spip.net/function.unlink'>function.unlink</a>]: No such file or directory in /mnt/102/sdb/a/8/regis.lardennois/articles/ecrire/inc/flock.php on line 276</p> <p>En bref, il y a encore quelques problèmes.</p> <p>J'ai cependant pu jouer un peu avec et je suis intéressé par l'utilisation de cette version sur mon site normal (un peu plus tard!).</p> <p>Cordialement.<br class='autobr' /> Régis</p> Essayez SPIP 2.1-RC 2010-03-24T15:48:02Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428143 2010-03-24T15:48:02Z <p>Pas de pb pour moi sur les MàJ couteau suisse, sur la 2.1ß</p> Essayez SPIP 2.1-RC 2010-03-24T15:31:03Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428140 2010-03-24T15:31:03Z <p>Bonjour,</p> <p>tout fonctionne bien chez moi, sauf trois plugins : <br />- notations <br />- notifications <br />- actijour</p> <p>je les ai désactivés pour l'instant</p> Essayez SPIP 2.1-RC 2010-03-24T12:46:43Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428128 2010-03-24T12:46:43Z <p>Non, pat, je ne crois pas parce que cette fonction du Couteau Suisse fonctionne sur un autre site spip en 2.010 (version du Couteau 36374).</p> Essayez SPIP 2.1-RC 2010-03-24T11:23:23Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428120 2010-03-24T11:23:23Z <p>Dans mon cas, le bouton justement n'apparaissait pas lorsqu'on cochait une case. Après avoir effacé tous les plugins, tout est rentré dans l'ordre.</p> Essayez SPIP 2.1-RC 2010-03-24T11:12:29Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428119 2010-03-24T11:12:29Z <p>SPIP 2.1.0-rc [14698]</p> <p>- ecrire/?exec=config_fonctions&image_process=gd2<br class='manualbr' />l'affichage de la taille des image que SPIP peut digérer a disparu. Dommage, c'estait joli ;-)</p> <p>- sur un site déjà installé la mise à jour par spip_loader ne marche pas. cf. captures d'écran. La mise à jour par FTP marche très bien.<br class='manualbr' /><a href="http://www.spip.de/IMG/jpg/001-start.jpg" class='spip_url spip_out' rel='external'>http://www.spip.de/IMG/jpg/001-start.jpg</a><br class='manualbr' /><a href="http://www.spip.de/IMG/jpg/002-erreur_line480.jpg" class='spip_url spip_out' rel='external'>http://www.spip.de/IMG/jpg/002-erre...</a><br class='manualbr' /><a href="http://www.spip.de/IMG/jpg/003-updatedb_apres_ftp-install.jpg" class='spip_url spip_out' rel='external'>http://www.spip.de/IMG/jpg/003-upda...</a><br class='manualbr' /><a href="http://www.spip.de/IMG/jpg/004-updatedb_confirmation_par_ftpl.jpg" class='spip_url spip_out' rel='external'>http://www.spip.de/IMG/jpg/004-upda...</a></p> <p>SPIP 2.1.0-rc SVN [15044] <br />- Pour effectuer la mise à jour de la bdd il faut faire la vérification par FTP même si on est auteur1 / webmestre</p> <p>- Echec de l'installation du plugin Sélection d'articles</p> <p>- Erreur du plugin mediathèque après mise à jour 2.0->2.1: 1 Fehler in Layoutvorlage <br class='autobr' /> 1 SQL-Tabelle « DOCUMENTS_LIENS » unbekannt ../plugins/auto/mediatheque/prive/inc-galerie.html _liens 114<br class='autobr' /> Tentative de mise à jour échoue: Warning: touch() [function.touch]: Utime failed: Operation not permitted in /srv/www/web21/web/ecrire/inc/pclzip.php on line 3856<br class='manualbr' />Réinstallation de la médiathèque après l'avoir effacé sur le serveur -> OK</p> <p>- après mise à jour 2.0->2.1: nécessité d'actualiser la liste des plugins disponibles pour l'installation automatique</p> <p>- après mise à jour 2.0->2.1: erreur du plugin lecteur multimédia flash</p> <p>Autrement c'est super! Merci à tous les contributeurs et contributeuses ;-)</p> Essayez SPIP 2.1-RC 2010-03-24T10:56:46Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428116 2010-03-24T10:56:46Z <p>Free désactive peut-être les accès distants ?</p> Essayez SPIP 2.1-RC 2010-03-24T10:39:02Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428114 2010-03-24T10:39:02Z <p>Le bouton “enregistrer” de modification apparait si on coche ou décoche une checkbox dans la liste une fois la page totalement chargée. Ça m'a induit en erreur, et j'ai pensé avoir un problème alors que pas du tout. Peut être la même chose de ton coté ?</p> Essayez SPIP 2.1-RC 2010-03-24T10:34:07Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428113 2010-03-24T10:34:07Z <p>merci à vous deux pour ces pistes... je vais en effet corriger ce code (je l'avais généré il y a au moins un an, je n'ai pas pensé à y regarder depuis, étant donné que ça fonctionnait!), et ensuite retenter avec spip 2.1 pour voir ce qu'il me dit!</p> Essayez SPIP 2.1-RC 2010-03-24T10:30:46Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428112 2010-03-24T10:30:46Z <p>je suis étonné que tes tables soient reconnus sous SPIP 2.1. Si elle sont réellement externe à SPIP, il faut que la syntaxe soit du type <code><BOUCLE_youp(xxx:WP_POSTS)></code><a href="http://programmer.spip.org/Declarer-une-autre-base" class='spip_url spip_out auto' rel='nofollow external'>http://programmer.spip.org/Declarer-une-autre-base</a></p> <p>pour le titre typo, l'extension “filtres images” a-t-elle bien été installé automatiquement ?</p> Essayez SPIP 2.1-RC 2010-03-24T10:26:38Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428111 2010-03-24T10:26:38Z <p>Tu as une étrange façon d'écrire tes boucles dont je me demande si elle ne peut pas expliquer tes mésaventures... C'est la présence de la balise <code><//B_nomdetaboucle></code> sans qu'il y ait de balise <code></B_nomdetaboucle></code> qui la précède... Je me demande comment est interprété le code dans ces conditions...<br class='manualbr' />Je ne sais pas si ça a réellement un rapport, mais, bon, on peut toujours commencer par remetttre les choses au carré</p> Essayez SPIP 2.1-RC 2010-03-24T09:24:34Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428109 2010-03-24T09:24:34Z <p>Je confirme que sur un site de test (chez free, peut-être pas très performant), la rc fonctionne , divers plugins installés aussi, mais pas les mises à jour auto du Couteau Suisse.</p> Essayez SPIP 2.1-RC 2010-03-24T08:59:58Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428106 2010-03-24T08:59:58Z <p>Pour être certaine qu'il se s'agissait pas en effet d'erreur de codage de ma part, je suis repassée à spip 2.0.10 (version stable), et toutes les erreurs, ou tous les codes non interprétés avec la version 2.1 de spip se sont remis à fonctionner...<br class='autobr' /> Pour être plus précise: <br />- les plugins étaient à jour. D'ailleurs, pour faire mon test, je n'avais activé que skeleditor... directement pensé pour la version 2.1 et cfg... même pas spip-bonux! <br />- au cas où, mon FTP de test est un 60gp de chez ovh <br />- pour les tables externes, voici un exemple de boucle non reconnue (j'avais un message d'erreur disant que les tables WP_POSTS et WP_COMMENTS étaient inconnues...)</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_youp(WP_POSTS){post_title=#TITRE}> <BOUCLE_idyoup(WP_COMMENTS){comment_post_id=#ID}></BOUCLE_idyoup> <img src="/IMG/commentaire.png"> #SET{wp,#TOTAL_BOUCLE}<//B_idyoup> </BOUCLE_youp><//BOUCLE_youp> <BOUCLE_decompte(FORUMS) {id_article}{plat} />[(#TOTAL_BOUCLE|plus{#GET{wp}})] <//B_decompte> réaction(s)</code></pre></div> <p>- pour le filtre typographique, je parlais d'un code comme [(#TITRE|image_typo<i>police=comm.ttf,taille=17,couleur=71A9B0</i>)]</p> <p>ma police comm.ttf est bien présente dans le sous dossier “polices” de squelettes... mais spip se borne à afficher mon titre dans la police dustissimo...</p> <p>- pour l'erreur sur #URL_DOCUMENT, je ne sais pas du tout... mais avec la version précédente de spip, la stable, je n'ai aucun souci, sachant que comme je suis en train de refaire un site, je suis partie du squelette de la dist, pour le modifier progressivement, je ne pense donc pas avoir intégré de code barbare....</p> Essayez SPIP 2.1-RC 2010-03-23T20:11:06Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428087 2010-03-23T20:11:06Z <p><i>Dans tous les cas de test, les “mises à jour automatiques du <a href='https://contrib.spip.net/Le-Couteau-Suisse' class='spip_in' hreflang='fr'>Couteau Suisse</a>” ne fonctionnent plus. </i></p> <p>Je viens de faire l'essai, tout semble pourtant fonctionner...</p> <p>Merci pour ta réponse Pat, je refais des tests demain et te tiens informé. Ch</p> Essayez SPIP 2.1-RC 2010-03-23T20:01:09Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428085 2010-03-23T20:01:09Z <p>Il faut en dire un peu plus. Est-ce que tes plugins sont à jour ?<br class='autobr' /> Pour les tables externes, il faut que le nom de la table soit respécté, y compris majuscules/minuscules.<br class='autobr' /> L'erreur sur #URL_DOCUMENT vient peut-être d'une construction obsolète avec des<br class='autobr' /> <code>|#URL_DOCUMENT</code> ?</p> <p>Pour les filtres typo je ne sais pas à quoi tu fais allusion.</p> Essayez SPIP 2.1-RC 2010-03-23T19:45:57Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428083 2010-03-23T19:45:57Z <p>premières erreurs de mon côté : <br />- les boucles sur tables externes ne fonctionnent pas... <br />- les filtres typographiques non plus <br />- j'ai systématiquement l'erreur dans les squelettes “Filtre #URL_DOCUMENT non défini”</p> Essayez SPIP 2.1-RC 2010-03-23T06:00:56Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428036 2010-03-23T06:00:56Z <p>Aucun problème d'installation. Ne me reste qu'à faire joujou. Merci pour le boulot accompli!</p> Essayez SPIP 2.1-RC 2010-03-22T15:06:09Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428023 2010-03-22T15:06:09Z <p>J'ai effacé tous les plugins puis les ai ensuite réinstallé : cela fonctionne. Peut-être un problème lorsque les plugins ont été activés dans une version précédente?</p> Essayez SPIP 2.1-RC 2010-03-22T14:52:11Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428022 2010-03-22T14:52:11Z <p>Je viens d'installer cette version RC. Dans la gestion des plugins, je ne trouve pas le bouton pour activer un nouveau plugin? <br class='autobr' /> Et serait-il possible de savoir quelles évolutions ont été apportées?</p> Essayez SPIP 2.1-RC 2010-03-22T13:54:50Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428019 2010-03-22T13:54:50Z <p>Le dossier cache avait bien été supprimé, mais effectivement, il devait rester des traces quelque part. Quoi qu'il en soit, une suppression de connect.php a bien résolu le problème.</p> <p>On va donc dire mise à jour réussie, en attendant le test des nouveautés.</p> <p>Merci Cédric</p> Essayez SPIP 2.1-RC 2010-03-22T13:49:12Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428018 2010-03-22T13:49:12Z <p><strong>En fait, c'est le fichier spip_loader.php qui merdouille.</strong></p> <p>J'ai effacé spip sur le serveur, téléchargé spip_loader proposée sur cette page. Et la version qui s'installe est la 2.0.10.</p> <p>Il faudrait faire une instal manuelle. Mais bon. Pour l'instant je vais me contenter de la version stable du moment.</p> Essayez SPIP 2.1-RC 2010-03-22T12:53:52Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428013 2010-03-22T12:53:52Z <p>De toute évidence, tu n'as pas vidé le cache de SPIP, et les squelettes gardent encore la trace de Zpip que tu avais du installer. Par ailleurs, quand je test un login avec test/test j'ai bien un message d'erreur de mot de passe.</p> <p>Supprime le fichier config/connect.php, et retourne dans ecrire/ pour refaire la connexion à la base de données et resaisir ton login/pass d'administrateur.</p> Essayez SPIP 2.1-RC 2010-03-22T12:35:30Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428011 2010-03-22T12:35:30Z <p>Sur ce site de test <a href="http://testspip38.free.fr/" class='spip_out' rel='external'>http://testspip38.free.fr/</a>, passage raté de la 2.0.10 à la 2.1rc.</p> <p>Procédure suivie :</p> <p>effacement par ftp de tous les dossiers sauf config et IMG, envoi par ftp de tous les fichiers de la 2.1rc.</p> <p>résultat : blocage sur la page d'identification. impossible d'entrer dans l'espace privé, sans aucun message d'erreur !</p> <p>???</p> <p>à suivre</p> Essayez SPIP 2.1-RC 2010-03-22T12:14:29Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428009 2010-03-22T12:14:29Z <p>J'ai rencontré le même message, lors de la mise à jour d'un SPIP 2.0.10 vers la RC. Mais j'ai pu continuer ensuite et constater que la mise à jour s'était faite correctement.</p> Essayez SPIP 2.1-RC 2010-03-22T11:35:57Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment428005 2010-03-22T11:35:57Z <p>Bonjour à vous,<br class='autobr' /> Le test (en manuel) sur Wampserver de la 2.1.0-RC [15517] s'est correctement déroulé. <br> Par contre un certain nombre de plugins ne fonctionnent pas en php 5.3 voire 5.3.1(exemple PageRank et Lecteur Flash pour MP3 -celui qui n'est pas en auto-). Tout rentre dans l'ordre en php 5.2.11 <br> Dans tous les cas de test, les “mises à jour automatiques du Couteau Suisse” ne fonctionnent plus. <br> Étonnant, bienque la date système soit au 22 mars, un article post daté au 24 mars a été mis en ligne. <br> Merci pour ce boulot.<br> A+<br class='autobr' /> Ch</p> Essayez SPIP 2.1-RC 2010-03-22T10:51:03Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427998 2010-03-22T10:51:03Z <p>Meme bug. Mise à jour impossible avec spip_loader.php de la version 2.0.10 vers 2.1 rc.</p> <p>Le message d'erreur est le suivant : “Espace interdit SPIP est déjà installé.”</p> <p>Je suis le seul auteur inscrit sur le site pour le moment.</p> Essayez SPIP 2.1-RC 2010-03-22T08:15:33Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427992 2010-03-22T08:15:33Z <p>Merci de le rappeler, cela m'est déjà arrivé, mais dans ce site de test, je suis seul auteur et j'ai été bloqué pendant la mise à jour et non pour son accès, au deuxième ou troisième tableau...</p> Essayez SPIP 2.1-RC 2010-03-21T17:43:35Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427986 2010-03-21T17:43:35Z <p>Je viens d'installer la RC en mode manuel</p> <p>L'espace privé me semble + rapide à tous les niveaux. L'organistation de la section “Gestion des plugins” est beaucoup plus simple et plus claire. Hébergée sous free.fr, la version 2.0.10 me renvoyait systématiquement un message d'erreur lors de la mise à jour des listes de plugins (error de type “uniquid”)</p> <p>La refonte des images de l'espace privé est très réussie.<br class='autobr' /> Bravo et merci aux nombreux développeurs qui font avancer spip.</p> <p>J'attends donc la version 2.1 stable :)</p> Essayez SPIP 2.1-RC 2010-03-21T16:57:06Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427983 2010-03-21T16:57:06Z <p>A noter une erreur avec le plugin Spip_liste 2.0143.</p> <p>Fatal error: Call to undefined function ajax_retour() in /www/mon_site/plugins/auto/spip-listes_1_9_3/exec/spiplistes_menu_navigation.php on line 63</p> <p>Fatal error: Call to undefined function plugin_get_infos() in /www/mon_site/plugins/auto/spip-listes_1_9_3/inc/spiplistes_api_presentation.php on line 871</p> Essayez SPIP 2.1-RC 2010-03-21T15:33:34Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427982 2010-03-21T15:33:34Z <p>C'est installé ... à suivre ...</p> Essayez SPIP 2.1-RC 2010-03-21T12:16:26Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427972 2010-03-21T12:16:26Z <p>Bonjour,</p> <p>Je suis en train de tester cette nouvelle version. L'ensemble à l'air plutot bien, et la mise-à-jour s'est passée sans problème.</p> <p>Cependant, j'ai une erreur récurrente avec plusieurs plugins (notamment Facteur 1.1)<br class='autobr' /> qui me retourne cette erreur à l'installation : <br class='autobr' /> <code>Fatal error: Call to undefined function plugin_get_infos() in Z:\www\mon_site\plugins\facteur\base\facteur.php on line 6</code></p> <p>Y a-t-il quelque chose à faire ?</p> <p>Merci</p> Essayez SPIP 2.1-RC 2010-03-20T11:23:12Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427935 2010-03-20T11:23:12Z <p>Merci à Pierre, le problème a été trouvé : j'ai uploadé une image trop grosse et le serveur ne suivait pas pour la redimensionner. Du coup impossible d'afficher l'article, aussi bien dans la partie privée que publique.</p> Essayez SPIP 2.1-RC 2010-03-20T11:01:56Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427934 2010-03-20T11:01:56Z <p>il me semble que spip_loader a toujours refusé l'installation si tu n'es pas connecté en tant que webmaster (id 1 par défaut, autres id à ajouter dans mes_options.php) sur le site en “fonction”. A vérifier si ce n'est pas ça qui t'as bloqué dans la maj...</p> Essayez SPIP 2.1-RC 2010-03-20T10:40:36Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427933 2010-03-20T10:40:36Z <p>C'est dans ta boîte.</p> Essayez SPIP 2.1-RC 2010-03-20T10:18:38Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427932 2010-03-20T10:18:38Z <p>Salut manu</p> <p>Oui, pour l'admin restraint tu as bien fais comment je pensais. Pour le reste envoie mes un id par mail privé.</p> Essayez SPIP 2.1-RC 2010-03-20T10:14:42Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427931 2010-03-20T10:14:42Z <p>Salut Pierre,</p> <p>j'avoue ne pas avoir tout compris. Tu parles des auteurs et de choix de les faire apparaître ou pas dans la liste des personnes connectées ?<br class='manualbr' />Je me suis connecté avec l'identifiant de mon admin retsreint et je n'ai pas trouvé ce choix, même sous son compte.</p> <p>Je constate aussi ce matin énormément de pages blanches. Par exemple, quand je suis sur la page d'accueil de la partie privée et que je clique sur le titre d'un des derniers articles publiés, page blanche. Bien entendu, cet hébergement contient d'autres sites, dont plusieurs SPIP 2.0.10 qui ne présentent aucun soucis.</p> <p>Je peux fournir l'URL et les identifiants si nécessaire.</p> Essayez SPIP 2.1-RC 2010-03-20T09:34:29Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427930 2010-03-20T09:34:29Z <p>manu</p> <p>Il me semble qu'il faut désormais que tu peux pas choisir pour les autres, il faut te connecter à leur place.</p> Essayez SPIP 2.1-RC 2010-03-20T09:23:29Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427929 2010-03-20T09:23:29Z <p>Bonjour et bravo à tous les participants de cette grande aventure.</p> <p>Pour mon cas, le spip_loader.php refuse l'installation si un spip est déjà en fonction, j'ai lancé l'installation en manuel.</p> <p>Surprise, la mise à jour de la base nécessite de créer un dossier dans /tmp/ (retour à l'ancienne méthode???)</p> <p>L'esthétique est très agréable, je travaille sur des plugins et autres complément et je confirme mon impression de confort à l'utilisation.</p> <p>Bonne continuation à toute l'équipe.</p> Essayez SPIP 2.1-RC 2010-03-19T22:48:28Z https://contrib.spip.net/Essayez-SPIP-2-1-RC#comment427922 2010-03-19T22:48:28Z <p>Tout d'abord, un grand merci à ceux qui consacrent du temps à coder SPIP et qui partagent leur travail. J'ai fait quelques tests de cette RC.</p> <p><strong>[Installation]</strong> <br />- aucun problème pour une installation à partir du spip_loader, pour un site vierge (je teste demain la migration d'un site existant). <br />- lors de la dernière étape de l'installation, je suggère qu'une courte description fonctionnelle accompagne les extensions présentées.</p> <p><strong>[bizarre ?]</strong> <br />- je m'attendais à retrouver l'interface privée de spip-contrib. C'est pourtant les mêmes numéros de version mais ça n'a rien à voir. J'ai raté un épisode ?</p> <p><strong>[auteur]</strong> <br />- j'ai créé un nouvel admin restreint sans difficulté mais je n'ai pas trouvé l'option permettant de le faire apparaître ou pas dans la liste des personnes connectées.</p> <p><strong>[article]</strong> <br />- lorsque je crée un article et que je veux ajouter une image, le double clic sur <code><img1|center></code> pour insérer le raccourci dans le corps du texte ne fonctionne pas <br />- impossible d'enregistrer un article avec le raccourci vers une image : page blanche —> dans prive_spip.log, je constate une redirection systématique vers une page 302, je ne sais pas s'il y a un rapport</p> <p><strong>[plugins]</strong> <br />- j'ai installé les plugins spip-bonux et médiathèque. Quand je vais dans la médiathèque, je clique sur le lien “modifier” correspondant à un document et seul le haut du formulaire s'affiche.</p> <p>C'est tout pour ce soir, je continue demain ;)</p>