Mosaïque - comments Mosaïque 2017-12-05T17:34:02Z https://contrib.spip.net/Mosaique#comment494753 2017-12-05T17:34:02Z <p>Bonjour,</p> <p>Comme indiqué à la fin de cette doc, le plugin Ordoc remplace maintenant Mosaïque.</p> <p>Il existe même un plugin pour migrer facilement de Mosaïque à Ordoc : <a href="https://contrib.spip.net/Migration-de-Mosaique-vers-Ordoc" class='spip_url auto' rel='nofollow'>https://contrib.spip.net/Migration-de-Mosaique-vers-Ordoc</a></p> Mosaïque 2017-12-05T17:32:28Z https://contrib.spip.net/Mosaique#comment494752 2017-12-05T17:32:28Z <p>tu sais lire ? en SPIP 3.2, la fonction glisser et déposer est fourni en natif (voir le lien <a href='https://contrib.spip.net/Ordoc-ordonner-les-documents-attaches-4860' class='spip_in' hreflang='fr'>plugin ordoc</a>) rendant le plugin mosaïque inutile.</p> Mosaïque 2017-12-05T17:24:05Z https://contrib.spip.net/Mosaique#comment494751 2017-12-05T17:24:05Z <p>Bonjour</p> <p>Quid d'une mise à jour vers SPIP 3.2 <br />- Est-ce qu'un portage est prévu ?</p> Mosaïque 2016-09-26T09:11:48Z https://contrib.spip.net/Mosaique#comment489135 2016-09-26T09:11:48Z <p>En fait, je viens de mettre un float: left sur les li et l'ordre suit maintenant. J'avais l'impression que c'était mélangé et non juste inversé du fait que chaque ligne de miniature suivait un float: right et que sur plusieurs lignes, ça donnait l'impression d'un mélange… <br class='autobr' /> Je ne sais pas si je suis très clair, mais ça marche !</p> Mosaïque 2016-09-26T08:30:52Z https://contrib.spip.net/Mosaique#comment489134 2016-09-26T08:30:52Z <p>Bonjour !</p> <p>Me revoilà à nouveau, j'aime toujours autant ce plugin pour trier l'ordre des images… Mais voilà, je suis passée à Spip 3.1.1 et j'ai un souci : l'ordre n'est pas pris en compte à l'affichage des miniatures. Je ne sais pas s'il est incompatible ou plus sûrement je ne sais pas adapter le code qui semble avoir un peu changé depuis Spip 3.0.</p> <p>En effet, la boucle source de inclure/documents.html est devenue :<br class='autobr' /> <code><BOUCLE_documents_portfolio(DOCUMENTS) {id_article?}{id_rubrique?}{objet?}{id_objet?} {mode=document}{extension IN png,jpg,gif} {par num titre, date}{doublons}{vu=non}></code></p> <p>J'ai tenté ça, ce qui ne donne pas de message d'erreur mais ne prend pas l'ordre en compte :<br class='autobr' /> <code><BOUCLE_documents_portfolio(DOCUMENTS) {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}} {mode=document}{extension IN png,jpg,gif}{doublons}{vu=non}></code></p> <p>Help please :-) ! D'avance merci, bonne journée.<br class='autobr' /> Karen</p> Mosaïque 2016-04-05T18:54:37Z https://contrib.spip.net/Mosaique#comment486922 2016-04-05T18:54:37Z <p>Bonjour, le projet de compatibilité avec le plugin <i>albums</i> est-il toujours d'actualité? Je trouve que les deux se complètent :)</p> Mosaïque 2015-03-24T10:38:31Z https://contrib.spip.net/Mosaique#comment480550 2015-03-24T10:38:31Z <p>parfait ! mon intuition était donc la bonne.</p> Mosaïque 2015-03-24T10:30:40Z https://contrib.spip.net/Mosaique#comment480546 2015-03-24T10:30:40Z <p>Oups ! Pardon, bien sûr ! J'ai mis à jours sur tous les sites concernés, c'est nickel ! Plus de message d'erreur, pas d'autres bugs relevés.<br class='autobr' /> Merci encore !<br class='autobr' /> Karen</p> Mosaïque 2015-03-24T10:07:10Z https://contrib.spip.net/Mosaique#comment480545 2015-03-24T10:07:10Z <p>des retours sur la mise à jour ? histoire d'être sur que j'ai bien fait la bonne modification...</p> Mosaïque 2015-03-21T23:27:41Z https://contrib.spip.net/Mosaique#comment480457 2015-03-21T23:27:41Z <p>Décidément, un grand merci la communauté pour votre réactivité ! Je guette alors la mise à jour, bien que ça ne semble pas poser de problème fonctionnel majeur…<br class='autobr' /> Merci Maïeul et Thom ! Vraiment très bien ce plugin :-)</p> Mosaïque 2015-03-21T18:39:51Z https://contrib.spip.net/Mosaique#comment480454 2015-03-21T18:39:51Z <p>Merci Maieul, je note l'astuce pour la prochaine fois !</p> Mosaïque 2015-03-21T18:34:18Z https://contrib.spip.net/Mosaique#comment480453 2015-03-21T18:34:18Z <p>je viens d'envoyer une correction. Il faudra procéder à la mise à jour vers la 0.5.1, bientôt ;-)</p> Mosaïque 2015-03-21T18:21:19Z https://contrib.spip.net/Mosaique#comment480452 2015-03-21T18:21:19Z <p>je viens de regarder ... les personnes qui se sont occupés de la mise à jour du plugin ne savent pas que celui-ci doit procéder aux mise à jour de la BDD lorsqu'il se met à jour... je vais regarder si je peux corriger cela rapidement.</p> Mosaïque 2015-03-21T17:41:54Z https://contrib.spip.net/Mosaique#comment480450 2015-03-21T17:41:54Z <p>Bonjour,</p> <p>Au risque d'insister… personne n'a ce problème ?<br class='autobr' /> J'ai reproduit exactement le même phénomène sur tous mes sites : <br class='autobr' /> – mise à jour de Saisie pour formulaires 2.1.1 > OK<br class='autobr' /> – mise à jour de Champs Extra 3.5.0 > OK<br class='autobr' /> – mise à jour de Mosaique 0.5.0 > message d'erreur, uniquement sur la partie privée d'une page de rubrique… ça ne semble pas poser de problème fonctionnel, mais j'aime pas les messages d'erreur ;-)<br class='autobr' /> Et je ne suis pas assez experte en php/sql etc. pour mettre les mains dedans !</p> <p>Cordialement,<br class='autobr' /> Karen</p> Mosaïque 2015-03-17T14:24:40Z https://contrib.spip.net/Mosaique#comment480340 2015-03-17T14:24:40Z <p>Bonjour,</p> <p>Je viens de mettre à jour les plugins Mosaique (0.5.0) ainsi que Saisie (2.1.1) et Champs Extra (3.5.0).<br class='autobr' /> Depuis, j'ai cette erreur pour les pages de rubriques :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="spip"><code>Erreur SQL 1054 Unknown column 'mosaique' in 'field list' SELECT mosaique FROM spip_rubriques WHERE id_rubrique=1</code></pre></div> <p>Est-ce que quelqu'un d'autre a ce problème ?</p> <p>Cordialement,<br class='autobr' /> Karen</p> Mosaïque 2015-03-16T14:51:57Z https://contrib.spip.net/Mosaique#comment480323 2015-03-16T14:51:57Z <p>En effet, c'est “text” qui est recommandé ici. C'est corrigé !</p> Mosaïque 2015-03-02T19:39:54Z https://contrib.spip.net/Mosaique#comment479885 2015-03-02T19:39:54Z <p>ouch, je ne me rappelais pas non plus de cette discussion... ça craint là, faut faire un break... merci en tout cas pour ce script qui m'est très utile, je m'en sers comme chemin de fer pour des ebooks, c'est top. Oui il semble que text soit la meilleure solution, voyons ce qu'en disent les experts ;)<br class='autobr' /> A plus!</p> Mosaïque 2015-03-02T18:24:40Z https://contrib.spip.net/Mosaique#comment479884 2015-03-02T18:24:40Z <p>Salut Pi r,</p> <p>Merci pour ta contrib super rapide !</p> <p>Je crois qu'il y avait déjà eu un commit pour passer en varchar(1000) qui avait été annulé, varchar ne devant pas dépasser 255 selon ce que moi et plusieurs autres avions compris. J'ai retrouvé la conversation sur la liste : <a href="http://comments.gmane.org/gmane.comp.web.spip.zone.cvs/70076" class='spip_url spip_out auto' rel='nofollow external'>http://comments.gmane.org/gmane.comp.web.spip.zone.cvs/70076</a> (c'est curieux d'ailleurs, je m'aperçois que je n'ai jamais reçu ton mail du 5 Jul 08:10 2013)</p> <p>D'après la doc de MySQL, varchar > 255 n'est supporté qu'à partir de MySQL 5.0.3.</p> <p>Personnellement je n'ai pas d'avis, je n'y connais pas grand chose. Deux petites questions cependant :</p> <p>Pourquoi varchar(1000) plutôt que text ? (pour ma culture générale)</p> <p>En admettant qu'on opte pour varchar(1000), est-ce qu'on peut décider d'abandonner le support des MySQL < 5.0.3 ? Quelle est la compatibilité attendue pour un plugin Spip ?</p> <p>Et vu que je suis une bille sur cette dernière question, je m'en vais de ce pas la poser sur la liste !</p> <p>Bonne soirée !</p> Mosaïque 2015-03-02T15:17:16Z https://contrib.spip.net/Mosaique#comment479878 2015-03-02T15:17:16Z <p>ou varchar max plutôt? c'est ce que j'ai fait et c'est nickel... ++</p> Mosaïque 2015-03-02T15:06:32Z https://contrib.spip.net/Mosaique#comment479877 2015-03-02T15:06:32Z <p>ah oui pardon, si le plugin est installé cela nécessite de changer la valeur champ en base...<br class='autobr' /> 255 c'est vraiment pas assez, même 1000 peut s'avérer rapidement insuffisant...<br class='autobr' /> voyez vous un inconvénient à ce que l'on passe en text?</p> Mosaïque 2015-03-02T14:32:26Z https://contrib.spip.net/Mosaique#comment479873 2015-03-02T14:32:26Z <p>Merci<br class='autobr' /> J'ai chnagé le code et ça n'a pas solutionné le problème mais en changeant la valeur Varchar du champ via phpMyAdmin je n'ai plus le problème<br class='autobr' /> Merci beeaucoup !!!!</p> Mosaïque 2015-03-02T12:58:37Z https://contrib.spip.net/Mosaique#comment479871 2015-03-02T12:58:37Z <p>hello, si c'est le même problème, c'est qu'il y a trop de documents dans l'article pour la config d'origine du champ sql, solution : modifier le fichier base/mosaique.php, remplacer</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code>'sql' => "varchar(255) NOT NULL DEFAULT ''", par 'sql' => "varchar(1000) NOT NULL DEFAULT ''",</code></pre></div> Mosaïque 2015-03-02T12:24:16Z https://contrib.spip.net/Mosaique#comment479870 2015-03-02T12:24:16Z <p>Bonjour<br class='autobr' /> On est en 2015 et j'ai ce problème mais lors de l'enregistrement d'un article cette fois -ci... à quoi cela pourrait-il être dû ?</p> Mosaïque 2014-04-25T07:02:47Z https://contrib.spip.net/Mosaique#comment475108 2014-04-25T07:02:47Z <p>Bonjour et merci thom_b…<br class='autobr' /> pour votre réactivité, en plus de cette contribution très utile.</p> <p>Je viens de tester et ça fonctionne.</p> <p>Très bonne journée, la mienne vient de commencer merveilleusement ;-)</p> Mosaïque 2014-04-24T19:54:12Z https://contrib.spip.net/Mosaique#comment475106 2014-04-24T19:54:12Z <p>Bonjour,</p> <p>Normalement Mosaïque n'insère aucun JS dans les pages de l'espace public, il active juste jquery.ui.sortable via le pipeline adéquat.</p> <p>Il faut vérifier qu'aucun script n'est appelé deux fois (je pense à jquery). Appeler jquery/jquery UI avec les fonction de SPIP est une bonne façon d'éviter ça.</p> <p>Pour info, il existe un plugin SPIP tout prêt qui fait la même chose (il me semble) que scrolldjs : <a href="http://contrib.spip.net/Ancres-douces" class='spip_url spip_out auto' rel='nofollow external'>http://contrib.spip.net/Ancres-douces</a></p> <p>Bon courage !</p> Mosaïque 2014-04-24T19:35:10Z https://contrib.spip.net/Mosaique#comment475105 2014-04-24T19:35:10Z <p>Salut,</p> <p>Ça fait un petit moment que je n'ai pas mis les mains dans le cambouis, je vais essayer de ne pas dire d'idioties...</p> <p>Je dirais qu'il faut essayer de passer l'id de l'article xx au modèle <code>ordre_mosaique</code>. Peut-être avec :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="spip"><code><span class="re40">{id_document IN <span class="re1">#MODELE</span>{ordre_mosaique,id_article=<span class="re1">#ENV</span>{id}}<span class="re50">|explode</span>{','}}</span></code></pre></div> <p>Attention également à l'ordre des critères dans la boucle, cf la doc du plugin :</p> <blockquote class="spip"> <p>De même, on veillera à n'insérer les autres éventuels critères qu'après l'appel d'ordre_mosaique dans les critères</p> </blockquote> <p>Bon courage</p> Mosaïque 2014-04-24T14:37:40Z https://contrib.spip.net/Mosaique#comment475102 2014-04-24T14:37:40Z <p>Bonjour,</p> <p>D'abord un grand bravo et merci à thom_b pour cette excellente contribution ! L'air de rien, la gestion des images est un vaste chantier !<br class='autobr' /> Et donc, depuis 2007 que je parcours et lis ce forum en long, large et travers, je passe le pas de m'inscrire aujourd'hui !</p> <p>Voilà mon problème : j'utilise une version personnalisée, carrousel vertical, de Galleria (je précise d'entrée que le problème serait le même avec le vrai plugin > vérifié).</p> <p>J'ai donc créé un modèle galleria.html et je l'ai adapté pour qu'il fonctionne avec Mosaïque en appelant le <code>mode=document</code> (grâce aux contribs trouvées sur ce site), et jusqu'ici, tout va bien, que ce soit un appel <code>#GALLERIA</code> dans le squelette ou directement <code><galleria></code> dans le champ texte de l'article.</p> <p>Or, j'aimerais pouvoir appeler ce modèle à partir d'un autre article, par exemple appeler le portfolio de l'article xx dans l'article yy par un appel du type <code><galleriaxx></code>.<br class='autobr' /> Mais ça ne fonctionne pas (que dans l'article concerné et pas dans un autre article) car cette partie de la boucle empêche l'appel du modèle : <br class='autobr' /> <code>{id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}</code></p> <p>Voici ma boucle complète dans le modèle :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_galleria (DOCUMENTS){id_article=#ENV{id}}{extension==jpg|gif|png} {pagination #ENV{pagesize,30}}{id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}> <a href="#FICHIER"><img src="#FICHIER" [title="(#TITRE|textebrut)" ][alt="(#DESCRIPTIF|textebrut)" ]/></a> </BOUCLE_galleria></code></pre></div> <p>Quelqu'un pourrait-il m'aider pour faire en sorte de rendre ce modèle (ou tout autre modèle) appelable avec Mosaïque ? Par exemple pouvoir appler <code><galleria5></code>, ou <code><modelexx></code> dans l'aticle 27 ?<br class='autobr' /> Je précise que je connais le html et le css, un peu les boucles SPIP (assez limité tout de même), mais pas le php ni javascript, et aussi qu'en principe je cherche plusieurs jours avant de me décider à poster quelque part… mais là, je cale !</p> <p>D'avance merci pour vos réponses, et plus largement pour toutes ces merveilleuses contributions.<br class='autobr' /> Karen</p> Mosaïque 2014-04-14T16:35:52Z https://contrib.spip.net/Mosaique#comment474952 2014-04-14T16:35:52Z <p>je reprends, parce que, pour moi ça ne fonctionne pas...<br class='autobr' /> bon, je suis débutante spip, donc pas encore familiarisée avec la logique des boucles...</p> <p>je dois noter ?<br class='autobr' /> <BOUCLE_article (ARTICLES) {id_article=#ENV{id}}><br class='autobr' /> <BOUCLE_galleria (DOCUMENTS){extension==jpg|gif|png} {pagination #ENV{pagesize,30}} {mode=#ENV{mode,image}} {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}><br class='autobr' /> ....<br class='autobr' /> </BOUCLE_galleria><br class='autobr' /> </boucle_article></p> <p>ou bien alors ?<br class='autobr' /> <BOUCLE_article (ARTICLES) {id_article=#ENV{id}}></boucle_article><br class='autobr' /> <BOUCLE_galleria (DOCUMENTS){extension==jpg|gif|png} {pagination #ENV{pagesize,30}} {mode=#ENV{mode,image}} {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}><br class='autobr' /> ....<br class='autobr' /> </BOUCLE_galleria></p> <p>j'ai essayé les 2 sans succès...</p> <p>merci de votre aide</p> Mosaïque 2014-02-21T05:33:43Z https://contrib.spip.net/Mosaique#comment473989 2014-02-21T05:33:43Z <p>Mosaique ne traite que les images dans le portfolio.</p> <p>Voici deux astuces pratiques pour faciliter sa mise en oeuvre.</p> <p>Si sur un site existant, vous voulez passer toutes les images précédentes dans le portfolio, voici la requête SQL</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="sql"><code><span class="kw1">UPDATE</span> <span class="st0">`spip_documents`</span> <span class="kw1">SET</span> mode<span class="sy0">=</span><span class="st0">"document"</span> <span class="kw1">WHERE</span> mode<span class="sy0">=</span><span class="st0">"image"</span></code></pre></div> <p>Vous pouvez aussi ajouter dans <strong>mes_options.php</strong>, la ligne suivante qui force l'ajout des documents dans le portfolio</p> <div class='precode'><pre dir='ltr' style='text-align: left;'class="php"><code><a href="http://www.php.net/define"><span class="kw3">define</span></a><span class="br0">&#40;</span><span class="st_h">'_LARGEUR_MODE_IMAGE'</span><span class="sy0">,</span> <span class="nu0">1</span><span class="br0">&#41;</span><span class="sy0">;</span></code></pre></div> Mosaïque 2014-01-07T15:56:59Z https://contrib.spip.net/Mosaique#comment473113 2014-01-07T15:56:59Z <p>Bonjour,</p> <p>Le plug in Mosaïque semble bloquer le bon fonctionnement d'un autre plug in qui sert à scroller le site via des ancres.<br class='autobr' /> (nom du plug in: scrolld.js)<br class='autobr' /> <a href="http://scrolldjs.com/" class='spip_url spip_out auto' rel='nofollow external'>http://scrolldjs.com/</a></p> <p>Une fois Mosaïque activé, les liens du menu qui utilisent ScrollD ne fonctionnent plus.<br class='autobr' /> Je pense qu'il doit y avoir un conflit dans l'execution des scripts jquery.<br class='autobr' /> L'appel du script ScrollD se fait dans le fichier head.html.</p> <p>Avez vous connaissance d'un bug à ce niveau? si vous avez une piste, je suis preneur!</p> <p>Merci pour votre aide!</p> Mosaïque 2014-01-06T15:44:36Z https://contrib.spip.net/Mosaique#comment473074 2014-01-06T15:44:36Z <p>Bonjour,</p> <p>Ça marche parfaitement! Merci pour le coup de main! <br class='autobr' /> Avec cette astuce, l'ordre des images d'un diaporama utilisant le plug in galleria sur spip peut désormais être modifié avec l'interface du plug in mosaïque.</p> <p>Merci!</p> Mosaïque 2013-11-20T23:35:59Z https://contrib.spip.net/Mosaique#comment472329 2013-11-20T23:35:59Z <p>Bonjour,</p> <p>La compatibilité entre ces deux plugins n'étant pas prévue, il faut mettre un peu les mains dans le cambouis. Je ne connais pas le plugin Galleria, mais la manip ne doit pas être très complexe. Dans Galleria, il faut probablement surcharger le squelette <code>modeles/galleria.html</code> pour faire en sorte que la boucle <code>DOCUMENTS</code> prenne l'ordre de la mosaïque (voir partie “<i>Utilisation dans les squelettes</i>” de l'explication ci-dessus).</p> <p>Très vite fait et sans tester, je dirais qu'il faut ajouter</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_article (ARTICLES) {id_article=#ENV{id}}></code></pre></div> <p>au début, puis remplacer le début de la <code>BOUCLE_galleria</code> par :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_galleria (DOCUMENTS){extension==jpg|gif|png} {pagination #ENV{pagesize,30}} {mode=#ENV{mode,image}} {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}></code></pre></div> <p>et ne pas oublier de fermer la <code>BOUCLE_article</code> à la fin.</p> <p>Puis appeler le plugin de façon normale (c'est-à-dire en suivant les explications de la doc de Galleria).</p> Mosaïque 2013-11-20T23:08:59Z https://contrib.spip.net/Mosaique#comment472328 2013-11-20T23:08:59Z <p>Bonjour,<br class='autobr' /> Si la surcharge et les modifs dans le squelette inclus ne fonctionnent pas, c'est peut-être parce que ce n'est pas le bon squelette qui est appelé.<br class='autobr' /> Il faut regarder ça avec var_mode=inclure (voir <a href="http://www.spip.net/fr_article4453.html" class='spip_url spip_out auto' rel='nofollow external'>http://www.spip.net/fr_article4453.html</a>) pour savoir d'où vient la boucle appelée.</p> Mosaïque 2013-11-20T11:01:23Z https://contrib.spip.net/Mosaique#comment472301 2013-11-20T11:01:23Z <p>Bonjour,</p> <p>merci pour ce plug in bien pratique.</p> <p>j'utilise le plug in galeria pour afficher dans un diaporama les images du portfolio d'un article.<br class='autobr' /> Le diaporama affiche correctement les éléments du portfolio. <br class='autobr' /> Cependant l'ordre des images défini à l'aide de votre plug in n'est pas pris en compte. Il continue d'afficher les images par ordre d'inclusion dans l'article.</p> <p>voici un exemple de boucle:</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><div id="diapo3"> <BOUCLE_article(ARTICLES){id_article=12}> <div id="gallery3"> [(#MODELE{galleria}{ordre_mosaique,id_article,lightbox=true}{mode=document})] </div> </BOUCLE_articledate3> </div></code></pre></div> <p>Auriez vous un conseil pour m'aider à résoudre ce problème?<br class='autobr' /> Merci pour votre aide!</p> Mosaïque 2013-11-07T17:27:41Z https://contrib.spip.net/Mosaique#comment472087 2013-11-07T17:27:41Z <p>Bonjour, <br class='autobr' /> j'attends depuis longtemps un tel plugin! Je l'ai donc installé avec tout ce qu'il faut et tout se passe bien dans la partie privée; mais les modifications faites n'apparaissent pas dans la partie publique. L'ordre des images du portfolio reste inchangé... A noter que j'ai pas observé de surcharge dans le fichier 'documents.html' , j'ai donc modifié comme expliqué la boucle 'BOUCLE_documents_portfolio'comme suit:</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_documents_portfolio(DOCUMENTS) {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}}>[ <li><a href="(#URL_DOCUMENT)" type="#MIME_TYPE" onclick="location.href='[(#URL_ARTICLE |url_absolue |parametre_url{id_document,#ID_DOCUMENT} |ancre_url{documents_portfolio} )]';return false;"[ class="(#EXPOSER)"][ title="(#TITRE|attribut_html|couper{80})"]>[(#FICHIER |image_passe_partout{90,90} |image_recadre{90,90} |inserer_attribut{class,spip_logos} |inserer_attribut{alt,[(#TITRE|attribut_html|couper{80})]})]</a></li> ]</BOUCLE_documents_portfolio></code></pre></div> <p>et ça ne change rien.. Est-ce quelqu'un aurait une idée? Je désespère..<br class='autobr' /> version: SPIP 3.0.11 [20757]<br class='autobr' /> Merci d'avance !</p> Mosaïque 2013-10-05T16:49:42Z https://contrib.spip.net/Mosaique#comment471354 2013-10-05T16:49:42Z <p>Bonjour,</p> <p>Non, le plugin n'est pas compatible avec Spip 2.1.x et je n'ai pas prévu d'assurer cette compatibilité. Mais les contributions sont les bienvenues !</p> <p>Sur le deuxième point, je ne comprends pas vraiment l'intérêt de passer par ce plugin pour afficher des images dans un ordre aléatoire. Mosaïque n'est rien de plus qu'une solution pour ordonner les images d'un article dans l'espace privé. Le plugin ne s'occupe pas de la présentation des images sur la partie publique (ou plutôt, il conserve le comportement natif de spip à ce niveau-là). Sa seule utilité est d'établir un ordre (34, 5, 2, 12...).</p> <p>Du coup je comprends mal cette dernière question...</p> Mosaïque 2013-10-03T20:22:21Z https://contrib.spip.net/Mosaique#comment471310 2013-10-03T20:22:21Z <p>Bonjour,</p> <p>Ce plugin marche-t-il avec SPIP 2.1.x ? Sinon, serait-il possible de le rendre compatible ?<br class='autobr' /> Existe-t-il un code pour que la mosaïque s'alimente aléatoirement d'images de tous les articles publiés, qui une fois cliquées renverraient vers les articles d'où elles proviennent ?</p> <p>Merci d'avance</p> Mosaïque 2013-06-28T11:56:35Z https://contrib.spip.net/Mosaique#comment469214 2013-06-28T11:56:35Z <p>le problème venait de la capacité du champ mosaique varchar 255, en passant à 1000 c'est glop ;)<br class='autobr' /> donc pour ceux qui voudraient étendre aux articles, c'est du gateu, merci thom pour le boulot!</p> Mosaïque 2013-06-28T10:07:45Z https://contrib.spip.net/Mosaique#comment469211 2013-06-28T10:07:45Z <p>mon impression c'est que l'enregistrement de la rubrique ne laisse pas le temps de l'injection des id dans le champ hidden..</p> Mosaïque 2013-06-28T07:06:24Z https://contrib.spip.net/Mosaique#comment469205 2013-06-28T07:06:24Z <p>hello, j'essaie d'étendre ce plugin bien sympa aux articles d'une rubrique via un cvt en public.<br class='autobr' /> Je rencontre un problème à l'enregistrement du champ mosaique dans la table rubriques<br class='autobr' /> “un problèmr technique empêche l'enregistrement correct du champ mosaique...”<br class='autobr' /> j'ai ça dans spip_log ..,2274,2277,', ),)<br class='autobr' /> je suppose que c'est ce ,', qui bloque mais je n'arrive pas à m'en débarasser , une idée?<br class='autobr' /> merci, bonne journée, Pierre</p> Mosaïque 2013-01-11T12:22:03Z https://contrib.spip.net/Mosaique#comment464399 2013-01-11T12:22:03Z <p>Voilà, c'est testé et ça marche.<br class='autobr' /> <strong>Merci.</strong></p> Mosaïque 2013-01-11T12:12:34Z https://contrib.spip.net/Mosaique#comment464398 2013-01-11T12:12:34Z <p><strong>Merci pour ce retour rapide.</strong><br class='autobr' /> Je teste dés que possible.</p> Mosaïque 2013-01-11T11:14:06Z https://contrib.spip.net/Mosaique#comment464397 2013-01-11T11:14:06Z <p>Bonjour,</p> <p>Oui, en effet, l'un n'empêche pas l'autre, et c'est normal : c'est pour cela qu'il y a plusieurs modes d'insertion possibles.</p> <p>Si vous utilisez les squelettes par défaut (dist), normalement le portfolio devrait automatiquement prendre l'ordre de la mosaïque. Donc si le portfolio est déjà appelé par vos squelettes (ce qui est le cas dans la dist), placer <code><article2|mosaique></code> dans le texte affichera logiquement un doublon. Effectivement ça peut être gênant quand on veut insérer une mosaïque dans le texte sans avoir de doublon après.</p> <p>Voici une solution qui permet de ne pas afficher le portfolio quand la mosaïque est déjà présente dans le texte. Les modifications sont à faire dans une surcharge du squelette <code>inclure/documents.html</code> :</p> <p>Au tout début (ligne 2), ajouter :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code>[(#INFO_TEXTE*{article,#ENV{id_article}}|match{<article#ENV{id_article}\|mosaique>}|non) #SET{afficher_portfolio,1}]</code></pre></div> <p>Puis remplacer les critères de la <code>BOUCLE_documents_portfolio</code> par :</p> <div class='precode'><pre dir='ltr' style='text-align: left;'><code><BOUCLE_documents_portfolio(DOCUMENTS) {id_article} {id_document IN #MODELE{ordre_mosaique,id_article}|explode{','}} {si #GET{afficher_portfolio}}{doublons}{vu=non}></code></pre></div> <p>Je n'ai pas trop le temps de m'en occuper en ce moment, mais ce sera ajouté dans la prochaine version du plugin.</p> <p>Merci pour ce retour !</p> Mosaïque 2013-01-11T08:58:06Z https://contrib.spip.net/Mosaique#comment464387 2013-01-11T08:58:06Z <p>Bonjour,<br class='autobr' /> Tout d'abord, merci pour ce plugin.<br class='autobr' /> J'ai toutefois 2 affichages avec le code <br class='autobr' /> <code><article2|mosaique></code></p> <p>- la mosaïque ordonnée par mes soins... et <br />- mon portfolio habituel en dessous.<br class='autobr' /> J'ai bien sur réussi à supprimer la visibilité du portfolio (plugin Compositions) mais existe t il un moyen d'éviter d'en passer par ce stratagème?<br class='autobr' /> Quel code placer dans la rédaction de l'article 2 pour faire apparaitre ma mosaïque?<br class='autobr' /> <strong>Merci.</strong></p> Mosaïque 2013-01-03T15:16:43Z https://contrib.spip.net/Mosaique#comment464208 2013-01-03T15:16:43Z <p>Non, et ça fait partie des améliorations de l'ergonomie prévues ;)<br class='autobr' /> À l'heure actuelle il reste possible (et pas très difficile) de changer ça dans les squelettes concernés de plugins-dist/media/ pour que l'ordre soit pris en compte dans le privé.<br class='autobr' /> Merci pour vos retours !</p> Mosaïque 2013-01-03T14:38:39Z https://contrib.spip.net/Mosaique#comment464207 2013-01-03T14:38:39Z <p>Au temps ou autant pour moi, extraordinaire !</p> <p>Merci pour ce travail, c'est un gain de temps énorme.</p> <p>PS : dans l'espace privé, les images ne s'affichent pas par ordre mosaïque ?</p> Mosaïque 2013-01-03T13:25:31Z https://contrib.spip.net/Mosaique#comment464205 2013-01-03T13:25:31Z <p>Bonjour,</p> <p>En fait, le lien « Trier les images du portfolio » doit normalement s'afficher sur la page d'édition de l'article où se trouve le formulaire d'édition du texte, etc. (et non sur la page de résumé des infos). Sur votre copie d'écran, il faut donc cliquer sur le bouton « Modifier cet article » en haut à droite pour y avoir accès.</p> <p>J'avoue que ce n'est pas forcément le chemin le plus intuitif. Il y a deux ou trois petits détails ergonomiques qui mériteraient d'être améliorés dans ce plugin. Peut-être pour une prochaine révision...</p> <p>En attendant j'ai mis la doc à jour pour qu'elle soit plus explicite.</p> Mosaïque 2013-01-03T00:51:38Z https://contrib.spip.net/Mosaique#comment464195 2013-01-03T00:51:38Z <p>Bonjour,</p> <p>Excellente idée de plugin !</p> <p>Je viens de l'installer sur un SPIP 3.05 et rien ne s'affiche, quelle déception, j'ai 100 photos à ordonner ...</p> <p>- J'ai désactivé tous les plugins (sauf les dépendances à Mosaique), et rien n'y fait. <br />- Le champ “mosaique” a bien été crée dans la table article. <br />- Les documents sont bien activés sur les articles, j'ai un bouton en bas “Ajouter un document”, mais pas de bloc “Ajouter un document ou une image” à gauche, <strong>ni de bloc Mosaique</strong></p> <p>Une idée de la cause de cette déchirante absence ?</p> Mosaïque 2012-10-13T17:31:18Z https://contrib.spip.net/Mosaique#comment462186 2012-10-13T17:31:18Z <p>Oui, l'idée est à peu près ça. Plus précisément, le plugin permet d'ordonner les <i>images</i> du portfolio (petite nuance).</p> <p>Contrairement à l'ordre traditionnel par le <code>num titre</code>, l'ordre des images est ici propre à chaque article. Par exemple, on peut avoir :</p> <p>article 1 > img1, img2, img3<br class='autobr' /> article 2 > img2, img3, img1</p> <p>Du coup le code <code><articleN|mosaique></code> retoune la mosaïque de l'article N (c'est-à-dire les images du portfolio de l'article N, dans l'ordre établi par glisser-déposer sur la page dudit article et présentées sous forme de mosaïque), quel que soit le contexte d'utilisation.</p> Mosaïque 2012-10-13T17:15:07Z https://contrib.spip.net/Mosaique#comment462185 2012-10-13T17:15:07Z <p>Bonjour,</p> <p>Je crois que j'ai fait une confusion entre album / diaporama et la possibilité offerte par votre plugin.</p> <blockquote class="spip"> <p> Dans l'idée, la mosaïque n'est pas un groupement d'images distinct du portfolio (ce que sont, par exemple, les albums), mais un ordre appliqué aux images du portfolio.</p> </blockquote> <p>Je pense avoir compris le principe : on peut réorganiser l'ordre de TOUS les documents joints - ou tout au moins inclus dans le portfolio - plus facilement. Ce qui m'a mise sur une mauvaise voie, c'est le code <code><articleN|mosaique></code> : ce code serait alors plutôt applicable à un article différent de N ? ???</p> <p>Merci pour votre contribution et votre réponse,<br class='autobr' /> Cordialement,<br class='autobr' /> KMk</p> Mosaïque 2012-10-13T15:17:46Z https://contrib.spip.net/Mosaique#comment462182 2012-10-13T15:17:46Z <p>Bonjour,</p> <p>Je ne suis pas sûr de bien comprendre la question...</p> <p>Dans l'idée, la mosaïque n'est pas un groupement d'images distinct du portfolio (ce que sont, par exemple, <a href="http://contrib.spip.net/Albums-v2-DEV" class='spip_out' rel='external'>les albums</a>), mais un ordre appliqué aux images du portfolio. Autrement dit, toutes les images du portfolio apparaissent dans la mosaïque.</p> <p><i>«Y a-t-il un moyen d'adapter de sorte que si une image est incluse dans une mosaïque, elle n'apparaisse pas dans le portfolio ?»</i></p> <p>==> De fait, ça reviendrait à ne pas du tout afficher les images du portfolio, puisqu'elles sont toutes dans la mosaïque. Or ça me semble délicat, dans la mesure où si elles ne sont plus affichées, impossible de les sortir du portfolio... et donc de la mosaïque !</p> <p>Ou alors je vous ai mal compris...</p> Mosaïque 2012-10-13T09:04:52Z https://contrib.spip.net/Mosaique#comment462170 2012-10-13T09:04:52Z <p>Bonjour,</p> <p>Très bonne idée de pouvoir organiser les images de façon graphique dans l'interface privée et les insérer dans l'article là où on le désire...</p> <p><strong>Petite question</strong> : comme les images doivent être présentes dans le portfolio, il y a une redondance «image de la mosaïque dans l'article / image dans le portfolio»... Moi, cela ne me gêne pas, je peux «bidouiller» ; mais je suis en train de construire un site pour quelqu'un qui n'est pas familier avec spip...</p> <p>Y a-t-il un moyen d'adapter de sorte que si une image est incluse dans une mosaïque, elle n'apparaisse pas dans le portfolio ?</p> <p>En tout cas, merci pour cette fonctionnalité que je mets de côté pour d'autres occasions !</p> <p>KMk.</p> Mosaïque 2012-09-21T13:24:22Z https://contrib.spip.net/Mosaique#comment461413 2012-09-21T13:24:22Z <p>Tout à fait, cela étant j'ai du installer YAML “manuellement” car son absence bloquait l'affichage complet des articles dans l'admin.</p> Mosaïque 2012-09-21T13:21:15Z https://contrib.spip.net/Mosaique#comment461412 2012-09-21T13:21:15Z <p>Bonjour,</p> <p>Cette page me dit quelque chose, j'avais déjà dû tomber dessus auparavant.</p> <p>Je viens de télécharger la version dev d'Albums V2 et (vu de loin) il semble que ce ne serait pas trop compliqué d'ajouter la gestion des albums à une future révision du plugin mosaïque. C'est peut-être plus simple dans ce sens là pour commencer, non ?</p> Mosaïque 2012-09-21T13:16:04Z https://contrib.spip.net/Mosaique#comment461411 2012-09-21T13:16:04Z <p>Bonjour,</p> <p>Sauf erreur de ma part (?), c'est l'interface des champs extra qui nécessite yaml. Or c'est l'API de champs extra qu'on utilise ici.</p> <p>Sinon, le plugin est en phase de test (je croise les doigts pour qu'aucun bug monstrueux ne se manifeste...), et tous les retours sont bienvenus !</p> Mosaïque 2012-09-21T10:59:37Z https://contrib.spip.net/Mosaique#comment461408 2012-09-21T10:59:37Z <p>Bonjour,<br class='autobr' /> Bonne idée, ce plugin, il faut que je teste au plus vite !<br class='autobr' /> Concernant le plugin albums, je sais pas si tu as vu, il est en développement ici : <a href="http://contrib.spip.net/Albums-v2-DEV" class='spip_out' rel='external'>http://contrib.spip.net/Albums-v2-DEV</a><br class='manualbr' />Il faudra que je regarde comment y intégrer ta contribution, pour l'instant je manque un peu de temps et il y a d'autres choses à finaliser avant, mais n'hésite pas à commiter.</p> Mosaïque 2012-09-21T10:27:21Z https://contrib.spip.net/Mosaique#comment461406 2012-09-21T10:27:21Z <p>Super !!!<br class='autobr' /> Ça fonctionne dans l'admin.<br class='autobr' /> Dans les dépendances requises mais non installée il faut ajouter YAML (mais qui n'est pas une dépendance directe)</p> <p>Je ferai un test en production dans quelque temps, pour le moment pas de soucis avec un spip 3.05</p>