z-editor : édition HTML en WYSIWYG

All contributions published for previous SPIP versions

Les utilisateurs peu accoutumés à l’informatique sont parfois rebutés par l’insertion de code pour la mise en forme, même si le système est simple.
Spip permet d’insérer du texte en HTML, ce petit add-on va vous permettre d’éditer le texte HTML en WYSIWYG.

z-editor est un petit add-on qui vous offre un outil visuel de saisie de texte, avec conversion en HTML et transfert dans Spip.

Attention ! cet outil ne fonctionne que sur plate-forme Windows avec Microsoft Explorer 5.0 ou supérieur.

Cela limite bien évidement la portée d’un tel outil. A ce propos, juste trois remarques :

-  Cet outil a été développé initialement pour être utilisé dans un intranet, composé à 100% d’un parc Windows/Explorer ;
-  Z-editor est un outil complémentaire, facultatif. Laissons-donc le choix à l’utilisateur !
-  L’utilisation du HTML existe d’origine dans Spip, cet outil permet seulement d’en simplifier l’usage.

Divers :

-  La dernière version, ainsi que les instructions, sont disponibles ici.
-  Si vous désirez tester le système, connectez-vous ici : et utilisez le user et le password z-editor. Créez un article et en dessus de la rubrique Texte, cliquez sur utiliser z-editor pour mettre en forme votre texte.

Installation :

en 3 clics et 3 minutes :

  1. Créez un sous répertoire /inline_editor/ dans votre site, par /spip/inline_editor/ ;
  2. Décompressez l’archive dans le sous-répertoire créé (cela va copier tous les fichiers nécessaires et créer un nouveau sous-répertoire) ;
  3. Editez le fichier /ecrire/articles_edit.php de spip, pour y apporter les 3 modifications décrites dans le fichier MODIFICATIONS.RTF.

Note des admins : Attention z-editor modifie le code source de SPIP en ajoutant une fonctionalite. N’oubliez pas il ne fonctionne qu’avec Internet Explorer.
Et comme dit l’auteur : Je pense que les webmasters qui veulent offrir ce style d’outil aux utilisateurs ne trouveront pas trop de problèmes à faire ces corrections et les reporter dans les prochaines versions.

Discussion

22 discussions

  • 1

    Je retombe souvent sur cet article et je me pose bcp de questions :
    -  Pourquoi ne se situe t’il pas dans la rubrique Bidouilles>Editeurs WYSIWYG ?
    -  Pourquoi les liens ne mènent plus vers ce sujet ?
    -  Pourquoi s’obstiner à promouvoir cet éditeur en ligne compatible uniquement avec IE ?

    Il existe d’autres éditeurs en ligne compatible avec d’autres navigateurs tels FireFox ou Safari.
    Ils font l’objet d’articles bcp plus récents dans la bonne rubrique.
    Ils proposent plus de fonctionnalités.

    J’ai pour ma part mis en oeuvre successivement KTML, HTMLAREA, FCKeditor puis finalement TinyMCE.
    J’en suis très content car j’estime qu’on ne peut pas imposer aux autres ce qu’on n’a pas envie d’utiliser soi-même, je parle des raccourcies typographiques de SPIP.

    Ces raccourcis étaient un bon paliatif au manque d’éditeur en ligne à l’origine.
    Depuis, la technique évolue et, utilisateur de SPIP depuis 2004, il me semble qu’il faut aussi faire évoluer SPIP dans le bon sens sinon il va perdre en intérêt.

    Je me suis mis depuis peu à utiliser WordPress. Il propose de base TinyMCE comme éditeur.
    Pourquoi SPIP ne le proposerait-il pas au moins en option ?

    • TinyMce m’interesse beaucoup.

      Tu pourrais détailler un peu l’installation dans spip pour le mettre dans la partie privée?

      J’ai vu aucune doc a ce sujet, pas même dans le forum de tiny.

      Merci d’avance

    Reply to this message

  • 3
    Loulou

    Je viens de mettre à jour mon site avec la version 1.8.1. Est-ce que je peux utiliser z-editor sans problème?

    • ca fonctionne avec Spip 1.8.1. Les numéros de ligne changes dans les modifications à apporter dans ’articles_edit.php’ : La ligne 282 à remplacer est en fait la ligne 333 dans la version Spip 1.8

      Je n’ai pas vu l’utilité de remplacer la ligne 409

      L’ajout de la ligne 411 s’effectue maintenant à la ligne 477.

    • Marc, tu sembles être parvenu à le faire fonctionner avec Spip 1.8.1 mais ton message est bien le seul que je trouve sur ce point. J’ai essayé de faire les modifs que tu indiques mais hélas ce que je trouve aux N° de lignes que tu indiques ne colle pas avec ce qu’on devrait y trouver apparemment.
      Ne pourrais-tu pas uploader tes fichiers modifiés pour nous simplifier la tâche stp ?
      Merci

    • Salut,

      je découvre SPIP et je viens de tenter d’installer zEditor ça marche super,
      J’ai cpdt du mettre les corrections suivantes:
      ligne 282---> 386
      ligne 411---> 488

      Merci CGan et pi pour une fois que je comprends qq chos!

      Salut@

    Reply to this message

  • Moi j’ai un probleme
    En faite les textes sont préparé sur word, puis copier coller dans z-editor.
    Seulement voila, il me genere des erreurs
    <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>
    _ Visible dans le rendu
    Il faut donc que j'aille moi meme les virer a la main apres le travail des redacteurs
    Un peu chiant quand meme !!!

    Reply to this message

  • 6
    LAURENT Stephane

    Salut à tous,
    Ayant besoin d’un editeur WYSIWYG pour mes rubriques, je me suis lancé dans l’adaptation de produits existants.
    z-editor manquait de certaines fonctionnalités alors j’ai cherché un peu et ... FCKEditor !
    Frederico Caldeira Knabben a fait un travail fabuleux !
    Je l’ai integré en 3mn, ca passe plutot bien.
    OK, c’est pas adapté pour les articles, mais ca rend bien des services sur les rubriques.
    Je ne sais pas si il faut que je poste une contrib.
    A votre avis ?

    • je cherche un éditeur qui permette un peu de faire du “frontepage sur spip” si ton editeur marche, j’aimerai bien savoir comment cela s’installe
      merci

    • euh... est-ce que tu pourais m’expliquer comment tu a fais pour intégrer FCKEditor? (moi j’ai juste réussi un bricolage avec du copier-coller...)

    • Salut Stéphane,

      En effet je serais curieux de savoir comment tu as fait. Pour l’instant je teste z-editor (qui est très bien) mais FCKEditor parait pas mal aussi. As-tu mis la possibilité de charger des images directement depuis l’éditeur ?

      Amicalement.

    • La reponse a ete donne plus bas
      En tout cas voici la solution qui est identique a ZEditor
      http://spip-edu.edres74.net/article.php3 ?id_article=120

    • DUCREUX Alexandre

      Attention quand même avec FCK Editor pour la fusion verticale de cellules.

    • j’ai essayé, et ça marche très bien (sous IE...).
      Le problème, c’est que cela bloque la barre de raccourcis typographiques integrée a SPIP (je suis sous la 1.7.2).
      Comment faire pour les faire cohabiter ?

    Reply to this message

  • stéphane

    A voir : la tentative élégante de Lyfoung théoriquement fonctionnel avec IE et Mozilla/Firefox...

    Reply to this message

  • 2

    Ben moi j’au du faire un truc qui fallait pas, tout est bien installé apparament, mais je ne peux pas entrer de texte dans Z-Editor :-/
    çà vient de quoi ?
    vs faite pas de souci j’ai tjrs des truc à la c** !!

    • quelle est ta plate-forme ? PC avec IE ? versions ?

    • Je rencontre le même problème.
      ma config : IE6/win XP, spip 1.7

      Savez-vous d’où cela peut venir ?

    Reply to this message

  • 2

    La version 1.6 de spip est-elle la même que la version 1-6b2 ? Z-editor fonctionne sur 1-6b2 mais ne semble pas fonctionner sur 1-6 en téléchargement sur spip ?? Ou bien est-ce un pb de chemin d’accès; chez mon hébergeur je n’ai pas de répertoire spip mais simplement WWW ??
    Désolé, mes questions sont peut-être naîves! Mais pour mon école j’ai besoin à la fois de la version 1-6 et d’un éditeur de texte.

    • spip ça pu sa mère c pour les nb

    • quel courage! tant qu’a ne pas aimer quelque chose, autant dire pourquoi et en assumer les cosnéquences... ça me tue ça
      :-(

    Reply to this message

  • 2

    Une autre alternative sous GPL
    FCKeditor

    Reply to this message

  • test_agora

    Est-il possible d’ajouter cet éditeur également sur Agora??

    Merci.

    Reply to this message

  • Bonjour !

    J’ai installé Z-editor dns spip 1.6 mais lorsque je clique sur “Z-editor pour mettre en forme votre texte”, l’hébergeur répond que le fichier n’existe pas or quand je clique sur ce lien je peux lire http://monsite/ecrire/articles_edit.php3?new=oui&var_lang=fr#.

    Quelle est mon erreur ? Merci !

    Reply to this message

Add a comment

Avant de faire part d’un problème sur un plugin X, merci de lire ce qui suit :

  • Désactiver tous les plugins que vous ne voulez pas tester afin de vous assurer que le bug vient bien du plugin X. Cela vous évitera d’écrire sur le forum d’une contribution qui n’est finalement pas en cause.
  • Cherchez et notez les numéros de version de tout ce qui est en place au moment du test :
    • version de SPIP, en bas de la partie privée
    • version du plugin testé et des éventuels plugins nécessités
    • version de PHP (exec=info en partie privée)
    • version de MySQL / SQLite / PostgreSQL
  • Si votre problème concerne la partie publique de votre site, donnez une URL où le bug est visible, pour que les gens puissent voir par eux-mêmes.
  • En cas de page blanche, merci d’activer l’affichage des erreurs, et d’indiquer ensuite l’erreur qui apparait.

Merci d’avance pour les personnes qui vous aideront !

Par ailleurs, n’oubliez pas que les contributeurs et contributrices ont une vie en dehors de SPIP.

Who are you?
[Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document

Follow the comments: RSS 2.0 | Atom