SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano

278 Plugins, 195 contribs sur SPIP-Zone, 90 visiteurs en ce moment

Accueil > Vie de SPIP et autour de SPIP > SPIP-core > Spip 2.1 est sorti

Spip 2.1 est sorti

10 avril 2010 – par L’équipe de SPIP-Contrib – 87 commentaires

50 votes

Nous avions envisagé de la sortir le 14 février ...

Nous avions également envisagé de la sortir le 1er avril ...

Elle sort finalement aujourd’hui, ce jour exceptionnellement ordinaire
qui est le 100e jour de l’année.

Cette version est téléchargeable depuis l’adresse habituelle
http://www.spip.net/fr_download

Pour savoir ce que contient cette version, rendez vous sur l’article
de spip.net concocté
spécialement pour cette nouvelle série 2.1 :
http://www.spip.net/fr_article4728.html

P.-S.

Une version 2.0.11 de maintenance sortira sous peu si vous
voulez rester dans la série 2.0

Une rencontre SPIP est prévue du 13 au 16 mai, tous les détails
sont ici http://spip-party.net/Troglo-2010 , n’hésitez pas à vous
inscrire !

Retour en haut de la page

Tout afficher

Vos commentaires

  • Le 6 avril 2011 à 13:45, par josephtux En réponse à : Spip 2.1 est sorti

    Bonjour

    Le problème s’est auto-réparé avec le temps !
    Pourtant, j’avais bien vidé les caches avant les mises à niveau, et ( cru faire ? ) fait de même avec mes navigateurs ( iceweasel/firefox 3.5 et chromium 6.0 sur Debian 6 )

    Le problème est donc résolu, mais l’explication me manque toujours..

    Encore merci à tous les auteurs et contributeurs de SPIP

    Répondre à ce message

  • Le 25 mars 2011 à 18:39, par josephtux En réponse à : Spip 2.1 est sorti

    Bonjour,

    je viens de mettre à jour SPIP selon la recommandation suivante : ( via le spip_loader.php du jour )

    de Ben. <ben@rezo.net>
    à spip-ann@rezo.net
    date 25 mars 2011 17:24
    objet [Spip-Ann] SPIP 2.1.9
    liste de diffusion spip-ann.rezo.net

    et depuis je ne peux plus me logger pour accéder à l’espace privé : !@Z !!

    le formulaire d’identification s’affiche mais ne reconnaît plus mon mot de passe ;
    je suis donc passer par la procédure « mot de passe oublié », qui me fournit un courriel avec un lien : ce lien me renvoie la page vide avec le message suivant :

    Fatal error : Cannot redeclare balise_config() (previously declared in /homepages/18/d144218061/htdocs/wsb3919082801/spip/plugins/auto/spip-bonux/configurer/pipelines.php:296) in /homepages/18/d144218061/htdocs/wsb3919082801/spip/plugins/auto/cfg/cfg_fonctions.php on line 17

    J’ai refait la mise à jour via ftp, sans résultat ( lien sur spip.zip du jour : 2.1 )


    Ce problème se pose pour 2 sites, à un moment différent de la procédure :

    Dans le 1er site, l’installeur me demande une authentification ftp en créant un répertoire (nommé précisément ) sous tmp/, et semble avoir réussi.
    Dans le 2e site, l’installeur ne pose pas cette question, mais affiche le formulaire d’authentification ( et bloque donc à ce stade ).
    J’ai donc vérifié sur le 1er site : l’accès à l’espace privé n’est pas plus possible !

    AU SECOURS ( dans un grand cri de douleur et un sentiment de panique ! )

    Répondre à ce message

  • Le 15 décembre 2010 à 13:56, par rodolphe En réponse à : Spip 2.1 est sorti

    Bonjour,

    Depuis que je suis passé à spip 2.1.2 je ne peux plus télécharger les fichiers joints à mes articles, ni les images... Par contre cela fonctionne dans la partie privée...

    Voici une page de mon site pour exemple dans laquelle il est impossible de télécharger le fichier bulletin d’adhésion :

    http://raptorsangers.fr/spip.php?article5

    Quelqu’un a t’il une solution ?

    Merci

    • Le 16 décembre 2010 à 11:52, par rodolphe En réponse à : Spip 2.1 est sorti

      J’ai réinstallé mon site en local, et là ça fonctionne par contre je n’ai plus les vignettes dans la partie administrative...

      Voici une copie écran de l’erreur que j’ai sur le site en ligne...

      Merci

      JPEG - 563.7 ko

    Répondre à ce message

  • Le 2 août 2010 à 13:17, par PK En réponse à : Spip 2.1 est sorti

    Bonjour,

    Je viens de réaliser une mise-à jour de SPIP 2.0 à SPIP 2.1.1 sur trois sites différentes, non mutualisés, mais hébergés sur le même serveur.

    Un des trois sites ne reconnaît plus mes identifiants login/passwd. Les deux autres ne posent pas de problèmes/.

    J’accède néanmoins au site problématique si je fais une demande de récupération de mot de passe. je reçois le lien magique par email et je me rends à la page qui me permet de définir un nouveau mot de passe.
    J’entre le mot de passe, puis je me connecte à l’espace privé en retapant le même mot de passe. À la première connexion, tout fonctionne parfaitement.

    Dès que je me déconnecte et tente de me reconnecter avec le même mot de passe, je reçois un message indiquant que le mot de passe est erroné.

    Idem si je change le mot de passe d’un utilisateur et tente de me connecter avec le nouveau couple login/mot de passe.

    J’ai appliqué cette procédure plusieurs fois.

    1. Est-il possible que ce problème soit lié à la mise en place de sha256 sur les mots de passe et actions ?
    2. Quelles informations puis-je vous fournir pour déterminer l’origine du problème ?
    3. Y a-t-il un endroit plus adapté pour poster ces informations ?

    Merci d’avance pour toute aide et suggestions.

    Pascal

    • Le 2 août 2010 à 13:25, par Cedric Morin En réponse à : Spip 2.1 est sorti

      Est-ce que tes mots de passes contiennent des caractères accentués ?
      Est-ce que le site qui pose problème contient un formulaire de login personalisé ?

    • Le 2 août 2010 à 14:14, par PK En réponse à : Spip 2.1 est sorti

      Bonjour,

      Merci pour cette réponse rapide.

      Le site ne contient pas de formulaire de login personnalisé.

      En outre, j’ai testé avec différents mots de passe. Pour tester les problèmes d’accents, j’ai pris comme mot de passe 123456789, mais sans succès.

      Ce qui m’étonne, c’est la différence de comportement entre la première fois que je me connecte et la seconde.

    • Le 2 août 2010 à 14:23, par PK En réponse à : Spip 2.1 est sorti

      Re-bonjour,

      Je viens de mettre à jour tous les plugins et de redécompresser l’archive de spip 2.1.1.

      Le site fonctionne correctement maintenant.

      Désolé pour le dérangement.

      Pascal

    Répondre à ce message

  • Le 13 juillet 2010 à 08:41, par baptiste En réponse à : Spip 2.1 est sorti

    Bonjour,

    j’ai un soucis depuis la migration d’un Spip en 2.1. J’inclue un fichier PHP dans un squelette SPIP avec la syntaxe suivante :

    Avant d’être en 2.1, je pouvais dans mon fichier PHP, récupérer les paramètres passés dans la boucle inclure via la variable « $contexte_inclus », par exemple « $param = $contexte_inclus[’param’] ; »

    Or cela ne fonctionne plus, avez-vous une explication ?

    Merci d’avance !

    Répondre à ce message

  • Le 10 avril 2010 à 10:38, par Louis En réponse à : Spip 2.1 est sorti

    Bonjour, j’ai également pas mal de soucis de compatibilité avec la 2.1.
    Mon navigateur ne trouve plus le plugin Flash, par exemple, alors que je lis du Flash sur d’autres sites... avec le plugin XSPF. Pour le moins étrange... Jusque là, j’avais passé tous les update. Mais voilà, avec la 2.1, firefox ou IE me demande d’installer le plugin Flash, pourtant déjà en place et remis à jour...

    J’ai quelques messages d’erreur de code SPIP à propos de filtre alors que les lignes incriminées qu’ils ne varient pas de la dist... du coup, je vois pas ce que je peux faire pour déboguer...

    Sinon, bravo pour l’amélioration de la barre typo... Beaucoup plus mieux !!!
    Et je n’ai pas tout découvert... alors à bientôt...

    • Le 10 avril 2010 à 10:46, par Maïeul En réponse à : Spip 2.1 est sorti


      Mon navigateur ne trouve plus le plugin Flash, par exemple, alors que je lis du Flash sur d’autres sites... avec le plugin XSPF

      pas compris, c’est un plugin SPIP ? tu a vérifié la mise à jour. Si c’est un plugin firefox, ben ca n’a rien à voir


      J’ai quelques messages d’erreur de code SPIP à propos de filtre alors que les lignes incriminées qu’ils ne varient pas de la dist... du coup, je vois pas ce que je peux faire pour déboguer...


      on peut t’aider si tu donne les erreurs :)

    • Le 10 avril 2010 à 11:26, par Louis En réponse à : Spip 2.1 est sorti

      Le plugin XSPF est bien un plugin SPIP, On en parle ici dans spip contrib : http://www.spip-contrib.net/Comment-ajouter-des-videos-dans
      Et on le trouve là : http://kent1.sklunk.net/spip.php?article96
      Je le trouve personnellement assez réussi, malgré qu’il ne soit pas distribué dans spip-contrib... dommage. Il regroupe un jpg rotator, un lecteur mp3 et un lecteur flv...

      Les messages d’erreurs apparaissent uniquement quand je suis connecté et n’ont pas encore d’incidence notable sur le fonctionnement du site mais je vais suivre ça de près et je remonte les infos au fur et à mesure...

      Merci de ta réponse giga-rapide...

    • Le 23 avril 2010 à 13:00, par Louis En réponse à : Spip 2.1 est sorti

      Désolé de répondre un peu tardivement, mais en fait tout fonctionne bien après un vidage du cache par SPIP lui même...

      Donc le trop méconnu plugin xspf fonctionne bien sous spip2.1...

      Merci et encore bravo !!!

    • Le 14 mai 2010 à 22:54, par KMK En réponse à : Spip 2.1 est sorti

      Bonjour, Louis,

      Comme vous, j’utilisais le plugin xspf notamment le rotator. De mon côté, j’ai toujours le message d’erreur « Get the flash player »... qui y est, pourtant.

      Avez-vous une idée de la façon dont le problème s’est réglé sur votre site ?

      Merci pour cette éventuelle lueur.

      Cordialement,
      KMk.

    • Le 15 mai 2010 à 19:23, par Louis En réponse à : Spip 2.1 est sorti

      et bien non... mais beaucoup de choses se sont résolus après une réinstall de tous les plugins, y compris le xspf et les dernières versions de spip bonux... ensuite vidage du cache... et c’est reparti. Le cache est un peu réticent à se vider parfois.

      En tout cas c’est reparti sans que je touche une ligne de programme. Donc j’en conclu que ça peut marcher partout.

      Bon courage !
      Louis

    Répondre à ce message

  • Le 15 mai 2010 à 14:47, par Mathis En réponse à : Spip 2.1 est sorti

    Je viens de créer un site avec SPIP 2.1 tout semble bien fonctionner en dehors d’un petit bémol : la barre typo ne s’affiche pas lors de la rédaction (ou la modification) d’un article

    Merci de votre aide

    PS : sur le même micro ordinateur, je gère un autre site qui fonctionne avec SPIP 2.0.9 et la je n’ai pas ce problème

    Répondre à ce message

  • Le 14 mai 2010 à 16:50, par seds En réponse à : Spip 2.1 est sorti

    bonjour

    pas de gestion des forums publics sur l’accès privé ?

    sur SPIP 2.0.3 [13596] tout va bien mais sur SPIP 2.1.0 [15604], nada !

    je vais devoir revenir sur la version précédente s’il n’y a pas de mise à jour

    c’est très très ennuyeux...

    Répondre à ce message

  • Le 16 avril 2010 à 19:23, par Lisa En réponse à : Spip 2.1 est sorti

    bonjour,
    J’ai comme un problème : depuis la mise à jour, je n’ai plus accès à aucun document joint des articles.
    J’ai un message

    Forbidden

    You don’t have permission to access /IMG/... (doc, pdf...)

    Quand j’ai fait la mise à jour, j’ai copié les fichiers sur le site, mais spip ne m’a pas demandé l’accès ftp comme indiqué dans le « mode d’emploi »

    Merci de votre aide

    • Le 21 avril 2010 à 09:22, par yodea En réponse à : Spip 2.1 est sorti

      même problème

      don’t have permission to access /IMG/ ....

    • Le 21 avril 2010 à 10:34, par nico4peace En réponse à : Spip 2.1 est sorti

      +1

      Problème de permission.

    • Le 21 avril 2010 à 10:49, par yodea En réponse à : Spip 2.1 est sorti

      Je n’ai toujours pas accès à :
      http://www.dorvador.org/IMG/jpg/hotels-de-ville-saint-antoine-l-abbaye-france.jpg

      J’ai pourtant chmodé les dossiers contenu par IMG 777 et les fichiers en 666 par filezilla pourtant rien n’y fait.

    • Le 2 mai 2010 à 09:55, par yodea En réponse à : Spip 2.1 est sorti

      Bonjour,

      Quelqu’un a t-il une solution a ce problème de permission ?

    • Le 14 mai 2010 à 11:58, par deor En réponse à : Spip 2.1 est sorti

      Le soucis ne vient peut-être pas des droits sur les répertoires :

      • Si vous essayez d’accéder à site.com/IMG, il vous balance une erreur 403, tout à fait normale, puisque le listing du répertoire est protégé par le .htaccess (pour vérifier, essayez d’accéder à une image en particulier, du style http://site.com/IMG/rubon1.jpg , si ça ne fonctionne pas, c’est bien un problème de droits)
      • Le soucis que j’ai eu, par contre, c’est que la table spip_types_documents avait été vidée (passage 2.0.10 à 2.1.0), n’autorisant alors plus l’upload d’aucun document et, bizarrement, n’affichant plus aucun document joint (il doit y avoir un contrôle sur cette table). Si vous reprenez le contenu de votre ancienne version (car vous avez bien sûr fait une sauvegarde ;) )et que vous le remettez dans la table, ça devrait résoudre le problème. NB : le vidage de cet table semble aléatoire : j’ai fait deux migrations du même site, dans les mêmes conditions, pas de soucis pour la première, par contre, vidage de cette table pour la seconde...

    Répondre à ce message

  • Le 25 avril 2010 à 17:56, par Paulo En réponse à : Spip 2.1 est sorti

    Bonjour,
    Et le bug dans sitemap.xml.html, évoqué ici et là ?
    Pour mémoire : l’URL [URL_SITE_SPIP]/sitemap.xml produit ce message :

    Erreur d’analyse XML : instruction de traitement XML ou texte pas au début d’une entité externe
    Emplacement : http://localhost/soriano/spip.php?page=sitemap.xml
    Numéro de ligne 4, Colonne 1 : <?xml version="1.0" encoding="UTF-8"?>
    ^

    Toute contribution serait la bienvenue. Merci d’avance.

    • Le 13 mai 2010 à 15:27, par majoux En réponse à : Spip 2.1 est sorti

      J’ai le même problème, si quelqu’un pouvait se pencher dessus, le xml c’est pas mon dada !

    • Le 14 mai 2010 à 09:11, par majoux En réponse à : Spip 2.1 est sorti

      -  Le sitemap de Spip 2.1 est lu correctement par Google et par IE 8 . Par contre Firefox ne l’affiche pas car il contient une erreur.
      -  Après analyse sur le site w3c, il détecte un warning comme quoi il manque le DOCTYPE :

      Warning No DOCTYPE found ! Checking XML syntax only.


      -  Il detecte surtout une erreur :

      Error Line 3, Column 5 : XML declaration allowed only at the start of the document
      <?xml version="1.0" encoding="UTF-8"?>

      Pour tout test, utiliser mon sitemap :
      http://blogduroux.free.fr/spip.php?page=sitemap.xml

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Agenda 2.0

    3 novembre 2008 – 923 commentaires

    Voici la version pour SPIP 2.0 du Plugin Agenda pour SPIP 1.9.2, avec une interface remaniée pour encore plus de plaisir. Pour une documentation concernant l’utilisation d’Agenda 3 pour SPIP 3, veuillez pour l’instant vous référer à SPIP 3, Agenda (...)

  • Mosaïque

    21 septembre 2012 – 31 commentaires

    Ce plugin permet d’organiser les images du portfolio par simple glisser-déposer des vignettes d’une mosaïque accessible depuis la page d’édition de l’article. Dépendances Ce plugin nécessite les plugins Champs extra et Saisies pour fonctionner. (...)

  • elFinder

    1er avril – commentaires

    Ce plugin permet de parcourir l’arborescence de son site SPIP grâce au gestionnaire de fichiers Elfinder. Principe Ce plugin permet aux administrateurs de parcourir l’arborescence d’un site SPIP à travers un outil ressemblant à un gestionnaire de (...)

  • Critère {mots}

    6 août 2009 – 251 commentaires

    Permettre de sélectionner facilement des objets SPIP ayant un ou des mots clefs en communs.

  • Fulltext

    14 mars 2009 – 168 commentaires

    Ce plugin permet d’une part d’exploiter le mode de recherche FULLTEXT de MySQL et d’améliorer ainsi énormément les recherches par rapport au fonctionnement natif de SPIP, et d’autre part d’indexer le contenu de certains (...)