Plugin Jolie Recherche

Un plugin qui remplace le formulaire recherche par de jolie boîte de saisie.

Installation

Télécharger ce plugin

L’installer selon la méthode habituelle

Utilisation

Une fois le plugin activé, tous vos #FORMULAIRE_RECHERCHE ressembleront à ça :

Un bouton de validation du formulaire sous forme d’image apparaît à droite, ce qui laisse 2 façons de lancer la recherche : la touche entrée ou le clic sur le bouton.

Discussion

8 discussions

  • 3

    Ce plugin est compatible avec spip 3 (en tout, j’ai fais un test concluant) à condition de modifier le fichier plugin.xml

    • JérômeD

      Bonjours,

      Pouvez-vous nous donner le contenu du fichier plugin.xml à modifier et je suppose renommer en paquet.xml

      Merci d’avance

    • Il s’agit de la ligne :

      <necessite id="SPIP" version="[1.9.0;2.1.99]" ></necessite>

      (qui signifie nécessite une version de spip comprise entre la 1.9.0 et la 2.1.99)

      On peut la modifier par exemple en :

      <necessite id="SPIP" version="[1.9.0;3.1.99]" ></necessite>
    • j’ai modifié le plugin.xml sur la zone. cela évitera que d’autres fasses la même demande.

    Répondre à ce message

  • 4

    Bel exercice de style,

    cependant, sur un fond coloré, les arrondis ne sont pas doux mais en escalier, cf. la copie d’écran ci-jointe

    Cordialement

    FDG

    Répondre à ce message

  • Ce plugin ne fonctionne pas sous IE9 et IE8. En fonction de ce que l’on met (0 ou 1px) à la propriété top de la dernière ligne du css, il y a un décalage en haut ou en bas du champ input.

    Répondre à ce message

  • Fonctionne bien sous IE 9 ou sous IE 8 mais pas les 2 ! Sur au moins un des deux navigateurs, il y a un décalage du champ input par rapport aux arrondis de début et de fin, vers le haut ou le bas çà dépend si on met un 1 ou un 0 à la propriété top de la dernière ligne du css. Sinon look sympa, je l’utilise quand même.

    Répondre à ce message

  • Bonjour,

    Pour ma part, tout semble fonctionner parfaitement à l’exception de la page sommaire où là se chevauchent les deux versions (normale et « Joli »).

    Si quelqu’un y comprend quelque chose ?

    Répondre à ce message

  • 1

    bonjour
    j’ai instaler le plugin souq 2.1.10 mais il ne marche pas ?
    merci pour votre aide

    • Bon j’ai désactivé tous les autres plugins sans résultats. Même en désactivant mes feuilles de styles.

      F.M BILLARD

    Répondre à ce message

  • C’est moi qui délire où personne ne voit qu’il manque un gros E à « Joli » ?

    Une recherche ?

    Ça m’agresse les yeux dans l’article, dans le ZIP, partout. :)

    Répondre à ce message

  • Philippe

    Merci pour ce plugin. je l’ai installé ce matin sur lille.lesverts.fr.

    Il fonctionne très bien sur cette version 1.9.2. J’ai toutefois du retoucher le css car j’avais un décalage vers le bas de la partie centrale du formulaire.

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 11 novembre 2017