Plugin Vidéo(s)

Interface de gestion et modèle d’insertion des vidéos :

  • Dailymotion
  • Vimeo
  • Youtube

Modèle de la balise HTML5 video avec alternative flash html5media :

  • Lecture HTML5/Flash pour tout navigateur des fichiers MP4/H264/Ogg/WebM/Mkv
  • Support mobile, iPad, iPhone, Android, etc.

A quoi ça sert ?

Ce plugin permet d’intégrer à partir d’un simple copier/coller d’URL sur les pages articles des vidéos hébergées sur les principales plateformes d’hébergement vidéo et de les gérer comme des documents à part entière.

Ce plugin gère également l’affichage HTML5 des vidéos aux formats MP4, H264, Ogg, WebM et Mkv.
Ll’affichage par défaut prend en compte les navigateurs mobiles. Les vidéos sont ainsi disponibles sur iPad, iPhone ou autres Androïds.

Pourquoi le plugin Vidéo(s) plutôt qu’une alternative HTML5 classique avec Fallback Flash ?

Et bien parce que le plugin Vidéo(s) s’appuie sur une détection JavaScript des formats disponibles et reconnus et non sur la détection native du navigateur qui ne vérifie que si la balise HTML5 vidéo est gérée, mais pas si un format lisible est présent.

L’alternative Flash gérée classiquement n’est proposée qu’aux navigateurs ne gérant pas la balise HTML5 vidéo, mais elle ne prend pas en compte la gestion des formats proposés. Ainsi, une vidéo au format H264 sera visible sous Safari/Chrome (nativement), sous Internet Explorer (alternative Flash) mais pas sous Firefox qui connaît bien la balise vidéo et sait l’interpréter, mais ne sait pas lire le H264, il renverra donc une balise vidéo vide, pas de film ! Ainsi, vous devrez encoder votre vidéo dans tous les formats afin de vous assurer qu’elle sera lisible partout. En Ogg par exemple pour Firefox, en plus du H264 pour Safari et autres.

Le plugin Vidéo(s) va plus loin, sa détection se base sur la présence d’un format lisible par le navigateur et s’appuie sur le plugin Javascript html5media. Ainsi, dans notre exemple précédent, Firefox recevra l’alternative flash et sera donc capable de lire la vidéo H264 sans avoir besoin d’une version Ogg du fichier.

Pourquoi ne pas utiliser un lecteur Flash compatible HTML5 comme JW Player ?

Parce que ces lecteurs prennent le problème à l’envers ! Ils génèrent une balise HTML5 vidéo pour les navigateurs qui peuvent l’utiliser. Le code source quant à lui ne contient que des appels Javascript. La sémantique n’est donc pas respectée.

Le plugin Vidéo(s) quant à lui s’appuie sur la balise vidéo qu’il insert dans le code source pour proposer au besoin uniquement, une alternative Flash. Le code source est respecté.

Cependant, les lecteurs n’auront donc pas le même rendu graphique, la balise vidéo étant laissée à la charge du navigateur qui l’interprète. JW Player quant à lui propose une interface unifiée pour l’affichage de la balise HTML5 vidéo ainsi que son alternative Flash, mais aussi pour les vidéos Dailymotion, Vimeo et autres Youtube. C’est bien le seul avantage qu’on pourra donc vouloir trouver à ces solutions (souvent payantes).

Comment ça marche ?

L’installation du plugin se fait comme pour tous les plugins.

Configuration

Un panneau de configuration permet pour l’instant de choisir une taille d’affichage vidéo par défaut pour toutes les vidéos.


Ce panneau sera élargi pour offrir des réglages spécifiques à chaque type de vidéo : Dailymotion, Viméo, Youtube...

Ajouter une vidéo

Depuis la page d’un article ou depuis la page d’édition d’article dans la colonne de gauche un champ de saisie permet de copier/coller le lien vers la page de votre vidéo.

Aucun besoin d’extraire un identifiant ou de copier un code quelconque, l’adresse complète est suffisante :

Les vidéos sont alors disponibles comme n’importe quel document depuis la page article ou depuis la Médiathèque de SPIP (https://contrib.spip.net/Mediatheque qui permet au plugin Vidéo(s) d’insérer l’auteur et la durée du film).


Afficher une vidéo

Le plugin Vidéo(s) de SPIP surcharge le modèle "video" qui permet aux auteurs de SPIP d’intégrer n’importe quelle vidéo depuis n’importe quel article.

Le fonctionnement est le fonctionnement classique des modèles :

  1. <videoYY>

avec YY (:p) représentant le numéro de document de la vidéo.

Les options peuvent se rajouter à la suite :

  1. <videoYY|largeur=640|hauteur=360>

Ce nouveau modèle rajoute la lecture des vidéos importées depuis les plateformes ainsi que la lecture HTML5 des contenus de type MP4/H264, WebM, Ogg.
Dans tous les autres cas (autres extensions), c’est le fonctionnement classique qui est respecté.

Pour les webmasteurs, depuis les squelettes l’appel se fait également de manière classique :

#MODELE{video,document=XX}
#MODELE{video,document=XX,largeur=640,hauteur=360,autoplay=oui}

Une page de test et d’exemple est disponible dans le dossier "exemple/" du plugin Vidéo(s), il suffit de la glisser dans le dossier "squelettes/" de votre SPIP et de vérifier à l’adresse :
http://www.votreDomaine.com/spip.php?page=mesVideos
Elle affiche toutes les vidéos distantes qui ont été uploadées avec le plugin.

Et les vidéos HTML5 pour tous ?

Avec la diversité des formats, il devient difficile de satisfaire tout le monde. Le HTML5 offrant une forme élégante d’affichage des vidéos, il est cependant frustrant de devoir compresser autant de vidéos que de navigateurs.

Le modèle vidéo intégré au plugin Vidéo(s) suggère une alternative simple mais basée sur le format propriétaire H264.

Les vidéos H264 peuvent en effet être lues nativement dans tous les navigateurs modernes grâce à la balise HTML5 (à l’exception de Firefox qui utilise l’alternative). Elles sont de plus accessibles aux iPad et autres mobiles qui n’ont pas la possibilité d’utiliser Flash.

Enfin, pour tous les autres navigateurs, les vidéos H264 sont tout de même lues et de manière transparente par Flash Player à partir de sa version 9.

Nous pouvons donc utiliser un même fichier H264 afin de satisfaire l’intégralité des navigateurs, soit via HTML5 soit via son alternative Flash !

Si vous utilisez la balise #INSERT_HEAD de SPIP (de nombreux squelettes l’utilisent par défaut), les autres navigateurs utiliseront l’alternative flash (player FlowPlayer proposée par le script du projet html5media).

Cependant, bien que très répandu (Blueray, Télévision, Internet, etc.) le H264 est un format propriétaire boycotté par les navigateurs tels que Firefox et Google Chrome. Ces deux navigateurs utiliseront donc l’alternative Flash si seule une version H264 de votre vidéo est disponible.

Toutefois, grâce au plugin Vidéo(s) de SPIP, si une même vidéo est disponible en plusieurs format (même nom de fichier mais extensions différentes) ils seront tous utilisés par la balise vidéo. Il devient ainsi possible d’ajouter votre vidéo en WebM ou Ogg (ou les 2) en plus de la vidéo H264 (ou sans la vidéo H264).

Cependant l’encodage du fichier dans différent format représente une perte de temps en compression ainsi qu’en temps de mise en ligne et nécessite plus d’espace d’hébergement. Le choix vous appartient donc.

Et moi ? Comment je compresse mes vidéos ?

La compression H264 est réalisable avec une facilité déconcertante grâce au logiciel libre HandBrake.

Les seuls paramètres importants à respecter étant "Web Optimized" et un débit moyen (average bitrate) de 1500kbps (1200 si l’on souhaite conserver une qualité optimale mais rendre la vidéo disponible sur iPhone par réseau 3G, 1900 maximum pour que les vidéos restent accessibles aux iPad sur réseau WiFi).

Si votre source vidéo provient d’une caméra DV Pal, n’oubliez pas de désentrelacer votre image (deinterlace ON / fast).

Et j’ai quoi comme options ?

Options générales

  • responsive : pour que largeur et hauteur soient dynamiques (fluides) et occupent au mieux l’espace qui leur est disponible, tout en conservant les proportions
  • largeur : pour forcer une largeur différente de la largeur par défaut
  • hauteur : pour régler une hauteur différente de la hauteur par défaut

"Dit donc ça fait pas grand chose..."
C’est vrai, mais tout est déjà dans le code, il manque juste quelques heures de travail pour finaliser et piloter intégralement tous les players :)

Et YouTube dans tout ça ?

Comme à son habitude, le diable Google n’arrête pas de changer ses API, sans trop crier gare... Il est désormais nécessaire de posséder une clef d’API YouTube afin de pouvoir récupérer une vidéo de la plateforme.

La première chose à faire est de se rendre dans la console des développeurs Google avec un compte Google Developper (en créer un au besoin) :
-  https://console.developers.google.com/
(ce lien aura très certainement changé 40 fois dans les 5 mois à venir, comme d’hab avec Google, rien ne reste !)

Les étapes suivantes à partir du Developper Center sont données par Mist. GraphX :
-  créer un projet si ça n’est pas déjà le cas,
-  aller dans l’onglet API et authentification > API, sur cette page on aura la liste de toutes les API disponibles (cf la capture), sur l’onglet Bibliothèque d’API,
-  aller sur l’onglet API Activés pour vérifier les API actives, activer l’API YouTube au besoin,
-  dans la partie identifiants on peut générer la clef, ou la re-générer dans la partie Accès à l’API publique
-  il faut utiliser la clef pour le navigateur, vu que c’est ce que l’on recherche, à priori SPIP n’est pas encore une appli mobile... là il n’y a pas trop de choix, on clic sur créer sans renseigner de référents.

Pour résumer, il faut donc aller dans Bibliothèque d’API > API YouTube > YouTube Data API et là il suffit de cliquer sur le bouton "activer".

Enfin, sur la page d’administration du plugin Vidéo(s), il restera simplement à saisir la clé de serveur dans le champs "Clé d’API YouTube".

Et si je ne veux pas faire de H264... ?

Les compressions WebM sont quant à elles réalisables à partir du simplissime Miro Video Converter.

La qualité de ce dernier n’étant pas des plus reluisantes à mon goût, vous pourrez lui préférer certaines alternatives (utilisateurs Mac OS). N’hésitez pas à vous référer à la documentation officiel du projet WebM

Enfin, dans tous les cas, pour les utilisateurs avancés, FFmpeg reste bien entendu la solution la plus complète, en ligne de commande s’il vous plait.

Avec quoi ça casse ?

Avec une mauvaise configuration serveur
Certains serveurs peuvent se tromper sur les types MIME de vos fichiers qui ne seront alors pas forcément reconnus par les navigateurs. Dans ce cas (par exemple présence d’un fichier .webm Firefox refusant de le jouer), il suffit de corriger la configuration côté serveur ou simplement dans votre fichier .htaccess en renseignant les bons types :

AddType video/ogg  .ogv
AddType video/mp4  .mp4
AddType video/webm .webm

Avec PHP4
Le plugin utilise pour l’instant PHP5 que l’hébergement doit donc supporter.

Et si je n’ai pas PHP5 par défaut ?

  • Chez OVH : http://guides.ovh.com/Php5ChezOvh (SetEnv PHP_VER 5)
  • Chez Ouvaton : ajouter en tête du fichier .htaccess de SPIP la ligne :
    AddHandler application/x-suexec-php5 .php si le fichier n’existe pas, le créer et y mettre seulement cette ligne, ou renommer htaccess.txt de SPIP en y ajoutant la ligne en entête
  • Chez les autres : http://www.google.fr
  • Chez 1 and 1 : activer PHP5 depuis l’espace client, dans le dossier « ecrire » de spip, rajouter un fichier php.ini contenant :
    allow_url_fopen = on 
    allow_url_include = on
  • Chez InfoManiak (ou plus largement sur les serveurs interdisant fopen de php)
    Pour InfoManiak il vous suffira de rajouter à votre fichier .htaccess les informations suivantes détaillées sur leur FAQ :
    php_flag "allow_url_fopen" "On"
    php_flag "allow_url_include" "On"
  • mis à jour 2016 pour InfoManiak Sur la nouvelle plateforme, il ne faut pas plus passer par le .htaccess mais par l’interface d’administration et activer l’option "Activer allow_url_fopen" (voir les détails de leur nouvelle FAQ]

Sinon pour l’instant aucun plugin ne semble contre indiqué et le plugin Médiathèque vous est même fortement recommandé.

Comment faire (encore) mieux ?

  • Compléter les options de modèles et configurations Dailymotion / Youtube / Vimeo / HTML5
  • Revoir un brin l’ergonomie et les messages
  • Rajouter un sélecteur simple pour gérer le format (1,77 / 2,35 / 4/3 etc.)
  • Retirer l’affichage <doc>et mettre <video> à la place dans la colonne de gauche
  • Edition des URL pour les corriger à la main (crayon sur #FICHIER - déjà possible avec Mediatheque)

Dernière modification de cette page le 24 février 2019

Discussion

191 discussions

  • 2

    Bonjour,
    pour une vidéo, dans la médiatheque un clic sur l’image [ ../IMG/n°x ] de la vidéo conduit à une erreur : Not Found The requested URL ...ecrire/n°x was not found on this server.
    (pour une image distante [ https://unsiteqcq.biz/img.jpg ] le lien est ok, ça ouvre une fenêtre modal)

    • Je ne me rappelais pas avoir posté ce quasi même message il y a qcq mois. Désolé de ce radotage.

    • Autre petit Pb :
      Ce n’est pas possible de changer la vidéo par Modifier le document > [Changer]
      (car alors on change le N°seul de la vidéo, inscrit en bdd, pour http://.../autreN°devideo)

    Répondre à ce message

  • 1

    bonjour,
    qu’une vidéo signalée par son icône s’ouvre dans une fenètre modal, comme cela se fait pour une image, ce serait techniquement possible ?

    • j’ai trouvé cette solution (pour vimeo, à compléter), ce qu’il faut c’est (cf http://contrib.spip.net/MediaBox) : « Ouverture en iFrame : Pour que la boîte ouvre la cible du lien dans une iFrame, il suffit d’ajouter la classe boxIframe et des pseudo-classes servant à spécifier les dimensions »

      <B_videos_jointes>
      	<BOUCLE_videos_jointes(DOCUMENTS){id_album}{media?}{par #ENV{par,media}, titre, fichier}{extension==dist_vimeo}>
      			<a href="//player.vimeo.com/video/#URL_DOCUMENT?byline=0&amp;autoplay=0" type="#MIME_TYPE" rel="album#ID_ALBUM" class="mediabox boxIframe boxWidth-640px boxHeight-400px" title="#GET{titre}">
      			[(#LOGO_DOCUMENT{icone}
      				|image_reduire{#ENV{icone,16}}
      				|inserer_attribut{alt,#GET{titre}})
      			][<strong class="titre">(#GET{titre})</strong>]
      			</a>
      	</BOUCLE_videos_jointes>
      </B_videos_jointes>

    Répondre à ce message

  • 16

    Bonjour,

    J’ai le problème suivant :
    Not Found
    The requested URL /www.youtube.com/embed/hhUK22_YIrc was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Une idée du problème ?

    • Et une url de ce type :
      https://www.youtube.com/watch?v=hhUK22_YIrc
      ça donne quoi ????

    • stephan

      Même souci sur youtube avec une clé API serveur générée à l’instant. J’ai le plugin version 30 sous spip3. Le message est presque du même ordre :

      The information file for the video you are trying to get is unavailable (HTTP/1.0 403 Forbidden)

      pourtant l’adresse de la vidéo est correcte. J’ai tenté en https et en http. Idem. Une idée d’où cela peut venir ?

    • Stéphan

      Après un vidage du cache et j’imagine un peu de temps pour que Google accèpte la clé... ça marche. Ouf.

    • bonjour,

      j’ai le même problème à l’insertion d’une vidéo youtube (la clé API de youtube est renseignée dans la configuration du plugin) : erreur 403.

    • j’ai regardé (très vite) le code, est-ce que ce n’est pas la bibliothèque videopian qui n’est plus à jour par rapport à ce qu’attend youtube ?

      En attendant, du côté de oEmbed, il semble que cela fonctionne normalement.

      Pourquoi développer différents plugins qui ont à peu près les mêmes fonctionnalités ? ;-)

    • Quelles sont/de quelle forme sont les urls des vidéos que vous essayez de joindre :
      youtube.com/embed/identifiant
      ou
      youtube.com/watch ?v=identifiant

    • de la forme youtube.com/watch ?v=identifiant.

    • Bonjour, j’ai exactement le meme souci, avez vous trouvé une solution ?
      Merci

    • Une purge du cache suffit. Je crois qu’il faut attendre un peu pour que la clé soit active. Une heure tout au plus.

    • bonjour, comme je l’indiquais dans ma réponse du 27 juin, je suis passé du côté d’oEmbed. Donc je n’ai pas cherché plus loin.

    •  ;-) oui moi ça fonctionne très bien chez moi et sur tous les sites ou je l’ai installé : donc j’ai pas cherché plus loin ^^.

      Tout les retours ou messages d’erreur cités indique clairement que l’accès a l’api youtube n’est pas bon : soit pour un problème de clef mal configurée, ou pas créée.

      J’ai re-re-re-testé et franchement je n’arrive pas a ne pas y arriver. donc si certains on des problème, merci d’être plus précis au moins sur vos configurations php, serveur, sinon difficile de savoir ou chercher :/

      Au pire contactez moi je vous passerais une clef d’api fonctionnelle pour les test...

    • Déjà pour le problème de Pierre, c’est pas une url de cette forme qui est bonne :

      pour avoir le code a intégrer il faut aller sur partager et prendre le lien de ce type :

      https://youtu.be/hhUK22_YIrc

      et pas une url embed

      Et la ça fonctionne correctement

    • Bonjour à tous

      En fait j’avais un script qui changeais les url et j’ai corrigé le problème

    • J’ai le même soucis survenu depuis peu sur l’un de mes sites.

      The information file for the video you are trying to get is unavailable (HTTP/1.0 403 Forbidden).

      Savez-vous si le httpS est nécessaire aujourd’hui pour communiquer avec l’API de Youtube.

      Car sur un autre de mes sites avec un certificat SSL, cela fonctionne parfaitement.

      Julien

    • Bonjour Julien,

      Je viens de faire le test, sur un site non https, et je n’ai pas de problème en intégrant cette video youtube :

      Je récupère bien les infos, titre et vignette.

      Quel est l’url de la video en question ?
      Peut être des infos coté google dev console ? un quota dépassé (devrais renvoyer une erreur spécifique si on se fie a https://developers.google.com/youtube/v3/docs/errors) ?

      peut être testé en essayant de créer une autre clef d’API ....,
      un problème avec la méthode oAuth de l’api et la config serveur ?

      Arnaud B. (Mist. GraphX)

    • Il suffit que je post quelque chose pour que cela fonctionne. :/

      Je suis allé dans le « tableau de bord » dans le gestionnaire d’api de google, j’ai ensuite clické sur YouTube Data API v3, après je suis allé dans en l’explorateur des API et mis sur ON « Authorize requests using OAuth 2.0 ».

      Et cela refonctionne, mais je n’ai jamais du faire tout ça auparavant...

      Ça a du sens cette marche à suivre ?

    Répondre à ce message

  • Si jamais, j’ai constaté un problème d’affichage. Je ne sais pas si d’autres personnes peuvent confirmer.

    Si j’ai, dans un article, QUE des vidéos dans le portfolio (pas d’image), ceux-ci n’apparaissent pas dans la colonne de gauche lors de l’édition de l’article.

    Julien

    Répondre à ce message

  • Bonjour,
    dans la médiathèque de l’espace privé, pour une vidéo xyz, le lien sur la miniature /site.truc/ecrire/xyz renvoi une erreur .
    de même, #URL_DOCUMENT donne /site.truc/xyz qui ne correspond à rien
    c’est possible d’y remédier ?

    Répondre à ce message

  • Est-il possible espérer une version qui fonctionne sur SPIP2.1

    Répondre à ce message

  • 5

    Bonsoir,

    Malgré version spip 3 à jour , plugin dernière versio net api créée sur google develoer, j’ai l’erreur « Fatal error : Uncaught exception ’Videopian_Exception’ with message ’The information file for the video you are trying to get is unavailable’ in ... »

    Bizarre, j’ai tout bien fait comme vous avez dit et sur mes autre sites, aucun souvis, tout est ok ...

    La verison php a -t’elle une influence dans ce cas ?

    Merci de votre aide.

    • Ca me fait pareil même avec Vimeo et Dailymotion

    • Je confirme le bug sous youtube

      Par contre sous vimeo, l’import des vidéos et vignettes fonctionnent toujours bien.

    • Quelqu’un a t-il réussi à résoudre ce problème ?

    • Même problème ici, seulement avec YouTube. Ça marche bien avec Vimeo.
      Suggestions ?

    • Moi j’ai l’erreur suivante avec les videos youtube :

      Error while getting the video data.

    Répondre à ce message

  • Bonjour,

    J’ai recemment mis a jour le plugin et du le patcher a plein d’endroits pour remplacer l’utilisation de file_get_contents par des appels cURL. Je note tout de meme la presence de la fonction url_get_contents() qui est censee utiliser curl en priorite si il est installe. Toutefois l’utilisation de cette fonction dans le reste du code n’a pas ete generalise. Si cela pouvait etre pris en consideration dans les versions futures, cela m’eviterai de mettre mon nez dans le code a chaque update.

    Merci pour ce plugin en tous les cas.

    Répondre à ce message

  • 1

    Bonjour,

    Je viens vous remonter un soucis qui se produit depuis le 2 février sur un site utilisant ce plugin.

    Le flux RSS produit des erreurs dans certains logiciels de syndication et dans les systèmes de gestion automatisés des réseaux sociaux basés sur le flux RSS.

    Après recherche, il s’avère que c’est la balise enclosure qui pointe vers une 404 quand il n’y a comme document qu’une seule vidéo dans l’article. Si elle est accompagnée d’images, pas de blocage (mais une 404 tout de même).

    Pourquoi une 404 ? Car le lien vers le média s’écrit sous la forme
    <enclosure url="http://nomdusite.tld/6-Xt3-XbHI8" length="0" />
    L’identifiant à la fin de l’url étant l’id de la vidéo Youtube. De fait, ce lien renvoyant une 404, pas moyen pour le flux de savoir de quel type de média il s’agit, cette balise ne s’affiche donc pas, et la longueur en bytes est définie à 0.

    Je peux fournir un lien vers le validateur W3C si besoin est.

    Merci !

    • A noter également que lorsque l’on modifie un article, si on clique sur la vignette de la vidéo dans la colonne de gauche, le lien est du type :

      http://nomdusite.tld/ecrire/6-Xt3-XbHI8

      Ce qui mène à une 404 aussi. Je ne sais pas si c’est normal ou pas, et si c’est lié au soucis sus-cité ?

    Répondre à ce message

  • 7
    Le Jaseur Boréal

    Bonjour,

    Un nouveau problème apparait,, je n’arrive pas à détecter la solution.
    Avez-vous une idée miraculeuse car :

    L’affichage de vidéos externes est ok coté privé et disparait coté public

    Exemple : http://www.lettonie-francija.fr/Parize-pasaules-galvaspilseta-965

    Sur cette page la seule vidéo qui apparait c’est avec l’embed de partage de dailymotion .
    Les vidéos intégrées avec le Plugin Vidéo(s) sont visibles coté privé et invisibles coté public.
    C’est pareil avec Youtube depuis quelques semaines et mise à jour, pour d’autres pages et d’autres liens vidéos.

    D’où peut provenir ce problême ?

    Merci de toutes vos solutions.

    • Jaseur Boreal

      Bonjour

      Le problème est récurrent.

      Exemple, dans cette page publique :
      http://www.lettonie-francija.fr/EU2015LV-journees-Lettonie-Starsbourg-980?lang=fr

      Il y a une vidéo youtube incorporée avec :

      1. <embxxx|largeur=348|hauteur=196|left>

      Coté privé, elle est présente (voir l’image jointe), mais elle disparait de l’affichage public !

      Qu’est ce qui se passe, avez-vous une solution ?

      Merci

    • Salut.

      Il me semble bien que les vidéos doivent être incorporées avec video et non avec emb.

    • Jaseur Boreal

      Bonjour,

      j’ai aussi essayé avec la formule habituelle :

      1. <video3388|largeur=348|hauteur=196|left>

      Que cela soit avec « em » ou « vidéo », les deux étant proposés par le plugin,
      la vidéo est visible coté privé, mais coté public a disparu.

      Cela se produit pour les nouvelles incorporations, depuis les dernières mises à jour.

      Avec les incorporations de vidéos youtube réalisées par les mêmes formules il y a 1 an , les vidéos des pages anciennes apparaissent à la fois coté privé et coté public.

      Bizarre , bizarre !

    • Jaseur Boreal

      Cela semble réglé en ce moment

    • Jaseur Boreal

      Bonjour,

      En septembre 2015, de nouveau le même problème se produit.
      Je n’arrive pas à détecter l’origine, alors que cela s’affiche pour toutes les autres vidéos déjà intégrée.. Avez-vous une bonne idée miraculeuse car :

      L’affichage d’une nouvelle vidéos Youtube est ok coté privé
      mais disparaît de l’affichage coté public : une solution ?

      L’exemple est pour cet article tout chaud :
      http://www.lettonie-francija.fr/eurobasket-2015-france-latvija-Valdemars-Baumanis-1132

      Aucune vidéo n’apparaît, invisible coté public

      Or la vidéo intégrée avec le Plugin Vidéo est visible coté privé.

      D’où peut provenir ce problême ?

      Merci de vos idées.

    • Jaseur Boreal

      Bonjour, Bonne et enthousiaste année à tertous,

      Le problème est récurrent et aléatoire, avec une variante gênante dans un article comprenant deux vidéos incorporées :

      • Coté privé-rédacteur de l’article : Affichage et vision des deux vidéos dans l’article ( voir document image ci-dessous)

      Avez-vous une heureuse solution ?
      merci

    • Jaseur boreal

      Bonjour,

      FORCER LES DIMENSIONS DE LA VIDEO
      CRÉE LA DISPARITION DE L’AFFICHAGE COTE PUBLIC

      Apparemment le problème de disparition de l’affichage public des vidéos,
      alors qu’elles apparaissent dans l’affichage coté privé, se produit quand on ajoute largeur et hauteur à la vidéo.

      Les vidéos s’insèrent et sont visibles complétement avec seulement :

      <videoXXX> 

      Par contre quand on veut forcer les dimensions comme prévu ,

      • Coté privé l’affichage redimensionné en création de la page, c’est Ok
      • Coté public les vidéos sont invisibles quand le code est par exemple :
        <videoXXX|largeur=320|hauteur=180> 

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom