SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

286 Plugins, 197 contribs sur SPIP-Zone, 267 visiteurs en ce moment

Accueil > Vie de SPIP et autour de SPIP > SPIP-core > Annonce SPIP version 1.9.2d

Annonce SPIP version 1.9.2d

27 janvier 2008 – par L’équipe de SPIP-Contrib – commentaires

1 vote

Pour vous faire patienter jusqu’à la prochaine version majeure de SPIP, nous publions une 1.9.2d, 4e mise à jour de la version 1.9.2.

Reprise in-extenso du message sur les listes

Date : 27 janvier 2008 22:07:26 GMT+01:00
À : spip-ann at rezo.net, spip SPIP <spip-dev> , spip at ezo.net, spip-zone at rezo.net, spip-trad at rezo.net
Objet : Spip Version 1.9.2d

Bonjour,

pour vous faire patienter jusqu’à la prochaine version majeure de SPIP, nous publions une 1.9.2d, 4e mise à jour de la version 1.9.2.

Cette mise à jour concerne exclusivement des corrections de bugs. Le passage à cette version est conseillé, et ne doit entraîner aucun impact fonctionnel pour les visiteurs de votre site si vous utilisez déjà une version 1.9.2 (a,b ou c).

Les modifications apportées

Les modifications apportées sont :

Pour les rédacteurs et administrateurs :

-  correction d’une incohérence dans la gestion de date des documents (date/heure a la creation puis date seulement)
-  correction d’un bug sur le menu de rubriques qui en masquait certaines (ticket #1113)
-  éviter une erreur javascript au début du chargement de la page lorsque l’on bouge la souris trop vite
-  la configuration graphique et l’adresse du site ne sont pas écrasées lors de la restauration d’une sauvegarde, car liées au serveur
-  affichage correct des captures d’ecran successives dans les statistiques
-  mise à jour de la traduction en indonésien
-  correction d’un bug sur les droits de modification des sites syndiqués par les administrateurs restreints
-  correction d’une série de bugs relatifs à la gestion des droits sur les logos
-  correction d’un bug sur la requête sql du navigateur de rubriques qui le rendait inutilisable sur les gros sites (et tri des rubriques par num titre, titre)
-  correction d’un bug qui sur l’autorisation des autorisation des administrateurs restreints à déplacer un article publié dans une rubrique dont il n’est pas administrateur

Pour les développeurs de plugins

D’un point de vue plus technique, pour les développeurs de plugins :
-  remplacer la constante _INC_PUBLIC par la globale _INC_PUBLIC et l’incrémenter lors des inclusions pour que le plugin balise session fonctionne correctement (notamment sa gestion de cache reportée de la version en cours de développement)
-  amélioration de la purge du cache dans le CRON (la purge pouvait ne jamais réussir après le passage d’un robot, et saturer les ressources serveurs à essayer de calculer la taille du cache)
-  url_de_base peut être appelée depuis mes_options
-  Correction d’un include manquant qui pouvait faire échouer la fonction autoriser_voir_dist
-  recuperer_page prend correctement en charge les urls du type https (si php a été compilé avec le support de ssl)

L’équipe.

Téléchargement

Comme d’habitude c’est sur spip.net

Dernière modification de cette page le 27 janvier 2008

Retour en haut de la page

Vos commentaires

  • Le 9 février 2008 à 20:54, par ? En réponse à : Annonce SPIP version 1.9.2d

    Mon site sur free donne une erreur server 500 pareil que les autres utilisateurs
    j’utilise la 1.9.2d
    Apparemment free n’aime pas spip

    Répondre à ce message

  • Le 1er février 2008 à 10:29, par les2rives En réponse à : Annonce SPIP version 1.9.2d

    Pour des modifications mineures entre deux versions, il serait judicieux de pouvoir avoir le delta entre les deux versions pour faire une mise à jour plus rapide. Car en fait c’est généralement ce que nous faisons pour ne pas re-télécharger tous les fichiers.

    • Le 1er février 2008 à 10:58, par ? En réponse à : Annonce SPIP version 1.9.2d

      deux liens ici pour tes besoins :

      http://www.spip-blog.net/1-9-2d.html

    • Le 1er février 2008 à 19:38, par Chris En réponse à : Annonce SPIP version 1.9.2d

      Bonjour,
      Je rencontre un problème sur 2 sites free. Après une réinstallation de spip 192d sur le 1er et une installation sur le 2e, je rencontre la même erreur : « Erreur 500 - Erreur interne du serveur ». Par contre, en enlevant le .htaccess j’accède à l’interface privée. J’ai essayé le fichier « mes_options » pour bien spécifier le fichier « squelettes », rien n’y fait.
      Merci de bien vouloir m’aider.

    Répondre à ce message

  • Le 1er février 2008 à 15:16, par Cécile En réponse à : mise à jour 1-9-2c vers 1-9-2d, cht bdd ?

    J’ai fait une mise à jour de 1.9.2c vers 1.9.2d, est-ce normal si je nai pas le « message technique, cliquez pour la mise à jour de la base de données » ?

    Merci !

    (j’ai fait la maj car j’ai un bug bizarre sur un squelette, je voulais voir si ça le corrigeait, mais en fait non)

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Curator

    19 mars 2014 – 41 commentaires

    Présentation Curator est un plugin qui utilise un bookmarklet pour créer un article SPIP à partir d’une page web, (très librement) inspiré du bouton mémo. Installation Attention : avec le passage à la v 1.0, le bookmarklet a été modifié, il (...)

  • Site multilingue facile

    3 mai 2012 – 98 commentaires

    Site multilingue facile permet de mettre en place facilement un site multilingue avec une langue par secteur. Introduction Même si le multilinguisme est nativement intégré dans spip, réaliser un site multilingue n’est pas toujours évident. Ce (...)

  • Mailsubscribers

    16 janvier 2013 – 284 commentaires

    Ce plugin permet de gérer les inscriptions (ou abonnements) à la diffusion de contenu par email. Mailsubscribers permet de gérer les inscriptions par Opt-in simple ou double et la désinscription par URL. Ce plugin gère également plusieurs listes (...)

  • Accès Restreint Partiel

    8 septembre 2014 – 20 commentaires

    Voulez-vous masquer une partie du contenu de vos articles aux visiteurs de passage ? et réserver la totalité à certains de vos membres ? Voulez-vous remplacer le contenu occulté par un appel à l’action (pour devenir Membre, bla bla bla...) ? Le (...)

  • Plugins Giseh

    26 novembre 2010 – 412 commentaires

    Les plugins correspondants aux fonctionnalités de Giseh, compatibles avec SPIP 3.0 (et SPIP 2.1), sont les suivants : le plugin « ciparam : Configurateur de squelettes » le plugin « cisquel : Squelettes de base avec 3 colonnes » le plugin «  (...)

Ça spipe par là