SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

286 Plugins, 197 contribs sur SPIP-Zone, 360 visiteurs en ce moment

Accueil > Vie de SPIP et autour de SPIP > SPIP-core > SPIP 3.0.11, what else ?

SPIP 3.0.11, what else ?

14 août 2013 – par L’équipe de SPIP-Contrib – 15 commentaires

4 votes

SPIP 3.0.11 est essentiellement une version de maintenance, embarquant 11 semaines de corrections de bugs et améliorations.

À noter :

  • optimisations contre les dégâts des bots et spammeurs (stats, pétitions, forums et formulaires)
  • nouveau filtre |liens_nofollow
  • corrections de bugs de l’espace privé (couleurs, typo des textes, bouton d’action, icones du Porte-Plume...)
  • fin des travaux sur le formulaire d’inscription
  • création d’un var_mode=traduction qui permet d’identifier les chaînes de langues
  • améliorations sur |timestamp
  • évolutions de la boucle DATA
    • réparation de inc_simplexml_to_array qui reçoit de (DATA) une string et non un Object.
    • une constante _DATA_SOURCE_MAX_SIZE pour fixer la taille max des data recupérées par la boucle DATA
    • pour activer le namespace, ajouter en argument : <BOUCLE_flux(DATA){ source simplexml, http://opendata..., namespace}>.
  • Pour Textwheel et son décodeur Yaml, on propose par défaut un yaml_to_array

    Mise à jour du 2/9/2013 : la fonction inc_yaml_to_array_dist() était auparavant incluse dans le plugin Yaml et celui-ci a donc été mis à jour. Si votre site utilise ce plugin, mettez-le à jour avant de procéder à la mise à jour de SPIP. Voir http://blog.spip.net/SPIP-3-0-11-wh....


  • amélioration de l’échafaudage pour les nouveaux objets qui n’ont pas surchargé leur bloc d’info
  • une constante _INC_DISTANT_MAX_SIZE fixe la taille max (2Mo) des données récupérées par recuperer_page()
  • autres corrections : tâches CRON, upload des svg, retour des favicons, urls propres...
  • gestion des documents : affichage des crédits des documents modifiés, nouveaux pipelines afficher_contenu_objet et renseigner_document
  • optimisation des tables spip_versions et spip_versions_fragments
  • ...

Voir tous les détails sur : Changements entre 3.0.10 et 3.0.11

Mise à jour

N’hésitez pas à utiliser les différents moyens mis à disposition par
la communauté pour obtenir de l’aide lors de cette mise à jour :

-  Liste spip-user : http://listes.rezo.net/mailman/list...
-  Forum : http://forum.spip.net
-  IRC : http://irc.spip.net

Nous rappelons à toutes et tous que le meilleur moyen pour
signaler des failles, ou des suspicions de failles est
d’envoyer un email à « spip-team@rezo.net ».

Comment mettre à jour vers SPIP 3.0.11 ?

  • par spip_loader.php : mettez à jour (ou installez) spip_loader, puis rendez-vous à l’adresse http://VOTRE_SITE/spip_loader.php pour installer la dernière version de SPIP. Attention cependant : lisez bien les instructions de http://www.spip.net/fr_download#spip_loader pour ne pas être surpris par un passage non voulu de SPIP2 à SPIP3.
  • par copie des fichiers : SPIP 3.0.11 est disponible à l’adresse http://files.spip.org/spip/stable/spip-3.0.zip
  • par SVN : si vous êtes dans la branche 3 faites simplement un « svn up » svn ://trac.rezo.net/spip/branches/spip-3.0 la version 3.0.11 est aussi disponible sous la branche : svn ://trac.rezo.net/spip/branches/spip-3-stable et sous le tag svn ://trac.rezo.net/spip/tags/spip-3.0.11

Comment être tenu au courant de ces annonces ?

Le plus simplement du monde en s’inscrivant sur la mailing
liste http://listes.rezo.net/mailman/listinfo/spip-ann

Bien sûr les réseaux sociaux ne sont pas en reste :
-  Twitter : http://twitter.com/spip
-  Facebook : http://www.facebook.com/spip.net
-  Seenthis : http://seenthis.net/people/spip

Dernière modification de cette page le 2 septembre 2013

Retour en haut de la page

Vos commentaires

  • Le 16 octobre 2013 à 14:31, par lio En réponse à : SPIP 3.0.11, what else ?

    Bonjour,

    Je ne suis pas sur d’être sur le meilleur fil pour cette question, mais vous me direz en tout cas.
    Sauriez-vous me dire quel est la meilleure approche pour importer et utiliser des données d’une autre base de données ?
    Utilisation d’une boucle DATA, ou autre pouvant gérer la plus grande quantité d’informations, la plus grande base donc. (une base de surement plusieurs milliers d’informations, qui pourrait être au format le plus adéquat pour SPIP en xml,mysql ou autre, à vous de me dire la meilleure solution)

    • Le 16 octobre 2013 à 14:37, par Maïeul En réponse à : SPIP 3.0.11, what else ?

      Effectivement ce n’est pas le meilleur fil. Vous eussiez pu utiliser la liste de discussion générale de SPIP.

      Pour répondre à votre question : si votre contenu est dans la même base mysql que SPIP, vous pouvez faire une boucle standard : <BOUCLE(TABLE){critères}>#CHAMPS</BOUCLE>.

    Répondre à ce message

  • Le 4 septembre 2013 à 10:57, par mietbe En réponse à : SPIP 3.0.11, what else ?

    Après installation de la version 3.0.11 dans un site vide j’obtiens le message

    Fatal error : Cannot redeclare imagepalettetotruecolor() in C :\.....\ecrire\inc\filtres_images_lib_mini.php on line 586

    dès que je veux entrer dans l’espace privé...

    APACHE 2.4.4
    MYSQL 5.6.12
    PHP 5.5.0

    • Le 4 septembre 2013 à 11:09, par Maïeul En réponse à : SPIP 3.0.11, what else ?

      Le pb est résolu dans la version de dev... mais curieusement cela n’a pas été reporté en 3.0.11. Voir http://core.spip.org/issues/3016 pour plus d’info.

      Pour ce qui concerne la résolution directe de ton pb, deux solutions :
      -  passer à une version de PHP <IMG//> http://core.spip.org/projects/spip/repository/revisions/20656

    Répondre à ce message

  • Le 15 août 2013 à 07:15, par ypikaye En réponse à : SPIP 3.0.11, what else ?

    Merci Maïeul pour le coup de main !
    Console ADMIN à nouveau accessible. YALM mis à jour. Parfait ...

    Répondre à ce message

  • Le 14 août 2013 à 13:02, par ypikaye En réponse à : SPIP 3.0.11, what else ?

    Bonjour à toute l’équipe.
    Mise à jour effectuée via spip_loader et plus possible d’accéder à l’espace d’administration :
    voici le message :

    Fatal error : Cannot redeclare inc_yaml_to_array_dist() (previously declared in /home/neomens/public_html/spip/plugins/auto/yaml/v1.5.0/yaml_fonctions.php:12) in /home/neomens/public_html/spip/ecrire/iterateur/data.php on line 638

    • Le 14 août 2013 à 13:06, par Maïeul En réponse à : SPIP 3.0.11, what else ?

      avec ton ftp efface /plugins/auto/yaml/v1.5.0. Tu pourra te reconnecter. Il faudra juste passer dans la page d’admin des plugins pour installer la version 1.5.1 de YAML.

    • Le 14 août 2013 à 16:12, par Patrick En réponse à : SPIP 3.0.11, what else ?

      Il m’est arrivé la même aventure en local.
      La suppression de yaml a tout arrangé.
      Par contre, j’ai lu qu’il était dans un plugin-dist... du moins il me semble.
      En tout cas merci à vous tous et bonne journée.

    • Le 14 août 2013 à 16:14, par Maïeul En réponse à : SPIP 3.0.11, what else ?

      non, YAML n’est pas (normalement) dans plugin-dists.

    • Le 14 août 2013 à 17:39, par Patrick En réponse à : SPIP 3.0.11, what else ?

      Mille excuses, j’avais lu (et surement mal interprété) ceci dans le forum du plugin yaml sur spip contrib :

      « Il est déjà intégré dans les extensions avec textwheel (et d’ailleurs il me crash mon skip 3 avec Fatal error : Cannot access protected property TextWheel : :$ruleset in /home/blabla/www/extensions/textwheel/engine/textwheel.php on line 44 »

      J’ai cherché dans la fameuse extension et je n’y ai rien trouvé.
      Pas grave, ça marche sans.
      Merci.

    • Le 14 août 2013 à 23:07, par Pierre KUHN En réponse à : SPIP 3.0.11, what else ?

      Bonjour

      textwheel est un plugins-dist mais yaml est logiquement un plugin qui est demander par d’autre.
      Si tu l’a supprimer, regarde si d’autre se sont pas désactivé, sinon c’est qu’il te sert pas.

    • Le 15 août 2013 à 05:25, par Patrick En réponse à : SPIP 3.0.11, what else ?

      Merci, il devait faire fonctionner Jscycle (je crois) j’ai supprimé yaml et ça marche.
      Merci et bonne journée.

    Répondre à ce message

  • Le 14 août 2013 à 22:49, par Billou En réponse à : SPIP 3.0.11, what else ?

    Vous avez modifié les fichiers sources de JQuery ?

    Parce que depuis la mise à jour l’autocomplete ne s’affiche plus du tout comme avant, c’est complètement bugué et impossible de trouver comme réparer ça.

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Intranet / Extranet

    31 mai 2013 – 63 commentaires

    Intranet / Extranet est un plugin très simple permettant d’interdire l’accès au site à tout visiteur non identifié. Mise à jour Août 2014 : Version 0.4.0, plage d’IP paramétrable permettant de voir le site sans se logguer. Mise en place La (...)

  • Saisies

    27 mars 2010 – 472 commentaires

    Introduction Créer un formulaire est une tâche toujours un peu répétitive : les champs ont souvent les mêmes propriétés, le même accompagnement (message d’erreur, explication, ...) et la même structure HTML. Ce plugin est un outil pour les développeurs (...)

  • Plugin SPIP-Géoportail

    17 août 2010 – 460 commentaires

    Plugin pour l’intégration d’objets géographiques dans SPIP avec l’API Géoportail. Affichage de cartes Géoportail, OpenStreetMap (OSM), Google Maps, Bing ou Yahoo !... Nouvelle version Suite au changement de version de l’API géoportail et des (...)

  • Acces Restreint 3.0

    11 décembre 2008 – 788 commentaires

    Le plugin accès restreint permet de définir et de gérer des zones de l’espace public en accès restreint. Cette version du plugin a été redévelopée et optimisée tout spécialement pour SPIP 2.0. Il en découle une amélioration des performances sur les gros (...)

  • GIS 4

    11 août 2012 – 1304 commentaires

    Présentation et nouveautés La version 4 de GIS abandonne la libraire Mapstraction au profit de Leaflet. Cette librairie permet de s’affranchir des librairies propriétaires tout en gardant les mêmes fonctionnalités, elle propose même de nouvelles (...)