SPIP 3.0.17 fait son commit août ... ou de l’importance de mettre à jour pour une rentrée en douceur...

Voilà presque 5 mois que vous n’aviez pas entendu parler de la communauté SPIP : c’est long !

Voici donc une nouvelle version SPIP 3.0.17 qui corrige une série de petits bugs et une faille de sécurité liée aux formulaires.

Nouveautés de la version SPIP 3.0.17

-  Correction d’une faille de sécurité liée aux formulaires de configuration. Cette faille n’est pas critique, mais elle n’est pas prise en charge par l’écran de sécurité. Il est donc fortement conseillé de mettre à jour votre SPIP.
-  Cette nouvelle version de SPIP corrige une série de petits bugs. La liste complète sera publiée prochainement dans la rubrique « Evolutions et mise à jour » de spip.net . En attendant, vous pouvez déjà consulter le changelog en ligne : CHANGELOG.TXT

Mise à jour et sécurité

Nous rappelons qu’avoir un site à jour est la meilleur solution pour se protéger des piratages.

À propos de sécurité et pour éviter les mauvaises surprises, nous vous conseillons fortement la lecture de ce billet publié sur le blog : Leçon de Hack et mises à jour de SPIP

Un nouveau spip_loader

Le spip_loader vous permet d’installer ou de mettre à jour votre SPIP en moins de 5 minutes.

La nouvelle version (2.5.2), entièrement refondue, est disponible en téléchargement :
SPIP Loader.

Nous rappelons à toutes et tous que le meilleur moyen pour signaler des failles ou des suspicions de failles est d’envoyer un email à spip-team@rezo.net.

Si vous constatez des problèmes, pensez à les communiquer en rédigeant un « ticket » !

Bonne rentrée (et bonnes vacances pour ceux et celles qui y sont encore) et bon SPIP !

L’équipe SPIP

Mise à jour

RAPPEL : si vous utilisez le plugin YAML et que vous mettez à jour depuis une version antérieure à SPIP 3.0.11, il faut mettre à jour le plugin avant de mettre SPIP à jour.

De façon générale mettez à jour d’abord les plugins avant d’effectuer la mise à jour de SPIP.

-  Documentation pour vous aider à passer à la branche 3 de SPIP : http://www.spip.net/fr_article5693.html

-  N’hésitez pas à utiliser les différents moyens mis à disposition par la communauté pour obtenir de l’aide lors de cette mise à jour :

-  Liste spip-user : http://listes.rezo.net/mailman/listinfo/spip

-  Forum : http://forum.spip.net

-  IRC : http://irc.spip.net

Comment mettre à jour vers SPIP 3.0.17

-  par spip_loader.php : mettez à jour (ou installez) spip_loader, puis rendez-vous à l’adresse http://VOTRE_SITE/spip_loader.php pour installer la dernière version de SPIP.

Plus d’infos sur le spip_loader : http://www.spip.net/fr_article5705.html
Attention, lisez bien les instructions pour ne pas être surpris·e par un passage non voulu de SPIP 2 à SPIP 3 !

-  par copie des fichiers :

La version 3.0.17 est aussi disponible sous la branche svn ://trac.rezo.net/spip/branches/spip-3-stable et sous le tag svn ://trac.rezo.net/spip/tags/spip-3.0.17

Comment être tenu·e au courant de ces annonces ?

Le plus simplement du monde en s’inscrivant sur la mailing liste
spip-ann .

Et puisqu’il le faut bien, les dits réseaux sociaux ne sont pas en reste
(choisissez celui qui vous convient mais il est vrai qu’ils ne sont pas très actifs ;) :
-  Twitter : http://twitter.com/spip
-  Facebook : http://www.facebook.com/spip.net
-  Google+ : https://plus.google.com/communities/113773492726383896975

Et n’oubliez pas de bookmarker / suivre celui ci :
-  Seenthis : http://seenthis.net/tag/spip

Discussion

13 discussions

  • Bonjour,
    j’ai deux sites spip en 3.0.17, hébergés chez 1&1, avec un avec un squelette sarka-spip 3.4.5, qui présentent tous deux le même problème : impossible de mettre les plugins à jours (depuis plusieurs semaines mais je n’ai pas eu le temps de me renseigner pour m’en préoccuper sérieusement).
    Dans les fait, j’ai le bouton de mise à jour à droite de chaque plugin, mais quand je clique dessus, il mouline sans fin.
    Désormais certains plugins sont obsolètes et j’ai peur que les sites ne plantent.

    Quelqu’un rencontre-t-il ce problème ? aurait une solutions ? faut-il chercher plutôt du côté de sarka-spip ?

    Merci d’avance.

    ATC

    Répondre à ce message

  • 1
    Claure33

    Bonjour,
    J’ai eu aussi un pb de « rang » de webmestre lors de la mise à jour de 3.0.16 vers 3.0.17.
    je voulais vérifier au préalable mon « ordre » dans la hiérarchie des webmestres éventuels de mon site mais je n’ai pas de fichier « infos_perso » sous « ecrire / exec »...
    Puis-je le trouver ailleurs dans mon site (qui est maintenant sous 3.0.17 avec les logs du webmestre N° 1 sans doute...) ?
    Merci de vos lumières !

    Claure33

    • je ne comprend pas de quoi vous parlez. Il n’y a pas à ma connaissance de hiéarchie des webmestres au sein de SPIP...

    Répondre à ce message

  • 5

    Bonjour,
    j’installe le nouveau spip et il y a un message d’erreur à l’installation : Parse error : syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ’}’ in /mnt/153/sdb/a/9/prevconseils/ecrire/public/interfaces.php on line 51

    Que puis-je faire ?

    • Salut,

      • quelle est la version de php utilisée sur l’hébergement ? SPIP 3 nécessite PHP 5.1 mini.
      • es-tu certain que tous les fichiers ont bien étés transférés lors de la mise à jour ?
      • quelle méthode as-tu utilisé pour mettre à jour ?
    • bonjour, je suis chez free, j’ai activé la base de donnée mysql. j’ai mis les fichiers à la racine du site et le spip 3 ne marche pas. Le spip 2 marche par contre. y a t’il un bug ?

    • Bonjour, j’ai le même problème avec SPIP 3 et ovh.
      As tu trouvé une solution
      Merci

    • il faut vérifier que php 5 soit activé.

      voir ici des tuto selon différents hébergeurs, dont OVH http://wiki.pluxml.org/index.php?page=Activer+PHP5+sur+votre+h%C3%A9bergement

    • Merci parfait
      j’ai ajouté dans .htaccess a la racine du site

      SetEnv PHP_VER 5
      #PHP Version 5.2.17
      SetEnv PHP_VER 5_3
      #PHP Version 5.3.16
      SetEnv PHP_VER 5_4
      #PHP Version 5.4.6
      SetEnv PHP_VER 5_5
      #non fonctionnel -> PHP Version 5.2.17

    Répondre à ce message

  • 6

    Bonjour,
    je viens de migrer de spip 2.1.26 à 3.0.17 eu suivant les recommandations suivantes : http://www.spip.net/fr_article5693.html

    Tout semblait fonctionner après installation des plugins compatibles spip 3.

    Mais je viens de rencontrer un problème : je ne peux ni télécharger de documents joints dans l’espace privé

    (Erreur SQL 1054
    Unknown column ’segments’ in ’order clause’
    SELECT id_objet, type, url FROM spip_urls WHERE ((url IN (’spip/ecrire’,’spip’))) ORDER BY segments DESC, id_parent)

    ni voir ceux des anciens articles

    (Erreur SQL 1054
    Unknown column ’documents.statut’ in ’where clause’ ...)

    Merci d’avance pour d’éventuelles solutions !
    Djimel

    • J’ai moi aussi eu systématiquement cette erreur - Unknown column segments - dans certains écrans quand je passe dans l’Espace privé, par exemple sur Édition. Auteurs. Modifier, ou Sauvegarder la base.

      Erreur SQL 1054
      Unknown column ’segments’ in ’order clause’
      SELECT id_objet, type, url FROM spip_urls WHERE ((url IN (’monChemin’,’monDossier’))) ORDER BY segments DESC, id_parent

      L’erreur est aussi enregistrée dans le fichier mysql.log

      Aug 05 15:32:21 172.31.42.168 (pid 19766) :Pri:ERREUR : Unknown column ’segments’ in ’order clause’ -
      SELECT id_objet, type, url
      FROM `maBase`.spip_urls
      WHERE url=’.’
      ORDER BY segments DESC
      Aug 05 15:32:21 172.31.42.168 (pid 19766) :Pri:ERREUR : Unknown column ’segments’ in ’order clause’ - query inconnue
      Aug 05 15:32:21 172.31.42.168 (pid 19766) :Pri:ERREUR : Erreur 1054 de mysql : Unknown column ’segments’ in ’order clause’

      J’ai vérifié les champs de la table spip_urls d’une nouvelle installation, et j’ai vu que ces champs sont bien présents, alors qu’ils étaient... totalement absents de la table de mon site...

      Solution de contournement : ajouter les champs manquants à la main...

      ALTER TABLE `spip_urls` ADD `segments` INT ;
      ALTER TABLE `spip_urls` ADD `id_parent` INT ;

    • peux tu ouvrir un ticket sur http://core.spip.org ?

    • (D’accord, je vais y ouvrir un ticket core.spip.org quand j’en aurai * le temps.)

      Dans l’immédiat, je remarque que l’erreur est aussi arrivée à d’autres, comme cela est indiqué ici :
      http://forum.spip.net/fr_256790.html
      https://www.mail-archive.com/spip@rezo.net/msg48467.html

      mais l’erreur semble assez rare.

      * et que j’y aurai un compte actif : « Votre compte a été créé et attend l’approbation de l’administrateur. »

    • Salut, avant de suivre le conseil de maieul et de créer un rapport de bug, le mieux est de tenter une réparation de la base depuis la page de maintenance de l’espace privé, puis un passage par la page d’admin des plugins.

      Si après cela le bug est toujours présent, tu pourras créer un ticket en fournissant le maximum d’informations sur l’environnement utilisé :)

    • N’ayant pas vu ce message tout récent et ne connaissant pas l’outil de maintenance *, j’ai donc toutefois ouvert la demande : http://core.spip.org/issues/3340

      * je vais essayer maintenant...

    • Bonsoir...
      février 2015 :
      Je viens de réessayer une migration vers spip 3.03.17
      Tout fonctionne sauf encore l’apparition des documents joints dans l’espace public (et également le plugin calendrier_mini...mais c’est moins grave).

      Avez-vous une solutions ?

    Répondre à ce message

  • 3

    Je suis professeur de français langue étrangère et webmestre du site de mon collège en Espagne. Nous avons eu deux attaques de hackers pendant l’année 2014 en utilisant la version de SPIP 2.1.12 et donc j’ai décidé de migrer à la version 3.0.17 pour améliorer la sécurité et la qualité de notre site. Mais le problème est que je suis professeur et non pas, évidemment, expert en informatique ni programmation. J’ai suivi toutes les indications de l’article « changer à la version majeure de SPIP » mais quand j’avais réussi à publier notre site sur SPIP 3 il apparaît à plusieurs reprises le message suivant :

    Strict Standards : date() : It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ’Europe/Berlin’ for ’CET/1.0/no DST’ instead in /homepages/13/d362295941/htdocs/ecrire/inc/auth.php on line 300

    J’ai consulté avec notre hébergeur qui nous indique qu’il manque sur SPIP la fonction date_default_timezone_set(). Je suis déjà un peu désespéré. Est-ce que quelqu’un peut me donner un piste pour résoudre ce problème ?
    Merci

    • l’hébergeur devrait régler lui-même ce timezone au niveau de PHP... bref, en attendant le + simple est sans doute que tu utilise le plugin timezone Timezone

    • Merci beaucoup, je vais essayer. Si ça marche, je répondrai dans ce forum :D

    • Réussi ! Je suis ému, je pensais que n’y ariverais pas. Un grand merci. Muchas gracias desde España.

    Répondre à ce message

  • Bonjour,

    Toujours aussi sympa !

    Après la méthode manuelle, j’ai essayé celle automatique et toujours problème...
    Avec « spip_loader.php » à la racine de mon site qui ne fonctionne toujours pas , cela donne :
    "Téléchargement de SPIP
    Le chargement a échoué. Veuillez réessayer, ou utiliser l’installation manuelle.
    spip_loader 2.5.3"
    Mais que nenni dans les deux cas...

    Pages perso FREE : PHP version version 5.1.3RC4-dev

    Est-ce que quelqu’un a réussi à installer SPIP 3.0.17 sur les Pages perso de FREE puis à transférer avec succès son site local (moi sous LAMP) vers son site distant avec SUCCÈS ?
    Si oui, avec quelle procédure, manuelle ou automatique, détaillée ?

    Merci.

    Répondre à ce message

  • Bonjour à toute l’équipe de Spip. Je viens de passer mon site sous spip 3 depuis le 28 août 2014. Mon site n’est pas encore entièrement au point mais il semble que tout se passe bien. Je viens d’essayer l’outil de sauvegarde et de restauration !

    Tout cela pour dire que je félicite tout l’équipe de développeurs, de bénévoles, de relecteurs, de traducteurs, etc, etc... en fait, toute la communauté de spipiens et spipiennes qui ont contribué d’une manière ou d’une autre.

    Merci à tous et toutes de nous faire profiter de ce superbe CMS et outil (le meilleur selon moi) !

    Et bonne rentrée à chacun !!

    http://www.frsel.be

    Répondre à ce message

  • 1
    Renée Picard

    Est-ce qu’il y a une mise à jour pour la branche 2.1. Le site est en 2.1.24
    Merci

    • Pour l’instant, il n’y a pas de nouvelle mise à jour pour la branche 2.
      Il est possible qu’une version de maintenance sorte prochainement.

      La version stable pour cette branche 2 est SPIP 2.1.26.

    Répondre à ce message

  • 1

    Bonjour

    J’ai, comme je l’ai fait à chaque fois pour mettre à jour Spip, téléchargé SPIP que j’ai transféré à la racine de mon site et quand j’ai voulu revoir mon site, j’ai eu le message suivant :

    Fatal error : Call to undefined function include_once_check() in /home/kwartz/www/vanheckedk/tmp/cache/charger_plugins_options.php on line 5

    que faire ?

    Merci

    • Désolé, problème résolu..... j’avais transmis un ancien dossier SPIP avec une version antérieure.....

      Merci

    Répondre à ce message

  • bonjour,

    version 2.5.2 du spip loader et version 31 de firefox. Je suis auteur numéro 3 avec tous les droits.

    J’ai changé le spip_loader.php :

    define(’_SPIP_LOADER_UPDATE_AUTEURS’, ’1’) ;
    par :
    define(’_SPIP_LOADER_UPDATE_AUTEURS’, ’1:3’) ;

    j’ai aussi testé

    define(’_SPIP_LOADER_UPDATE_AUTEURS’, ’1’) ;
    par :
    define(’_SPIP_LOADER_UPDATE_AUTEURS’, ’3’) ;

    Et ça ne change pas : ça boucle...

    Merci de vos réponses

    fred

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 11 avril 2015