Plugin Logo SVG : pouvoir utiliser des logos SVG

Le SVG est un format vectoriel donc très léger et redimensionnable sans pertes, mais SPIP ne l’acceptait pas sur les logos. Ce plugin comble ce manque.

Installation

Si vous n’avez pas déjà le dépôt externals dans votre SPIP, ajoutez le dépôt https://files.spip.net/externals/archives_externals.xml pour trouver le plugin automatiquement.

Crédits

Une bonne partie du code du plugin a été reprise du core de SPIP et réadaptée pour gérer les SVG.

Comment contribuer ?

Le plugin est disponible sur GitHub pour vos forks : https://github.com/cariagency/spip-....

Dernière modification de cette page le 2 avril 2019

Discussion

10 discussions

  • 1

    @julien je viens de faire une pull request pour une 1.3.0 si tu as le temps

    Répondre à ce message

  • 2
    Yannick

    Bonjour et merci pour ce plugin.

    Je m’en sers pour des drapeaux de pays (genre https://commons.wikimedia.org/wiki/...) mais je constate que la méthode ->sanitize() ne prend pas en compte la balise « use » (qui est fréquemment utilisée dans ces SVG) car non présente dans la class AllowedTags.
    Y a-t-il une raison pour ça ?

    Localement j’ai ajouté « use » dans la liste de getTags() ; si ça ne pose pas de problème connu, peut-être faudrait-il l’ajouter dans le plugin pour que les images soient correctement rendues ?

    Répondre à ce message

  • 1

    Pour info : la version 1.2.1 fait planter l’affichage des pages ?exec=rubrique et ?exec=article sur un serveur en PHP 5.3.3
    Contournement possible : régresser le plugin en 1.0.0 (et donc perdre la fonction de sanitization des fichier uploadés)
    (désolé pour la pauvreté du débog : je n’ai pas la main sur la machine en question...)

    • Argh désolé cy_altern, je n’ai rien pour tester en dessous de 5.4.45 pour tester et cela fonctionne.

      5.3.3 c’est quand même très vieux :(

    Répondre à ce message

  • 2

    Vite, une version pour Spip 3.2 !
    Merci pour le boulot...

    Répondre à ce message

  • 2

    Bonjour,

    Un fichier SVG peut contenir un script JS malicieux : y a-t-il une analyse du contenu SVG au moment de l’importation dans SPIP ?
    Il me semble que non, mais je suis peut-être passé à côté ;-)

    Merci !!
    françois

    Répondre à ce message

  • Bonjour et merci pour cet outil !

    françois

    Répondre à ce message

  • 1

    Hello,

    J’utilise le plugin http://contrib.spip.net/Formulaire-d-upload-en-html5 et dans ce cas l’upload de logo d’un article ou d’une rubrique ne fonctionne pas : le logo n’apparaît pas et il n’est pas mis sur le serveur non plus.
    Par contre pour un document cela fonctionne. Mais alors le document n’est pas vu comme une image et la vignette n’est pas créée. Je ne sais pas si c’est génériquement possible ou pas avec un svg.

    dd

    • Bonjour DD,
      je viens d’apporter les modifs au plugin upload html5, mais avant il faut que Julien merge une modif sur le plugin logo_svg cf. ma demande

    Répondre à ce message

  • Bonjour Julien,
    je viens d’apporter une petite modification de ton plugin afin de pourvoir utiliser 1 fonction dans d’autres plugins, notamment, upload html5. J’ai fait un pull request sur ton dépot github.
    Si la modif te convient, pourrais tu merger afin que je puisse commiter ma modif sur le plugin uploadhtml5.

    Merci et bonne journée

    Répondre à ce message

  • 2

    Un grand merci pour ce plugin ! Je cherchais une solution simple et propre pour résoudre le problème de logo flou sur les écrans à haute densité de pixels (type retina), le plugin répond parfaitement au besoin.

    Par contre, je n’ai pas pu installer le plugin directement depuis l’interface de SPIP, il était introuvable. J’ai du saisir l’url de l’archive zip (http://files.spip.org/externals/logo-svg.zip) dans la section « Télécharger un plugin depuis son archive », puis activer manuellement le plugin.

    • J’ai repéré une incompatibilité avec le plugin Massicot (qui permet aux rédacteurs de recadrer les images dans l’interface admin de SPIP). Lorsque celui-ci est activé, les balises d’affichage d’image sur le front office (j’ai testé #LOGO_SITE et #LOGO_ARTICLE) n’affichent plus rien.

    • Merci pour ce retour associate-it

      Pour installer le plugin automatiquement (solution recommandée), il faut que tu aies activé le paquet http://files.spip.org/externals/archives_externals.xml dans SPIP.

      Pour le problème avec Massicot, peux-tu ouvrir une issue sur GitHub ?

      Bonne journée !

    Répondre à ce message

  • 1

    Salut, juste une question : je ne vois nul part dans le code du plugin une surcharge de la balise #LOGO_ARTICLE, du coup est-ce que l’affichage d’un logo SVG fonctionne bien quand on utilise la balise native ?

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom