Mediatheque pour SPIP 2.0

Un plugin pour gérer tous vos documents de façon centralisée.

Pour les fonctionnalités et la documentation se référer à l’article Médiathèque

Discussion

8 discussions

  • Bonjour,

    Comment contrôler la diffusion exterieur avec le plugins médiathèque ? Existe t’il un attribut associé à un document pour qu’il ne soit vu qu’en interne du site et pas dans la liste des documents téléchargeable ?

    Merci de votre aide,

    Répondre à ce message

  • laurent

    Jusqu’à présent le plugin fonctionnait bien et là au retour de vacances, lorsque je veux acceder à la médiathèque voici le message :

    Warning : Missing argument 1 for interdire_scripts() in /mnt/108/sda/3/f/challengedesmonts/ecrire/inc/texte.php on line 416

    Comment résoudre et surtout d’où vient le prob.

    Merci

    Répondre à ce message

  • 4

    étrange message après installation du zip par ftp

    Impossible d'activer le plugin ../plugins/auto/mediatheque_spip_2_0
    Nécessite SPIP en version [2.0.10;2.1) minimum.

    version SPIP 2.1.10 [17657]

    Répondre à ce message

  • demande de fonctionnalité

    Au niveau de la table des documents il est possible d’avoir un champ entier id_parent ;)
    Par contre, peut-on facilement faire ressortir cela dans l’interface au niveau de la page d’édition des documents ? :)

    J’explique rapidement le besoin/intérêt de la chose.
    Certains documents sont en plusieurs versions ou format...

    • Par exemple (vécu), un même document texte peut être proposé en PDF, ODT, DOC et RTF. Il est alors intéressant de pouvoir les grouper dans une boucle (où ils auraient le même id_parent) pour offrir un tableau présentant les formats et taille téléchargeables sans avoir à faire des tests sur les noms et titres de fichiers. Un autre usage est qu’on pourrait utiliser la vignette du document parent et ne pas encombrer le serveur avec la même vignette plusieurs fois ou manquer d’image personnalisée sur certains documents alors que d’autres au même contenu (mais formaté en interne autrement) en ont :/
    • On pourra, dans les vidéos et audios accessibles (en utilisant les balises HTML de même nom) spécifier une source principale (la première) et des sources (en fait formats en ce qui me concerne) alternatives... J’ai le cas sur un site où trois vidéos sont en deux ou trois encodages/formats mais qu’on ne sait pas gérer simplement avec SPI à l’heure actuelle :(

    Répondre à ce message

  • ERREURS MYSQL
    ------------------------
    J’ai régulièrement dans les logs un message Table’xxxxxxxxxx.POUR’ doesn’t exist dans lequel médiathèque semble mélé
    Dernier exemple en date

    Aug 06 17:05:38 82.252.202.29 (pid 17055) calcul (9.956 ms) [../plugins/auto/mediatheque/prive/inc-ajouter-documents] exec=portfolio, lang=fr, date='2011-08-06 17:05:38', date_default=1, date_redac='2011-08-06 17:05:38', date_redac_default=1 (345 octets)
    Aug 06 17:05:38 82.252.202.29 (pid 17055) Erreur mysql 1146
    Aug 06 17:05:38 82.252.202.29 (pid 17055) Table 'agriculturedeco.POUR' doesn't exist - SHOW CREATE TABLE `POUR`
    Aug 06 17:05:38 82.252.202.29 (pid 17055) trouver_table: table inconnue '' 'POUR'

    SPIP 2.1.10 [17657] - Médiathèque 1.6.7

    Une idée de ce qui se passe ?

    Répondre à ce message

  • Bonjour, le plugin Mediathèque change l’affichage privé d’édition des articles et on n’a plus accès a l’édition rapide des titres/descriptif, le lien « modifier » ouvre une nouvelle fenêtre, ce qui est un peu fastidieux, ne serait-il pas possible de garder le portfolio de spip en ajoutant un lien spécifique pour les modifications pointues ? ou une astuce sinon ?

    merci

    Répondre à ce message

  • magnifique !
    cédric, ton plug-in m’a permis de dégager un paquet de méga-octets du serveur simplement en nettoyant les images inutilisées par un site où s’entassent les fichiers par centaines.
    merci à toi ;-)

    Répondre à ce message

  • 1

    ne veux pas s’initialiser avec spip 2.1.1 !

    • jcdeloffre

      cette version du plugin est pour spip 2.0. Il existe une autre version pour spip 2.1

      Par contre je ne parviens pas à activer le plugin avec spip 2.0.9. Est-ce normal ?

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 19 avril 2011