Spip 2.1 est sorti

SPIP 2.1 sort aujourd’hui, ce jour exceptionnellement ordinaire
qui est le 100e jour de l’année. Tout savoir sur cette nouvelle version et la télécharger.

Nous avions envisagé de la sortir le 14 février ...

Nous avions également envisagé de la sortir le 1er avril ...

Elle sort finalement aujourd’hui, ce jour exceptionnellement ordinaire
qui est le 100e jour de l’année.

Cette version est téléchargeable depuis l’adresse habituelle
http://www.spip.net/fr_download

Pour savoir ce que contient cette version, rendez vous sur l’article
de spip.net concocté
spécialement pour cette nouvelle série 2.1 :
http://www.spip.net/fr_article4728.html

Une version 2.0.11 de maintenance sortira sous peu si vous
voulez rester dans la série 2.0

Une rencontre SPIP est prévue du 13 au 16 mai, tous les détails
sont ici http://spip-party.net/Troglo-2010 , n’hésitez pas à vous
inscrire !

Dernière modification de cette page le 9 février 2019

Discussion

42 discussions

  • bennett

    Passage de « édit » à « voir » lors de l’édition d’un article : nouveauté bienvenue !
    Chez moi, cela donne une page blanche avec IE8 ; pas de problème avec Firefox.

    Répondre à ce message

  • Salut à tous, après avoir fait la migration, dans l’espace privé je n’arrive plus avoir accès à la liste des plugins.

    Est ce que ce problème est général.

    Répondre à ce message

  • 1

    Bonjour,

    Bon, voici le résultat des tests faits en local :

    • Lecteur multimedia : les play-listes audio et vidéo ne fonctionnent pas. Une erreur dans un filtre du modèle play-liste video notamment :

    [(#INCLURE{fond=#GET{skin}}|compacte_css)]

    Le filtre compacte_css

    • Forms & tables : impossible d’écrire dans les champs des formulaires que l’on crée.

    Sinon, tous les plugins que j’ai testés fonctionnent.

    @ bientôt !
    KMk.

    • ... rectification : la play-liste audio fonctionne, mais pas la play-liste vidéo...

      KMk.

    Répondre à ce message

  • 1

    Bonjour,

    Après le plugin crayon,c’est le plugin Thickbox qui ne fonctionne plus, ou plutôt l’activation du script associé, du moins je présume.

    Il faudra bien quelques jours aux uns et aux autres pour rendre leurs plugins compatibles à cette nouvelle version, patience... et merci à tous.

    • Concernant le plugin crayon, ça se précise un peu. C’est en fait l’activation du #INSERT_HEAD depuis le couteau suisse qui me désactive cette fonctionnalité. Et il y a des chances que le problème vienne aussi de là concernant le plugin thickbox. Edit : Les instructions de cette balise rentraient en conflit avec celles précisées dans mon head, notamment concernant le JQuery. tout est rentré dans l’ordre en récupérant le inc_head d’origine de spip 2.1.

    Répondre à ce message

  • 2

    C’est presque parfait ! Sauf pour le plugin « publication ouverte » qui m’offre ce joli bug :

    Fatal error : Cannot redeclare execute_pipeline_op_squelette() (previously declared in /home/www/client/www/tmp/cache/charger_pipelines.php:567) in /home/www/client/www/tmp/cache/charger_pipelines.php on line 584

    Pour m’en sortir j’ai du effacer, par ftp, le plugin publication ouverte et effacer le fichier « charger_pipelines.php » dans le dossier tmp/cache

    mais j’ai besoin de ce plugin. Quelqu’un a-t-il une solution ?

    • Ce ne serait pas une histoire de cache, ça ? Qu’est-ce que ça donne en effaçant les fichiers de tmp (sauf tmp/dump, bien sûr ) ?

    • Effectivement, cela ne se produit que quand je vide le cache dans la partie privée. mais c’est très ennuyeux ! et ça ne règle pas mon problème

    Répondre à ce message

  • 2

    Bonjour,

    J’ai noté un problème de compatibilité entre les plugins CKEditor et porte_plume.
    Lorsque je crée un nouvel article, la fenêtre où j’écris le texte se divise en deux et propose les deux barres d’outils (cf. la capture d’écran).

    * Ma première tentative de résolution a été de configurer CKEditor en cochant la case « uniquement ce mode ». Aucun résultat.

    * Ma seconde tentative de résolution fut plus radicale : supprimer porte_plume (dans le répertoire extensions). Cette fois-ci cela fonctionne : je n’ai plus que la barre d’outils CKEditor.

    Sachant que je n’utilise que CkEditor, cette solution me convient. Je suppose que cela ne sera pas le cas de tous.

    Enfin, vous remarquerez sur la gauche la présence d’une image « Nec.bmp ». Bizarrement, je n’ai pas chargé celle-ci et elle a été effacée du serveur depuis belle lurette.

    * J’ai vidé le cache pour voir si cela résoudrait le problème. Rien.

    * J’ai alors crée et sauvegardé un article test. Spip m’a indiqué que le document présent dans le porte-folio était introuvable. Je l’ai supprimé. Finalement, j’ai crée un second article test : l’affichage de l’image « Nec.bmp » n’apparait plus.

    Désolé si mes solutions font plus penser à du bricolage, je n’ai pas mieux à proposer pour le moment.

    • Pour voir la capture d’écran en plus grand :
      http://bayimg.com/HalDOaaCn

    • Ravanelli93

      même pb que toi et j’ai essayé de trouver une soluce en vain. je suis donc repassé en FCKEditor qui semble être plus stable avec cette version 2.1.0.

    Répondre à ce message

  • Grizzly

    Bravo pour cette nouvelle version de SPIP. Migration de 130k articles passée sans problème, mise à jour des plugins sans problème. La charge du serveur semble avoir diminué d’un bon 20 %.

    En revanche nos statistiques ne fonctionnent plus depuis janvier, et la nouvelle version n’a pas réglé le problème, mais j’imagine que c’est une autre histoire.

    Bravo et merci à l’équipe !

    Répondre à ce message

  • 1
    Serguei

    Bonjour,

    Après avoir mis à jour mon site en local j’ai plusieurs erreurs :
    -  certains plugins me renvoyent une erreur lors de l’installation dans l’espace privé, par exemple le plugin facteur :

    Fatal error : Call to undefined function plugin_get_infos() in Z :\www\mon_site\plugins\facteur\base\facteur.php on line 6


    -  le couteau suisse, lorsque je modifie des paramètres m’envoye systématiquement une erreur 403

    Merci d’avance pour votre aide

    Répondre à ce message

  • 2

    Bonjour,

    Je viens d’installer cette dernière mouture de spip pour me rendre compte des évolutions.

    Une petite remarque : on ne dispose pas dans l’interface publique des boutons « Recalculer cette page », « Espace privé », « Voir cet article, » etc... Est-ce normal ?

    Je continuerai les tests quand j’aurai un peu de temps...

    Merci en tout cas pour ce nouveau bond en avant !

    KMk

    • non, vérifiee que le cookie de correspondance est bien posté (page d’acceuil de l’espace privé)

      en tt cas chez moi pas de souci.

      attention aussi : « modifier cet article x » s’intitule désormais « article x »

    • Bonjour,

      De retour d’une saine promenade en forêt... les dits boutons sont apparus... Affaire classée. Je continuerai donc à tester et ferai remonter les remarques !

      KMk...

    Répondre à ce message

  • Gefonline

    Bonjour,

    pour moi la mise à jour a entraîné la disparition des fonctionnalités du plugin crayon côté public, impossible désormais de modifier le texte directement.

    A suivre...

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom