SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

288 Plugins, 197 contribs sur SPIP-Zone, 224 visiteurs en ce moment

Accueil > Améliorations de l’espace privé > Lister les pages de configuration > Lister les extensions PHP chargées > Lister les extensions PHP chargées

Lister les extensions PHP chargées

8 août 2015 – par Teddy Payet – commentaires

1 vote

Ce plugin permet de lister les extensions PHP chargées dans SPIP.

Installation

Ce plugin s’installe comme tous les plugins.
Il nécessite le plugin « Lister les pages de configuration ».

Utilisation


Ici, vous verrez les différentes extensions PHP actives sur votre site (plus exactement sur votre serveur).
Chaque extension PHP présente est cliquable. Après cette action, la liste des fonctions de cette extensions sera visible. Si vous cliquez sur le nom de la fonction, vous serez redirigé vers le site de PHP où vous y trouverez la documentation de cette fonction. Si par hasard cette fonction n’a pas de documentation existante, vous serez alors sur une page de recherche, toujours sur le site de PHP.

De retour sur cette page d’extensions PHP de votre site, il peut arriver que l’extension n’ait pas de fonctions. Une phrase vous le signalera. Quoiqu’il advienne, la phrase sera toujours cliquable pour vous amenez sur le site de PHP.

Voir en ligne : http://plugins.spip.net/lister_exte...

Dernière modification de cette page le 8 août 2015

Retour en haut de la page

Vos commentaires

  • Le 15 juillet à 15:11, par Loiseau2nuit En réponse à : Lister les extensions PHP chargées

    Re- re- :)

    Est-ce qu’il y a des recommandations particulières quand au nombre d’extens. chargées par rapport aux performances, aux spécificités d’hébergement, autre, préciser ........ ?

    Parce que quand je regarde ta capture avec 53 extensions chargées, je regarde ma liste de 440 extensions chargées et je m’interroge... (VPS OVH entrée de gamme, debian apache2, peu de trafic car sites en dev donc fermés au public et aux bots)

    Merci

    • Le 16 juillet à 10:29, par Teddy Payet En réponse à : Lister les extensions PHP chargées

      Re-re,

      Quand j’ai créé ce plugin, j’avais demandé les extensions minimum mais je n’ai pas eu de réponses concluantes. Comme beaucoup dans la communauté, on a la majeure partie du temps la main sur le serveur ou du moins, on crée une installation standard d’une debian ou d’un linux. Donc, on prend les packages tels quels.

      Il faudrait en fait un build de PHP et mettre au fur et à mesure des extensions et ainsi déterminer les extensions minimales pour que SPIP fonctionne sans problème.
      Cela permettrait d’avoir une installation PHP optimisée sur le serveur et ainsi ne pas avoir une configuration de compétition alors qu’on a besoin d’une 2CV. :-D

      Teddy

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Des jeux dans vos articles !

    9 décembre 2006 – 566 commentaires

    Le plugin « Jeux » permet d’insérer dans vos articles des jeux ou des exercices de toute sorte.

  • Qrcode

    3 novembre 2010 – 46 commentaires

    Les QrCodes sont des codes barres lisibles essentiellement par les téléphones portables et permettent d’échanger avec ceux-ci diverses informations, et en particulier des liens. Ce plugin à pour objet de permettre à spip d’utiliser des QrCodes pour (...)

  • Plugin Modèles media

    25 avril 2011 – 180 commentaires

    Les modèles , et produisent chacun un résultat différent et ce résultat, pour les images, dépend du fait qu’elle soit dans le portfolio ou non. Ce plugin propose une nouvelle série de modèles ayant un comportement unifié et indépendant du mode des (...)

  • Speedsyndic pour SPIP 2 et SPIP 3

    11 octobre 2010 – 27 commentaires

    Ce plugin est une version compatible spip 2.0.x / 2.1 / 3.1 du plugin Speedsyndic Note : Une bonne partie du texte ci-dessous a été pompé de cet article, expliquant la version précédente du plugin. je n’ai fait qu’adapter le code pour spip 2, (...)

  • LIM : alléger l’espace privé

    20 avril 2015 – 41 commentaires

    Ce plugin permet de désactiver l’affichage de blocs ou de boutons, présents par défaut dans SPIP mais qui peuvent devenir inutiles dans le cadre de votre projet. Il allège du coup l’interface d’édition et supprime d’éventuels risques de confusion (...)

Ça spipe par là