Vérifier ses plugins avant un changement de version de SPIP

Lister la compatibilité des plugins avec une autre version de SPIP

Ce plugin est le successeur du plugin Vérifier ses plugins pour le passage à SPIP 3.1.

Il permet de vérifier si ces plugins sont compatibles avec des versions plus récentes de SPIP.

Une fois le plugin installé, se rendre dans le menu Maintenance > Vérifier ses plugins ... ou directement à la page :
http://monsite/ecrire/?exec=verifier_plugins

La page liste tous les plugins actifs et leurs bornes de comptabilités.

  • Si un plugin est incompatible, on le signale.
  • Si une version plus récente du plugin est compatible, on le signale et propose la mise à jour.

Avertissement

La vérification de compatibilité des plugins se base sur les informations fournies par les plugins eux-mêmes.
Le plugin ne donne pas de garantie si cette compatibilité est réelle ou non.

Que faire si un plugin n’est pas compatible ?

Si un plugin n’est pas compatible, consulter sa documentation pour savoir si une évolution est envisagée.

Vous pouvez aussi tenter de tester la validité du plugin incompatible vous-même :

  • éditer :
    • le fichier paquet.xml du plugin et modifier la borne de compatibilité
      par exemple compatibilite="[3.0.8;3.1.*]" devient compatibilite="[3.0.8;3.2.*]" pour le rendre activable sous SPIP 3.2
    • si le plugin ne dispose pas de fichier paquet.xml mais d’un fichier plugin.xml, la borne de compatibilité est de type <necessite id="SPIP" version="[1.9.0;3.1.99]" />, à modifier en <necessite id="SPIP" version="[1.9.0;3.2.99]" /> pour le rendre activable sous SPIP 3.2
  • enregistrer votre modification
  • tester si le plugin fonctionne bien
  • si c’est le cas, signalez le sur les forums du plugin en question

Éventuellement vous pouvez demander à son auteur de le rendre compatible avec la version demandée ou le faire vous-même si vous avez les compétences ...

Discussion

Une discussion

  • 1

    ah super ...

    mais on m’a parler aussi d’un truc pour forcer la compat sans toucher aux bornes pour réaliser un test.

    un define a mettre dans mes_options.php, tu n’en parle pas dans ton article , c’est volontaire ?

    • En SPIP 3.2 , le gestionnaire de plugins SVP propose un mode de compat forcée qui permet effectivement d’activer des plugins encore bornés à 3.1 (j’ai pas testé en 3.1)

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 2 novembre 2018