SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

286 Plugins, 197 contribs sur SPIP-Zone, 293 visiteurs en ce moment

Accueil > Administration et BDD > SVP > STEP - Système de Téléchargements de Plugins

STEP - Système de Téléchargements de Plugins

17 février 2011 – par Matthieu Marcillaud, Suske – 41 commentaires

54 votes

Màj du 14 mars 2012 :

En l’état actuel, STEP est devenu peu utilisable. Les bugs soulevés dans les forums ci-dessous et d’autres sont connus mais le développement de STEP est arrêté.

En effet, ce plugin a été intégré à l’extension SVP) qui gère les plugins dans SPIP 3. De ce fait, une série de normes ont été définies pour SVP qui ont un impact sur les outils « serveur » de gestion des plugins (dont archives.xml). Ces modifications ont été faites dans le souci de maintenir la compatibilité avec la gestion des plugins intégrée à SPIP 2 mais, logiquement, pas celle avec STEP.

Du coup, STEP est un bel outil pour SPIP 2 qui fonctionne moins bien en 2012 sous spip 2.1.12 qu’en 2010 sous spip 2.0... Son auteur original n’y touchera plus vu qu’il consacre son temps disponible à l’avenir plutôt qu’au maintien de l’existant., mais le source du plugin est sur la zone et si d’aucun-e-s veulent y corriger les bugs, « il n’y a qu’à ».


STEP est un outil permettant de télécharger des plugins de SPIP2 en gérant leurs dépendances et en proposant de les télécharger également. Il permet de plus de déterminer les plugins à mettre à jour et de les effectuer. Il permet enfin de supprimer (physiquement) les plugins.

Nécessaire

Pour bien fonctionner, STEP nécessite un répertoire lib/ et un répertoire plugins/auto/ dans lequel le serveur peut écrire. STEP est programmé pour ne pas écrire en dehors du répertoire plugins/auto/.

Présentation

Ce système STEP vient en complément du système d’installation de plugin présent dans SPIP 2.1. Il permet de sélectionner une liste de plugins (ceux archivés sur la Zone) et en analyse le contenu [1]. En comparant avec les plugins déjà présents sur le site, STEP peut déterminer les mises à jour qui existent et les proposer.

PNG - 31.7 ko
Après l’installation, STEP est accessible via « Configuration » dans l’espace privé
PNG - 15.5 ko
Pour être opérationnel, STEP doit connaître la ou les listes de plugins : on ajoute celle proposée en exemple
PNG - 10.6 ko
La zone étant connue par STEP, il reviendra au webmestre de l’actualiser si nécessaire.

Utilisation

STEP propose une interface de recherche dépliable. La recherche en texte libre peut être orientée par type de plugin mais aussi selon l’emplacement du plugin ou l’état de développement.

PNG - 47.9 ko
Recherche d’un plugin - Cliquer sur le nom ouvre la description
PNG - 47.4 ko
La sélection peut être multiple : le système est modifié seulement via le clic sur « Appliquer les modifications »
PNG - 13.9 ko
Activation de deux nouveaux plugins
PNG - 17.5 ko
Les modifications ont été appliquées - Recharger la page est nécessaire

A l’installation d’un plugin, STEP indiquera la liste des éventuelles dépendances à d’autre plugins, qu’il téléchargera pour vous.

PNG - 14 ko
Installation de « Soyez créateurs » : STEP sélectionne automatiquement la dépendance « Fonctions d’images »

De même lors d’une désinstallation ou désactivation d’un plugin, il indiquera que certains plugins en dépendent, et proposera alors de les désactiver proprement dans la foulée.

PNG - 26.8 ko
Gestion de dépendances lors de la désactivation de SPIP-Bonux sur un site d’exemple
Pour éviter les dégâts, il suffit de cliquer sur « Annuler » :-)

Fonctionnement des mises à jour

STEP dispose de la liste des plugins présents dans extensions/, plugins/ (et donc plugins/auto/). Il dispose également de la liste des plugins existants (sur la Zone).

Pour savoir si une mise à jour existe, il regarde :

  • le préfixe (qui doit être identique)
  • la version de SPIP nécessaire au plugin (qui doit fonctionner avec le SPIP utilisé)
  • la version du plugin existant (qui doit être supérieure au plugin installé)
  • l’état du plugin (stable, dev, test...) qui doit être supérieur ou égal à celui du plugin installé.

Ainsi l’on a un « agenda, stable, 1.12 », et qu’il existe un « agenda, test, 1.13 », STEP ne proposera pas la mise à jour automatiquement, puisque le plugin de version supérieure existant a un état de stabilité inférieur.

PNG - 14.4 ko
Une nouvelle version « supérieure » de Champs Extra 2 est disponible
PNG - 16.7 ko
Cliquer sur « Mettre à jour » inscrit l’opération comme devant être réalisée
PNG - 51.2 ko
Il reste possible de faire d’autres manipulations avant de valider les changements

Tout plugin est installé dans plugins/auto/

STEP installe ou met à jour les plugins dans le répertoire « plugins/auto/ ». Si un « plugins/xx » peut être mise à jour et que vous l’acceptez, STEP installera la nouvelle version de ces plugins dans plugins/auto/xx et activera ce plugin à la place de l’ancien. STEP ne touche donc pas les plugins en dehors de plugins/auto/.

Par contre, tout plugin déjà dans auto/ et pouvant être mis à jour sera mis à jour dans ce répertoire (et les fichiers obsolètes seront effacés).

Note importante ou Todo : Il faudra peut être envisager de dupliquer l’ancien plugin au lieu de le mettre à jour en le renommant à la date de la mise à jour suivant ce schéma :

  • plugins/auto/xx est à mettre à jour ;
  • il est dupliqué dans plugins/auto/xx.date
  • plugins/auto/xx est mis à jour

De la sorte, si un problème survenait, on pourrait toujours revenir à l’état précédant une mise à jour... au moins manuellement par FTP.

Les extensions

Nous avons choisi arbitrairement que STEP ne puisse pas toucher aux extensions : il ne propose donc pas automatiquement les mises à jour (même si l’icone de mise à jour pour l’extension reste visible).

Néanmoins (à vos risques et périls) il suffit dans les options de recherche de cocher « plus récents : tous », pour que les plugins plus récents que votre extension à mettre à jour s’affichent ; ils peuvent alors être activés (ce qui désactivera l’extension au profit du plugin plus à jour)...

Avenir...

Il est prévu de reprendre ce plugin et son fonctionnement et de le coupler aux travaux d’Eric sur « SVP » (système de visualisation de plugin), mais ce (gros) chantier n’est pas réalisé. En l’état actuel (v0.13.x de STEP), ces deux plugins sont totalement incompatibles.

Aussi STEP est donc voué à être profondément modifié pour interagir avec ce nouveau système de recherche de plugins (SVP).

Dans ce contexte, le développement de STEP est ainsi actuellement gelé et proposé sous statut "En développement". Il est fonctionnel sous 2.1 mais comporte très probablement encore des bugs. N’hésitez pas à les signaler dans le forum, selon les disponibilités de chacun, ils seront corrigés ou non :)

Voir en ligne : http://plugins.spip.net/step

Notes

[1qu’il stocke dans une table SQL spip_plugins

Dernière modification de cette page le 11 juin 2012

Retour en haut de la page

Tout afficher

Vos commentaires

  • Le 2 mars 2012 à 14:41, par Jean-Baptiste Pressac En réponse à : STEP - Système de Téléchargements de Plugins

    Hello,
    J’ai installé STEP 0.15.6 sur SPIP 2.1.12 et configuré l’utilisation de la zone de dépôt par défaut (http://files.spip.org/spip-zone/archives.xml). Par contre, les recherches de plugins ne renvoie pas toujours des résultats pertinents.

    Par exemple, une recherche sur « bonux » renvoie « Spip-Bible » (alors que le mot clé ne figure pas dans le descriptif du plugin) et « Thèmes interface privée » mais pas « SPIP Bonux » ou encore, « menu » ne retourne pas « Menus » ou Menu de langues sous forme de liens.

    Est-ce dû à la manière dont ces plugins sont déclarés dans le fichier XML ?

    Jean-Baptiste

    • Le 3 mars 2012 à 14:58, par Suske En réponse à : STEP - Système de Téléchargements de Plugins

      Salut,

      En l’état actuel, STEP est devenu moins (peu) utilisable. Les bugs que tu soulèves et d’autres sont connus mais Matthieu ne le développe plus pour des raisons très compréhensibles : ce plugin a été réécrit et intégré à l’extension SVP (http://zone.spip.org/trac/spip-zone...) qui gèrera les plugins dès spip 3. Une série de normes ont été définies pour SVP qui ont un impact sur les outils « serveur » de gestion des plugins (dont archives.xml). Ces modifications ont été faites dans le souci de maintenir la compatibilité avec la gestion des plugins intégrée à SPIP 2 mais, logiquement, pas celle avec STEP. Celui-ci est un plugin et c’est à lui de s’adapter aux évolutions de SPIP, pas l’inverse :-p En outre, des corrections au core de spip ont aussi eu un impact sur l’utilisabilité de STEP.

      Du coup, bon, ben c’est un bel outil pour SPIP 2 qui fonctionne moins bien en 2012 sous spip 2.1.12 qu’en 2010 sous spip 2.0... Il est sur la zones et si d’aucun-e-s veulent y corriger des bugs, c’est la zone, « il n’y a qu’à ». A ma connaissance, Matthieu n’y touchera plus vu qu’il consacre son temps disponible à l’avenir plutôt qu’au maintien de l’existant.

      Personnellement, je suis incapable d’aider à ça : j’ai fait la présente doc avec Matthieu alors que STEP existait déjà depuis... longtemps, en me disant qu’il fallait partager ça. Je t’avoue que de mon côté, SPIP3 commence à être la norme sur mes sites perso aussi et sur mes 2.1.12 j’ai désactivé STEP ou, en tous les cas, je repasse par l’admin classique de gestion des plugins après avoir utilisé STEP car certaines tâches d’activation semblent aussi ne plus aboutir sous STEP...

      Voilà, voilà.

      Vivement SPIP3 (qui motorise le présent site depuis quelques semaines déjà :-) ) !

    • Le 5 mars 2012 à 14:52, par Jean-Baptiste Pressac En réponse à : STEP - Système de Téléchargements de Plugins

      Merci pour ces informations, Surke.
      Jean-Baptiste

    • Le 23 avril 2013 à 16:23, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      C’est rigolo, je viens de tester sur un 2.1 et STEP semble parfaitement fonctionner contrairement à ce que j’aurais pu croire.

      Et si le plugin « spip-bible » ressort lorsque tu cherches « bonux », c’est bien parce que le descriptif du plugin cite « spip-bonux ».

      Bref. Je suis étonnamment surpris, mais j’ai bien l’impression que ça fonctionne encore.

    • Le 23 avril 2013 à 16:44, par Suske En réponse à : STEP - Système de Téléchargements de Plugins

      Sincèrement, je ne me souviens plus, je n’ai plus de 2.1 depuis 10 mois ^^

      Mais bon, il y avait des bugs ci et là qui obligeaient de temps à autre à passer par l’interface SPIP pour mettre à jour, des màj non notifiées par STEP, ce genre de choses. Il y a encore eu une remarque de ce type il y a quelques jours sur les listes (ou forum ?) : un plugin annoncé à jour alors qu’il en est à x versions depuis lors.

      Après, oui je l’utilisais toujours pour l’installation des plugins. De mémoire ;-) Donc, si tu fait un autre constat, corrige l’article (et je pars me flageller). Mais OK STEP a toujours été utilisable : c’est pourquoi j’ai écrit « moins utilisable » (puis « peu utilisable »), cette dernière formule étant trompeuse peut-être. Je ne sais plus.

    • Le 23 avril 2013 à 17:33, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      Bah on a corrigé tellement de choses dans SVP que ça m’étonne qu’à moitié. D’ailleurs je pensais même que STEP ne pouvait plus fonctionner (hors plugins locaux), mais il arrive toujours à rechercher et choper des plugins distants et les télécharger. C’est bien que ça doit fonctionner encore un peu :)

    Répondre à ce message

  • Le 28 avril 2012 à 15:16, par Corrobori En réponse à : STEP - Système de Téléchargements de Plugins

    Hello,

    est-ce que la chaine de langue

    l’ensemble des actions demandées ont été réalisées

    est encore présente dans spip 3 ? Avec une recherche rapide je n’ai pas trouvé. Si tel est le cas on modifiera en

    l’ensemble des actions demandées a été réalisé

    Répondre à ce message

  • Le 16 août 2011 à 00:14, par DD En réponse à : STEP - Système de Téléchargements de Plugins

    Bonjour,

    En mettant à jour
    STEP Version
    0.15.2 (dernière version : 0.15.3)

    (vu sur 2 sites en SPIP 2.1.10 [17657])
    ... avec STEP

    tous les autres plugins sur la page ecrire/ ?exec=step deviennent grisés
    comme s’ils étaient désactivés
    par contre les sites semblent fonctionner correctement (après vidange du
    cache)

    Petit bonus :
    message d’erreur après mise à jour du plugin Bonux revision 49254 3 juillet 2011 (avec le gestionnaire de plugins)

    Warning : constant() [function.constant] : Couldn’t find constant in /srv/d_site/www/www.site.fr/htdocs/plugins/auto/step/inc/step_actionneur.php on line 560

    Warning : Cannot modify header information - headers already sent by (output started at /srv/d_site/www/www.site.fr/htdocs/plugins/auto/step/inc/step_actionneur.php:560) in /srv/d_site/www/www.site.fr/htdocs/ecrire/inc/actions.php on line 212

    dd

    • Le 31 août 2011 à 15:34, par stefdn En réponse à : STEP - Système de Téléchargements de Plugins

      Bonjour,

      j’ai le même souci... avec SPIP 2.1.10 [17657] voir dans l’image jointe

      pour info, step (0.15.1) est stocké dans /plugins/ et tous les autres plugins sont dans /plugins/auto/

      PNG - 13.3 ko
    • Le 1er septembre 2011 à 17:27, par Suske En réponse à : STEP - Système de Téléchargements de Plugins

      j’ai de temps à autre des soucis aussi : ils sont en général résolus après un passage sur la page « classique » de gestion des plugins...

    • Le 8 septembre 2011 à 10:13, par JLuc En réponse à : STEP - Système de Téléchargements de Plugins

      Avec STEP 0.15.4 et en mettant à jour spip-lettres, j’ai pas les warning signalés mais j’ai le double affichage contradictoire comme sur la copie d’écran de stefdn :

      L’ensemble des actions demandées ont été réalisées.
      -  La mise à jour du plugin « SPIP-Lettres » (version : 4.5.9) s’est correctement déroulée" et
      -  L’installation du plugin « SPIP-Lettres » (version : 4.5.9) a échoué

      alors que la version 4.5.9 de spip-lettres, c’est la version installée, la version à jour étant la 4.5.12.

    Répondre à ce message

  • Le 21 février 2011 à 12:23, par filnug En réponse à : STEP - Système de Téléchargements de Plugins

    Bonjour,

    Ce plugin m’intéresse spécialement pour la possibilité de mettre à jour facilement les plugins sans passer par le couteau suisse. Or, je constate qu’aucune mises à jour ne sont disponibles. Or certains de mes plugins ne le sont pas du tout ! Pourquoi je ne vois pas l’icone de « mise à jour » ?

    Merci

    • Le 21 février 2011 à 12:40, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      Parce que le plugins/auto n’est pas là ? parce que la liste des plugins est pas installée ? comment savoir sans plus de précisions ?

    • Le 21 février 2011 à 12:51, par Suske En réponse à : STEP - Système de Téléchargements de Plugins

      Tu as validé la liste des plugins ?

      PNG - 15.5 ko
      Pour être opérationnel, STEP doit connaître la ou les listes de plugins : on ajoute celle proposée en exemple
      PNG - 15.5 ko
      Pour être opérationnel, STEP doit connaître la ou les listes de plugins : on ajoute celle proposée en exemple
    • Le 21 février 2011 à 14:41, par filnug En réponse à : STEP - Système de Téléchargements de Plugins

      ^^
      J’avais tout simplement pas mis la bonne adresse. En fait, j’avais bêtement recopié les adresses des flux rss de spip-contrib et plugin.spip.
      Forcément, ça ne marchait pas.

      Vraiment désolé pour le désagrément !

    • Le 3 avril 2011 à 17:08, par gilcot En réponse à : STEP - Système de Téléchargements de Plugins

      C’est STEP ou il y a un problème avec Contrib ?
      Depuis hier sur un site, puis aujourd’hui sur un autre, il n’y a plus qu’un plugin qu’il dit...

      PNG - 41.2 ko
    • Le 3 avril 2011 à 19:22, par marcimat En réponse à : STEP - Système de Téléchargements de Plugins

      Faut mettre à jour STEP je crois (un minibug corrigé normalement)...

      Ou, autre possibilité... la zone devient trop grosse :)

      Nous avons découvert avec Eric qu’il y a une limitation dans les preg_match() de PCRE qui limite par défaut une taille de certaines recherches à 100 000 caractères... je ne pense pas que STEP tombe là dessus.

    • Le 3 avril 2011 à 21:03, par gilcot En réponse à : STEP - Système de Téléchargements de Plugins

      J’ai mis à jour avec le zip ici (version du 1er avril donc) juste avant de poster, mais sans changement.

      Pour moi c’est pas bien grave tant que les mises à jours sont récupérées (un gros boulot de maintenance des sites sous SPIP que STEP m’a allégé —je me demande même pourquoi en adept de apt-get .. je n’y avait pas pensé—) Ça, on le verra dans le temps...

      L’interface standard syndiquait 214 plugins le 25 mars et 216 aujourd’hui ; et vu la longueur des noms + description, je crois pas qu’on tombe sur la limite, mais je ne fais que supposer. :)
      STEP utilise lui un autre fichier qui (une fois téléchargé et ouvert dans un éditeur de texte) a 39861 lignes (en 39808 si on excepte les blancs, le tout pour 1298277 caractères :/) et a 755 occurrences de <archive id= (ce qui était bien le nombre indiqué par STP avant de se mettre à dire 1 : ouf, sont donc tous là...)
      C’est vrai que ce chiffre indique une assez grosse zone (et le succès de notre écureuil) Faudrait que STP utilise aussi les flux rss, ou alors que la liste archive.xml puisse et soit généré par branche... (je trouve qu’il ne sert à rien de trouver des plugins qui soient pas pour la la version qu’on utilise...)

    • Le 4 avril 2011 à 17:08, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      Le problème de 1 plugin est corrigé par http://zone.spip.org/trac/spip-zone/changeset/46339

      Ne dites pas à Éric qu’il aurait du prévenir qu’il changeait le format de archives.xml ... :)

    • Le 5 avril 2011 à 13:14, par Déesse A. En réponse à : STEP - Système de Téléchargements de Plugins

      Ce n’est pas la zone qui devient trop grosse, c’est le code d’affichage des plugins qui n’est pas bon. Dans la branche Spip-2.2, j’ai corrigé code qui comportait une énorme redondance de calcul, c’est expliqué ici. Avec ça, j’affiche les 775 plugins de la zone en une quinzaine de secondes, alors qu’avec la version courante de SPIP on dépasse les 30 secondes fatidiques et la page reste vide.

    • Le 5 avril 2011 à 23:09, par DD En réponse à : STEP - Système de Téléchargements de Plugins

      Bonjour,

      j’ai ce flux d’activé pour STEP : http://files.spip.org/spip-zone/archives.xml
      et il m’indique qu’aucune mise à jour de plugin n’est disponible.

      Auparavant j’utilisai la lame « mise à jour automatique » du couteau suisse. et celui-ci m’indique :
      Bandeau 2.1 (v1.1.10) La révision 46305 est disponible.
      cfg : moteur de configuration (v1.16.0) La révision 45709 est disponible.
      Couteau KISS (v1.0.2) La révision 45902 est disponible.
      Mediathèque (v1.6.2) La révision 46206 est disponible.
      etc..
      (tous dans /auto )

      Quelle est la différence entre les 2 outils de mise à jour ? J’aimerai autant laisser tomber le couteau suisse si possible.

      merci

      dd

    • Le 5 avril 2011 à 23:50, par gilcot En réponse à : STEP - Système de Téléchargements de Plugins

      @ Matthieu Marcillaud
      Je me confirme que STEP est dans les choux (d’une part aucune recherche ne renvoyait plus rien, d’autre part j’avais une mise à jour qu’il ne voyait/détectait pas) et une heure après tu annonce que c’est réglé \o/
      Euh... Éric le sait quand même et s’en excuse :D

      @ Désse A.
      C’est vrai que 775 c’est beaucoup, mais la zone set loin d’être grosse avec ça ;P C’est vrai aussi que c’est quand même assez long et je suis content de voir que tu as pu booster ça.
      Une bonne nouvelle chaque jour : c’est mieux que les œufs de Pâques 0 :)

      @DD
      Il faut que tu mettes à jours STEP manuellement (de façon classique/traditionnelle) pour qu’il continue à voir les mises à jours... La description de la zone a changé et du coup il voit plus rien.
      Pour le couteau suisse, je ne sais pas du tout : j’ai jamais été tenté donc même pas essayé.

    • Le 6 avril 2011 à 11:11, par marcimat En réponse à : STEP - Système de Téléchargements de Plugins

      Pour la différence CS / STEP je crois (de mémoire) que CS indique une mise à jour dès que quelqu’un fait un dépot sur le SVN du plugin sur la ZONE alors que STEP ne la propose que si le numéro de version a changé (pas son numéro SVN)

    Répondre à ce message

  • Le 5 avril 2011 à 11:50, par filnug En réponse à : STEP - Système de Téléchargements de Plugins

    Bonjour,

    J’ai un gros souci de mise à jour de step.
    J’ai essayé en vain de le mettre à jour manuellement en écrasant, par upload, le plugin step.
    Depuis, j’ai une fatal error qui m’empêche d’accéder à mes plugins ! :

    Call to undefined function step_get_infos_plugin()

    Par FTP, il m’est impossible d’effacer le plugin ! Avez vous svp une solution pour réinitialiser ce plugin ?

    Merci

    • Le 5 avril 2011 à 11:55, par filnug En réponse à : STEP - Système de Téléchargements de Plugins

      Bon... C’est tout bon.

      J’ai rechargé step via l’installation auto de plugins. Apparemment, tout est rentré dans l’ordre. Désolé pour le dérangement... ^^

    Répondre à ce message

  • Le 28 mars 2011 à 15:24, par Teddy Payet En réponse à : STEP - Système de Téléchargements de Plugins

    Bonjour,

    Un message pour signaler un « bug » d’affichage.

    Lorsqu’on est sur ?exec=step, on peut n’afficher que les « Mise à jour disponible ». Cela s’affiche correctement, ici. Au lieu de cliquer sur « Sélectionner les mises à jour », je sélectionne un par un les plugins qui m’intéressent.
    Je clique sur « Mettre à jour ». Il s’ajoute bien dans la liste de tâches à faire.
    Mais là, tous les plugins réapparaissent, ignorant de ce fait mon choix précédent « Mise à jour disponible » (qui est resté en gras).

    Je dois cliquer sur « Mise à jour disponible » pour défaire mon choix puis re-cliquer pour ne voir que les plugins avec mise à jour disponible…

    Est-ce que j’ai été compréhensible ?

    Répondre à ce message

  • Le 24 mars 2011 à 16:12, par Boyquotes En réponse à : STEP - Système de Téléchargements de Plugins

    Bonjour,

    Vraiment pas content de tous ça, ça bug dans tous les sens, c’est pas ergonomique,... et non je rigole, c’est impeccable ! :)

    Nicolas.

    Répondre à ce message

  • Le 27 février 2011 à 19:17, par tetue En réponse à : STEP - Système de Téléchargements de Plugins

    Je viens de comprendre pourquoi je croyais que ce plugin ne marchait pas : cliquer sur le bouton « activer » ne suffit pas car il faut ensuite cliquer sur le second bouton « appliquer les modifications ». Pourquoi ce bouton n’agit pas de suite ? Il ne faut pas qu’il ait l’apparence d’un bouton, mais d’un simple texte, voir une case à cocher, ce sera plus compréhensible !

    Quelques remarques en vrac :
    -  on ne distingue plus suffisamment les plugins actifs des autres (je dois garder STEP et ?exec=admin_plugin ouverts dans 2 onglets côte à côte pour m’y retrouver) ; l’habillage de la page ?exec=admin_plugin est beaucoup plus simple et compréhensible :P
    -  quand on termine une action (après avoir activé un plugin, par exemple) on se trouve dans une impasse, avec le seul message de succès, mais aucun lien ne permet de revenir à la liste des plugins (sauf à passer via le menu « configuration »)

    • Le 27 février 2011 à 19:39, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      Comme indiqué,

      • il est possible d’effectuer plusieurs actions avant de les appliquer
      • si l’activation nécessite des dépendances, tu es donc mis au courant, et c’est toi qui décide d’appliquer quand même la proposition, sinon d’annuler,
      • ça reste un bouton qui enregistre, en quelque sorte l’action que tu veux faire, et teste si elle est réalisable ou non. Il ne l’appliquera effectivement que si tu « appliques les changements »

      Pour les remarques

      • la distinction est peut être insuffisante effectivement. Cependant, je n’aime absolument pas l’interface ?admin_plugin que tu décris comme plus simple de ton point de vue, mais pas du mien, et ne pas y voir les « plugins présents » ou « plugins récemment utilisés » sur ?admin_plugin m’ennuie profondément.
      • quand tu termines l’action, un bouton apparait : « recharger la page »... Il suffit de cliquer dessus ! Plus précisément, comme les actions se font en ajax, il faut recharger ensuite la page pour que tout l’extérieur soit mis à jour, mais pour voir les messages du formulaires (pour savoir si les opérations se sont bien déroulées), on ne peut pas vraiment recharger tout l’ensemble automatiquement une fois les actions réalisées, sinon nous perdrions les messages en question.
    • Le 27 février 2011 à 20:05, par tetue En réponse à : STEP - Système de Téléchargements de Plugins

      Oui, c’est en lisant la doc que j’ai compris qu’il y avait un second bouton à actionner. Il n’est pas évident à trouver, en haut de page. Il y a peut-être des améliorations d’interface à apporter pour rendre moins bloquantes certaines étapes morcellés par l’ajax. Mais bon, comme tu dis, c’est surtout que ce plugin ne correspond pas à mon utilisation (ça sert vraiment à qqch de voir les « plugins récemment utilisés » !?? ;)

    Répondre à ce message

  • Le 18 février 2011 à 12:00, par igor En réponse à : STEP - Système de Téléchargements de Plugins

    Il apparait sous "Modifications à réaliser" et lorsque je l’applique... ça fonctionne maintenant ?!

    Mais le message est différent lorsqu’on le déplie dans la liste des plugins ("Ce plugin est installé en tant qu’« extension ». Aucune action ne peut être effectuée.")

    • Le 18 février 2011 à 12:41, par Matthieu Marcillaud En réponse à : STEP - Système de Téléchargements de Plugins

      Oui, finalement... on vient de décréter qu’une extension ne peut pas être mise à jour. Le bouton ne fait maintenant plus cela.

    • Le 25 février 2011 à 11:30, par JLuc En réponse à : STEP - Système de Téléchargements de Plugins

      La maj des extensions ne pourrait elle pas être accessible aux webmestres ? Ils ont de toute façon accés au FTP alors autant leur faciliter la vie...

    • Le 25 février 2011 à 16:02, par Suske En réponse à : STEP - Système de Téléchargements de Plugins

      J’ai pas mal réfléchi à cette question et chaque argument tend à faire pencher dans un sens ou dans l’autre. En fin de compte, je ne suis pas pour la màj des extensions, pour les raison suivantes :

      -  les extensions ne sont pas des plugins comme les autres. Associées à SPIP-core, elles vont former une sorte de distribution. Elles vont devenir de plus en plus nombreuses : brèves, statistiques, forums, ... Tout ça va devenir « extensions ». Dans le futur, une « version » SPIP sera une sorte de distribution « packagée » avec des extensions de base qui maintiennent a minima les fonctionnalités fondamentales d’un SPIP d’avant les extensions. Si des bugs sont trouvés dans les extensions, cela justifiera un nouveau package avec incrément de version et tout. Donc une mise à jour « de SPIP » tel que packagé.
      -  A contrario, si des mises à jours sont faites sur les extensions sans mettre à jour le core, le risque de casser sera plus grand. STEP facilite tellement les choses que l’on risque sérieusement de provoquer des accidents chez les webmestre amateurs. Pour les autres, la mise à jour est toujours possible en FTP. Imagine le cas d’un plugin qui nécessiterait une version d’extension supérieure, incompatible avec le core... Tu fais ça automatiquement ? Pouf. Enfin bref, c’est tout la problématique des dépendances qui va « surgir » là.

      Enfin bref, je suis pas pour... Par contre, je t’avoue que du coup j’ai retiré le porte-plume des extensions pour le mettre en plugin, si tu vois ce que je veux dire... Mais bon : j’estime que je sais à quoi je m’engage... Mais tu as raison, c’est tellement facile :-)

      Il y a aussi des questions plus stratégiques sur la maintenance, le sad, la motivation à tester les choses en dev et en test, la faisabilité de packager des distributions spip spécifiques, etc. Mais ça se passe sur la taverne à Tonton plutôt.

    Répondre à ce message

  • Le 25 février 2011 à 13:04, par JLuc En réponse à : STEP - Système de Téléchargements de Plugins

    Hello,

    ça marche bien :-)

    Quelques remarques quand même :

    Parfois on est un peu perdu dans cette liste indifférenciée, donc au niveau de la présentation, ce serait chouette de voir tout de suite ce qui est installé sur le site et ce qui ne l’est pas, de même qu’on voit tout de suite ce qui peut être actualisé.

    Parfois on se retrouve avec 500 plugins affichés, ce qui n’est pas très exploitable. La recherche pourrait ne retourner que les 50 premiers résultats par exemple.

    Enfin, il manque le lien de documentation dans la présentation des plugins, qui, d’ailleurs, est parfois un texte simple=une url, parfois un lien spip texte...

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Mailsubscribers

    16 janvier 2013 – 274 commentaires

    Ce plugin permet de gérer les inscriptions (ou abonnements) à la diffusion de contenu par email. Mailsubscribers permet de gérer les inscriptions par Opt-in simple ou double et la désinscription par URL. Ce plugin gère également plusieurs listes (...)

  • noiZetier v2

    9 novembre 2012 – 36 commentaires

    Le noiZetier offre une interface d’administration permettant d’insérer au choix des éléments modulaires de squelettes (noisettes) et de les ajouter ainsi à ses squelettes. Compatibilité La version 2 du noizetier fonctionne sous SPIP 3. Elle est (...)

  • cirr : plugin « rédacteur restreint »

    29 octobre 2010 – 60 commentaires

    Ce plugin « cirr : rédacteur restreint » permet d’affecter des rubriques aux rédacteurs et modifie les droits afin qu’un rédacteur restreint (ou un administrateur restreint) voit dans l’espace privé uniquement les rubriques qui lui sont affectées (et leur (...)

  • Un retour d’expérience d’utilisation de Formidable

    26 octobre – commentaires

    Il s’agissait de créer un formulaire d’inscription à un évènement modérer les inscriptions dans le privé publier les inscriptions dans le public Nous avons discuté de cette présentation lors de l’apéro SPIP du 15 février 2016 à la Cantine (...)

  • Métas +

    3 décembre – 14 commentaires

    Améliorez l’indexation de vos articles dans les moteurs et leur affichage sur les réseaux sociaux grâce aux métadonnées Dublin Core, Open Graph et Twitter Card. Installation Activer le plugin dans le menu dédié. Dans le panel de configuration, (...)

Ça spipe par là