Tincredible

Tincredible est une adaptation pour zpip du thème du même nom initialement développé pour Wordpress.

Tincredible est un thème bleu, sobre et élégant à deux colonnes utilisant CSS 3 et se dégradant correctement lorsque CSS 3 n’est pas supporté par le navigateur.

Voir une démo du thème Tincredible.

Installation

L’installation du thème s’effectue comme celle de n’importe quel autre thème :

- Téléchargez le Thème Tincredible,
- Déposez-le dans le dossier themes/ à la racine de votre SPIP (créez-le s’il n’existe pas).
- Installez le plugin Zen-garden (nécessite les plugins Squelettes Zpip, et SPIP-Bonux),
- Un fois l’installation effectuée, un sous-menu « Thèmes » apparaît dans le menu « Configuration » de votre interface privé Spip. Cliquez dessus, et choisissez le thème Tincredible dans la liste des thèmes présents sur votre configuration.

Vous pouvez utiliser le plugin Menus, pour définir votre menu principal. Identifiez-le comme suit : barrenav

Le slider de la page d’accueil

Ce slider intègrera automatiquement vos articles qui ont un mot clef nommé "slider" associé. Les articles sont affichés dans un ordre aléatoire.
Si aucun article n’est associé à ce mot clef, alors le slider n’apparaîtra pas.

Dernière modification de cette page le 13 février 2019

Discussion

21 discussions

  • Sébastien

    Bonjour,

    Je viens de passer un bout de temps sur un problème de conflit Javascript entre le plugin jQuery Cycle de Tincredible et le mini-calendrier de Spip (qui intègre du jQuery). Ce conflit empêchait le mini-calendrier de s’afficher.

    Une solution qui fonctionne pour moi est expliquée dans le forum du mini-calendrier.

    Sébastien

    Répondre à ce message

  • 3

    Bonjour, j’utilise ce thème depuis quelques temps avec SPIP 3.0. Je souhaite passer à SPIP 3.1, mais le plugin qui teste la compatibilité des plugins avec SPIP 3.1 me dit que Tincredible n’est pas compatible.

    Une mise à jour pour la 3.1 est-elle prévue ?
    Merci

    • Bonjour,
      le plugin de test de compatibilité vérifie les informations fournis dans la description du plugins.
      Celles-ci sont mise à jour APRÈS qu’un test pour spip 3.1 ait été effectué.

      A priori, vu la nature du présent thème, il ne devrait pas y avoir de souci pour passer à SPIP 3.1, mais il faudrait que tu fasse le test, pour qu’ensuite nous validions sont résultats et marquions le thème comme compatible (ou non).

      Donc pour cela
      1) installe une SPIP 3.1
      2) modifie le fichier plugin.xml du theme en remplaçant [2.0.10;3.0.99] par [2.0.10;3.1.99].
      3) Active le thème
      4) Vérifie que tout marche bien
      5) Fait un retour.

    • Merci Maïeul pour cette réponse très rapide,
      je viens de suivre tes instructions. Tout semble OK sur mon site ! : http://sm.plil.net/
      Merci

    • De rien. Je viens de marquer le thème comme compatible 3.1

    Répondre à ce message

  • rodolphe

    Bonjour,

    Très beau thème !

    Je souhaite mettre une bannière (banniere.jpg dans le dossier /IMG à la racine du site) dans le header de mon site à la place de la bande bleu (#4E799D). Je ne sais pas comment faire.

    Quelqu’un peu m’aider ?

    Merci

    Répondre à ce message

  • 4
    OneMore

    Bonjour à tous,

    J’ai installé Tincredible sur un SPIP 3.0,
    tout va bien, tout roule.
    Cependant ce qui me gêne, c’est l’absence de puces,
    ou de flèches de nav dans le slider,
    l’obligation de laisser dérouler le slider, sans prise dessus.

    Là, dessus, j’ai cherché et trouvé le Thème et Squelettes Brominerary,
    qui a un slider avec puces permettant le défilement manuel.

    Mais... il n’est pas compatible 3.0.
    Résultat : le slider est absent, malgré le mot clé Slider ajouté à des articles.

    J’ai essayé de mettre ce slider dans Tincredible,
    jusque là echec.

    Auriez vous une solution ?

    Merci encore aux contibuteurs de haut vol qui développent
    ces thèmes et plugins.

    OneMore

    J’ai bien essayer de mettre le slider de Brominerary dans mes squelettes/thèmes, mai

    • OneMore

      En fait, en inspectant la page avec Firebug,
      je vois qu’il y a en bas à gauche une div
      appelée slideshow-controller, dans la css,
      dont les lignes suivante :

      div#slideshow-controller button#jqc-prev
      background : url(« ./images/cycle/button-featured-prev.png ») repeat scroll left top transparent ;

      div#slideshow-controller button#jqc-next
      background : url(« ./images/cycle/button-featured-next.png ») repeat scroll left top transparent ;

      Le dossier cycle, dans images, n’étant pas présent, je l’ai créé
      et y ai « versé » une image bouton « next »,
      mais non rien n’apparait.

      Je vois en inspectant le code de la page, qu’il y a une pagination,
      mais cela reste invisible dans le navigateur.

      Auriez vous une piste pour faire apparaitre cette « pagination » ?

      Merci

    • OneMore

      Bon, la div était glissée sous le slider, et
      une fois l’image button-featured.png téléchargée et la div décallée,
      le controleur est bien présent, sauf qu’il n’a guère d’intérêt,
      puisque les « puces numérotées » servent à accéder à l’article
      et non , ce que je recherchais, à passer à l’image suivante dans le slider.

      Merci encore.

    • Je cherche a faire exactement la même chose, pouvoir controller le slider. Les controller étaient en display:none. J’ai fais en sorte qu’ils soient visibles, ils le sont mais non utilisable. Non cliquable. En gros ils ne servent à rien. Comment les rendre actif ?

    • Up. Même problème.

    Répondre à ce message

  • Petite remarque : Tincredible et le plugin jQuery Cycle activé provoquent des problèmes de js. Problème de chargement et de fonctionnement pour Jquery Cycle

    Répondre à ce message

  • 13
    angelofnight

    Bonjour,

    Comment votre thème prend-il en charge un site multilingue ?
    Même chose du coup pour le menu déroulant...

    • Bonjour,

      Je viens juste de mettre en place un site multilingue, c’est possible. (des modifs à faire, mais surtout sur Zpip, peu dans le thèmes).

      Pour zpip dans squelettes :
      -  dans contenu : article.html et rubrique.html, ajouter le filtre « lang ».
      -  dans inclure : article-resume.html, ajouter filtre « lang ».

      Dans interface admin :
      -  couteau suisse, j’ai mis « forcer lang »
      -  Pour description, slogan, menu et titre des rubrique, j’ai utilisé la balise « multi ».
      -  La structure des articles, j’ai mis dans les rubriques en « multi », les articles avec les langues associées.

      Dans le thème, j’ai ajouté dans habillage.css :
      .formulaire_menu_lang
      background : none repeat scroll 0 0 transparent ;
      margin : 0 ;
      padding : 0 ;
      width : 150px ;
      position : absolute ;
      top : 10px ;
      right : 20px ;

      Pour un effet visuel (ça rend pas super bien sinon le choix de la lang)

      -  Puis également un filtre « lang » dans le thème / inclure / slider_tincredible.html, pour l’affichage des articles dans la langue pour le slider.

      -  On peut aussi récupérer le logo de l’article d’origine, pour ne pas avoir à le mettre à chaque fois :
      http://www.spip-contrib.net/Recuperer-le-logo-de-l-article-d

      Le résultat (en dév, les trads sont pas faites) : http://zazalachevre/ kultur

      En espérant que ça te serve... Hésites pas à me contacter à travers ce site, si tu veux en savoir plus. Je voudrais pas pourrir cet article ;)

    • Salut ! merci d’avoir travaillé sur la gestion des langues dans le thème.

      Peux- tu faire les modifications directement sur le svn de spip-zone ?

    • Salut,

      Je vais voir ça (par contre, je suis pas très calé en svn ;) Mais ça doit pas être bien compliqué !

      Les plus grosses modifs étant dans zpip, mais je suis pas sûr que zpip vise le multilinguisme...

    • Salut,

      Au fait, c’est intégré pour la langue.

      Bref, j’ai fait une version marron http://www.alterkultur.org/, ça vaut le coup de mettre ça sur la zone ?

      C’est vrai qu’il y a pas beaucoup de template en 2.1...

      Si oui, on l’intègre à l’article ?

    • Salut,

      Ca me semble inutile de mettre sur la zone les déclinaisons de thèmes, on propose le thème d’origine et ensuite chacun fait sa personnalisation... non ?

      cool pour les modifs sur le svn

      a+

    • Re,

      effectivement, on peut le faire soit même (la preuve ;) ), mais je pense que certains peuvent galérer en css, retouche d’image...

      Bref, si il y en a que ça intéresse, ils peuvent toujours me contacter.

      Ben

    • Bonjour,

      Merci pour ces modifications.

      Cependant, pour le menu de droite qui liste les rubriques, lorsque je suis en français tout s’affiche correctement mais lorsque je bascule en anglais il me met une erreur 404.

      Toutes les traductions fonctionnent sauf l’affichage des rubriques.

      Pourriez vous me donner un coup de main svp ?

    • Bon en fait c’est bon, je n’ai plus d’erreur 404, le filtre lang dans contenu/rubrique.html me donnait cette erreur, je l’ai donc enlevé.

      Maintenant j’ai bien le nom de la rubrique en Anglais mais je n’ai pas l’affichage des articles dans cette catégories.

      Alors qu’en français, tout est ok...

    • Bonjour,

      Notre site est multilingue, par défaut le site est en français.

      Si nous donnons l’adresse du site à quelqu’un avec le paramètre http://trimestres-lmb.univ-fcomte.fr/?lang=en le site s’affiche bien en anglais mais si l’on clique sur n’importe quel lien interne au site, ce sont les articles en français qui s’affichent.

      En passant par le sélecteur de langue, il n’y a aucun problème.

      Je pense que c’est un problème de cookie/session qui n’a pas l’info que l’on veut le site en anglais. J’imagine que le sélecteur de langue inclu dans le cookie ou autre la langue dans laquelle on veut tout le site...

      Si quelqu’un sait comment régler ce soucis, je suis preneur.

      Merci d’avance.

    • Salut,

      tu peux tenter en mettant

      $forcer_lang=true ;

      dans mes_options.php et je crois que tu peux aussi activer ça dans le couteau suisse (dans Affichage public)

      Ben

    • Bonjour,

      forcer_lang était déjà dans mes_options.php

      Je continue de chercher..

    • Et avec un #ENVlang ?

      Comme ici :
      http://forum.spip.net/fr_212622.html

      Bonne chance

      Ben

    • Merci, c’est exactement le même soucis.

      Je test.

    Répondre à ce message

  • Bonjour !
    Bravo pour ce plugin que j’ai découvert pour habiller mon spip 3 tout neuf.

    Je ne suis pas encore bien habitué à la logique Zpip et j’ai un peu de mal à me retrouver dans ce qui est à modifier entre le plugin et le thème pour avoir ce que je veux... Mais ça va venir !!!!

    J’ai deux soucis :

    1. je n’arrive pas à remettre les logos de documents (quand je rajoute [(#LOGO_DOCUMENT|#URL_DOCUMENT)] à la place de #URL_DOCUMENT, j’ai du texte non cliquable....)
    2. je n’arrive pas non plus à changer « titre documents joints » : aucun des fichiers « lang » que j’ai trouvé ne contient ce texte...

    Si vous avez une piste, merci !!

    Voir sur mon site

    Répondre à ce message

  • 4

    Bonjour et bravo pour ce beau thème,

    Pour que le menu déroulant fonctionne correctement (comme sur le site « démo »), faut il ajouter des plugins, configurer l’habillage ? Et que faut il changer pour que les rubriques de la barre de menu ne soient pas « collées » aux séparations ?

    Merci pour l’aide !

    • Bonjour,

      Pour que des menus déroulants apparaissent, il faudra créer des « sous-menus » depuis la configuration du plugin Menus.

      Si il y a un soucis de calage css, pouvez-vous vérifier qu’il n’y a pas d’erreur javascript ?

      Arnault

    • J’ai crée des sous menus en test, oui.
      Avec Javascript Debugger, pas d’erreurs constatées à priori.
      Pour visualiser le problème : http://lyon2024.host22.com
      Je n’ai pas fait grand chose mis à part personnaliser quelques couleurs. (je précise que le problème apparaissait déjà avant les modifs)

    • Je crois avoir compris ! Pour que tout fonctionne dans le meilleur des mondes il faut que chaque entrée soit un lien. (menu principal et sous menus)

    • Bonjour, comment faire pour que les articles ne figurent pas sur la page d’accueil ? Je souhaite uniquement que mes articles figurent dans leurs rubriques respectives.

      Merci pour votre aide

    Répondre à ce message

  • 2

    bonjour,
    je viens d’installer le thème tincredible sur mon site mais je ne parviens pas à afficher le slider... (je débute) j’ai pourtant ajouté le mot clé slider dans mon article.
    Dans quel groupe de mots clés dois-je créer le mot clé slider ? ou ai-je oublié une étape ?

    • je précise que lorsque je lie un mot clé a un article, je n’ai plus aucun article qui s’affiche...

    • j’ai la réponse : mon image était trop grande...

    Répondre à ce message

  • 1
    Pierre 67

    Bonjour

    A propos du slider, cela fonctionne pour le texte des articles mais pas pour les images..y a un truc ???

    Merci d’avance

    Pierre

    • Je rencontre le même problème que pierre. Le cadre réservé à l’iumage est vide.

      Merci pour votre aide

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom