Installation de SoyezCréateurs

SoyezCréateurs est un squelette très paramétrable, multi-usages, RWD et accessible (WCAG/RGAA).

Créé à l’origine pour SPIP 1.6 en 2003, il a évolué avec SPIP et est parfaitement adapté à SPIP 3.2 !

Installation

Le squelette SoyezCreateurs est un squelette multi-usages pouvant être configuré très largement.

L’installation du squelette est très simple, il suffit de l’installer comme n’importe quel autre plugin.

L’installation nécessite que vous ayez défini un 2e dépôt : https://files.spip.net/externals/archives_externals.xml [1]

Autres plugins à installer

SoyezCreateurs nécessite d’autres plugins pour fonctionner. Ces derniers sont installés automatiquement par SVP.

Plugins facultatifs permettant plus de fonctionnalités

Linux

Pour les utilisateurs ayant accès à un shell linux, il est possible d’exécuter ce script pour installer le squelette d’un seul coup avec SPIP (http://zone.spip.org/trac/spip-zone/browser/_squelettes_/soyezcreateurs_net/plugins_2.1/documentation_a_ne_pas_publier_par_ftp_sur_son_site/linux/installsc.sh) :

Un script pour la mise à jour est aussi disponible (http://zone.spip.org/trac/spip-zone/browser/_squelettes_/soyezcreateurs_net/plugins_2.1/documentation_a_ne_pas_publier_par_ftp_sur_son_site/linux/updatesc.sh) :

Résultat

Apparence à l’installation (en 2018)
Apparence à l’installation (en 2005)
Voici l’apparence du site à l’installation.

Notes

Discussion

49 discussions

  • 4

    Bonjour,
    je cherche à installer le plugin Soyezcréateur (v5.0.11) sur un Spip 3.2.0 (php5.4.16) et lors de l’activation du plugin, il m’affiche d’abord une page blanche puis :

    Impossible d’activer le plugin ../plugins/soyezcreateurs_rebirth_5

    Nécessite le plugin MINIDOC en version ≥ 1.0.3.
    Nécessite le plugin ORDOC en version ≥ 1.1.2.

    Or les deux plugins en question sont intégré à Spip 3.2 d’après ce que j’ai pu lire.
    Auriez-vous une idée de ce qui provoqué ce problème ?
    Merci

    • Bonjour,

      Est-ce que tous les plugins sont à jour ?
      Je ne saurais que trop te conseiller de passer à une version récente de PHP (5.6 minimum, mais plutôt 7)
      Et de mettre à jour SPIP (il est bien possible que les versions des plugins-dist intégrés à SPIP soient différente entre 3.2.0 et 3.2.1)

      Merci de dire si la seule mise à jour de SPIP a suffit.

    • Merci pour la réponse ultra rapide, les plugins sont à jour, je vais tester la version 3.2.1 de Spip.

    • Bon finalement, j’ai remplacé dans paquet.xml

      et

      par

      on a pas mal de sites sur le même serveur et on souhaitait garder la même version pour tous.
      ça semble fonctionner.

    • Pardon, je n’avais pas vu que le code ne passait pas :

      <necessite nom="ordoc" compatibilite="[1.1.2;[" />
      et
      <necessite nom="minidoc" compatibilite="[1.0.3;[" />
      par
      <necessite nom="medias" compatibilite="[2.10.27;[" />

    Répondre à ce message

  • 4

    Bonjour ou bonsoir, c’est selon,

    Impossible d’installer le squelette Soyez créateurs sur un SPIP 3.2.1 via la fonctionnalité Ajouter des plugins de SPIP. Ça me dit :

     Le plugin Squelette SoyezCréateurs Rebirth dépend du plugin NOIZETIER ≥ 3.0.12.

    Sauf que :
    1/ ledit plugin est bien installé, merci ;
    2/ la dernière version indiquée sur la page des plugins de SPIP, https://plugins.spip.net/noizetier.html, est la 2.7.14 (en test, même).

    Bref arrivé à ce stade, à part prendre un billet de voyage dans le temps, on fait quoi ?

    Merci.

    • Pour l’instant, il faut rester en version 4 de SoyezCréateurs.
      Et ne passer à la 5 que lorsque les zip du nouveau Noizetier développé sur la Zone sera disponible.

    • Bonjour,

      J’ai fait la même erreur. (je suis sous spip 3.2.1).
      J’ai désinstallé la version 5.
      Sauf que la version 4 est considérée comme obsolète donc impossible de la réactiver (complétement grisée)

      Une solution ?

      Merci pour votre aide.

    • Bonjour,

      J’ai supprimé la dépendance à Noizetier (cf https://zone.spip.net/trac/spip-zone/changeset/111439)
      Vous pouvez installer la V5 !

      Belle journée à vous !

    • Super , merci beaucoup !

    Répondre à ce message

  • 2

    Bonjour,
    Lors de la maj de nos plugins et en particuliers celui d’Agenda« de la version 3.19.3 à la version 3.19.4 un message d’erreur apparaît à l’écran : »Impossible d’activer le plugin Soyez Créateurs 4.3.9, il a besoin de la version d’Agenda 3.14.10 (voir document joint)

    Ce message apparaît, encore après la maj de Soyez créateurs de 4.3.9 en 4.3.11.

    Notre site est en SPIP 3.2.1

    Nous sommes dans l’impasse, sans squelette sur notre site.
    Merci d’avance de vos contributions
    Corinne

    • Ça ressemble plus à une erreur de SPIP (SVP) que de SoyezCréateurs.

      Maintenant que le plugin Agenda est à jour, ça donne quoi de réactiver SoyezCréateurs ?

    • Oui, nous avons réinstallé et activé le plugin Agenda dans sa dernière version, et tout est rentré dans l’ordre, le plugin Soyez Créateurs s’est réactivé automatiquement. Tout est ok maintenant. Merci de votre réponse.
      Corinne

    Répondre à ce message

  • 3

    En mettant à jour le plugin SoyezCréateurs 4.1.12 [106873] en 4.1.14 [107071] sur le site http://www.choletcatho.net/ sous Spip 3.2.0 [23778], le fil d’ariane a disparu sous le menu horizontal en haut de l’écran.

    SoyezCréateurs est paramétré avec le mode « Affichage de l’édito ».

    J’ai remis l’ancienne version SoyezCréateurs 4.1.12 [106873].

    Est-ce un bug ? ou y a-t-il une option à activer dans la configuration de SoyezCréateurs ?

    • Non, ça n’est pas un bug, mais une évolution.

    • Merci pour votre réponse.

      Je viens de mettre à jour le plugin SoyezCréateurs en dernière version 4.2.2 [107192] et, bonne surprise, je vois maintenant le fil d’Ariane sous le menu horizontal : http://www.choletcatho.net.

      Je ne comprends pas pourquoi je ne le voyais pas en version 4.1.14 [107071]. Je ne cherche pas à comprendre : l’important est que cela soit résolu.

      Pensez à ajouter « Spip 3.2 » dans « Compatibilité » en haut à droite de cet écran : SoyezCréateurs fonctionne très bien.

    • Il y a beaucoup d’évolutions en ce moment sur SoyezCréateurs.
      Et il peut y avoir des bugs transitoires.

    Répondre à ce message

  • 2

    Aïe ! Il semble que le couteau suisse ne soit pas compatible, dommage j’aimais bien la fonction :
    Raccourcis typographiques -> Découpe en pages et onglets. Cela permettait de créer un sommaire dans le fichier.

    Mais c’est vrai cette version est en test et peut-être que… ?

    Sur la page d’accueil pas moyen de changer l’image du chat où j’aimerais y mettre une autre image plus en rapport avec le site que j’essaie de construire.
    Cette image disparaît en fenêtre réduite au lieu de se réduire comme sur d’autres squelettes RWD…

    Merci d’avance ;)

    • Le Couteau Suisse est compatible, mais pas conseillé. De plus, certaines des lames sont explicitement bloquées. Il est bien possible que la lame de découpe en page le soit, car c’est une FBI (Fausse Bonne Idée). Pourquoi ? Parce que le moteur de recherche de SPIP cherche dans les pages entières, et que la découpe en page peut conduire à ne pas voir ce qu’on a cherché. Sans compter la problématique d’impression.

      Le chat, c’est juste le logo du site (Configuration, identité).

      Pour l’image en RWD, si tu as une idée de comment faire ça en CSS...

    • Bonjour,

      Par contre la fonction • Blocs Dépliables : <bloc></bloc> (alias : <invisible></invisible>) et <visible></visible> du Couteau Suisse semble être une Vrai Bonne Idée et ne semble pas affecter les recherches de SPIP, ni de Google.

    Répondre à ce message

  • 9

    Bonjour,

    A quand une version compatible SPIP 3.0 voir 3.1 et responsive ?

    Merci.

    • Bonjour,

      SoyezCréateurs est déjà Responsive ! Qu’est-ce qui te fais dire qu’il ne l’est pas ?

      Pour le passage en SPIP 3.x, il est prévu, mais pas urgent : Pourquoi SoyezCréateurs est encore en SPIP 2.1 ?.

    • Oups… en effet, j’avais mal vu RWD. Désolé. C’est vraiment un bon squelette mais repasser en 2.1 m’ennuie un peu. Tant pis, je vais attendre avec mon SarkaSpip.

    • Comme je suis toujours en local, j’ai installé spip 2.10 pour y essayer « SoyezCréateurs ».

      Après avoir paramétré Spip, retour au site public « Voir le site public » et là… page blanche !

    • Ça peut-être le .htaccess

      Ou un problème de configuration du LAMP/WAMP/MAMP local

      Je n’ai pas de boule de cristal ;-)

    • Bonjour,

      Je viens d’essayer d’installer « SoyezCréateurs Rebirth » 4.0.20 sur mon SPIP 3.0.17 [21515] en local.

      J’avais retiré tout autre plugin et je ne devais voir que celui-ci dans la liste des plugins inactifs mais il est considéré comme incompatible… :(

    • Quel est le message d’erreur précis ?

      Sachant que pour l’instant, c’est en statut « test ».

    • Rien ne vaut une capture d’écran.
      Bravo pour ce passage à Spip 3x tant attendu qui est encore en test mais qui saura devenir « stable ».

    • SoyezCréateurs pour SPIP 3 nécessite SPIP 3.0.19.

      Donc, 3.0.17, c’est pas assez.

    • Merci !

      Super ! j’ai mis à jour en 3.0.20, il y a du travail pour maîtriser ce squelette mais je pense qu’il a de sérieuses possibilités à exploiter.

      Bon travail malgré ses 27 plugins… mais certains ne serviront sans doute pas.

    Répondre à ce message

  • Bonjour,
    j’utilise actuellement la version SPIP 2.1.12 et Soyezcréateurs 3.7.4.
    Question surement basique mais évidemment je ne veux par faire d’erreur et ne trouve pas de d’information suffisante, ou dont je ne suis pas sur qu’elles sont adaptées à Soyezcreateurs. Comment mettre à jour Soyezcreateurs à sa nouvelle version 3.20.1.
    Merci

    Répondre à ce message

  • 2
    Quentin

    Bonjour,

    J’utilise spip 2.1.11 et soyezcréateur depuis 2011 sans problème.
    Malheureusement, j’ai récemment voulu faire une mise à jour de Spip vers la version 2.1.21 pour des questions de compatibilité avec d’autres pluggins.

    Cette mise à jour a été catastrophique car sous 2.1.21 j’ai énormément de conflits :(
    Je me suis dit, pas de soucis, j’ai sauvegardé tous les fichiers présents sur le serveur avant la maj ainsi que la base de données, j’efface donc tout (db, fichiers, ...) et je remet tout à l’identique de 2h plus tot. Seulement voilà, lorsque j’essai de réactiver le plugin soyezcréateurs, ca ne marche pas et ce avec l’erreur :
    « Fatal error : Call to undefined function id_groupe() in /mnt/113/sda/0/1/t.i.gre/plugins/soyezcreateurs_net_3/base/soyezcreateurs_install.php on line 77 »
    Qq’un aurait il une idée parce que là je sèche...

    Merci d’avance.

    • Essaye de vider le cache de SPIP par FTP (dossier tmp/)

    • Quentin

      déjà tenté sans succès :( mais merci quand même. Tu as d’autres idées ?

    Répondre à ce message

  • 2

    Bonjour,
    je dois installer un site Internet avec SoyezCreateurs selon la préférence de bénévoles d’une association.
    Je m’inquiète que celui-ci ne soit pas compatible avec Spip 3 et de ce fait l’installation non pérenne.
    Est-ce que le développement a été abandonné ? Dois-je préférer une autre solution ?
    Merci par avance,
    Gaëlle (zéro en dév !)

    • Ce squelette est maintenu et régulièrement amélioré.

      Il n’est cependant pas encore porté sous SPIP 3 car certaines de ses boucles ne fonctionnent plus en SPIP 3 et certains plugins ne sont pas encore portés sous SPIP 3.

      Mais c’est en projet !

    • Merci beaucoup pour cette réponse, rapide et qui m’incite à vous faire confiance pour poursuivre l’utilisation de ce squelette.
      En espérant à très bientôt, bon courage pour le développement !

    Répondre à ce message

  • Alors étonnat qu’une mise à jour se soit déclenchée et qu’elle ai résout mon problème sur ce site.
    Au moins un de réglé.
    Bien maintenant sur trois sites c’est :
    Espace interdit SPIP est déjà installé.
    Safe mode de PHP sur off, création nouveau dossier cache en 777,
    Rien à faire !

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?
  • [Se connecter]

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 29 septembre 2018