PHANTOM (HTML5UP)

Squelette SPIP pour intégrer le modèle Phantom de HTML5UP.
https://html5up.net/phantom

Installation

A l’activation, le plugin installe aussi les plugins suivants :

Options

La page de configuration propose quelques options :

  • la couleur de la typographie
  • la couleur de survol des liens et autres accents colorés
  • la couleur d’arrière plan de la page
  • la couleur d’arrière plan du pied de page
  • la largeur du contenu : si les lignes longues nous gênent sur les grands écrans, une largeur maximale pour le contenu peut être définie.

Des pages uniques

Avec le plugin Pages on peut créer :

  • une page nommée “accueil” qui servira de texte sur la page d’accueil, au-dessus de la liste des articles choisis,
  • une page nommée “mentions” qui servira pour les mentions légales et sera liée en pied de page.

Les articles en page d’accueil

Le plugins Champs Extras est utilisés pour ajouter deux champs aux articles de SPIP. Lors de l’édition de n’importe quel article, il est alors possible de sélectionner l’article pour qu’il apparaisse sur la page d’accueil, et de définir un ordre de tri dans cette liste.

Les logos des articles sont utilisés pour l’image, et avec le plugin Couleur d’Objet, la couleur transparente par-dessus les logos est aussi configurable. Pour cela, il faut bien configurer ce plugin Couleur d’objet pour autoriser le choix de couleur sur les articles : retrouvez la page de configuration depuis la page d’administration des plugins, sur la ligne de Couleur d’Objet et l’icône à droite “marteau/clef à molette”, ou voir la page de votre site ../ecrire/?exec=configurer_couleur_objet
Le plugin Centre Image permet de cibler le centre d’intérêt d’une image qui doit être recadrée, ici au format carré.

La page d’une rubrique

Elle affiche les articles qu’elle contient de la même manière que les articles en page d’accueil, avec logos et couleur de l’article transparente.
Les sous-rubriques éventuelles sont listées dans le menu du site.

Les liens sociaux

Le plugin Liens Sociaux permet d’utiliser des liens et des icônes adéquates vers les réseaux utilisés.

Le formulaire de contact

Le plugin Formulaire de contact avancé permet d’ajouter facilement un formulaire en pied de page.

Personnalisation

La feuille de style /squelettes/css/perso.css sera prise en compte pour personnaliser l’affichage sans perdre les mises à jour possibles.

Les objets éditoriaux et fonctionnalités de SPIP

Seuls les squelettes article.html et rubrique.html sont intégrés à ce squelette, avec les pages sommaire.html et plan.html
Les mots-clefs seraient certainement bien appréciés.
Les sites syndiqués, les forums ou les pétitions ne sont pas encore prévus.

Comme tout dans l’univers SPIP, il est possible à tout utilisateur de participer en proposant une amélioration.

Bon SPIP !

Les autres squelettes HTML5 UP

Le site html5up.net propose de beaux thèmes dont certains ont été adaptés pour SPIP. Voyez la liste des squelettes HTML5Up adaptés pour SPIP.

updated on 2 October 2019

Discussion

13 discussions

  • 18

    Après plusieurs mois d’utilisation, toujours aussi content de ce Plugin !
    Néanmoins, je vais avoir besoin de faire évoluer mon site très prochainement et je suis confronté à une limite : est-il possible, sur la page d’accueil, de répertorier des rubriques plutôt que des articles ?

    • Bonjour,
      oui, il faut modifier le fichier sommaire.html en le copiant dans le dossier /squelettes à la racine du site. https://zone.spip.net/trac/spip-zone/browser/spip-zone/_squelettes_/html5up_phantom/sommaire.html
      La partie concernée est celle-ci

      <section class="tiles">
                                              [(#REM) selection des articles choisis pour la page sommaire]
                                              #SET{articlesaccueil,#ARRAY}
                                              <BOUCLE_tblarticlesaccueil(ARTICLES){extras_accueil=on}>#SET{articlesaccueil,#GET{articlesaccueil}|push{#ID_ARTICLE}}
                                              </BOUCLE_tblarticlesaccueil>
                                              [(#REM) on boucle sur ce tableau]
                                                      <BOUCLE_articlesaccueil(ARTICLES){id_article IN #GET{articlesaccueil}}{par extras_ordre_accueil}>
                                                      <INCLURE{fond=inclure/btn_article,id_article} />
                                                      </BOUCLE_articlesaccueil>
      </section>

      il faudra remplacer les appels à la table ARTICLES par des appels à la table RUBRIQUES, puis extraire les bonnes informations en remplaçant
      <INCLURE{fond=inclure/btn_article,id_article} /> par ce qui convient aux rubriques... il faut peut-être lire des indications par ici : https://www.spip.net/fr_article904.html

    • Si tu arrives à faire apparaître les bonnes couleurs de rubriques sur les vignettes cela m’intéresse..

    • Merci beaucoup pour cette réponse très précise, c’est top ça !
      Je vais préparer un peu les changements et mettre ça en pratique assez vite.

    • Finalement, non concluant, je ne suis pas parvenu à modifier le fichier comme il faut. Pas assez compétent, je pense, je ne suis pas allé assez loin dans SPIP pour suivre les ramificatoins qui me permettraient de faire un travail propre. Je vais ruser et mettre des images associées à des liens sur la page unique “Accueil” pour rediriger vers les rubriques.

      J’en profite pour une autre question : je viens de changer les url de mon site et de passer à des url en arborescence. Depuis, le menu à droite ne s’affiche plus que sur la page d’accueil. Sur les autre pages, à la place des 3 traits horizontaux le mot “menu” et plus rien qui ne s’affiche. Est-ce que c’est lié au plugin ou vaut-il mieux que j’explore une autre piste ?

    • Dommage pour les boucles...
      Sinon je ne vois rien qui pourrait lier les urls arborescentes et un bug du menu. On pourrait voir le site en question ?

    • Concernant la boucle, j’y reviendrai de toute façon. Mais il faut d’abord que je réorganise mon site et c’est loin d’être la page la plus importante de mon site et ce n’est pas elle qui aide à son référencement.

      Voilà le site (en cours de restructuration, du coup) : https://www.stewencorvez.com/

    • Pour info, je viens de poser la question sur le forum au sujet du menu. Je viens de réaliser que c’est sûrement dû au fait que je viens de reconfigurer mes URLs.

    • Re,

      On tient une piste : ça pourrait venir d’une incompatibilité entre le plugin lui-même et les URLs en arborescence. Je vais réfléchir à la question et voir si je persiste à utilise PHANTOM (qui me plaît bien quand même) en mettant les mains dans le cambouis... ou si je repars sur des bases plus simples (à mon échelle).

    • Et je confirme : c’est bien les URLs en arborescence qui font planter le menu.

    • Problème réglé en passant par les URLs libres. Ce n’est pas tout à fait ce que je voulais, mais le principal y est : pouvoir renvoyer les gens vers les rubriques /mariage, /corporate et /blog facilement.

    • Bonjour,
      la version 0.2.9 devrait résoudre le problème du menu avec les urls arbo : https://zone.spip.net/trac/spip-zone/changeset/117968/spip-zone
      Merci tcharlss !

    • Oui, vu et mis en place ! Ça fonctionne très bien désormais. Merci à tcharlss !

    • Je commence en en voir le bout pour l’histoire des rubriques à la place des articles dans le sommaire.

      J’ai donc modifié le sommaire de cette manière :

      <section class="tiles">
      					[(#REM) selection des articles choisis pour la page sommaire]
      					#SET{rubriquesommaire,#ARRAY}
      					<BOUCLE_tblrubriquesommaire(RUBRIQUES) {par num titre}>#SET{rubriquesommaire,#GET{rubriquesommaire}|push{#ID_RUBRIQUE}}
      					</BOUCLE_tblrubriquesommaire>
      					[(#REM) on boucle sur ce tableau]
      						<BOUCLE_rubriquesommaire(RUBRIQUES){id_rubrique IN #GET{rubriquesommaire}}{par num titre}>
      						<INCLURE{fond=inclure/btn_rubrique,id_rubrique} />
      						</BOUCLE_rubriquesommaire>

      Puis j’ai créé le btn_rubrique

      <BOUCLE_rubrique(RUBRIQUES){id_rubrique}><rubrique class="style#ID_ARTICLE">
      	<span class="image">
      		[(#LOGO_RUBRIQUE|image_recadre{1:1,-,focus}|image_reduire{360,360}|vider_attribut{class})]
      	</span>
      	<a href="#URL_RUBRIQUE">
      		<h2>#TITRE</h2>
      	</a>
      </rubrique></BOUCLE_rubrique>

      Le titre des rubriques s’affiche et renvoie à la bonne rubrique. Me manque plus que la mise en forme, et je soupçonne, peut-être à tort, que la clé est sur cette ligne : mais je peine sur ça : class=“style#ID_ARTICLE”. Je suppose qu’il faut modifier le css quelque part pour l’adapter au titre de la rubrique. Je suis sur la piste, mais je suis preneur si vous avez un moyen plus rapide d’y arriver.

    • C’est parfait nickel sauf un tout petit détail : <article>..</article> est une balise html qui peut très bien contenir les informations de la rubrique.
      (<rubrique></rubrique> n’est par contre pas une balise connue à ce jour...o;)
      Donc il suffit de rétablir “article” dans cette balise et la mise en page sera magiquement revenue...
      Bravo pour l’adaptation !

    • il faudra vérifier peut-être le style#ID_ARTICLE et mettre style#ID_RUBRIQUE, puis mettre en lien avec le feuille de styles où la boucle pour les articles devra aussi être adaptée : https://zone.spip.net/trac/spip-zone/browser/spip-zone/_squelettes_/html5up_phantom/styles_config.css.html?rev=117975#L38
      C’est presque fini...

    • Bonsoir,

      J’ai moi aussi eu ce besoin pour les rubriques, je ne l’ai pas complètement résolu.
      J’ai ajouté dans styles_config.css.html :
      <BOUCLE_rubriques(RUBRIQUES)>[.tiles article.style#ID_RUBRIQUE> .image, .tiles article.style#ID_RUBRIQUE > .image:before { background-color:(#COULEUR); }]</BOUCLE_rubriques>

      Et mon btn_rubrique.html contient :

          <B_rub>
              <BOUCLE_rub(RUBRIQUES){id_rubrique}>
                  <article class="style#ID_RUBRIQUE">
                      <span class="image">                 [(#LOGO_RUBRIQUE|image_recadre{1:1,-,focus}|image_reduire{360,360}|vider_attribut{class})]
                      </span>
                      <a href="#URL_RUBRIQUE">
                          <h2>#TITRE</h2>
                          [<div class="content">(#DESCRIPTIF)</div>]
                      </a>
                  </article>
                  </BOUCLE_rub>
          </B_rub>

      La couleur de fond est bien celle de la rubrique (ou celle de son parent le cas échéant) SAUF s’il y a un article dans le site qui a le même ID que cette rubrique. (si l’article est une page unique cela fonctionne)

      C’est énervant..

    • Merci pour le coup de pouce, Chankalan !

      Effectivement DD, ça veut pas !

      Mais je vois bien que je ne suis plus très loin...
      Ça bloque encore sur le ID#RUBRIQUE...
      La nuit porte conseil, je verrai demain :-)
      En attendant, j’ai remis les articles en page d’accueil en plus des titres de rubriques... Histoire de moins perturber les nouveaux venus sur le site !

    • Et bien ça y est, ça fonctionne !
      J’avais juste corrigé le btn_rubrique du plugin au lieu d’aller corriger celui du dossier squelette, ce qui fait que ça ne prenait pas en compte mes modifications.

      Maintenant que j’en ai terminé avec la structure et le fonctionnement du site, je vais pouvoir passer à l’amélioration de l’habillage !

      Encore merci Chankalan, tes conseils auront été très précieux !

    Reply to this message

  • 1

    J’essaie d’adapter ce squelette pour avoir aussi des couleurs auto sur les rubriques.

    Dans le fichier de style squelettes/styles_config.css.html j’ai :

    <BOUCLE_rubriques(RUBRIQUES)>[.tiles article.style#ID_RUBRIQUE> .image, .tiles article.style#ID_RUBRIQUE > .image:before { background-color:(#COULEUR{parent,recursif}); }]</BOUCLE_rubriques>
    
        <BOUCLE_articles(ARTICLES)>[.tiles article.style#ID_ARTICLE > .image, .tiles article.style#ID_ARTICLE > .image:before { background-color:(#COULEUR{parent,recursif}); }]</BOUCLE_articles>

    et alors le bidule s’emmêle les crayons entre les articles et rubriques : si il y a un article avec le même ID qu’une rubrique (même hors de sa branche) alors cette rubrique prend la couleur de cet article et pas la couleur définie par la rubrique parente.
    Alors que les articles de la rubrique ont bien la couleur de la rubrique parente.

    Indice : si la rubrique à le même ID qu’une page unique cela fonctionne (au contraire d’un article “standard”).

    Dans le squelette btn_rubrique j’ai :

     <BOUCLE_rub(RUBRIQUES){id_rubrique}>
         <article class="style#ID_RUBRIQUE">
        <span class="image">      [(#LOGO_RUBRIQUE|image_recadre{1:1,-,focus}|image_reduire{360,360}|vider_attribut{class})]
        </span>
        <a href="#URL_RUBRIQUE">
            <h2>#TITRE</h2>
        </a>
        </article>
    </BOUCLE_rub>

    Comment faire pour différencier les ID rubriques des articles pour le choix de la couleur ?

    Merci

    • Bonjour,
      il faudrait que dans le code html il y ait une différence, avec une classe rubrique par exemple lorsqu’il s’agit d’une rubrique, pour pouvoir différencier des articles ensuite dans les styles...

    Reply to this message

  • 5

    Bonjour
    J’essaie d’ajouter un squelette spécifique type article-7.html pour une présentation.
    Or, je suis également en sites mutualisés (spip 3.2) et je n’arrive pas à ce que le squelette soit pris en compte!
    Placé dans squelette ou directement dans le répertoire du plugin.
    Quelqu un a t il une idée?
    Merci.
    Philippe

    • Bonjour,
      article-7.html c’est bien pour les articles de la rubrique 7 ?

    • Bonjour,
      tout à fait !
      En principe cela fonctionne bien, sauf avec ce plugin!
      C’est la 1ere fois au j’utilise un plugin pour un thème !

    • Est-ce que le fichier article.html du plugin est bien copié dans le dossier squelettes ? Sa présence est nécessaire pour que squelettes/article-7.html soit considéré...

    • Bonjour
      Oui pour article.html.
      Pour être complet, le site est mutualisé (plugin mutualisation ) et multilingue (2 langues)
      Donc j’ai adapté article, rubrique et sommaire pour ajouter lang, le tout dans squelettes. De même avec bt-article et menu dans squelettes/inclure.
      En réalité, le but de la manip est d’avoir un article unique (plusieurs en fait) pour les 2 langues : j’ai pensé à la création d’un squelette article spécifique.
      Les articles en questions ne sont constitués que d’images ou films qui peuvent évoluer: un seul article à mettre à jour pour les 2 langues !
      Trop optimiste ou mauvaise option ?

    • Bonjour,
      Je devais être fatigué, ou une mauvaise manip!!
      Bref, cela fonctionne comme prévu ! ( article-7.html bien pris en compte )
      Merci à Chakalan.

    Reply to this message

  • 4

    J’arrive à faire à peu près ce que je veux. Merci pour ce modèle élégant.
    C’est dommage d’avoir des ! important dans le fichier css du plugin car cela oblige à pas mal de hacks pour adapter les styles par défaut du modèle (par exemple avoir une couleur d’accent différente pour les :hover et pour les .on

    • Bonjour,
      généralement j’utilise en tout dernier recours ces règles, et sans avoir vérifié je pense que ça vient du thème Phantom lui-même...
      Ce sont quelles règles exactement ?

    • Oui il y a dans main.css pas mal de color: #xx !important;

    • Oui, c’est le thème qui donne cette feuille de styles, je ne suis pas sûr que ce soit bien de la modifier...

    • Du coup j’ai copié main.css dans mon dossier perso pour le modifier.

    Reply to this message

  • 7
    Stewen

    Merci pour cette adaptation vraiment réussie ! J’utilise ce plugin depuis quelques mois et j’en suis vraiment très content. Cependant j’ai un petit soucis concernant l’affichage des galeries du plugin Albums 3 sur mobile (aucun souci sur PC). En effet, certains images dépassent du cadre, et d’autres non. Je n’arrive pas à identifier la source du problème. Merci d’avance pour votre aide, n’hésitez pas à me demander plus de précisions si ma description ne vous parait pas claire.

    Reply to this message

  • 9

    Je comprends pas trop comment fonctionne les css de ce squelette. Je dois avoir une incompatibilité quelque part car pour voir les couleurs en surimpression des logos d’articles je dois enlever ceci de spip.css du plugin phantom :

    "/* on remet a 0 les couleurs des articles pour ceux dont l'id pourrait correspondre */
    .tiles article.style1 > .image:before,
    .tiles article.style2 > .image:before,
    .tiles article.style3 > .image:before,
    .tiles article.style4 > .image:before,
    .tiles article.style5 > .image:before,
    .tiles article.style6 > .image:before { background-color: transparent; }"

    Sinon je ne vois pas les couleurs.

    Reply to this message

  • Bonjour à tous,

    j’essaie de m’inspirer du modele de PHANTOM (HTML5UP) https://files.spip.net/PHANTOM-HTML5UP#Installation pour faire une page portfolio comme la demo, donc sur la page d’accueil avec trois boucles (une par image ) ça fonctionne, mais pour une page particulière avec la boucle du plugin cela m’affiche les images sur une seule colonne et non sur les trois, et sans les effets de survol...

    ==================================================================================
    code de la page d’accueil: qui fonctionne mais une boucle par image ce qui n’est pas très pratique...

    <section class="tiles">
    
    <article class="style1">
    <BOUCLE_listDocs1(DOCUMENTS spip_documents_liens){id_rubrique}{par rang_lien,num titre, date}{mode=document}{extension==jpg|png|gif}{titre==^[aA]}>
    <span class="image">
    <img src="[(#FICHIER|image_reduire{600,400}|extraire_attribut{src})]" alt="[(#TITRE|textebrut)]" />
    </span>
    <a href="#URL_RUBRIQUE{2}">
    <div class="content">
    </div>
    </a>
    </BOUCLE_listDocs1>
    <h4 id="contenu1">.</h4>
    </article>
    
    <article class="style2">
    <BOUCLE_listDocs2(DOCUMENTS spip_documents_liens){id_rubrique}{par rang_lien,num titre, date}{mode=document}{extension==jpg|png|gif}{titre==^[bB]}>
    <span class="image">
    <img src="[(#FICHIER|image_reduire{600,400}|extraire_attribut{src})]" alt="[(#TITRE|textebrut)]" />
    </span>
    <a href="#URL_RUBRIQUE{18}">
    <div class="content">
    </div>
    </a>
    </BOUCLE_listDocs2>
    <h4 id="contenu2">.</h4>
    </article>
    
    <article class="style3">
    <BOUCLE_listDocs3(DOCUMENTS spip_documents_liens){id_rubrique}{par rang_lien,num titre, date}{mode=document}{extension==jpg|png|gif}{titre==^[cC]}>
    <span class="image">
    <img src="[(#FICHIER|image_reduire{600,400}|extraire_attribut{src})]" alt="[(#TITRE|textebrut)]" />
    </span>
    <a href="#URL_RUBRIQUE{11}">
    <div class="content">
    </div>
    </a>
    </BOUCLE_listDocs3>
    <h4 id="contenu3">.</h4>
    </article>
    
    <h3 id="contenu4">.</h3>
    </section>

    =========================================================================

    code de la page portfolio:

    <B_documents_portfolio>
    <section class="tiles">
    <article class="style1">
    
    <div class="liste documents documents_portfolio">
    <h2 class="h2"><:medias:info_portfolio:></h2>
    
    <div class="box alt">
    <div class="row uniform">
    <BOUCLE_documents_portfolio(DOCUMENTS) {id_article?}{id_rubrique?}{objet?}{id_objet?} {mode=document}{extension IN png,jpg,gif} {par num titre, date}{vu=non}{doublons}>
    <div class="[(#COMPTEUR_BOUCLE|alterner{4u,4u,4u$})]">
    
    <span class="image">
    <img src="[(#FICHIER|image_reduire{500,300}|extraire_attribut{src})]" alt="[(#TITRE|textebrut)]" />
    </span>
    <a>
    <h2>[(#TITRE|textebrut)]</h2>
    <div class="content">
    <p>[(#DESCRIPTIF)]</p>
    </div>
    </a>
    
    </div>
    </BOUCLE_documents_portfolio>
    </div>
    </div>
    </div>
    </article>
    </section>
    </B_documents_portfolio>

    Les images de l’article s’affichent sur une colonne seulement...
    j’en ai au moins une trentaine a mettre, alors une boucle par image avec mot clé ce n’est pas très pratique..

    Si vous aviez une idée?

    merci d’avance
    jmarc

    Reply to this message

  • Si le plugin metaplus 1.2.8 est déjà installé on a l’erreur :
    • Mise à jour du plugin « Metas + » (de la version 1.2.8 à )
    et page blanche
    En désinstallant l’existant et le réinstallant depuis la zone cela fonctionne.

    Reply to this message

  • 8

    Bonjour,
    Après avoir passé pas mal de temps sur mon site a essayer d’adapter ce plugin, voici quelques améliorations à envisager :
    -  Mettre un “P” majuscule à “plan du site” en bas de page (j’ai tenté de le faire mais ça ne fonctionne pas).
    -  Désinstaller automatiquement le plugin “Spip Reset” quand on, désinstalle « Phantom » car on retrouve un site qui est intégralement en page 404! (et ça prend pas mal de temps pour en trouver la raison quand on ne connait pas ce fameux plugin).
    -  Classer les articles et les contenus des rubriques du menu par ordre de publication, le plus récent avant (l’ordre alphabétique n’a pas vraiment d’intérêt).
    -  Retirer la croix blanche sur les images cliquables qui apparait avant le roll over, ça donne l’impression que ce sont des images de démo et ce n’est pas très beau (je n’ai pas réussi à le faire).
    -  Dans le plan du site, ne pas mettre la même taille de police pour le nom de la rubrique que pour “Article”. Voir retirer “Article” et mettre une taille de police de plus en plus petite pour le nom de la rubrique, du nom de la sous rubrique, le nom de l’article
    -  Comme il n’y a pas de vision du contenu du site (autre que le plan du site), l’installation d’une fenêtre de moteur de recherche serait vraiment bienvenue.
    -  Personnellement j’ai retiré tous les titres en majuscules sur les images car les majuscules sont moins lisibles.
    -  Corriger le problème avec le plugin Galleria sous Firefox (le plus problématique pour moi).
    -  Corriger le problème avec le plugin « Formulaire de contact avancé » signalé il y a quelques jours. J’ai contourné le problème en renseignant mon adresse mail dans le plugin “Liens vers les réseaux sociaux”.
    Merci de me dire si tout cela est possible assez rapidement ? Ou si non comment le faire.

    • Deux points à ajouter
      -   Quand on change la couleur par défaut des liens les barres du menu burger et les croix pour fermer le menu en question restent avec la couleur d’origine de livraison.
      -   Il me semble indispensable de dater les articles.
      Merci

    • Bonjour,
      Merci de vos retours et tests...
      je suis d’accord sur certains points et pas sur d’autres. Le modèle d’origine fait certains choix qu’on ne peut pas remettre en question dans une intégration générale. Mais si certains utilisateurs veulent personnaliser, il est tout à fait possible de faire ces modifications seulement pour son site...

      Le fil d’ariane est absent comme les dates, c’est un parti pris dans Phantom de faire assez sobre il me semble.
      Pour le champ de recherche aussi, enfin ce serait certainement bien de l’avoir mais surtout je n’ai pas le temps en ce moment de chercher une vraie solution...

      Je viens de corriger la mise en forme du formulaire de contact en pied de page + la couleur des boutons du menu latéral.
      Pour le classement des articles dans le menu, je propose une solution assez souple de trier par numéro de titre d’il y en a, sinon par date inversée. Identique pour la liste des articles en page rubrique.
      J’ai tenté de corriger les petites coquilles et pour le plan du site, j’ai fais au mieux mais simple.
      J’ai aussi mis le plugin “typographie enluminée” qui permet sans rien changer dans la rédaction, d’avoir des intertitres correctement hiérarchisés.

      Par contre, je ne connais aucun moyen de désactiver un plugins en même temps qu’un autre. Ça sera encore à l’administrateur de choisir de les désactiver...

      Les croix blanches sur les logos me semble un parti pris dans Phantom, donc il faudrait faire la modification dans votre squelettes/css/perso.css :
      .tiles article > .image::after { background-image:none; }

      Je suis désolé mais je n’ai pas le temps en ce moment de me pencher sur le problème avec Galleria que je ne connais pas du tout...

      Toutes les modifications devraient être dans la version 0.2.0 du plugin, bientôt en ligne...

    • Merci pour ces réponses et les évolutions à venir. J’ai pu retirer l’image de fond en croix et ajouter la date en faisant un copié collé d’un autre plugin. En définitive, j’ai désactivé Phantom car pour moi le problème avec Galleria est trop important.
      Si quelqu’un a une solution, je suis preneur.

    • J’ai pris le temps de tester Galleria de mon côté, et je ne vois rien de bloquant dans l’usage par défaut, le diaporama est bien fonctionnel dans Firefox... avez-vous l’occasion de tester sur une instance neuve de SPIP avec les plugins minimums et non modifiés ?

    • Bonjour,
      J’ai installé en local Spip et les plugins en “auto”. J’ai créé quelques articles et des galeries à partir des mêmes images et tout fonctionne sous Frirefox !!!!

      J’ai tenté d’y importer la base et les images mais j’ai renconrté de gros problèmes de récupération de la base.

      J’utilise Spip depuis 2004 et il y a peut être des fichiers anciens qui trainent. Depuis que Spiploader existe je fais les MAJ avec cet outil.

      En tout cas merci d’y avoir passé du temps.

    • 14 ans sans problème c’est déjà pas mal, et puis là c’est pas forcément grave non plus...

    • J’ai passé des jours et des nuits à essayer d’adapter des squelettes sur les 14 ans en question et a me faire peur avec des grosses erreurs sur le site ou le site qui ne marche plus du tout (là par exemple je viens de changer le mot de passe à l’accès à la base sur phpMyadmin et plus rien ne fonctionnait, c’est le support OHV qui m’a indiqué qu’il fallait aussi le modifier dans le fichier config.php...).
      Aussi je viens de passer pas loin de 20h00 a faire migrer ma sauvegarde en provenance d’une base Mysql4 vers une base en local en Mysql5. Il faudra que je le fasse de toute façon sur le site en production. Une fois qu’on sait ce qu’il faut remplacer c’est assez simple à faire.

      Bref sur le site en local avec tout mon contenu et toutes les galeries “Galleria” fonctionne bien sous Firefox avec le plugin Phantom. J’en arrive à penser que cela provient peut être de la version de Mysql j’ai remplacé dans la sauvegarde, TYPE=MyISAM par ENGINE=MyISAM et `maj` timestamp(14) NOT NULL, par un `maj` timestamp NOT NULL,

    • Bonjour,
      J’ai passé le site en ligne en mysql5 et ça ne marche pas avec Firefox !
      Sur PC tout marche bien sur Edge. Sur Chrome,c’est aléatoire, en rechargeant la page ça se débloque. Avec Firefox aucune galerie ne fonctionne. J’ai essayé sur un autre PC qui a la même version de Windows (10) et de Firefox et de Chrome et c’est identique. Par contre quand on n’est pas sur Windows, à savoir sur un iphone ou un ipad, tout fonctionne sur tous les navigateurs, idem sur une tablette Android.

      Donc la question est de savoir qu’est ce qui peut bloquer l’action de défilement des images (par clic) qui soit différent sur Wamp et chez OVH dans un environnement Window que Firefox et parfois Chrome ne supportent pas quand le plugin Phantom (exclusivement) est installé ?
      Didier

    Reply to this message

  • 9

    Bonjour,
    merci pour ce squelette prometteur.
    Est-il normal que les modèles suivant

    <carte_gis1|objets=articles|id_rubrique=1|zoom=16|limit=100|scale=oui|autocenterandzoom=oui>
    <media10|vignette|right>

    insérés dans le texte d’un article, n’affichent rien ?
    Merci

    • Bonjour,
      il faut avoir activé certains plugins qui doivent générer ces modèles... GIS et Modèles Média ???

    • Merci de la réponse. Of course ;-) c’est pour cela que je ne comprends pas ce qui se passe...

    • sans le squelette Phantom ça marche ? juste sur le squelette-dist ?

    • Salut, le plus efficace serait de nous donner l’adresse de la page qui pose problème pour qu’on puisse t’aider.

    • Bonjour
      voici l’adresse
      Sous le mot carte il y a le code d’insertion de la carte et du media 10
      Merci

    • Bonjour,
      mais du coup, est-ce que ça marche en désactivant tous les plugins sauf ceux strictement nécessaires ?

    • La réponse est oui : cela fonctionne avec uniquement les plugins GIS, Saisies pour formulaires et Modèles media

    • J’ai testé de mon côté et je n’ai de problème ni avec l’un ni avec l’autre, avec ou sans Phantom... je ne vois pas trop comment trouver l’origine du problème...

    • Merci d’avoir essayé. Je sais qu’une fois b_b m’avait dépanné en allant directement voir dans le moteur...;-)

    Reply to this message

Comment on this article

Who are you?
  • [Log in]

To show your avatar with your message, register it first on gravatar.com (free et painless) and don’t forget to indicate your Email addresse here.

Enter your comment here

This form accepts SPIP shortcuts {{bold}} {italic} -*list [text->url] <quote> <code> and HTML code <q> <del> <ins>. To create paragraphs, just leave empty lines.

Add a document

Follow the comments: RSS 2.0 | Atom