SPIP-Contrib

SPIP-Contrib

عربي | Deutsch | English | Español | français | italiano | Nederlands

289 Plugins, 197 contribs sur SPIP-Zone, 157 visiteurs en ce moment

Accueil > Squelettes > Squelettes éditoriaux > IENSP > Squelettes IENSP-ac-lyon pour SPIP 2 et 3

Squelettes IENSP-ac-lyon pour SPIP 2 et 3

20 février 2011 – par StephK – commentaires

4 votes

Présentation

-  Nom du Squelette : « IENSP-ac-lyon »
-  Version du squelette : 1.2
-  Auteur : Stéphane Kus
-  Licence : GPL
-  Compatibilite SPIP : compatible SPIP > 2.0 et >3.0
-  Visualiser
-  Développement sur SPIP-Zone

Principales fonctionalités et spécificités

Un squelette avec une barre de navigation et un menu déroulant tout en CSS, un annuaire des sites web référencés. L’habillage s’inspire des sites institutionnels de l’Académie de Lyon : l’objectif était de pouvoir proposer un squelette SPIP proche pour les sites de l’Académie qui le souhaite. Un exemple : l’Espace Ressources du Centre Académique Michel Delay

J’espère que ces squelettes vous donneront envie de plonger dans le CSS afin de créer un style propre à vos sites.

-  menu déroulant à 3 niveaux
-  calendrier dans la page d’accueil et dans les pages articles (plugin Agenda 2 nécessaire à installer via l’interface privé-> Configuration -> Gestion des plugins)
-  intègre également les plugins article PDF et Version Imprimable à installer via l’interface privé-> Configuration -> Gestion des plugins.

La version 1.1 permet l’installation automatisée en tant que plugin depuis l’interface privée

La version 1.2 ajoute la compatibilité avec SPIP 3 (attention il faut aussi installer la version des plugins compatible avec SPIP 3

Il est à noter que les squelettes utilise le filtre « supprimer_numero » qui vous permet d’ordonner vos rubriques en leur ajoutant un numéro qui sera invisible dans l’espace public. Pour faire apparaître les rubrique dans l’ordre que vous souhaitez il suffit de les nommer de la manière suivante :

  • 01. marubrique
  • 02. marubrique

Attention : vous devez obligatoire mettre un espace après le point pour que ça fonctionne.

Testé sur ces navigateurs

Testé ?PlateformeNavigateurVersion
oui windows Internet explorer 7 et 8
oui windows Firefox .
oui Mac Safari .
oui Mac Firefox .
oui Mac Opera .
oui Unix/Linux Firefox .

Personnaliser le squelette

Vous pouvez aisèment personnaliser ces squelettes en changeant les couleurs dans le fichier habillage.css, il suffit de faire un rechercher/remplacer sur ces couleurs :

-  #d0d0d0 : couleur de fond de la page
-  #FFF : couleur de fond des blocs
-  #e78301 : couleurs du titre du site et des liens

images à modifier :

-  images/banniere.jpg : le fond de l’entête
-  images/ArtWindTop.jpg, images/ArtWindTopCentre.jpg, et images/ArtWindTopLarge.jpg : haut des blocs

Téléchargement

Version 1.2.0

Voir en ligne : http://plugins.spip.net/ienspaclyon

Dernière modification de cette page le 25 octobre 2017

Retour en haut de la page

Vos commentaires

  • Le 4 avril 2014 à 08:30, par mo En réponse à : Squelettes IENSP-ac-lyon pour SPIP 2 et 3

    bonjour,
    merci pour ce squelette géniale, en fait moi je voulais l’installer sous spip 3 mais a chaque fois que je l’installe c’est marqué version non compatible. merci bien de vouloir m’aider sur la bonne version qui sera compatible avec spip 3.0

    Répondre à ce message

  • Le 22 mars 2011 à 02:54, par Raymond En réponse à : Squelettes IENSP-ac-lyon pour SPIP 2.1

    Bonjour,

    J’ai installé ce squelette par le plugin, avec spip 2.18 et je n’ai plus la possibilité de le désactivé et en plus dans « liste des plugins » j’ai :
    Un plugin activé.
    configurer_IENSP-ac-lyon pas autorise

    Et les autres plugins « plume » « calendrier » etc ont disparu.
    Que faire ?

    • Le 22 mars 2011 à 15:21, par StephK En réponse à : Squelettes IENSP-ac-lyon pour SPIP 2.1

      Bonjour,

      Il s’agit d’un petit défaut du fichier plugin.xml : le prefixe du plugin ne devrait pas comporter de majuscules ou de tirets. Il suffit donc de remplacer <prefix>IENSP-ac-lyon</prefix> par <prefix>ienspaclyon</prefix>

      Je fais immédiatement la correction sur la zone...

      StephK

    Répondre à ce message

Répondre à cet article

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici Les choses à faire avant de poser une question (Prolégomènes aux rapports de bugs. )
Ajouter un document

Retour en haut de la page

Ça discute par ici

  • Enluminures typographiques V3

    25 juillet 2009 – 203 commentaires

    Les Enluminures typographiques V3 permettent d’ajouter au Porte plume les raccourcis typographiques présents dans le Plugin Barre Typographique Enluminée. C’est une extension du PortePlume. Pour la documentation d’usage, se reporter à celle du (...)

  • Hyperspace : squelette responsive

    8 mars 2016 – 46 commentaires

    Description Ce squelette distribué en plugin est un portage pour SPIP du thème responsive « Hyperspace », proposé sur le site . Voir la démo originale : Sites utilisant le plugin : C’est une base de départ pour l’intégration d’un site simple de (...)

  • Escal-V3 et Escal-V4

    16 février 2012 – 320 commentaires

    Un jeu de squelettes proposant un affichage en 2 ou 3 colonnes avec un large choix de noisettes à insérer ou pas, fortement paramétrable depuis l’espace privé. Présentation A l’instar de sa petite soeur plugin Escal-V2 dont elle reprend toutes les (...)

  • Planning simple

    9 septembre 2015 – commentaires

    Ce plugin permet de créer et imprimer un emploi du temps de façon simple. Il dispose de deux méthodes, l’une est d’écrire une liste des évènements dans le corps de l’article, l’autre requiert le plugin agenda. Le plugin planning simple permet (...)

  • Réservation d’événements

    16 mars 2015 – 348 commentaires

    Ce plugin permet d’offrir aux visiteurs de s’inscrire pour un évènement du plugin Agenda et de gérer les réservations enregistrées. Installation Le plugin s’installe comme n’importe quel plugin. il nécessite : Agenda API de vérification Facteur (...)