Galleria (fr)

Une galerie d’image qui utilise la librairie javascript Galleria.

Description

Ce plugin vous permet d’ajouter des galeries d’images à vos articles. La galerie créée utilise la librairie javascript Galleria. Le plugin propose un modèle nommé <galleria>.

Utilisation

Pour créer une galerie d’image ajoutez une balise <galleria##> dans un article, où ## est l’ID d’un article.Les images de la galerie sont celles liés à l’article.

Options

Les options les plus courantes du modèle sont :
-  width
-  height
-  lightbox :true
-  transition :[fade|flash|pulse|slide|fadeslide|doorslide]
-  theme : le nom d’un theme Galleria
-  pagesize : le nombre d’image par page

Ex : <galleria22> une galerie dans l’article 22 ; <galleria22|lightbox=true> activation de l’effet lightbox

Pour plus d’options et de personnalisation de la galerie reportez-vous directement au site de Galleria

Bug connu

Lorsqu’on ajoute plusieur galerie dans un même article, la galerie ne fonctione pas correctement. (bug fermé avec la version 1.3.1)

Références

version 2.0.0
SPIP minimum 3.2 librairie JQuery n’est plus compatible avec les versions <3.2
version Galleria 1.5.7 site de Galleria
version de SPIP pour développement 3.2
svn svn://zone.spip.org/spip-zone/_plug...

Retro compabilité

version 1.3.5
SPIP 1.9.2>= et <3.2.0 librairie JQuery
version Galleria 1.2.9 site de Galleria
version de SPIP pour développement 2.1.11
svn svn://zone.spip.org/spip-zone/_plug...

ouverture avec lightbox/open with lightbox

Discussion

71 discussions

  • Bonjour,
    afin de personnaliser la présentation de l’image qui s’affiche en pleine page quand on clique sur la photo avec le thème classic, je voudrai intervenir sur
    .galleria-lightbox-shadow
    .galleria-lightbox-content
    l’opacité et la couleur du texte.
    Je ne trouve pas le fichier à modifier, j’ai ajouté des éléments dans galleria-classic.css mais cela n’a aucun effet.
    Merci de votre aide.

    Répondre à ce message

  • 4

    Bonjour,
    J’ai de très nombreuses galeries sur mon site et j’utilise Galleria depuis très longtemps avec une grande satisfaction.
    Un nouvel habillage de site vient de sortir sous la forme du plugin nommé Phantom https://contrib.spip.net/PHANTOM-HTML5UP .
    J’ai voulu utiliser ce plugin mais les galeries de Galleria ne fonctionnent pas, la première image apparait bien mais impossible de faire fonctionner les flèches de droite et de gauche ou de faire défiler les miniatures sous la grande image. Idem si je clique sur l’image afin qu’elle s’affiche en grand format ça ne marche pas.
    J’ai posé la question à Phantom mais pour le moment pas de réponse. Auriez vous une piste ?
    Merci
    Didier

    • Une piste mais je ne sais pas résoudre le problème. Cela fonctionne avec Edge pour toutes les galeries mais avec Chrome, Firefox et Brave, certaines galeries fonctionnent et d’autres pas. Alors que sans ce plugin elles fonctionnent toutes quelque soit le navigateur.
      Didier

    • Je n’ai toujours pas trouvé de solution. Le concepteur de Phantom me dit que ça fonctionne chez lui en local. J’ai installé l’ensemble de mon site en local, sur Wamp et toutes les galeries fonctionnent effectivement. Chez OVH, mon hébergeur, ma base de données était en mysql4 alors que sur wamp elle était en mysql5. J’ai tout migré chez OVH sur mysql5 et là aucune galerie ne fonctionne sous Firefox.

      Tout marche bien sur Edge et sur Brave. Sur Chrome c’est aléatoire, en rechargeant la page ça se débloque. Avec Firefox aucune galerie ne fonctionne. J’ai essayé sur un autre PC qui a la même version de Windows (10) et de Firefox et de Chrome et c’est identique. Par contre quand on n’est pas sur Windows, à savoir sur un iphone ou un ipad, tout fonctionne sur tous les navigateurs, idem sur une tablette Android.

      Donc la question est de savoir qu’est ce qui peut bloquer l’action de défilement des images (par clic) qui soit différent sur Wamp et chez OVH dans un environnement Window que Firefox et parfois Chrome ne supportent pas quand le plugin Phantom (exclusivement) est installé ?

    • Bonjour,

      Votre problème est complexe , je ne suis pas sur de pouvoir vous aider.
      Cependant , avez vous regardé la console javascript des navigateurs ? Elle est activable dans tout les navigateurs connus.
      Un autre conseil est de faire un tableau avec les différents environnements et l’état de fonctionnement.
      ex :

      galleria + phantom +wamp + mysql 4 galleria +wamp + mysql 4 galleria + phantom +wamp + mysql 5 galleria +wamp + mysql 5
      firefox partiel ok nok
      edge
    • Merci emthanh pour cette réponse.
      Sous Windows, pour Wamp tout est ok, sous Msql5, quel que soit le navigateur (pas essayé de mettre en Mysql4 car l’objectif était de tout passer en Mysql5).

      Le problème vient du site en production avec Firefox (et parfois Chrome) https://www.gualeni.com/ sous Windows, qui est à présent en Mysql5 et en https avec un code AddThis (mais en http et sans AddThis, le problème est toujours présent sous Firefox et parfois avec Chrome).

      Sous Android et sous IOS tout est ok quel que soit le navigateur tablette ou smartphone.

      Sous windows
      Site en production + phanthom + galleria : Firefox NO OK, Chrome Parfois Ok, se met à fonctionner souvent en rechargeant la page ctrl + F5, Edge OK
      Site en production + galleria  : Tout OK
      Site sous wamp +phanthom + galleria : Tout OK
      Site sous wamp + galleria : Tout OK

      Avec la console de Firefox apparait l’erreur suivante sur une page avec une gallerie Galleria et avec Phanthom
      [Exception... « Failure » nsresult : « 0x80004005 (NS_ERROR_FAILURE) » location : « JS frame : : jar:file :///C :/Program%20Files/Mozilla%20Firefox/omni.ja !/components/nsLivemarkService.js : : handleResult : : line 798 » data : no]
      handleResult jar:file :///C :/Program Files/Mozilla Firefox/omni.ja !/components/nsLivemarkService.js:798:15 FP_sendResult jar:file :///C :/Program Files/Mozilla Firefox/omni.ja !/components/FeedProcessor.js:1242:9 FP_reportError jar:file :///C :/Program Files/Mozilla Firefox/omni.ja !/components/FeedProcessor.js:1289:7 FP_onDataAvailable jar:file :///C :/Program Files/Mozilla Firefox/omni.ja !/components/FeedProcessor.js:1275:5 onDataAvailable jar:file :///C :/Program Files/Mozilla Firefox/omni.ja !/components/nsLivemarkService.js:841:7

    Répondre à ce message

  • 2

    Bosoir,
    Dans le Back office de SPIP, on peut depuis pas mal de temps « déplacer/poser » (drag and drop) les illustrations d’un article, ce qui permet d’ordonner ces images et c’est très pratique. Par contre Galleria ne tient pas compte de cet ordonnancement comment remédier à cela ?

    • je n’utilise pas galleria, mais il semble que le squelette modelles/galleria.html fourni par le plugin,prévoit le critère de tri de son choix puisque la boucle contient un critère de tri personnalisable

      {par ?#ENV{tri}} 

      Du coup, que donne l’écriture

      <galleria1234|transition=fade|lightbox=true|width=520|height=390|autoplay=true|tri=rang_lien>
    • Fabuleux, ça marche ! Un grand merci Manu.

    Répondre à ce message

  • 2

    Bonjour
    je fais évoluer un ancien site et je voulais tester “galleria". Je suis parti sur une installation toute propre en local (SPIP 3.2.1) aucun autre plugin installé.

    J’ai pris le squelettes de base "articles" dans la dist et je l’’ai personnalisé en inserant
    [(#MODELE{galleria}{id_article})]
    à la place de
    [(#INCLURE{fond=inclure/documents,id_article,id_rubrique='',env})]

    malheureusement il ne se passe rien ?aucune des images qui se trouvent dans le portfolio de mon article ne s’affiche

    j’ai essayé
    <galleria11> directement dans le texte de l’article .. rien non plus ?

    qu’est ce que j’ai loupé ?

    merci de vos conseils

    jacques

    • Bonjour,

      ce plugin affiche les images qui ne font pas partie du porfolio. Le porfolio est une fonctionnalite qui a ete ajoutée apres la creation de ce plugin.

      Pour resoudre votre problème veuilllez retirer les images du porfolio.

    • Bonjour

      merci pour votre retour. Je n’avais pas compris la subtilité !
      jacques

    Répondre à ce message

  • 6
    fhamonno

    Bonjour
    Lors d’un affichage via le carrousel, je voudrais que le bloc « info » (title + alt) s’affiche en permanence sous l’image, comme pour l’affichage « lightbox ».
    J’ai essayé de modifier le css... mais sans bon résultat !
    Merci de votre aide.

    • Bonjour,

      Vous voulez que le bloc info soit affiché sur le caroussel.
      C’est une fonction qui n’est pas de base dans le comportement du plugin.
      La librairie galleria utilise un systeme de « theme » , celui livré de base est classic.
      cf https://galleria.io/downloads
      Vous pouvez modifier celui-ci (classic) ou créer le votre pour avoir le comportement voulu.

    • Merci pour votre réponse.
      Le site « Galleria » propose des thèmes qui tous affichent les infos de l’image !
      Dommage qu’ils soient payant ... mais on a rien sans rien !!!
      Merci encore
      Cordialement
      fhamonno

    • fhamonno

      J’ai donc supprimé l’ancien thème (classic) et l’ai remplacé par le nouveau « Azur ».
      J’ai déactivé le plugin « Galleria » puis je l’ai réactivé...
      Mais quand j’affiche un article, toutes les photos s’affichent à la suite l’une de l’autre !
      Merci de votre aide.
      F. Hamonno

    • fhamonno

      J’ai téléchargé le thème « azur » qui est venu avec le thème « fullscreen ».
      Mais, au lieu d’afficher les images, il me donne l’erreur
      « Could not extract a stage height from the CSS. Traced height : 0 »

      J’ai fait tout ce que dit le site concernant cette erreur.
      J’ai mis l’option wait=true et maxsize=2.
      J’ai ajouté le code (function() G.init() ; ()) ;
      J’ai fait l’essai avec deux images de taille réduite (42Ko et 105Ko),
      mais l’erreur est toujours là.

      Le carrousel s’affiche correctement avec le thème « classic »,
      mais l’erreur apparait avec les 2 thèmes « azur » et « fullscreen » !

      Je ne sais plus quoi faire !!!
      Merci de votre aide.

    • Bonjour,
      Je n’ai pas testé l’ajout d’un autre theme. Mais la facon dont vous procédez (remplacement des fichiers) n’a pas l’air "safe".
      Vous devrier ajouter votre theme "azur" dans le répertoire themes de votre plugin galleria.
      Puis utiliser l’option du plugin

      theme=azur

      remarque :
      « Mais quand j’affiche un article, toutes les photos s’affichent à la suite l’une de l’autre ! »
      veut dire que le plugins ne fonctionne pas. Vous pouvez regarder les erreurs dans la console web de votre navigateur.
      Vous pouvez soumettre ces informations (apres selection) lors d’une demande d’aide.

    • fhamonno

      Merci pour votre réponse.
      J’ai trouvé le paramètre « thème » tardivement (!) et j’ai donc mis au propre ma gestion du plugin... mais c’est après qu’est apparue l’erreur « stage height ».
      Merci de votre aide

    Répondre à ce message

  • 2

    Bonjour,
    Y a t il un moyen pour faire en sorte que cette galerie soit nativement responsive (une bidouille dans la feuille de style ou un truc de ce genre) ?
    J’ ai commencé à ajouter à chaque galerie « |responsive=true » ça marche mais j’ai beaucoup de galeries. Aussi s’il suffit d’ajouter une syntaxe qui fait que ça se fait tout seul ça serait super.
    Merci

    • Je me réponds si cela peut aider d’autres personnes.
      Il faut aller dans modeles/galleria.html et là, à la suite de « responsive »il faut remplacer false par true (à 2 endroits).
      Pourquoi ce n’est pas le cas par défaut c’est assez incompréhensible.

    • Bonjour,
      Ce plugins utilise la librairie galleria , les paramètres de base sont utilisées.

    Répondre à ce message

  • 4
    Christian Voillemont

    Bonjour,
    J’utilise ce magnifique plugin sur plusieurs de mes sites et j’aimerai passer en spip 3.2.0
    Est ce que la comptabilité avec SPIP 3.2.0 sera assurée ?

    Répondre à ce message

  • Nouvelle URL du site Galleria :
    https://galleria.io/

    Répondre à ce message

  • juste pour dire que le site de galleria a apparemment changé. C’est https://galleria.io/ maintenant

    Répondre à ce message

  • la fougale

    Bonjour
    Je n’arrive pas a creer une gallerie avec ce plugin, avec pour seul résultat l’affichage des images de manière classique spip.
    Je suis sur un serveur local (linux Lamp), GD2 est activé, sous spip 3.1, le plugin 1.3.4.
    Avez vous une idée du problème
    merci

    Répondre à ce message

Ajouter un commentaire

Qui êtes-vous ?

Pour afficher votre trombine avec votre message, enregistrez-la d’abord sur gravatar.com (gratuit et indolore) et n’oubliez pas d’indiquer votre adresse e-mail ici.

Ajoutez votre commentaire ici

Ce champ accepte les raccourcis SPIP {{gras}} {italique} -*liste [texte->url] <quote> <code> et le code HTML <q> <del> <ins>. Pour créer des paragraphes, laissez simplement des lignes vides.

Ajouter un document

Suivre les commentaires : RSS 2.0 | Atom

Dernière modification de cette page le 29 septembre 2018